Subject: Re: [Dime] Section 4.5: Relevance of "SHLD NOT" column

From: Victor Fajardo <[email-masked]>
Date: Fri, 01 Feb 2008 08:31:43 -0500

Comments inline:
>  
> There have been changes in section 4.5: Diameter Base Protocol AVPs
> between bis3-bis6 document. 
> Can you please explain
>  
> a) the rational behind retaining "SHLD NOT" column in the table. 
>   

Probably to cover rfc2119 conventions ... though it may not make sense 
to have it there

> b) use case where marking a AVP bit to "SHLD NOT" will help. AFAIR
> haven't seen an application marking an AVP bit as "SHLD NOT".
>   

have'nt seen any as well and i don't think there's any use case for it.

regards,
victor

> c) what should be the behavior incase a message is received with an AVP,
> where a "SHLD NOT" bit is set in the header.
>  
> Regards,
> Satendra
>
>   

_______________________________________________
DiME mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/dime

---

From: "Satendra Gera" <[email-masked]>
Date: Sat, 2 Feb 2008 14:09:15 +0530

Thanks Victor for the prompt reply.
In that case, I suggest we remove the column to avoid confusion and
temptation for applications to mark a bit as "SHLD NOT" assuming some
behavior.

Regards,
Satendra

-----Original Message-----
From: Victor Fajardo [mailto:[email-masked]] 
Sent: Friday, February 01, 2008 7:02 PM
To: Satendra Gera (satgera)
Cc: [email-masked]; Shwetha Bhandari (shwethab); [email-masked]
Subject: Re: Section 4.5: Relevance of "SHLD NOT" column

> a) the rational behind retaining "SHLD NOT" column in the table. 

Probably to cover rfc2119 conventions ... though it may not make sense to
have it there

regards,
victor

> c) what should be the behavior incase a message is received with an 
> AVP, where a "SHLD NOT" bit is set in the header.
>  
> Regards,
> Satendra
>
>