Subject: [Dime] Suggestion for Enhancement in RFC 3588

From: Preeti Shandilya <[email-masked]>
Date: Wed, 13 Feb 2008 10:35:51 +0530

Hi !

I have a suggestion which should consider when we comeout with the next 
bis for RFC 3588.

In my opinion, there are some information provided in the RFC 3588 and in 
the latest bis , which in my opinion should not be the part of this RFC.

RFC 3588 should only specify the detail of the diameter base procedures , 
commands and AVPs used by base messages.

It should not define any other messages and its' ABNF, state machines and 
procedures. This unnecessarily creates the duplication of the information 
in the multiple RFCs and creates the  inconsistency.

To site an  example, base RFC defines the accounting messages, 
corresponding state machine and AVPs. I am not able to  understand why it 
is a requirement to define these in the diameter base. Accounting should 
be prerogative of the application specific RFCs. Application specific RFCs 
should define the command codes and corresponding procedures.

Having accounting in diameter base should never be a requirement.

RFC indicates that RAR, ASR and STR are base messages. In my opinion this 
should come under application specific messages as Diameter base ideally 
would not maintain the application sessions. 

Regards
Preeti

***********************  Aricent-Unclassified   ***********************
"DISCLAIMER: This message is proprietary to Aricent  and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
DiME mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/dime

---

From: Victor Fajardo <[email-masked]>
Date: Wed, 13 Feb 2008 09:32:14 -0500

Hi,

> would not maintain the application sessions. 

I think this discussion has been hashed before. Some folks (including 
me) agree that it would have been a better choice to have two(2) 
documents; a base protocol doc and session related doc. However, going 
with that approach this late is not productive and would cause even more 
delays in delivering the document as well as breaking an ever increasing 
document dependencies.

-- victor