Subject: Re: [Dime] Diameter Prefix Delegation Application

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 18 Jun 2008 09:38:59 -0700 (PDT)

RFC 4818 defines an application (a mini application) by which the delegating router gets a bunch of delegated prefixes from AAA server that has them. The question is this: can you qualify this "application" as a valid AAA application according to your qualification?

In my opinion it is because AAA server authorizes the use the prefixes by AAA client. 

----- Original Message ----
From: Glen Zorn <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Wednesday, June 18, 2008 11:10:31 AM
Subject: RE: [Dime] Diameter Prefix Delegation Application

Behcet Sarikaya [mailto:[email-masked]] writes:

Glen, 
  In your gut feeling, can you please assess RFC 4818 of which none of us
are coauthors vis-a-vis your statement?
it appears that the single application that is being discussed and
cannot be handled in Diameter NASREQ right now _has nothing to do with _user
authorization
 
I don't understand the question.

BTW, RFC 4818 applies to Diameter as well although the title mentions only
Radius.
I'm aware of that.

Regards,

Behcet
----- Original Message ----
From: Glen Zorn <[email-masked]>
To: Frank Xia <[email-masked]>
Cc: [email-masked]; Behcet Sarikaya <[email-masked]>; Julien Bournelle
<[email-masked]>
Sent: Tuesday, June 17, 2008 2:11:19 PM
Subject: RE: [Dime] Diameter Prefix Delegation Application

Frank Xia [mailto:[email-masked]]
writes:

> Hi Glen
> 
> Please check my inline clarification...
> 
...

> >>
> >> IMHO,  Diameter as a AAA protocol
> >> can be used in dynamically authorization.
> >
> > Of _users_.
> Frank=>Most of cases in the diameter PS  are users' authorization
related,
such as LMA requesting prefix for it's PMIPv6 user,  access routers asking
for prefix for the mobile nodes attached.

I wrote: "it appears that the single application that is being discussed
and
cannot be handled in Diameter NASREQ right now _has nothing to do with _user
authorization__.  As I stated in my original message, I'd be happy to be
told that I'm mistaken about this but nobody's done that."  Still
true.

...

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: "Glen Zorn" <[email-masked]>
Date: Thu, 19 Jun 2008 00:54:12 +0700

RFC 4818 defines an application (a mini application) by which the delegating
router gets a bunch of delegated prefixes from AAA server that has them. 

RFC 4818 says nothing about a "bunch" of prefixes, it says that "The
Delegated-IPv6-Prefix MAY appear in an Access-Accept packet, and  can appear
multiple times."

The question is this: can you qualify this "application" as a valid AAA
application according to your qualification?

In my opinion it is because AAA server authorizes the use the prefixes by
AAA client. 

I'm not sure where you get either of these ideas.  The AAA server is
authorizing the use of the prefixes by the requesting router, in this case
taking the role of a NAS client; it is not, as you seem to think, simply
handing out a bunch of prefixes for the RADIUS client to delegate as it may
please.   Please see RFC 3633 for details on the operation of prefix
delegation in DHCP.

----- Original Message ----
From: Glen Zorn <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Wednesday, June 18, 2008 11:10:31 AM
Subject: RE: [Dime] Diameter Prefix Delegation Application

Glen, 

I'm aware of that.

Regards,

Behcet

----- Original Message ----
From: Glen Zorn <[email-masked]>
To: Frank Xia <[email-masked]>
Cc: [email-masked]; Behcet Sarikaya <[email-masked]>; Julien Bournelle

...

> Frank=>Most of cases in the diameter PS  are users' authorization related,

I wrote: "it appears that the single application that is being discussed and
cannot be handled in Diameter NASREQ right now _has nothing to do with _user
authorization__.  As I stated in my original message, I'd be happy to be
told that I'm mistaken about this but nobody's done that."  Still true.

...