Subject: [Dime] One question on DWR.

From: "Gowda, Avinash" <[email-masked]>
Date: Mon, 23 Jun 2008 15:18:50 +0530

Hi,

When a DWR is sent with wrong version (For E.g.: 10) from Server to
Client then DWA is sent by Client with Result-Code set to
DIAMETER_UNSUPPORTED_VERSION.

After this DWR/DWA exchange does Client need to close the connection and
establish a new connection?

Thanks in advance,

Avinash Gowda

_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: "Gowda, Avinash" <[email-masked]>
Date: Mon, 23 Jun 2008 22:37:00 +0530

Can anybody help me in this issue?? Please..........

Thanks,

Avinash Gowda

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Gowda, Avinash
Sent: Monday, June 23, 2008 3:19 PM
To: [email-masked]
Cc: Ranjan Rath, Rashmi; Krishnamoorthy, Balachandar; Sarkar, Biplab
Subject: [Dime] One question on DWR.

Hi,

Thanks in advance,

Avinash Gowda

---

From: Sebastien Decugis <[email-masked]>
Date: Tue, 24 Jun 2008 09:57:15 +0900

Hi,

I think it is odd that the DWR has a wrong version number. If a DWR is 
sent at all, it means that a previous CER/CEA exchange was successful 
(and therefore the version number was correct). Why would the protocol 
version change during the lifetime of the connexion?

Anyway, I think that the bad DWR should result is similar process as if 
it had not been received. But terminating the connexion is probably OK too.

Hope this helps,
Sebastien.

Gowda, Avinash a écrit :
>
> Can anybody help me in this issue?? Please……….
>
>  
>
> Thanks,
>
> Avinash Gowda
>
> ------------------------------------------------------------------------
>
> *From:* [email-masked] [mailto:[email-masked]] *On 
> Behalf Of *Gowda, Avinash
> *Sent:* Monday, June 23, 2008 3:19 PM
> *To:* [email-masked]
> *Cc:* Ranjan Rath, Rashmi; Krishnamoorthy, Balachandar; Sarkar, Biplab
> *Subject:* [Dime] One question on DWR.
>
>  
>
> Hi,
>
>  
>
> *DIAMETER_UNSUPPORTED_VERSION.*
>
> * *
>
> After this DWR/DWA exchange does Client need to close the connection 
> and establish a new connection?
>
>  
>
> Thanks in advance,
>
> Avinash Gowda
>
>  
>
> ------------------------------------------------------------------------
>

-- 
Sebastien Decugis
Research fellow
Network Architecture Group
NICT (nict.go.jp)

---

From: "Gowda, Avinash" <[email-masked]>
Date: Tue, 24 Jun 2008 08:31:31 +0530

Hi Sebastien,

I got your explanation. It was just a testing of negative scenario. 

I have one more query. :)

When a DWR is sent with wrong version from server then is it must for client to send DWA back??

Thanks,
Avinash Gowda

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sebastien Decugis
Sent: Tuesday, June 24, 2008 6:27 AM
To: [email-masked]
Subject: Re: [Dime] One question on DWR.

Hi,

Hope this helps,
Sebastien.

---

From: Sebastien Decugis <[email-masked]>
Date: Tue, 24 Jun 2008 12:16:27 +0900

Hi,

I am not sure what should be the correct behavior. In my opinion, when a 
message with an incorrect version number is received, it should just be 
discarded. Since the version has changed, we can not assume anything 
about the format of the message, so how can one be sure that the message 
is really a DWR for example? I don't understand the use for the 
"DIAMETER_UNSUPPORTED_VERSION" error code with this respect.

Anyway I am also beginner in Diameter protocol so maybe someone with 
more experience can provide more information on how a mismatching 
version number may be handled (can we assume forward compatibility of 
the message with future versions?)

Thanks,
Sebastien.

---

From: "Gowda, Avinash" <[email-masked]>
Date: Tue, 24 Jun 2008 08:31:31 +0530

Hi Sebastien,

Thanks,
Avinash Gowda

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sebastien Decugis
Sent: Tuesday, June 24, 2008 6:27 AM
To: [email-masked]
Subject: Re: [Dime] One question on DWR.

Hi,

Hope this helps,
Sebastien.

---

From: "Gowda, Avinash" <[email-masked]>
Date: Tue, 24 Jun 2008 10:43:51 +0530

Thanks a lot for your feedback on this issue. Will wait for somebody to reply on this. Let's see what will be their opinion.

Thanks,
Avinash Gowda

-----Original Message-----
From: Sebastien Decugis [mailto:[email-masked]] 
Sent: Tuesday, June 24, 2008 8:46 AM
To: Gowda, Avinash
Cc: [email-masked]
Subject: Re: [Dime] One question on DWR.

Hi,

Thanks,
Sebastien.

---

From: "Gowda, Avinash" <[email-masked]>
Date: Tue, 24 Jun 2008 20:14:39 +0530

Please anybody comment on this e-mail thread. We want to understand this behavior very clearly.

Thanks,
Avinash Gowda

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Gowda, Avinash
Sent: Tuesday, June 24, 2008 8:32 AM
To: Sebastien Decugis; [email-masked]
Subject: Re: [Dime] One question on DWR.

Hi Sebastien,

Thanks,
Avinash Gowda

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Sebastien Decugis
Sent: Tuesday, June 24, 2008 6:27 AM
To: [email-masked]
Subject: Re: [Dime] One question on DWR.

Hi,

Hope this helps,
Sebastien.

---

From: <[email-masked]>
Date: Wed, 25 Jun 2008 11:12:40 +0300

Hi,

> must for client to send DWA back??

In that kind of case client should send DWA back with result-code
DIAMETER_UNSUPPORTED_VERSION.

Best Regards,
Mikko

>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of ext Gowda, Avinash
>Sent: 24 June, 2008 17:45
>To: Gowda, Avinash; Sebastien Decugis; [email-masked]

---

From: "Gowda, Avinash" <[email-masked]>
Date: Wed, 25 Jun 2008 14:33:15 +0530

Hi Mikko,

One more question. 
After sending DWA back with result-code DIAMETER_UNSUPPORTED_VERSION do
we need to close the connection??

Thanks,
Avinash Gowda

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, June 25, 2008 1:43 PM
To: [email-masked]
Subject: Re: [Dime] One question on DWR.

Hi,

Best Regards,
Mikko

>Behalf Of Gowda, Avinash