Subject: Re: [Dime] dime-mip6-integrated and the type of home agent

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 24 Jun 2008 16:20:44 -0700

On Tue, Jun 24, 2008 at 1:04 AM,  <[email-masked]> wrote:
>
> So.. the following revision of the MIP6-Agent-Info would be OK so far:
>
> <MIP6-Agent-Info> ::= < AVP Header: TBD >
>                    *2[ MIP-Home-Agent-Address ]
>                        [ MIP-Home-Agent-Host ]
>                     * [ AVP ]

Ok.

>
> If some SDO would need the agent type.. that could be done in two ways:
> 1) decorating the FQDN
> 2) adding an optional AVP using the *[AVP] approach
>
> Comments?

I would prefer 2).

Vijay

>
> Cheers,
>  Jouni
>
>
> Vijay Devarapalli <[email-masked]> kirjoitti:
>>
>> Hi Jouni,
>>
>> On Sun, Jun 22, 2008 at 1:58 PM,  <[email-masked]> wrote:
>> > Hi,
>> >
>> >> Hi Jouni,
>> >>
>> >> What is the need to differentiate between a MIPv6 and DS-MIPv6 HA?
>> >> Since the DS-MIPv6 HA functionality includes MIPv6 HA, why would
>> >> someone deploy separate MIPv6 HA and DS-MIPv6 HA? If the discovered HA
>> >> does not support IPv4 Home Address assignment, the mobile node gets to
>> >> know about it anyway after the BU/BAck exchange.
>> >
>> > On a related issue, we should actually have two instances of
>> > IP addresses. One for IPv6 and one for IPv4. I.e.:
>> >
>> >    <MIP6-Agent-Info> ::= < AVP Header: TBD >
>> >                        *2[ MIP-Home-Agent-Address ]
>> >                          [ MIP-Home-Agent-Host ]
>> >                          [ MIP-Agent-Type ]
>> >                        * [ AVP ]
>> >
>> > ..as it is assumed that both DSMIP6 and PMIP6 will have deployments
>> > that need the IPv4 address as well.
>>
>> Agree.
>>
>> Would the MAG or the access router have to know that they also need
>> the IPv4 address in addition to the IPv6 address and request for both?
>> Or will both addresses be returned, irrespective of what the MAG or
>> the access router asked for?
>>
>> Vijay
>>
>> >
>> > Cheers,
>> >        Jouni
>> >
>> >
>> >>
>> >> On Wed, Jun 18, 2008 at 1:48 PM, Jouni Korhonen
>> >> <[email-masked]> wrote:
>> >> > Hi all,
>> >> >
>> >> > A proposal related to the MIP6-Agent-Info AVP. Currently
>> >> > the AVP contains only the address information of the HA,
>> >> > which is OK in the scope of the integrated scenario. However,
>> >> > having a slight wider look at the possible uses for the
>> >> > MIP6-Agent-Info AVP it might be beneficial to include an
>> >> > AVP describing the "flavor" of the HA.  What I am proposing
>> >> > is to add an enumerated MIP-Agent-Type AVP inside the group.
>> >> >
>> >> >    <MIP6-Agent-Info> ::= < AVP Header: TBD >
>> >> >                          [ MIP-Home-Agent-Address ]
>> >> >                          [ MIP-Home-Agent-Host ]
>> >> >                          [ MIP-Agent-Type ]
>> >> >                        * [ AVP ]
>> >> >
>> >> >
>> >> > The initial values would include:
>> >> >
>> >> > MIP6_HA (0)
>> >> > MIP6_LMA (1)
>> >> > MIP6_DSMIP_HA (2)
>> >>
>> >> What is the MIPv6 HA and PMIPv6 LMA are co-located?
>> >>
>> >> Its not clear to me what the above actually is trying to achieve. For
>> >> my benefit, can you please describe the scenario where such an
>> >> enumerated AVP would help? I could be missing something.
>> >>
>> >> Vijay
>> >>
>> >> >
>> >> > As a side note.. this discussion has been gone through at least
>> >> > once. At that time I thought using FQDN piggypack agent flavor
>> >> > information would be enough.. but having a separate AVP would
>> >> > actually be nicer imho.
>> >> >
>> >> > Cheers,
>> >> >        Jouni
>> >> > _______________________________________________
>> >> > DiME mailing list
>> >> > [email-masked]
>> >> > https://www.ietf.org/mailman/listinfo/dime
>> >> >
>> >> _______________________________________________
>> >> DiME mailing list
>> >> [email-masked]
>> >> https://www.ietf.org/mailman/listinfo/dime
>> >>
>> >
>>
>
>
_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: <[email-masked]>
Date: Wed, 25 Jun 2008 08:30:44 +0200

Hi Vijay,

Good.. As far as I know the integrated draft is about to move forward,
so this rather small change can be done during the auth48 stage.

Cheers,
	Jouni

> -----Original Message-----
> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: 25. kesäkuuta 2008 2:21
> To: [email-masked]
> Cc: Korhonen, Jouni /TeliaSonera Finland Oyj; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: [Dime] dime-mip6-integrated and the type of home agent
> 
>