Subject: Re: [Dime] Diameter Prefix Delegation Application

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 12 Jun 2008 07:45:14 -0700 (PDT)

Hi Rafael,
  The problem statement draft Problem Statement and Requirements for Diameter Prefix Delegation Application makes the case for an AAA Prefix Delegation application for use with PMIPv6 and many other cases. Currently DHCPv6 PD is defined and many attributes for AAA to carry prefixes (as you mentioned) but no Diameter/Radius application for PD.
  Please post your comments on this subject to dime list.

Regards,

Behcet

----- Original Message ----
From: "[email-masked]" <[email-masked]>
To: [email-masked]
Sent: Thursday, June 12, 2008 9:00:49 AM
Subject: Diameter Prefix Delegation Application

Hi Behcet,

I hope I don't disturb you...

I have read today your "Problem Statement and Requirements for Diameter Prefix Delegation Application" draft and it is very interesting.

Regarding prefix delegation for PMIP there exists already a message exchange between LMA and an AAA server. Draft asdfasdf recommends a new AVP called PMIP-HOME-Prefix AVP which can be used within an AA-Request and AA-Answer message, while a LMA registered a new mobile session (PBU) on the AAA server. If the AAA server has authorized the mobile node and it has determined that mobile node’s HNP is not set, then the AAA server can act as DHCP client and request the DHCP server for a prefix (IA_PD option) and send the assigned prefix within a AA-Answer message to the LMA, subsequently.

IMHO there is no need for a new Diameter Prefix Delegation application regarding PMIP, as the mentioned draft defines a good solution to delegate a prefix from the AAA to the LMA --> AA-Request and the PMIP6-Home-Prefix AVP.

May be I’m wrong and you mean, that there should be a new Diameter Prefix application with new command types, which can be used ad-hoc without involving a AAA session registration exchange like the NASREQ application would it do with its AA-Request/Response messages.

Can you provide me some information on this, please? Are there already new Ideas regarding a Diameter application for prefix delegation?

BR,

Rafael.

-- 
Psssst! Schon vom neuen GMX MultiMessenger gehört?
Der kann`s mit allen: http://www.gmx.net/de/go/multimessenger
_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 16 Jun 2008 08:40:56 -0700 (PDT)

forwarding to dime list.

----- Forwarded Message ----
From: Behcet Sarikaya <[email-masked]>
To: Glen Zorn <[email-masked]>
Sent: Monday, June 16, 2008 10:36:49 AM
Subject: Re: [Dime] Diameter Prefix Delegation Application

Hi Glen,
  Prefixes are used to subnet a given network. The address assignment comes next based on the prefix. Subneting a network is done by the network administration/management. 
  draft-sarikaya-dime-prefix-delegation-ps suggests that AAA can be used in prefix delegation (from a delegating server to a requesting server) just like AAA is currently being used for address assignment.
  More details like per-MN prefix use in cellular links are in the draft.
Regards,

Behcet

----- Original Message ----
From: Glen Zorn <[email-masked]>
To: Frank Xia <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Sent: Sunday, June 15, 2008 2:48:15 AM
Subject: Re: [Dime] Diameter Prefix Delegation Application

Frank Xia [mailto:[email-masked]] writes:

> > Hi Frank,
> >
> > see inline,
> >
> > On Fri, Jun 13, 2008 at 5:58 PM, Frank Xia <[email-masked]>
> wrote:
> >> Hi Julien
> >>
> >> Thank for your comments!
> >>
> >> Just as IPv4 address management needs not only
> >> DHCPv4 solution but also AAA mechanisms,
> >> IPv6 prefix management as an extension of
> >> address mangement also needs  corresponding
> >> facilitis.
> >
> > we already have some facilities. That was the point of my mail.
> 
> Frank=>Diameter Prefix Delegation application  is a
> complementary not exclusive solution to
> the current existing facilitis.  It is useful for a variety of
> deployment
> scenarios which are possible beyond our reasoning imagination.
> 
> Here is my argument,  why do we need AAA solution for IPv4
> address management while there is a DHCP method?

What do you mean by "IPv4 address management"?  It is possible for both
RADIUS & Diameter to assign IPv4 addresses to user machines but that is
hardly "management" as I understand the term.  Are there other capabilities
of which I am unaware?

...

> A operator  wants to renumber it networks( although
> this is not a frequent practice). All the subscribers should
> replace their old prefixes by new advertised prefixes.

Just my point: Diameter is _not_ a general purpose network management
protocol & shouldn't become one.

> During renumbering time(a couple of hours or days),
> old application sessions continue using old IP addresses
> while new application sessions begin to use new IP addresses
> 
> The following are some references on renumbering.

The question isn't whether renumbering is a problem, it's if Diameter is the
right solution to that problem.  Just because you have a hammer doesn't mean
that everything is a nail :-)...

...

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 17 Jun 2008 08:29:33 -0700 (PDT)

Glen, Julien,
 This is what I wrote: some people (like myself, etc.) are saying that it will be nice to define this missing piece.
  Is it so difficult to agree with this statement ?
BTW, I disagree with your claim that it will be misuse of Diameter but if you state is like above I could agree.
Regards,

Behcet

----- Original Message ----
From: Julien Bournelle <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: Glen Zorn <[email-masked]>; [email-masked]
Sent: Tuesday, June 17, 2008 10:02:17 AM
Subject: Re: [Dime] Diameter Prefix Delegation Application

Hi behcet, all,

On Tue, Jun 17, 2008 at 4:48 PM, Behcet Sarikaya
<[email-masked]> wrote:
> Hi Glen,
>   The delegated prefixes could be used by the requesting router in RAs in
> order to realize per-MN prefixes in cellular networks like WiMAX, so the use
> is not much related to Session-Lifetime but rather to IP session as Frank
> pointed out.
>   The fact is that AAA is being used in managed networks for address
> management and in prefix delegation as per 4818. The only missing piece is
> the PD application.
>   Some people are saying that it will be nice to define this missing piece.
> Let's agree on this.

I don't. We already have mechanism for prefix delegation and I'm not
convinced by your
PS. Defining a whole Diameter Application for this seems a misuse of
Diameter to me.

Regards,

Julien

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 18 Jun 2008 12:41:26 -0700 (PDT)

----- Original Message ----
From: Glen Zorn <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Wednesday, June 18, 2008 12:54:12 PM
Subject: RE: [Dime] Diameter Prefix Delegation Application

Behcet Sarikaya
[mailto:[email-masked]] writes:

RFC 4818 defines an application (a mini
application) by which the delegating router gets a bunch of delegated prefixes
from AAA server that has them. 
RFC 4818 says nothing about a
"bunch" of prefixes, it says that "The Delegated-IPv6-Prefix MAY
appear in an Access-Accept packet, and  can appear multiple times."
OK, Multiple number of prefixes.

The
question is this: can you qualify this "application" as a valid AAA
application according to your qualification?

In my opinion it is because AAA server authorizes the use the prefixes by AAA
client. 
I'm not sure where you get either of these
ideas.  The AAA server is authorizing the use of the prefixes by the
requesting router, in this case taking the role of a NAS client;

OK the AAA server is AUTHORIZING the use of the prefixes by a NAS client.

it is not,
as you seem to think, simply handing out a bunch of prefixes for the RADIUS
client to delegate as it may please.   Please see RFC 3633 for
details on the operation of prefix delegation in DHCP.

I know RFC 3633.
I am hoping that we are now in agreement more than we were before.

----- Original Message ----
From: Glen Zorn <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: [email-masked]
Sent: Wednesday, June 18, 2008 11:10:31 AM
Subject: RE: [Dime] Diameter Prefix Delegation Application
Behcet Sarikaya [mailto:[email-masked]] writes:

Glen, 
  In your gut feeling, can you please assess RFC 4818 of which none of us
are coauthors vis-a-vis your statement?
it appears that the single application that is being discussed and
cannot be handled in Diameter NASREQ right now _has nothing to do with _user
authorization
 
I don't understand the question.

BTW, RFC 4818 applies to Diameter as well although the title mentions only Radius.
I'm aware of that.

Regards,

Behcet
----- Original Message ----
From: Glen Zorn <[email-masked]>
To: Frank Xia <[email-masked]>
Cc: [email-masked]; Behcet Sarikaya <[email-masked]>; Julien Bournelle
<[email-masked]>
Sent: Tuesday, June 17, 2008 2:11:19 PM
Subject: RE: [Dime] Diameter Prefix Delegation Application

Frank Xia [mailto:[email-masked]]
writes:

> Hi Glen
> 
> Please check my inline clarification...
> 
...

> >>
> >> IMHO,  Diameter as a AAA protocol
> >> can be used in dynamically authorization.
> >
> > Of _users_.
> Frank=>Most of cases in the diameter PS  are users' authorization
related,
such as LMA requesting prefix for it's PMIPv6 user,  access routers asking
for prefix for the mobile nodes attached.

I wrote: "it appears that the single application that is being discussed
and
cannot be handled in Diameter NASREQ right now _has nothing to do with _user
authorization__.  As I stated in my original message, I'd be happy to be
told that I'm mistaken about this but nobody's done that."  Still
true.

...