Subject: Re: [Dime] Rechartering: draft-sarikaya-dimeradext-prefix-auth-ps-00.txt

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 16 Jul 2008 08:15:54 -0700 (PDT)

Hi Julien,

----- Original Message ----
From: Julien Bournelle <[email-masked]>
To: Hannes Tschofenig <[email-masked]>
Cc: [email-masked]
Sent: Wednesday, July 16, 2008 3:14:15 AM
Subject: Re: [Dime] Rechartering: draft-sarikaya-dimeradext-prefix-auth-ps-00.txt

Hi,

On Tue, Jul 15, 2008 at 8:29 PM, Hannes Tschofenig
<[email-masked]> wrote:
> Document:
> http://www.ietf.org/internet-drafts/draft-sarikaya-dimeradext-prefix-auth-ps-00.txt
>
> * Who is able to be editor of the document?
>
> * Who is interested to help the editor with the work on the draft by
> co-authoring it?
>
> * Who is able to provide reviews?
>
> * Who is unable to actively help with a specific document but supports the
> work?
>
> * Are there concerns regarding this document?

As I said previously in the ML. I'm not convinced by this I-D. Basically
I don't see the need for a specific Diameter Application for Prefix Delegation.

[behcet] The new draft is about Prefix Authorization. Prefix Authorization is well within AAA domain capabilities. Are you saying no to this?

Regards,

Behcet
_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: "Julien Bournelle" <[email-masked]>
Date: Thu, 17 Jul 2008 10:20:53 +0200

Hi behcet,

On Wed, Jul 16, 2008 at 5:15 PM, Behcet Sarikaya
<[email-masked]> wrote:
> Subject: Re: [Dime] Rechartering:
> draft-sarikaya-dimeradext-prefix-auth-ps-00.txt
>
> Hi,
>
> [behcet] The new draft is about Prefix Authorization. Prefix Authorization
> is well within AAA domain capabilities. Are you saying no to this?

 I don't want to reenter in this discussion since we already did it :)

 I'm not convinced by your Problem Statement. We are already able to
deliver Prefix during network access AAA (e.g. NASREQ or EAP Diameter
Application). And I may be wrong but I don't see the need for a specific
application for this.

 Regards,

 Julien

---

From: Frank Xia <[email-masked]>
Date: Thu, 17 Jul 2008 10:45:33 -0500

Hi Julien

Let talk about a  specific issue which is dealt with in the draft.

Current prefix definition RFC4005 has no lifetime which
is necessary for IPv6 renumbering.
There is the same issue with RADIUS (RFC4818).

BR
Frank

----- Original Message ----- 
From: "Julien Bournelle" <[email-masked]>
To: "Behcet Sarikaya" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, July 17, 2008 3:20 AM
Subject: Re: [Dime] 
Rechartering:draft-sarikaya-dimeradext-prefix-auth-ps-00.txt

---

From: Frank Xia <[email-masked]>
Date: Thu, 17 Jul 2008 11:27:59 -0500

Hi Julien

Julien wrote" We are already able to
 deliver Prefix during network access AAA 
(e.g. NASREQ or EAP Diameter
 Application). And I may be wrong 
but I don't see the need for a specific
application for this."

The solution you refered to is tied to authentication.
In some scenarios, prefix delegation is independent
of  authentication.

The following is a case in in proxy mobile IPv6
1) MN initiates access authentication. 
    MAG (mobile access gateway) is as the authenticator.
2)MAG sends PBU(Proxy Binding Update) 
   to LMA (Local Mobile Anchor). In this message,
   PBU asks for a prefix for the MN
3)LMA uses Diameter for dynamical prefix requesting
4)LMA sends the prefix to the MAG.  

BR
Frank

---

From: "Julien Bournelle" <[email-masked]>
Date: Thu, 17 Jul 2008 20:08:23 +0200

Hi Frank,

 I think we are little bit looping since I have the impression that we
already had this discussion. However, see my reply inline.

> There is the same issue with RADIUS (RFC4818).

 Maybe the reason is that the lifetime of the prefix is implicit and
is the same as the lifetime of the network access authorization.
I may be wrong but I don't see why we would do "hard" renumbering.
I mean that if we want to do renumbering there will be a transition period
during which the obsolete and the new prefix will be in place.

 Do you have a specific deployment scenarios in mind ?

 Regards,

 Julien

>
> BR
> Frank
>
>
> ----- Original Message ----- From: "Julien Bournelle"
> <[email-masked]>

---

From: "Julien Bournelle" <[email-masked]>
Date: Thu, 17 Jul 2008 20:12:54 +0200

Hi again,

> 4)LMA sends the prefix to the MAG.

 For the PMIP6 case, we wrote an I-D:

 http://tools.ietf.org/id/draft-korhonen-dime-pmip6-03.txt

 which hopefully should become a WG item.

 And as you will see, we have some exchange between LMA and AAA but right before
we have some exchanges between MAG and the AAA.

 So even in this case, I wouldn't say that it is only Prefix
Delegation Authorization which
is needed but a whole application to do AAA in the PMIPv6 case.

 Julien

---

From: Frank Xia <[email-masked]>
Date: Thu, 17 Jul 2008 13:23:59 -0500

Hi Julien

IMO, If you are arguing the necessity of the IP renumbering,
I think we can stop discussing on the topic of lifetime of prefix,
because we have fundamental disagreement on this
issue.

BR
Frank

---

From: Frank Xia <[email-masked]>
Date: Thu, 17 Jul 2008 13:32:34 -0500

Hi Julien

You'd better keep the draft
http://tools.ietf.org/id/draft-korhonen-dime-pmip6-03.txt
in the current scope, and not mix with prefix delegation.

LMA prefix delegation is a separate topic which  probably
involves DHCP/RADIUS/DIAMETER  methods

BR
Frank