Subject: Re: [Dime] DISCUSS: draft-ietf-dime-qos-parameters

From: "Hannes Tschofenig" <[email-masked]>
Date: Sun, 1 Mar 2009 15:21:58 +0200

Hi Chris, 

We have updated the document to address your discuss: 
http://www.tschofenig.priv.at/svn/draft-tschofenig-dime-diameter-qos/draft-i
etf-dime-qos-parameters-10.txt

References have been added to the document as requested. 

Ciao
Hannes

>-----Original Message-----
>From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
>Sent: 26 February, 2009 11:49
>To: jouni korhonen; Jouni Korhonen; Hannes Tschofenig; 
>[email-masked]
>Cc: [email-masked]
>Subject: FW: DISCUSS: draft-ietf-dime-qos-parameters 
>
>Please refer to the DISCUSS below and propose the edits to 
>resolve the lack of references. 
>
>Thanks and Regards,
>
>Dan
>
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Chris Newman
>Sent: Thursday, February 26, 2009 8:44 AM
>To: [email-masked]
>Cc: [email-masked];
>[email-masked]
>Subject: DISCUSS: draft-ietf-dime-qos-parameters 
>
>Discuss:
>This document has the following flaws:
>
>1. It names the "Diameter" protocol without providing a 
>reference to the protocol specification.
>
>2. This uses a formal grammar to define protocol elements 
>without providing a reference to the definition of the formal grammar.
>
>I believe both problems are resolved by adding the missing 
>normative reference to the Diameter base specification.
>
>

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Sun, 1 Mar 2009 15:22:44 +0200

Hi Pasi, 

Thanks for pointing out a bug in these two sections regarding extensibility.
We have updated the draft to address your comments: 
http://www.tschofenig.priv.at/svn/draft-tschofenig-dime-diameter-qos/draft-i
etf-dime-qos-parameters-10.txt

Ciao
Hannes
 
>From: Pasi Eronen [mailto:[email-masked]] 
>Sent: 26 February, 2009 13:28
>To: [email-masked]
>The text about QoS Profile IDs (in last paragraph of Section 4 
>and Section 5.2) doesn't make sense as is. The intent probably 
>is that the first four octets are an IANA-assigned Enterprise 
>Number, and for the latter four octets, IANA maintains a 
>registry for Enterprise Number 0 (but for other Enterprise 
>Numbers, it's up to the owner how they're used).
>
>But that's not quite what the text currently says (in 4.2, the 
>sentence "If the four octets.." does not parse, and in 5.2, it 
>suddenty starts talking about OIDs ).
>
>Also, what's the IANA assignment policy for numbers 4096..4294967295?
>
>