Subject: [Dime] Allowed host and realm naming for a diameter node

From: Lars Jørgen Lillehovde <[email-masked]>
Date: Sun, 15 Mar 2015 12:53:54 +0100

Hi,

I'm trying to clarify the allowed naming convension for the host and realm
of a diameter node. This relates to the values used in the Origin-Host AVP
(AVP Code 264) and Origin-Realm AVP (AVP Code 296). I've reviewed the
Diameter RFCs and cannot find a definitive answer to this issue.

The reason for asking this question is that I'm in discussion with a vendor
of a Diameter Routing Agent (DRA) which claims that the host of a diameter
node has to be in the format host.realm.

(1) Example of the only allowed format according to the vendor:
Origin-Realm: example.com
Origin-Host: node.example.com

I want to clarify if multiple subdomains are allowed to be added in the
host without being present in the realm.
(2) Example:
Origin-Realm: example.com
Origin-Host: node.site1.example.com

According to the vendor, the example 2 is not allowed. To have the host as
in example 2, the realm will have to be site1.example.com.

Could someone please clarify this naming issue or point me to the standard
where this is defined.

Thank you.

Best regards,
Lars J. Lillehovde

---

From: <[email-masked]>
Date: Mon, 16 Mar 2015 08:45:19 +0000

Hi Lars,

According to the base protocol, there is no such restriction. When the DiameterIdentity format is used to identify a Diameter node, the only requirement is that:
* the DiameterIdentity value in Origin/Destination-Host AVP is an FQDN.
* there is at least one peer table in the realm identified by the Origin/Destination-Realm  AVP that contains the host identified by the FQDN.

So Example 2 is perfectly valid from a base protocol point of view, as long as there is at least one node in "example.com" with a transport connection with the peer "node.site1.example.com".

Now, some Diameter applications may have defined specific rules regarding the format of realm/host identity, with explicit restrictions/limitations. It is then required to check if there is any of these restrictions defined in the related specification.

Regards,

Lionel

De : DiME [mailto:[email-masked]] De la part de Lars Jørgen Lillehovde
Envoyé : dimanche 15 mars 2015 12:54
À : [email-masked]
Objet : [Dime] Allowed host and realm naming for a diameter node

Hi,

I'm trying to clarify the allowed naming convension for the host and realm of a diameter node. This relates to the values used in the Origin-Host AVP (AVP Code 264) and Origin-Realm AVP (AVP Code 296). I've reviewed the Diameter RFCs and cannot find a definitive answer to this issue.

The reason for asking this question is that I'm in discussion with a vendor of a Diameter Routing Agent (DRA) which claims that the host of a diameter node has to be in the format host.realm.

(1) Example of the only allowed format according to the vendor:
Origin-Realm: example.com<http://example.com>
Origin-Host: node.example.com<http://node.example.com>

I want to clarify if multiple subdomains are allowed to be added in the host without being present in the realm.
(2) Example:
Origin-Realm: example.com<http://example.com>
Origin-Host: node.site1.example.com<http://node.site1.example.com>

According to the vendor, the example 2 is not allowed. To have the host as in example 2, the realm will have to be site1.example.com<http://site1.example.com>.

Could someone please clarify this naming issue or point me to the standard where this is defined.

Thank you.

Best regards,
Lars J. Lillehovde

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.