Subject: Re: [Dime] [Technical Errata Reported] RFC6733 (4473)

From: Jouni Korhonen <[email-masked]>
Date: Tue, 6 Oct 2015 08:11:17 -0700

(trimming the TO: and CC: lists)

Quick comment on the proposed resolution. I think it is wrong since the 
text in 6.1.4 concerning Destination-Host is in the context of the 
request message i.e. there is no Destination-Host AVP present in the 
request. The proposed resolution now makes it into a context of the peer 
table content, which is not what the original text intended to say IMHO. 
Also there in no Destination-Host _AVP_ per se in the peer table as the 
proposed resolution now suggests.

- Jouni

9/14/2015, 12:58 AM, RFC Errata System kirjoitti:
> The following errata report has been submitted for RFC6733,
> "Diameter Base Protocol".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=6733&eid=4473
>
> --------------------------------------
> Type: Technical
> Reported by: Keshab Upadhya <[email-masked]>
>
> Section: 6.1.4
>
> Original Text
> -------------
> 6.1.4.  Processing Local Requests
>
> The Destination-Host AVP is not present, the Destination-Realm AVP
> contains a realm the server is configured to process locally, and
> the Diameter application is locally supported; or
>
>
> Corrected Text
> --------------
> 6.1.4.  Processing Local Requests
>
> The Destination-Host AVP is not present in peer routing table,
> the Destination-Realm AVP contains a realm the server is
> configured to process locally, and
> the Diameter application is locally supported; or
>
>
> Notes
> -----
> 6.1.4 - Processing Local Requests
>
>        The Destination-Host AVP is not present, the Destination-Realm AVP
>        contains a realm the server is configured to process locally, and
>        the Diameter application is locally supported
>
> 6.1.6 - Request Routing
>
>     When a request is received that includes a realm
>     and/or application that is not locally supported, the message is
>     routed to the peer configured
>
> As given above 6.1.4 second rule contradicts with 6.1.6 para 2.
>
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC6733 (draft-ietf-dime-rfc3588bis-33)
> --------------------------------------
> Title               : Diameter Base Protocol
> Publication Date    : October 2012
> Author(s)           : V. Fajardo, Ed., J. Arkko, J. Loughney, G. Zorn, Ed.
> Category            : PROPOSED STANDARD
> Source              : Diameter Maintenance and Extensions
> Area                : Operations and Management
> Stream              : IETF
> Verifying Party     : IESG
>

---

From: <[email-masked]>
Date: Tue, 6 Oct 2015 15:26:45 +0000

I agree with Jouni's answer. The proposed modification is not correct.
Moreover, it is difficult for me to understand the issue that needs to be addressed .
It would be easier to detail/discuss the issue on the mailing list and after see if there is something to correct in the RFC6733. 

Regards,

Lionel

-----Message d'origine-----
De : Jouni Korhonen [mailto:[email-masked]] 
Envoyé : mardi 6 octobre 2015 17:11
À : RFC Errata System; [email-masked]; [email-masked]; MORAND Lionel IMT/OLN; [email-masked]; [email-masked]
Objet : Re: [Technical Errata Reported] RFC6733 (4473)

Quick comment on the proposed resolution. I think it is wrong since the text in 6.1.4 concerning Destination-Host is in the context of the request message i.e. there is no Destination-Host AVP present in the request. The proposed resolution now makes it into a context of the peer table content, which is not what the original text intended to say IMHO. 
Also there in no Destination-Host _AVP_ per se in the peer table as the proposed resolution now suggests.

- Jouni

9/14/2015, 12:58 AM, RFC Errata System kirjoitti:
> The following errata report has been submitted for RFC6733, "Diameter 
> Base Protocol".
>
> contains a realm the server is configured to process locally, and the 
> Diameter application is locally supported; or
>
>
> Corrected Text
> --------------
> The Destination-Host AVP is not present in peer routing table, the 
> Destination-Realm AVP contains a realm the server is configured to 
> process locally, and the Diameter application is locally supported; or
>
>
> Notes
> -----
> use "Reply All" to discuss whether it should be verified or rejected. 
> When a decision is reached, the verifying party (IESG) can log in to 
> change the status and edit the report, if necessary.
>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.