Subject: [Dime] Mail regarding draft-ietf-dime-rfc3588bis

From: Villa Silvia <[email-masked]>
Date: Fri, 26 Oct 2018 12:44:07 +0000

Hello Diameter experts and funs,

I have a question on the interpretation of RFC 6733.

I have a Client Diameter that opens many Diameter Connections with different Origin-Hosts and the same Origin-Realm.
The Client need to send AAR in session with maintained state to a Server.

Where a Diameter Server will send requests in session such as RAR or ASR?

The Destination-Host-AVP must be valued with the Origin-Host-AVP of the AAR sent by the client or a different Destination-Host-AVP can be chosen by realm?

What would happen if the diameter connection will fell and lost?
The Diameter Server must/can/cannot choose to send the request to a different Destination-Host-AVP of the same Client Realm?

I cannot understand where is the limit between protocol rules and custom policy local develop solution.

Thank you.

Silvia

Internet Email Confidentiality Footer ** La presente comunicazione, con le informazioni in essa contenute e ogni documento o file allegato, e' rivolta unicamente alla/e persona/e cui e' indirizzata ed alle altre da questa autorizzata/e a riceverla. Se non siete i destinatari/autorizzati siete avvisati che qualsiasi azione, copia, comunicazione, divulgazione o simili basate sul contenuto di tali informazioni e' vietata e potrebbe essere contro la legge vigente (ad es. art. 616 C.P., D.Lgs n. 196/2003 Codice Privacy, Regolamento Europeo n. 679/2016/GDPR). Se avete ricevuto questa comunicazione per errore, vi preghiamo di darne immediata notizia al mittente e di distruggere il messaggio originale e ogni file allegato senza farne copia alcuna o riprodurne in alcun modo il contenuto. Al link seguente e' disponibile l'informativa Privacy: http://www.italtel.com/it/about/privacy/ ** This e-mail and its attachments are intended for the addressee(s) only and are confidential and/or may contain legally privileged information. If you have received this message by mistake or are not one of the addressees above, you may take no action based on it, and you may not copy or show it to anyone; please reply to this e-mail and point out the error which has occurred. Click here to read your privacy notice: http://www.italtel.com/it/about/privacy/

---

From: Yuval Lifshitz <[email-masked]>
Date: Sun, 28 Oct 2018 12:06:45 +0000 (UTC)

Hello Silvia,The server is expected to send the RAR to the same host from which the session was initialized (i.e the Destination-Host of the RAR should be the same as the Origin-Host of the AAR).
There is no requirement, however, to send the RAR on the same Diameter connection that was used to send the AAR. For example, if there was a connectivity issue with the client after the AAR was sent, that was resolved (client reconnected wit the same Diameter identity), and then the server want to send the RAR, it should be allowed to send it over the new connection to the same client (with the correct Destination-Host).
Another case is where the client is not directly connected to the server (i.e. a Diameter agent sits between them). In such a case the server may use "realm routing" and send the RAR on any Diameter connection that may reach the desired realm. However, even in this case, the Destination-Host of the RAR must be set to the correct Destination-Host, and it is up to the Diameter agent(s) to route the request to the correct client.
Hope this helps,
Yuval
    On Friday, October 26, 2018, 3:47:26 p.m. GMT+3, Villa Silvia <[email-masked]> wrote:  
 
  <!--#yiv4562165256 _filtered #yiv4562165256 {font-family:"Cambria Math";panose-1:2 4 5 3 5 4 6 3 2 4;} _filtered #yiv4562165256 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;}#yiv4562165256 #yiv4562165256 p.yiv4562165256MsoNormal, #yiv4562165256 li.yiv4562165256MsoNormal, #yiv4562165256 div.yiv4562165256MsoNormal {margin:0cm;margin-bottom:.0001pt;font-size:11.0pt;font-family:"Calibri", sans-serif;}#yiv4562165256 a:link, #yiv4562165256 span.yiv4562165256MsoHyperlink {color:#0563C1;text-decoration:underline;}#yiv4562165256 a:visited, #yiv4562165256 span.yiv4562165256MsoHyperlinkFollowed {color:#954F72;text-decoration:underline;}#yiv4562165256 span.yiv4562165256StileMessaggioDiPostaElettronica17 {font-family:"Calibri", sans-serif;color:windowtext;}#yiv4562165256 .yiv4562165256MsoChpDefault {font-family:"Calibri", sans-serif;} _filtered #yiv4562165256 {margin:70.85pt 2.0cm 2.0cm 2.0cm;}#yiv4562165256 div.yiv4562165256WordSection1 {}-->
Hello Diameter experts and funs,

 

 

 

 

Thank you.

Silvia

 Internet Email Confidentiality Footer ** La presente comunicazione, con le informazioni in essa contenute e ogni documento o file allegato, e' rivolta unicamente alla/e persona/e cui e' indirizzata ed alle altre da questa autorizzata/e a riceverla. Se non siete i destinatari/autorizzati siete avvisati che qualsiasi azione, copia, comunicazione, divulgazione o simili basate sul contenuto di tali informazioni e' vietata e potrebbe essere contro la legge vigente (ad es. art. 616 C.P., D.Lgs n. 196/2003 Codice Privacy, Regolamento Europeo n. 679/2016/GDPR). Se avete ricevuto questa comunicazione per errore, vi preghiamo di darne immediata notizia al mittente e di distruggere il messaggio originale e ogni file allegato senza farne copia alcuna o riprodurne in alcun modo il contenuto. Al link seguente e' disponibile l'informativa Privacy: http://www.italtel.com/it/about/privacy/ ** This e-mail and its attachments are intended for the addressee(s) only and are confidential and/or may contain legally privileged information. If you have received this message by mistake or are not one of the addressees above, you may take no action based on it, and you may not copy or show it to anyone; please reply to this e-mail and point out the error which has occurred. Click here to read your privacy notice: http://www.italtel.com/it/about/privacy/_______________________________________________
DiME mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dime

---

From: Villa Silvia <[email-masked]>
Date: Mon, 29 Oct 2018 16:23:02 +0000

Thank you very much for your answer Yuval.

Do you think that is allowed to a Diameter Client sending a subsequent AAR for a Session by a different Origin-Host?
What do you think server will do?

Let me clarify...

I have this Diameter Client that opens many Diameter Connections with different Origin-Hosts and the same Origin-Realm.

Suppose that the Client sends an AAR for a new Session by Diameter-Connection-1 and Origin-Host-1.
Suppose that the Diameter-Connection-1 will fell and lost.
It shall be permissible for the Client to send subsequent re-auth for the same Session-Id by a Diameter-Connection-2 and Origin-Host-2?
The Server is required to update the Destination-Host associated to the Session-Id (like Target Refresh Requests in SIP dialogs)?
And so all subsequent RAR or ASR will be sent by Server to the Diameter-Connection-2 and Destination-Host-2.

Thank you again, Yuval.

Silvia

Da: Yuval Lifshitz [mailto:[email-masked]]
Inviato: domenica 28 ottobre 2018 13:07
A: [email-masked]; Villa Silvia <[email-masked]>
Oggetto: Re: [Dime] Mail regarding draft-ietf-dime-rfc3588bis

Hello Silvia,
The server is expected to send the RAR to the same host from which the session was initialized (i.e the Destination-Host of the RAR should be the same as the Origin-Host of the AAR).

Hope this helps,

Yuval

On Friday, October 26, 2018, 3:47:26 p.m. GMT+3, Villa Silvia <[email-masked]<mailto:[email-masked]>> wrote:

Thank you.

Silvia

Internet Email Confidentiality Footer ** La presente comunicazione, con le informazioni in essa contenute e ogni documento o file allegato, e' rivolta unicamente alla/e persona/e cui e' indirizzata ed alle altre da questa autorizzata/e a riceverla. Se non siete i destinatari/autorizzati siete avvisati che qualsiasi azione, copia, comunicazione, divulgazione o simili basate sul contenuto di tali informazioni e' vietata e potrebbe essere contro la legge vigente (ad es. art. 616 C.P., D.Lgs n. 196/2003 Codice Privacy, Regolamento Europeo n. 679/2016/GDPR). Se avete ricevuto questa comunicazione per errore, vi preghiamo di darne immediata notizia al mittente e di distruggere il messaggio originale e ogni file allegato senza farne copia alcuna o riprodurne in alcun modo il contenuto. Al link seguente e' disponibile l'informativa Privacy: http://www.italtel.com/it/about/privacy/ ** This e-mail and its attachments are intended for the addressee(s) only and are confidential and/or may contain legally privileged information. If you have received this message by mistake or are not one of the addressees above, you may take no action based on it, and you may not copy or show it to anyone; please reply to this e-mail and point out the error which has occurred. Click here to read your privacy notice: http://www.italtel.com/it/about/privacy/
_______________________________________________
DiME mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dime
Internet Email Confidentiality Footer ** La presente comunicazione, con le informazioni in essa contenute e ogni documento o file allegato, e' rivolta unicamente alla/e persona/e cui e' indirizzata ed alle altre da questa autorizzata/e a riceverla. Se non siete i destinatari/autorizzati siete avvisati che qualsiasi azione, copia, comunicazione, divulgazione o simili basate sul contenuto di tali informazioni e' vietata e potrebbe essere contro la legge vigente (ad es. art. 616 C.P., D.Lgs n. 196/2003 Codice Privacy, Regolamento Europeo n. 679/2016/GDPR). Se avete ricevuto questa comunicazione per errore, vi preghiamo di darne immediata notizia al mittente e di distruggere il messaggio originale e ogni file allegato senza farne copia alcuna o riprodurne in alcun modo il contenuto. Al link seguente e' disponibile l'informativa Privacy: http://www.italtel.com/it/about/privacy/ ** This e-mail and its attachments are intended for the addressee(s) only and are confidential and/or may contain legally privileged information. If you have received this message by mistake or are not one of the addressees above, you may take no action based on it, and you may not copy or show it to anyone; please reply to this e-mail and point out the error which has occurred. Click here to read your privacy notice: http://www.italtel.com/it/about/privacy/

---

From: Villa Silvia <[email-masked]>
Date: Mon, 29 Oct 2018 16:40:37 +0000

A new request in line

Hello Silvia,

[SILVIA] I would like to check if I understood this last sentence well.
In this last case where there is an agent between server and client..
The server can select a different routing street by “realm routing” so that server can send the RAR or ASR to a different diameter agent peer (compared to that used for the AAR).
However, server must anyway insert in this RAR the specific Destination-Host-AVP that must be the same as the Origin-Host of the AAR.
So that the new diameter agent peer will deliver the RAR always to the same “Client Origin-Host and Connection”.
It is correct?
I'm sorry if I ask you again but I do not know if I understood the second case correctly
Thank you very much.
Silvia

Hope this helps,

Yuval

Thank you.

Silvia

---

From: Yuval Lifshitz <[email-masked]>
Date: Wed, 31 Oct 2018 10:00:27 +0200

inline
> I'm sorry if I ask you again but I do not know if I understood the second case correctly

[yuval] yes, your understanding is correct

---

From: Yuval Lifshitz <[email-masked]>
Date: Wed, 31 Oct 2018 10:20:48 +0200

While it may be that some servers will allow that (folowing the "Robustness Principle"), the client should not do that.
Note that even in the case that the server don't mind the change in Origin-Host, it is most likely because it ignores it, and will not update the value - either way, this is server specific implementation and not part of the spec.
If the client just reconnected to the server, than the Diameter session should just continue, using the original parameters (including Origin-Host).
If the client went down, and a different client took over, than the client is either expected to start a new session (the common case where the client is stateless) whith a new Origin-Host, or to continue the same session (if the client is stateful) with the old Origin-Host.

Yuval