Subject: [Diversity] English translator and grammar tool

From: "George, Wes" <[email-masked]>
Date: Tue, 17 Jun 2014 16:07:59 -0400

Just saw this article today on a text tool called Ginger Page (http://www.gingersoftware.com/ginger-for-windows) that purports to help with translation and correction of spelling and grammar with some knowledge of context, and specifically mentions non-native English speakers as a target user group. It supports several browsers via an extension, mobile devices, as well as windows. The free version appears to be functional, with the exception that once a certain weekly usage threshold is reached, automatic corrections don’t happen anymore, it just flags the errors and you have to correct them manually.

I have no idea whether its translation is any more accurate than Google’s, nor how it will handle the IETF’s technical English, which often is (with apologies to Douglas Adams) almost, but not entirely, unlike actual English. However, I thought that it might be helpful if we are doing additional document language editing sessions at subsequent IETFs to maybe test it out with a non-native speaker so that a native speaker can evaluate the output to see if it might be a useful tool to add to our toolkit.
http://lifehacker.com/ginger-page-translates-for-you-makes-sure-your-english-1591785610

Thanks,

Wes George

Anything below this line has been added by my company’s mail server, I have no control over it.
-----------

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 18 Jun 2014 10:45:05 +0000

Thanks for the pointer.
I installed the free version.
I just uninstalled it.

This is one of those obnoxious programs that sits in the background,
randomly highlights words on your screen
and waits to pounce when it believes it knows what you want to say better than you do.
(Were it to be a standalone program I perhaps would have left it for occasional use, or at least more testing.)
Its UI is uncomfortable to use (for example, you can’t jump back and forth while translating, as in Google Translate,
and I didn’t find any way to globally accept or reject its suggestions with respect to a given rule).

Its knowledge of grammar seems to be on a par with the tools that come with Microsoft Office (in other words, dismal).
Its re-phrase feature is very limited, offering meaningless local swaps
(change “minimum” to “minimal”), but not reordering clumsy sentences.

The translation (I only tried Hebrew to English and French to English) is not at the level of Google Translate.
Its knowledge of technical terms is nonexistent.
English sentences produced were perhaps less stilted, but it mistranslated common expressions,
and was completely at loss when a word had more than one meaning.
For example, a word that I would have translated as “contingent upon” came out as “depends” –
when I asked for an alternative it returned “junky”.

I didn’t bother with the tests I usually perform on state-of-the-art automatic translation systems.
I just uninstalled.

Y(J)S

From: WGChairs [mailto:[email-masked]] On Behalf Of George, Wes
Sent: 17 June, 2014 23:08
To: [email-masked]
Cc: [email-masked]
Subject: English translator and grammar tool

Thanks,

Wes George