Subject: Re: [Diversity] [Mentoring-coordinators] Participation in active IETF work (was: Interim step on meetings site feedback for sites currently under active consideration)

From: <[email-masked]>
Date: Tue, 19 Apr 2016 14:37:03 +0000 (UTC)

Dave

On 4/19/2016 7:20 AM, [email-masked] wrote:
> 1.  Internet draft review teams (already started)
..
> 3.  Internet draft critique teams (will start time after next!)  Help
> people who have a draft make it better.

>Nalini,

>Can you clarify the difference between these two activities?  In the 
>IETF, 'review' usually involves critical analysis.

>My guess is that you intend the two efforts to come at different times 
>and to have people who differ in their relationship to the document 
>development process.  But that's just a guess and it's not very specific.
 Yes.  I think I need a different name for the activity #3.
What I was thinking is:
3.  Internet Draft Author Assistance:  The team will help an author who is due to present at an upcoming IETF.  etc, etc.

But, as I think more, we probably need a step in between, as in:
3.  Internet Draft Author Assistance: Phase 1:  The team will help an author who has a draft but does not have an agenda slot.  The group will help the author solidify his / her ideas, see where there are holes in the logic, etc.

4.  Internet Draft Author Assistance: Phase 2:  The team will help an author who is due to present at an upcoming IETF.  etc, etc

Nalini

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 19 Apr 2016 09:49:51 -0500

You folks are doing just fine with this, but ...

On Tue, Apr 19, 2016 at 9:37 AM, <[email-masked]> wrote:

> 3.  Internet Draft Author Assistance:  The team will help an author who is
> due to present at an upcoming IETF.  etc, etc.
>
>
> 3.  Internet Draft Author Assistance: Phase 1:  The team will help an
> author who has a draft but does not have an agenda slot.  The group will
> help the author solidify his / her ideas, see where there are holes in the
> logic, etc.
>

Could I suggest that you focus on something like "hasn't attracted the
attention of a working group", rather than "does not have an agenda slot"?

If the working group doesn't pay attention, the draft isn't going anywhere,
whether you have an agenda slot or not.

There are working group chairs who give agenda slots to drafts that don't
have the attention of a working group, just because they have time
available (after dealing with all chartered items, of course). That isn't
nearly as significant as presenters think it is.

Helping people who have the attention of a working group prepare for
presentations is, of course, fine.

Spencer

> 4.  Internet Draft Author Assistance: Phase 2:  The team will help an
> author who is due to present at an upcoming IETF.  etc, etc
>
> Nalini
>
>
>
>

---

From: Dave Crocker <[email-masked]>
Date: Tue, 19 Apr 2016 07:54:42 -0700

> attention of a working group", rather than "does not have an agenda slot"?

+1

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Dave Crocker <[email-masked]>
Date: Tue, 19 Apr 2016 08:04:10 -0700

>  > people who have a draft make it better.
...
> 3.  Internet Draft Author Assistance:  The team will help an author who
> is due to present at an upcoming IETF.  etc, etc.

Oh.  Yeah, that sounds extremely useful.

> help the author solidify his / her ideas, see where there are holes in
> the logic, etc.
>

So, there's a challenge in designing an overall approach this is simple 
and useful.  It will help quite a bit to create a careful list of the 
different kinds of help that might be provided, but I suspect the actual 
work needs to be divided into only a small number of of different groups.

My immediate thought is that you might want something like:

    1. Document Development Mentors

       These are the folk who help an author create a readable and 
useful document and help them interact with the working group. They have 
continuing 'context' for the work.  I suspect they also would help the 
author prepare for a presentation.

    2. Document Reviewers

       These would be outside readers who would comment informally.  In 
effect, they would augment the commentary of the document mentors.

d/

-- 

   Dave Crocker

---

From: Dave Crocker <[email-masked]>
Date: Tue, 19 Apr 2016 08:02:38 -0700

...

    2. Document Reviewers

d/

-- 

   Dave Crocker

---

From: <[email-masked]>
Date: Tue, 19 Apr 2016 15:02:57 +0000 (UTC)

>Could I suggest that you focus on something like "hasn't attracted the attention of a working group", rather than "does not have an agenda slot"? 
>If the working group doesn't pay attention, the draft isn't going anywhere, whether you have an agenda slot or not.
>There are working group chairs who give agenda slots to drafts that don't have the attention of a working group, just because they have time available (after dealing with all chartered >items, of course). That isn't nearly as significant as presenters think it is.
>Helping people who have the attention of a working group prepare for presentations is, of course, fine.

Yes.  I think that is very good.  There are multiple reasons why a draft doesn't attract the attention of a working group.   That could be a very fruitful conversation.
But, I what I actually meant is that the draft was written but not really ready for "prime time", if you will.   Just in my experience, it seems that once you have a network of people within the IETF, then if you have a draft that you are not quite ready to post to the WG email list, you ask people privately if they will review.   And others ask you.  I am doing that right now for someone else before they post.
But for people who don't have a network, then this is to help them.   I think it is very good to ask for private review first.  So, maybe we call it that:
As in:
3.  Internet Draft Author: Private Review: Prior to posting to the public email list for your WG.
You actually bring up the topic of "problems progressing your draft", I think.  A big topic.
Nalini

---

From: <[email-masked]>
Date: Tue, 19 Apr 2016 15:13:00 +0000 (UTC)

>effect, they would augment the commentary of the document mentors.

Dave, I like this approach a lot.   I think the document development mentors should be of two types :
1.  in native language (if needed)
2. English
I also think that if people wanted help in making their draft more readable - I am just talking about the English part of it, then maybe we need:

1.5  English Review Mentors
These are people who will just review for grammar, sentence construction, readability, etc.

The idea is that before you even post, you have done a lot of homework & review.  I think a nicely written, well-thought out draft, is more likely to attract the attention of the WG.  Putting your best foot forward, as it were!
Nalini

---

From: Dave Crocker <[email-masked]>
Date: Tue, 19 Apr 2016 08:24:38 -0700

On 4/19/2016 8:13 AM, [email-masked] wrote:
> I also think that if people wanted help in making their draft more
> readable - I am just talking about the English part of it, then maybe we
> need:
>

Well, my experience for such documents is that the mentor needs to get 
deeply into the substance of the document and the process needs to be 
extended.

In my experience, simple language help is easy, but frankly not that 
common or at least not really different from what drafts by 'native' 
English speakers need.

The real challenge is developing an adequate understanding of what the 
author /intends/ and then helping to figure out how to write that well.

And for reference, it's not uncommon to have a draft from a 'native' 
English speaker that also needs this sort of help...

d/
-- 

   Dave Crocker

---

From: <[email-masked]>
Date: Tue, 19 Apr 2016 16:35:22 +0000 (UTC)

English speakers need.

>English speaker that also needs this sort of help...

 I think you are right on all counts.  I have seen some very horrible prose from native English speakers.
But, the mentoring program is not just for non-native English speakers.  It is for all IETFers.
Having said all this, this is a great discussion but really better to be had close to IETF97 when such mentoring programs will start.   I will keep all these notes but we have some immediate issues with the current Internet Draft Review teams.
So far we have 25 people signed up.  So far, so good.  But the issue is that I can only form 2 teams out of these.  These are formed:  
1) Spanish : DNSOP
2) English: 6lo / 6tisch
Now, I have told the teams to go off & decide what drafts they want to review.  Great.
But, the problem is that I am left with a bunch of singletons, as it were.  That is, one person who wants to speak Spanish & work on TLS, for example.   So, I need a bigger pool to get more matches.  (Why do I feel like eharmony?)
I think that if the people leading the remote hubs could publicize the initiative, then we would probably get more people.  Any other ideas?   I think we are probably good for a week or so, but then pool size will become the problem preventing expansion.
Nalini

---

From: Dave Crocker <[email-masked]>
Date: Tue, 19 Apr 2016 09:38:48 -0700

On 4/19/2016 9:35 AM, [email-masked] wrote:
> think you are right on all counts.  I have seen some very horrible prose
> from native English speakers.
>

Nalini,

There is an appealingly subversive possibility in this:  Getting 
"outside" people to review work much earlier in its lifecycle.  We have 
long lamented the fact that we do reviews late in the cycle, after a 
great deal of energy has been expended and people have become 
entrenched.  Getting others to review the work early it its development 
could do considerably more than improve its writing...

d/

-- 

   Dave Crocker

---

From: <[email-masked]>
Date: Tue, 19 Apr 2016 16:52:38 +0000 (UTC)

>could do considerably more than improve its writing...

Indeed.
The mentoring initiative I want to start after Berlin is for people to solicit a team to work with them to co-author a draft.  That is, person x has an idea (but no draft), he / she gets 5 minutes & 2 foils to present the idea in a webinar.   Others on the webinar ask questions for another 5-10 minutes.   Then, if people would like, they can tell person x that they would be interested in being a co-author.
If person x gets no takers as far as co-authors, he / she may wish to draw the inevitable conclusion.
Of course, if person x feels that they have not fairly represented themselves, they can have a second chance.  But, after the second time, and still no takers ....
BTW, no third chances.
Nalini

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 20 Apr 2016 17:04:52 +0200

Hi Nalini,

I agree with you, but I will add that there are many people want to
participate in IDs but there are problems with some of the WG culture, no
secret. So The is a language of argument and discussion that new people may
not get use to, which is needed in such WG culture.

AB

On Tue, Apr 19, 2016 at 6:52 PM, <[email-masked]> wrote:

> The mentoring initiative I want to start after Berlin is for people to
> solicit a team to work with them to co-author a draft.  That is, person x
> has an idea (but no draft), he / she gets 5 minutes & 2 foils to present
> the idea in a webinar.   Others on the webinar ask questions for another
> 5-10 minutes.   Then, if people would like, they can tell person x that
> they would be interested in being a co-author.
>
> Of course, if person x feels that they have not fairly represented
> themselves, they can have a second chance.  But, after the second time, and
> still no takers ....
>
> BTW, no third chances.
>
> Nalini
>
>
>
>
> _______________________________________________
> diversity mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/diversity
>
>

---

From: <[email-masked]>
Date: Wed, 20 Apr 2016 15:16:26 +0000 (UTC)

>I agree with you, but I will add that there are many people want to participate in IDs but there are problems with some of the WG culture, no secret. So The is a language of argument and >discussion that new people may not get use to, which is needed in such WG culture.

Abdussalam,

Yes, the IETF culture has its strengths and drawbacks.  In fact, you may want to take a look at:

https://datatracker.ietf.org/doc/draft-elkins-ietf-unwritten-rules-values/

This is a presentation that we have started doing for new people at IETF.  It seems to have been quite well received.  So far, I am talking to people from Japan, China, & Latin America to translate into their own languages.  

You may also wish to look at:

https://www.ietf.org/tao.html

I suspect that the discussion style of "very frank" feedback may be what you are referring to?  Am I correct?

If I might, the goal of discussions is to have the best engineering solution come out.  And, I know sometimes people get passionate in their arguments and give feedback maybe a bit more directly than is considered normal in a number of cultures.

In my opinion, passion is good.   We need to care and care a LOT about what we do.  That is what will make the work good.

Definitely, people need to be kinder and more sensitive in how they give their feedback.  Is this what you are talking about?

I wonder if we should have mentoring workshops on "How to Give and Receive Feedback".    Just trying to get from you what you are thinking.

Nalini