Subject: Re: [dnssd] Last Call: <draft-ietf-dnssd-requirements-04.txt> (Requirements for Scalable DNS-SD/mDNS Extensions) to Informational RFC

From: Stuart Cheshire <[email-masked]>
Date: Tue, 03 Mar 2015 16:09:46 -0800

On 5 Jan, 2015, at 03:44, Markus Stenberg <[email-masked]> wrote:

> - REQ5: I am not sure what ‘integrate’ means here. Unidirectional access (SSD -> DNS-SD/mDNS? SSD <- DNS-SD/mDNS?)? Bidirectional?

Is this better?

   REQ5:   SSD should leverage and build upon with current link scope
           DNS-SD/mDNS protocols and deployments.

Stuart Cheshire

---

From: David Farmer <[email-masked]>
Date: Tue, 03 Mar 2015 19:03:42 -0600

>             DNS-SD/mDNS protocols and deployments.

The original wording at least implied some level of interoperability, 
I'm not sure "leverage and build upon" does that.  It sound more like 
code reuse is important rather than interoperability.

     REQ5:   SSD should inter-operate with current link scope
             DNS-SD/mDNS protocols and deployments to the extent
             practicable.

I think my answer to the question is bidirectional would be the best 
case.  But, remember these are competing requirements to be balanced. 
So, in the worst case ships-in-the-night meets REQ5 and REQ6.

-- 
================================================
David Farmer               Email: [email-masked]
Office of Information Technology
University of Minnesota
2218 University Ave SE     Phone: 1-612-626-0815
Minneapolis, MN 55414-3029  Cell: 1-612-812-9952
================================================

---

From: Stuart Cheshire <[email-masked]>
Date: Tue, 03 Mar 2015 17:08:31 -0800

On 3 Mar, 2015, at 17:03, David Farmer <[email-masked]> wrote:

> The original wording at least implied some level of interoperability, I'm not sure "leverage and build upon" does that.  It sound more like code reuse is important rather than interoperability.
> 
> I think my answer to the question is bidirectional would be the best case.  But, remember these are competing requirements to be balanced. So, in the worst case ships-in-the-night meets REQ5 and REQ6.

No, it’s more device reuse than code reuse. You shouldn’t have to buy a new printer to use it with SSD. Or new network cameras, home thermostats, etc.

No it’s not a bidirectional requirement. It’s unidirectional:

A modern client needs to be able to discover a ten-year-old printer even when it’s remote.

The ten-year-old printer doesn’t need to discover anything new.

Stuart Cheshire

---

From: David Farmer <[email-masked]>
Date: Tue, 03 Mar 2015 19:28:13 -0600

> No, it’s more device reuse than code reuse. You shouldn’t have to buy a new printer to use it with SSD. Or new network cameras, home thermostats, etc.

Agreed.

> The ten-year-old printer doesn’t need to discover anything new.

If possible I'd like both an old client to discover a new printer, as 
well as a new client to discover an old printer.  That was my 
interpretation of bidirectional.