Subject: [dnssd] Fwd: New Version Notification for draft-pusateri-dnsop-private-subdomains-00.txt

From: Tom Pusateri <[email-masked]>
Date: Mon, 11 Mar 2019 20:26:14 -0400

During the re-charter discussion last summer in Montréal, I presented some observations about service discovery to help focus our future work.

1. We should transition from using mDNS to using unicast DNS when possible for privacy, performance, and resource conservation. When we do use multicast, it should be for initial discovery but not for data transfer.
2. Some services are personal. Some services are meant to be openly shared, some are private.
3. Some services are location dependent but not necessarily network attachment dependent. Think on campus but attached cellular.

The Update proxy that I submitted on 12 Feb is meant to stimulate a discussion for #1.

This drafty draft below is meant for discussion on #2. It describes a method of creating personal subdomains for sharing private services. Unlike some of the other privacy solutions being discussed, it is not intended for use over mDNS but only over unicast DNS. Since it is still a work in progress, it would benefit from some other collaborators and so if you read the draft and have some contributions to make, I would love to work together. Protecting service discovery is not a security solution on its own. It’s just one more piece of the puzzle to not leak private information.

Thanks and see you in Prague.

Tom

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-pusateri-dnsop-private-subdomains-00.txt
> Date: March 11, 2019 at 4:06:37 PM EDT
> To: "Tom Pusateri" <[email-masked]>
> 
> 
> A new version of I-D, draft-pusateri-dnsop-private-subdomains-00.txt
> has been successfully submitted by Tom Pusateri and posted to the
> IETF repository.
> 
> Name:		draft-pusateri-dnsop-private-subdomains
> Revision:	00
> Title:		Private DNS Subdomains
> Document date:	2019-03-11
> Group:		Individual Submission
> Pages:		10
> URL:            https://www.ietf.org/internet-drafts/draft-pusateri-dnsop-private-subdomains-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-pusateri-dnsop-private-subdomains/
> Htmlized:       https://tools.ietf.org/html/draft-pusateri-dnsop-private-subdomains-00
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-pusateri-dnsop-private-subdomains
> 
> 
> Abstract:
>   This document describes a method of providing private DNS subdomains
>   such that each subdomain can be shared among multiple devices of a
>   single owner or group.  A private subdomain can be used for sharing
>   personal services while increasing privacy and limiting knowledge of
>   scarce resources.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 12 Mar 2019 00:21:18 -0400

It just occurred to me that I made the solution for query/responses overly complex in order to use caching at existing resolvers. The more obvious and simple solution is to directly query the authoritative servers using signed queries over TLS. This should remove the entire encoding/decoding encrypted resource record text. I don’t think this causes a problem because the number of devices is likely small and the query rate low.

I’ll push out another version shortly on github but it won’t get published in the internet-draft archive until the freeze is lifted. So keep that in mind if you read this before the -01 version is available.

Thanks,
Tom

> On Mar 11, 2019, at 8:26 PM, Tom Pusateri <[email-masked]> wrote:
> 
>> From: [email-masked] <mailto:[email-masked]>
>> To: "Tom Pusateri" <[email-masked] <mailto:[email-masked]>>
>> 
>> 
>> URL:            https://www.ietf.org/internet-drafts/draft-pusateri-dnsop-private-subdomains-00.txt <https://www.ietf.org/internet-drafts/draft-pusateri-dnsop-private-subdomains-00.txt>
>> Status:         https://datatracker.ietf.org/doc/draft-pusateri-dnsop-private-subdomains/ <https://datatracker.ietf.org/doc/draft-pusateri-dnsop-private-subdomains/>
>> Htmlized:       https://tools.ietf.org/html/draft-pusateri-dnsop-private-subdomains-00 <https://tools.ietf.org/html/draft-pusateri-dnsop-private-subdomains-00>
>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-pusateri-dnsop-private-subdomains <https://datatracker.ietf.org/doc/html/draft-pusateri-dnsop-private-subdomains>
>> 
>> 
>> Abstract:
>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>> 
>> The IETF Secretariat
>> 
> 
> _______________________________________________
> dnssd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnssd

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 12 Mar 2019 01:01:28 -0400

Sorry for the noise. The updated version can be found here:

https://github.com/pusateri/draft-pusateri-dnsop-private-subdomains/blob/master/draft-pusateri-dnsop-private-subdomains.txt <https://github.com/pusateri/draft-pusateri-dnsop-private-subdomains/blob/master/draft-pusateri-dnsop-private-subdomains.txt>

I’ll keep tuning it and submit it on 3/23 when draft submission opens up again.

Thanks,
Tom

> On Mar 12, 2019, at 12:21 AM, Tom Pusateri <[email-masked]> wrote:
> 
>> On Mar 11, 2019, at 8:26 PM, Tom Pusateri <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> [email-masked] <mailto:[email-masked]>