Subject: [dnssd] I-D Action: draft-ietf-dnssd-mdns-relay-02.txt

From: [email-masked]
Date: Mon, 11 Mar 2019 14:59:02 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Extensions for Scalable DNS Service Discovery WG of the IETF.

        Title           : Multicast DNS Discovery Relay
        Authors         : Ted Lemon
                          Stuart Cheshire
	Filename        : draft-ietf-dnssd-mdns-relay-02.txt
	Pages           : 29
	Date            : 2019-03-11

Abstract:
   This document complements the specification of the Discovery Proxy
   for Multicast DNS-Based Service Discovery.  It describes a
   lightweight relay mechanism, a Discovery Relay, which, when present
   on a link, allows remote clients, not attached to that link, to
   perform mDNS discovery operations on that link.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dnssd-mdns-relay/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dnssd-mdns-relay-02
https://datatracker.ietf.org/doc/html/draft-ietf-dnssd-mdns-relay-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dnssd-mdns-relay-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Jan Komissar (jkomissa)" <[email-masked]>
Date: Fri, 22 Mar 2019 22:27:03 +0000

Hi,

A few comments on this draft:

Section 2 Terminology (pg. 4)
========================
Nit: I would insert this phrase, just be very clear:
Discovery Relay		A network service, as specified by this document, which...

multicast link:
It seems kind of odd that this paragraph contains part of the rationale for the creation of this new service discovery infrastructure. Might it not be better placed elsewhere in the document?

Section 4: Pg 9:
=============
First para: Line 3: … FQDN as *an* Authentication…

Section 8 DSP TLVs, pg 14
=====================
Nit: This document defines the largest number of DSO TLVs of any document so far. I suggest dropping the word "modest."

Section 8.2 mDNS Link Data Discontinue, pg 14
=======================================
Para 1, Line 4, nit: Remove the first instance of "32-bit." (See Secs 8.1 & 8.3)

Section 8.10 Link Prefix, pg 17
=====================
Last line: Should "secondary TLV" be "additional TLV?"

Section 9.1.1 Multicast Link
=====================
Pg 19
Under link-identifier: I would prefer that the link identifiers are unique within each Relay. A Relay SHOULD assign permanent identifiers as links are created, stored in non-volatile memory or generated using a repeatable algorithm. The Discovery Proxy could prefix the link identifier with the Relay name or an internal Relay id. It could be useful to include a TLV to query a Relay for a table of all the links and their on-device defined names (preferably names that can be easily mapped to physical interfaces and/or appear in its user interfaces' representation thereof) and possible some indication of bandwidth. See section 9.1.3, pg 22, last para (before 9.2).

Under hr-name: Does "rich text" mean UTF-8? (like in draft-ietf-dnssd-hybrid-09, sec 5.1, pg. 9 etc.)

Section 9.1.3 Discovery Relay
=====================
pg 22, last para (before 9.2): Although "the details of this sort of configuration are not specified…," maybe it should define a method to extract its results. See comments to link-identifier, above.

Section 9.2 Configuration Files
=====================
pg 23
In Links upstairs-wifi & downstairs-wifi, should "name" be "hr-name"?

Following my comments to 9.1.1 link-identifier, the Link configurations could look like:
Link upstairs-wifi
  id upstairs.en0
  hr-name Upstairs Wifi

Link upstairs-wired
  id upstairs.en1
  hr-name Upstairs Wired

=======

Regards,

Jan.

On 3/11/19, 6:02 PM, "dnssd on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    
    Abstract:

    

    
    _______________________________________________
    dnssd mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/dnssd