Subject: [dnssd] I-D Action: draft-ietf-dnssd-push-18.txt

From: [email-masked]
Date: Mon, 11 Mar 2019 16:21:25 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Extensions for Scalable DNS Service Discovery WG of the IETF.

        Title           : DNS Push Notifications
        Authors         : Tom Pusateri
                          Stuart Cheshire
	Filename        : draft-ietf-dnssd-push-18.txt
	Pages           : 38
	Date            : 2019-03-11

Abstract:
   The Domain Name System (DNS) was designed to return matching records
   efficiently for queries for data that are relatively static.  When
   those records change frequently, DNS is still efficient at returning
   the updated results when polled, as long as the polling rate is not
   too high.  But there exists no mechanism for a client to be
   asynchronously notified when these changes occur.  This document
   defines a mechanism for a client to be notified of such changes to
   DNS records, called DNS Push Notifications.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dnssd-push/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dnssd-push-18
https://datatracker.ietf.org/doc/html/draft-ietf-dnssd-push-18

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dnssd-push-18

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Jan Komissar (jkomissa)" <[email-masked]>
Date: Fri, 22 Mar 2019 21:02:01 +0000

Hi,

A couple of comments:
6.3.1 PUSH Message
Pg 22, para 3: 
============
In the draft:
   … and names
   appearing within only the RDATA of the following DNS types should be
   compressed:

      NS, CNAME, PTR, DNAME, SOA, MX, AFSDB, RT, KX, RP, PX, SRV, NSEC

Suggested:
   … and names
   appearing within RDATA should only be compressed in/for the following RR types :

      NS, CNAME, PTR, DNAME, SOA, MX, AFSDB, RT, KX, RP, PX, SRV, NSEC

Pg 22, para 4:
===========
Considering that clients MUST treat PUSH messages larger than 16382 bytes as a fatal error, I suggest changing

the change notifications SHOULD
   be communicated in separate PUSH messages

to

the change notifications MUST
   be communicated in separate PUSH messages

pg 33, Line 3, last word:
===================
"Sever" should be "Server."

Regards,

Jan.

On 3/11/19, 7:22 PM, "dnssd on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    
    Abstract:

    

    
    _______________________________________________
    dnssd mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/dnssd

---

From: Stuart Cheshire <[email-masked]>
Date: Sat, 23 Mar 2019 20:28:03 +0100

Thanks for your feedback Jan. I have updated the document as you suggested.

Stuart Cheshire