Subject: [dnssd] Call for agenda items: DNSSD at IETF 105 in Montreal

From: David Schinazi <[email-masked]>
Date: Tue, 2 Jul 2019 17:07:04 -0700

Hello everyone,

DNSSD has been scheduled on Thursday, 2019-07-25 at 13:30-15:30 EDT.

If you would like to present, please reply to this thread,
or email <[email-masked]> with:
- title of presentation
- related draft(s) if applicable
- expected duration
- name of presenter
Please also let us know if you will be presenting remotely
or have any specific requests or questions.

Kindly note that your agenda request must be received before
next Tuesday 2019-07-09 at 23:59 UTC so the chairs have
sufficient time to upload the agenda before the datatracker deadline.

Thanks,
David & Barbara

---

From: Ted Lemon <[email-masked]>
Date: Tue, 9 Jul 2019 12:41:02 -0400

I could talk about any of the following things:

The DNSSD-SRP draft status (draft-ietf-dnssd-srp)
What updates have happened
What to do about Tom’s comments on the DNSSD-SRP draft that I haven’t addressed
What to do with the draft generally
Implementation report
DNSSD-Push implementation report (draft-ietf-dnssd-hybrid-proxy)
DNSSD Relay implementation status (draft-ietf-dnssd-mdns-relay)

I could also demo DNSSD Push if there’s interest.

The implementation reports should take on the order of five minutes.   The demo would probably take another five.   The draft status update shouldn’t take more than 10.   Stuart or one of the other authors might additionally want to talk about DNSSD Push status, since there’s been activity on that in IETF last call, but I’m not an author, so I’m not proposing to do that.

---

From: Stuart Cheshire <[email-masked]>
Date: Tue, 09 Jul 2019 18:50:50 -0700

> or have any specific requests or questions.

Here are some items for discussion:

Last Call feedback on draft-ietf-dnssd-push
We have two hot topics to resolve:
1. TLS close_notify vs. TCP reset
2. Allowing subscribe request in TLS early data?
Estimate 20 minutes

As Ted Lemon noted earlier today:
1. Implementation updates on draft-ietf-dnssd-hybrid, draft-ietf-dnssd-mdns-relay, including possibly a live demo.
2. Status update on draft-ietf-dnssd-srp

Finally, an important thing: Discussing the future of the DNSSD Working Group.

1. Draft-ietf-dnssd-srp is important for efficient reliable service discovery on mesh networks, such as Thread wireless home automation networks, and multi-link routed home networks such as envisioned by Homenet. Is there sufficient energy to pursue this work in the IETF, or will it end up moving somewhere else, like the Thread Group?

2. Privacy-respecting device and service discovery remains a very important topic, but in the past we struggled to find implementers creating real products that needed the privacy mechanisms we were considering. Is that still true? With increasing public awareness of the importance of privacy, we may see renewed interest in this area. It would be a pity to give up on this work just as its importance is being recognized.

Stuart Cheshire

---

From: David Schinazi <[email-masked]>
Date: Wed, 10 Jul 2019 11:58:24 -0700

Thanks Ted and Stuart.

We've posted the preliminary agenda (see link or copy in email below)
https://datatracker.ietf.org/doc/agenda-105-dnssd/

Feel free to bash the agenda.

Thanks,
Barbara and David

===

Introduction (Chairs - 15 minutes)

Update on DNS Push (Stuart Cheshire - 15 minutes)
    draft-ietf-dnssd-push
        - TLS close_notify vs. TCP reset
        - Allowing subscribe request in TLS early data?
        - Implementation report and demo

Service Registration (Ted Lemon, 15 minutes)
    draft-ietf-dnssd-srp
        - Latest updates to the draft
        - Tom Pusateri’s comments
        - Implementation report
        - Future of the draft

Discovery Relay (Ted Lemon, 5 mins)
    draft-ietf-dnssd-mdns-relay
        - Implementation report
        - Future of the draft

Future of the Working Group (Chairs - 30 minutes)

Conclusion (Chairs - 5 minutes)

===

On Tue, Jul 9, 2019 at 6:52 PM Stuart Cheshire <[email-masked]> wrote:

> 1. Implementation updates on draft-ietf-dnssd-hybrid,
> draft-ietf-dnssd-mdns-relay, including possibly a live demo.
> 1. Draft-ietf-dnssd-srp is important for efficient reliable service
> discovery on mesh networks, such as Thread wireless home automation
> networks, and multi-link routed home networks such as envisioned by
> Homenet. Is there sufficient energy to pursue this work in the IETF, or
> will it end up moving somewhere else, like the Thread Group?
>
> 2. Privacy-respecting device and service discovery remains a very
> important topic, but in the past we struggled to find implementers creating
> real products that needed the privacy mechanisms we were considering. Is
> that still true? With increasing public awareness of the importance of
> privacy, we may see renewed interest in this area. It would be a pity to
> give up on this work just as its importance is being recognized.
>
> Stuart Cheshire
>
>