Subject: [dnssd] Alexey Melnikov's Yes on draft-ietf-dnssd-push-23: (with COMMENT)

From: Alexey Melnikov via Datatracker <[email-masked]>
Date: Mon, 05 Aug 2019 03:52:49 -0700

Alexey Melnikov has entered the following ballot position for
draft-ietf-dnssd-push-23: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dnssd-push/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

This comment is for RFC Editor:

On page 21, HTML and text version has "TTL⩾0", which gets mangled in PDF version.

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 6 Aug 2019 08:16:17 -0400

> On Aug 5, 2019, at 6:52 AM, Alexey Melnikov via Datatracker <[email-masked]> wrote:
> 

I discussed this with the tools team and Henrik said it was a bug in the TXT to PDF converter. This converter is being replaced with direct XML to PDF in the near future and so I don’t think it will be fixed.

Tom

---

From: "Alexey Melnikov" <[email-masked]>
Date: Tue, 06 Aug 2019 14:09:56 +0100

On Tue, Aug 6, 2019, at 1:16 PM, Tom Pusateri wrote:
> I discussed this with the tools team and Henrik said it was a bug in 
> the TXT to PDF converter. This converter is being replaced with direct 
> XML to PDF in the near future and so I don’t think it will be fixed.

That is fine. I just want for the responsible AD and WG to be aware, in case you decide to change the document to work around.

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 6 Aug 2019 15:07:15 +0000

Tom,

Can you simply change the text in the XML MD source file into TTL >= 0 (i.e using C/SQL syntax and putting space around it?, if this it not enough, then use 'greater or equal')

Thank you

-éric

On 06/08/2019, 15:10, "dnssd on behalf of Alexey Melnikov" <[email-masked] on behalf of [email-masked]> wrote:

    
    _______________________________________________
    dnssd mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/dnssd

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 6 Aug 2019 11:11:21 -0400

That’s how it was until the last draft when Stuart introduced the UTF-8 character.

Tom

> On Aug 6, 2019, at 11:07 AM, Eric Vyncke (evyncke) <[email-masked]> wrote:
> 
> Tom,
>

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 6 Aug 2019 15:10:06 -0400

I’ve reverted this back to ASCII “>=“. Looking at RFC 7997, it doesn’t seem to permit UTF-8 for the purpose of maths. I think RFC 7997 should be updated to include mathematical symbols. But that’s for another day.

Thanks,
Tom