Subject: [dnssd] IPR Disclosure Apple Inc.'s Statement about IPR related to draft-ietf-dnssd-push

From: IETF Secretariat <[email-masked]>
Date: Thu, 21 Nov 2019 00:04:53 -0800

Dear Tom Pusateri, Stuart Cheshire:

An IPR disclosure that pertains to your Internet-Draft entitled "DNS Push
Notifications" (draft-ietf-dnssd-push) was submitted to the IETF Secretariat
on 2019-11-20 and has been posted on the "IETF Page of Intellectual Property
Rights Disclosures" (https://datatracker.ietf.org/ipr/3872/). The title of
the IPR disclosure is "Apple Inc.'s Statement about IPR related to
draft-ietf-dnssd-push"

Thank you

IETF Secretariat

---

From: Stuart Cheshire <[email-masked]>
Date: Thu, 21 Nov 2019 17:01:15 +0800

Apple Legal came though for us and formally submitted the IPR Disclosure below.

This echoes the previous similar IPR Disclosure from Apple, which was submitted for Long-Lived Queries over a decade ago <https://datatracker.ietf.org/ipr/1234/ <https://datatracker.ietf.org/ipr/1234/>>.

Since DNS Push was designed as the spiritual successor of Long-Lived Queries it is appropriate that this IPR should be offered under the same terms, since that was the intent of the original LLQ IPR Disclosure. The draft name changed, and the transport protocol changed from something-over-UDP to TCP, but the overall purpose of DNS Push is to be a better version of LLQ.

Hopefully this should not come as a big surprise to anyone who’s been following this work.

Stuart Cheshire

Begin forwarded message:

> From: IETF Secretariat <[email-masked]>
> Subject: [dnssd] IPR Disclosure Apple Inc.'s Statement about IPR related to draft-ietf-dnssd-push
> Date: 21 November 2019 at 16:04:53 GMT+8
> To: <[email-masked]>
> Cc: [email-masked], [email-masked]
>