Subject: [dnssd] I-D Action: draft-ietf-dnssd-prireq-03.txt

From: [email-masked]
Date: Fri, 20 Dec 2019 04:05:38 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Extensions for Scalable DNS Service Discovery WG of the IETF.

        Title           : DNS-SD Privacy and Security Requirements
        Authors         : Christian Huitema
                          Daniel Kaiser
	Filename        : draft-ietf-dnssd-prireq-03.txt
	Pages           : 20
	Date            : 2019-12-20

Abstract:
   DNS-SD (DNS Service Discovery) normally discloses information about
   devices offering and requesting services.  This information includes
   host names, network parameters, and possibly a further description of
   the corresponding service instance.  Especially when mobile devices
   engage in DNS Service Discovery over Multicast DNS at a public
   hotspot, serious privacy problems arise.  We analyze the requirements
   of a privacy respecting discovery service.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dnssd-prireq/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dnssd-prireq-03
https://datatracker.ietf.org/doc/html/draft-ietf-dnssd-prireq-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dnssd-prireq-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Daniel KAISER <[email-masked]>
Date: Fri, 20 Dec 2019 13:15:08 +0100

I want to kindly ask the people who gave feedback for this  document, if
the feedback has been sufficiently addressed in this new version.

In addition to addressing the feedback, we updated and clarified Section
4 (the requirements section). It would be very helpful if somebody could
check that section as well (it is short :)).

Kind regards,
Daniel

On 12/20/19 1:05 PM, [email-masked] wrote:
> _______________________________________________
> dnssd mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dnssd

-- 
Dr. Daniel Kaiser
Research Associate
SnT- Interdisciplinary Centre for Security, Reliability and Trust

University of Luxembourg
Maison du Nombre (MNO)
6, avenue de la Fonte
L-4364 Esch-sur-Alzette
Office: E02 0225-010

---

From: Christian Huitema <[email-masked]>
Date: Fri, 20 Dec 2019 07:56:44 -1000

Sure. But you can also publish 03, and ask feedback on that. Or format a txt draft from current XML, and ask feedback by email.

-- Christian Huitema 

> On Dec 20, 2019, at 2:15 AM, Daniel KAISER <[email-masked]> wrote:
> 
>  I want to kindly ask the people who gave feedback for this  document, if the feedback has been sufficiently addressed in this new version.
> 
> In addition to addressing the feedback, we updated and clarified Section 4 (the requirements section). It would be very helpful if somebody could check that section as well (it is short :)).
> 
> Kind regards,
> Daniel
>

---

From: Christian Huitema <[email-masked]>
Date: Fri, 20 Dec 2019 10:15:49 -1000

Sorry, e-mail sent out of context. Please disregard.

On 12/20/2019 7:56 AM, Christian Huitema wrote:
> Sure. But you can also publish 03, and ask feedback on that. Or format
> a txt draft from current XML, and ask feedback by email.
>
> -- Christian Huitema 
>
>>  I want to kindly ask the people who gave feedback for this 
>> document, if the feedback has been sufficiently addressed in this new
>> version.
>>
>> In addition to addressing the feedback, we updated and clarified
>> Section 4 (the requirements section). It would be very helpful if
>> somebody could check that section as well (it is short :)).
>>
>> Kind regards,
>> Daniel
>>

---

From: Florian Adamsky <[email-masked]>
Date: Sat, 21 Dec 2019 15:12:21 +0100

Dear all,

> the feedback has been sufficiently addressed in this new version.

thank you for taking my review into consideration. All my suggestions
have been included in the latest version. However, I have recognized only a
minor issue with the formatting in Section 4. All numerical items are
listed twice:

  1.  [...]
  1.
  2.  [...]
  2.

But as I said, this is a minor formatting issue. Apart from that, I
approve of advancing the dnssd requirements draft. Thanks again for
writing the draft and shedding light on this important issue!

[...]

Best Regards
--
Prof. Dr. Florian Adamsky
Professor for IT-Security

Hochschule für Angewandte Wissenschaften Hof
Hof University of Applied Sciences
Alfons-Goppel-Platz 1 
95028 Hof / Saale
Germany

Room: C 122
Fon:  +49 (0) 9281 / 409 4860
GPG:  2E36 67A9 1521 744E 0D8E 0930 8CFB DEC8 C702 72AB

**2019: 25 Jahre Hochschule Hof + 10 Jahre BayIND**

---

From: Daniel KAISER <[email-masked]>
Date: Sat, 21 Dec 2019 19:45:27 +0100

On 12/21/19 3:12 PM, Florian Adamsky wrote:
> have been included in the latest version. 
Thank you very much for proofreading the draft yet again :).
> However, I have recognized only a
That is strange. When I compile the draft using xml2rfc on my machine I
do not get this problem.
Maybe it is because there are xml comments at the points where the
superfluous numeration appears?
Should I re-upload a version without these comments?

University of Luxembourg
Maison du Nombre (MNO)
6, avenue de la Fonte
L-4364 Esch-sur-Alzette
Office: E02 0225-010