Subject: RE: [Ecrit] Fwd: I-D ACTION:draft-hardie-ecrit-iris-01.txt

From: "Stastny Richard" <[email-masked]>
Date: Wed, 6 Jul 2005 12:24:25 +0200

Hi Andy,

Thanks for your reply

> Many of the concerns you raise are not
> specific to ECON or LUMP, but are general issues that need to be
> resolved by this working group

Yes, many of the issues I raised in my reply to LUMP also
applies to ECON. I have also similar questions related to
administration, but since I am not so familiar with IRIS (yet),
I first need to get some more basic information.

> That doesn't mean it is the final list.  
The question is if there will ever be a final list ;-)

> We should strive for a comprehensive and unambiguous
> list that is as universal as possible for the purposes of
> internationalization (or more specifically, having those identifiers
> localized by the client).

> That is a lot of round trips and there is still the potential that
> the user won't understand a thing on the list (if it isn't in their
> language).

I agree that as much services as possible should be 
Internationalized and predefined, to allow native translations.
On the other side additional national services should be
possible, they may have only local meaning anyway.

I do not think that the round trips are a problem, because
service discovery should take place at connect time and
not at the time you make an emergency call. Do not
forget that there may also be a emergency service
reachability indicator. This would also happen at
connect time.

>In a hierarchical approach, would wild card semantics help?

Yes, I think so, as proposed in LUMP,
although this may still need some discussion.

Citizens from countries used to only one emergency number
may not be aware of the options. On the other hand, they
may get confused. I have no idea if already in all countries
having different emergency numbers also 112 or 911 like
access is available in addition

Any comments?

> With regard to getting out-of-hand, I tend to agree.  And do we
> really want to provide a use case for people with non-emergencies
> using a resource needed for emergencies?

I agree, but there is a problem lurking regarding dialing
plans, but this is out of scope in ECRIT.

But I basically have no idea where this problem is to be discussed:
(IPTEL, ENUM ?)

End-users on VoIP either use the home dialing plan or the international
E.164 numbering plan (i.e. +44 xxx xxx)

Short codes used for emergency and also non-emergency numbers
are non-E.164 numbers, so they cannot be dialled in E.164 format
and can also not be dialled from a dialing plan of another country,
so they can basically NOT be dialled at all by users roaming in another
country. Mobile operators have special agreements to provide roaming
users access to these numbers.

So we have three issues here:

1. Access to emergency numbers (ECRIT)
2. Access to police, etc in non-emergency cases (ECRIT?)
3. Access to other non-e.164 numbers (short codes) (IPTEL?, ENUM?)

Richard

Richard Stastny
OeFEG
tel:+43 664 420 4100
enum:+43 780 203 211
callto://fordprefect
http://voipandenum.blogspot.com

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Andrew Newton <[email-masked]>
Date: Wed, 6 Jul 2005 06:47:40 -0400

Richard,

I have a few followup comments and questions.

> possible, they may have only local meaning anyway.

I agree.

> reachability indicator. This would also happen at

What do you mean by "connect time"?  Is this when a device acquires  
an IP address on a network?
And what is the reachability indicator?

> 3. Access to other non-e.164 numbers (short codes) (IPTEL?, ENUM?)

This sounds like a discussion topic for Paris.

-andy