Subject: AW: [Ecrit] Issue 30: Summary

From: "Tschofenig, Hannes" <[email-masked]>
Date: Mon, 23 Jan 2006 15:10:26 +0100

hi mike, 
 
> Hannes,
> 
> We still seem to be glossing over terms and usage it seems.
> 
> When you talk about "emergency numbers", are you referring to an E.164
> number that the "emergency dial string" gets translated to?  Or, just
> that 3 digit emergency code?

i guess we should use the term 'emergency dial string'. 
i used the term 'emergency numbers' in my response to raymond since he
used it as well. i wanted to avoid confusion in the discussion with him
(and instead create other confusion).

> 
> Also, you seem to suggest that each of the hundred or so 
> emergency dial
> strings (112, 911, etc.) are reserved for emergency use 
> globally.

no, i do not make any suggestions with this regard. 
my summary was just an attempt to capture what was said and to
investigate what people really want. 
 
to me it seems that some people want to work on a mechanism to allow the
end point to learn information about the available local emergency dial
strings. 

>  Right
> now I understand there are some conflicts.  Are you proposing that all
> those emergency codes be reserved for emergency use in all countries.

you know that we cannot do that. 

> That is, where any of those codes is used for another purpose, that
> country must change their usage?  So, that the tourist from 
> any country
> can visit any country and any emergency code will work?

no.

ciao
hannes

> 
> Mike 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] 
> > On Behalf Of Hannes Tschofenig
> > Sent: Monday, January 23, 2006 5:15 AM
> > To: Raymond Forbes
> > Cc: [email-masked]; [email-masked]
> > Subject: Re: [Ecrit] Issue 30: Summary
> > 
> > hi raymond,
> > 
> > ~snip~
> > 
> > >  >   * Tourist Alice collapses, another tourist Bob finds the cell
> > >  > phone of Alice and dials its own home emergency number 
> > (because it  
> > > > does  > not know the local emergency number) and the home 
> > emergency 
> > > number is  > different from the local emergency number and 
> > Alice/Bob 
> > > have different  > home emergency numbers.
> > >  >
> > > 
> > > That seems essentially unsolvable. Given typical tourist 
> > herds that I 
> > > have observed, they tend to cluster by nationality (or at least 
> > > region), if only to make the job of the tour guide a bit 
> easier :-)
> > > 
> > > [rcf]: GSM Cell Phones address this problem as they can 
> > dail a number 
> > > of Emergency numbers from the SIM Card. The Phone can 
> translate the 
> > > Dialled number into the Local Emergency number 112, 911, 
> > 110, 111, 000 etc...
> > 
> > 
> > in gsm there is no equivalent to the global emergency 
> > identifier as we discuss it here.
> > as such, you need to have a mechanism to retrieve the local 
> > emergency numbers in order todo the translation from the home 
> > emergency number to the local onces.
> > 
> > ciao
> > hannes
> > 
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> > 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 23 Jan 2006 09:22:32 -0500

Then hopefully, the requirements/solution addresses these two cases:

Home dial string used for non-emergency service code coincides with
local visited emergency dial string.

Home emergency dial string coincides with local visited non-emergency
dial string service code.

as well as the cases:

Home emergency dial string not used in local visited network.

Local visited emergency dial string not used in home network.

Mike

> From: Tschofenig, Hannes [mailto:[email-masked]] 
> Sent: Monday, January 23, 2006 9:10 AM
> To: Michael Hammer (mhammer); Hannes Tschofenig; Raymond Forbes
> Subject: AW: [Ecrit] Issue 30: Summary
> 
> hi mike, 
>  
> > Hannes,
> > 
> i used the term 'emergency numbers' in my response to raymond 
> since he used it as well. i wanted to avoid confusion in the 
> discussion with him (and instead create other confusion).
> 
> > 
> > Also, you seem to suggest that each of the hundred or so emergency 
> > dial strings (112, 911, etc.) are reserved for emergency 
> use globally.
> 
> my summary was just an attempt to capture what was said and 
> to investigate what people really want. 
>  
> to me it seems that some people want to work on a mechanism 
> to allow the end point to learn information about the 
> available local emergency dial strings. 
> 
> >  Right
> > country must change their usage?  So, that the tourist from any 
> > country can visit any country and any emergency code will work?
> 
> no.
> 
> ciao
> hannes
> 
> > 
> > Mike
> > 
> > > From: [email-masked] [mailto:[email-masked]] On 
> > > Behalf Of Hannes Tschofenig

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Mon, 23 Jan 2006 15:53:57 +0100

hi mike, 

if you have your home and your local dial strings configured at the user agent then you map them to the global emergency identifier. as such, there is no problem anymore. 

the problem appears if you do not map them to the global emergency identifier. 

ciao
hannes

> -----Ursprüngliche Nachricht-----
> Von: Michael Hammer (mhammer) [mailto:[email-masked]] 
> Gesendet: Montag, 23. Januar 2006 15:23
> An: Tschofenig, Hannes; Hannes Tschofenig
> Cc: [email-masked]
> Betreff: RE: [Ecrit] Issue 30: Summary
>

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 23 Jan 2006 10:19:24 -0500

I like your approach, but have only one question.
 
Do folks from Asia, Africa, Australia, and South America accept that 911
and 112 are the global emergency dial strings?
 
Mike

________________________________

	From: Stastny Richard [mailto:[email-masked]] 
	Sent: Monday, January 23, 2006 10:06 AM
	To: Raymond Forbes; Michael Hammer (mhammer)
	Cc: [email-masked]
	Subject: RE: [Ecrit] Issue 30: Summary

	I am really getting tired of this discussion, which goes on now
for years,
	simply because there is no solution to have home and local
emergency
	dial strings working in any case because of conflicts that are
not resolvable
	on a global scale, and especially NOT by ECRIT.

	Since any user needs to have a dial plan agreed upon with his
provider
	(which will be in most cases the home dial plan) and this dial
plan
	can be configured into the device

	I suggest the following:

	The global emergency dial strings 911 and 112 MUST be supported
by any device

	and MUST be mapped to the default sos identifier
	In addition, the emergency dial strings supported in the home
dial plan MUST be supported

	and mapped accordingly

	Local emergency dial strings may be supported if there exists no
conflict. If the device
	is not aware of the local emergency dial strings or conflicting
other dial strings, it MUST NOT
	support these dial strings (in doubt)

	VoIP users should be made aware at subscription time that they
SHALL only use
	911 or 112 when abroad (also by NENA and EENA)

	Regards

	Richard

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Raymond Forbes
	Sent: Monday, January 23, 2006 3:23 PM
	To: [email-masked]
	Cc: [email-masked]
	Subject: RE: [Ecrit] Issue 30: Summary

	I was only pointing to the example in GSM (3GPP) today where
there most commonly used global numbers are stored in all SIM modules,
and further local national numbers may be additionally stored. 
	
	This alleviates the need for having a Global address as the
Roaming/Nomadic terminal inter-works with the region it is in. A global
address has certain advantages. 
	
	The GSM solution requires that other national numbers not in the
Prime list may be additionally stored. 
	
	This solves the problem of encountered my the majority of
tourists, US or Japanese Tourists in London. who do not know that their
national number (911 or 110) needs translating to 112. It does not solve
all problems. For example 110 in Germany will reach the Police not the
Emergency services. 
	
	Regards,
	
	Ray Forbes.
	
	+44 24 7656 3106 phone
	+44 24 7656 3816 fax.
	+44 771 851 1361 Mobile/text
	------------
	This e-mail and any attachments are confidential.  If you are
not the intended recipient, please notify us immediately by reply e-mail
and then delete this message from your system. Do not copy this e-mail
or any attachments, use the contents for any purpose, or disclose the
contents to any other person: to do so could be a breach of confidence.

"Michael Hammer \(mhammer\)" <[email-masked]> 

23/01/2006 13:45 

        To:        "Hannes Tschofenig" <[email-masked]>,
"Raymond Forbes" <[email-masked]> 
        cc:        <[email-masked]>, <[email-masked]> 
        Subject:        RE: [Ecrit] Issue 30: Summary

	
	Hannes,

	When you talk about "emergency numbers", are you referring to an
E.164
	number that the "emergency dial string" gets translated to?  Or,
just
	that 3 digit emergency code?
	
	Also, you seem to suggest that each of the hundred or so
emergency dial
	strings (112, 911, etc.) are reserved for emergency use
globally.  Right
	now I understand there are some conflicts.  Are you proposing
that all
	those emergency codes be reserved for emergency use in all
countries.
	That is, where any of those codes is used for another purpose,
that
	country must change their usage?  So, that the tourist from any
country
	can visit any country and any emergency code will work?
	
	Mike 
	
easier :-)
translate the

---

From: "Stastny Richard" <[email-masked]>
Date: Mon, 23 Jan 2006 16:33:26 +0100

IMHO basically all folks from countries having GSM implemented will
accept or
at least will know about 112, which includes all regions you mentioned

Richard

From: Michael Hammer (mhammer) [mailto:[email-masked]] 
Sent: Monday, January 23, 2006 4:19 PM
To: Stastny Richard
Cc: [email-masked]
Subject: RE: [Ecrit] Issue 30: Summary

Mike

	I suggest the following:

	and mapped accordingly

	Regards

	Richard

	

	
	
	Regards,
	
	Ray Forbes.
	
	+44 24 7656 3106 phone
	+44 24 7656 3816 fax.

23/01/2006 13:45 

	
	
	Hannes,

	
	
	Mike 
	
easier :-)
translate the

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 23 Jan 2006 11:57:57 -0500

But, such digits are not part of the emergency string, though they are
also part of the dial string.  On my cell phone, I also have to push the
"power-on" button, but I don't think it necessary to go down such
rat-holes.
 
Mike

	From: Raymond Forbes [mailto:[email-masked]] 
	Sent: Monday, January 23, 2006 11:22 AM
	To: Henning Schulzrinne <hgs
	Cc: [email-masked]; Michael Hammer (mhammer)
	Subject: Re: [Ecrit] Issue 30: Summary

	The common PBX escape digit may be 9 in the UK and US, but it is
0 in most of the world. 
	
	so 9-911, 9-112 and 0-112 would all be required. 
	
	Regards,
	
	Ray Forbes.
	
	+44 24 7656 3106 phone
	+44 24 7656 3816 fax.

	
	Henning Schulzrinne <[email-masked]> 

23/01/2006 15:51 

        To:        Raymond Forbes <[email-masked]> 
        cc:        [email-masked], [email-masked] 
        Subject:        Re: [Ecrit] Issue 30: Summary

	As was discussed previously, the 'longer list of numbers'
approach isn't 
	as workable for SIP, since (unlike for GSM), we also need to
deal with 
	PBX systems, where 3-digit extensions are common.
	
	I think the 112/911 default list, however, is quite workable in 
	practice. (The biggest problem with that is that '9' is the
common 
	escape digit to get an outside line so that in many PBX systems,
you 
	actually have to dial 9-911 to reach a PSAP.)
	
	> I was only pointing to the example in GSM (3GPP) today where
there most 
	> commonly used global numbers are stored in all SIM modules,
and further 
	> local national numbers may be additionally stored.
	> 
	> The GSM solution requires that other national numbers not in
the Prime 
	> list may be additionally stored.
	> 
tourists, US 
	> or Japanese Tourists in London. who do not know that their
national 
	> number (911 or 110) needs translating to 112. It does not
solve all 
	> problems. For example 110 in Germany will reach the Police not
the

---

From: "Stark, Barbara" <[email-masked]>
Date: Mon, 23 Jan 2006 12:08:05 -0600

Not all VoIP or SIP implementations are GSM or specified through 3GPP. I
really don't think the IETF or ecrit has any business specifying
emergency dial strings. That is the business of regulatory bodies that
have jurisdiction over the offered SIP service. The ecrit architecture
is completely independent of any particular dial string. All ecrit needs
to be requiring is something like:
 
UAs MUST be able to recognize emergency dial strings, and translate
these strings into the global emergency SIP URI (<reference to future
RFC>).
 
UAs MUST be able to support mapping of all "home" emergency dial
strings, consistent with the "home" dialing plan of the UA.
 
By the way, it's come as quite a revelation to myself and my colleagues
that our GSM phones do, indeed, support 112 (we've confirmed this with
our cell colleagues). None of us had any idea that this was so. I'd be
willing to go out on a limb and say that probably well over 99% of the
people in the US have absolutely no idea that their GSM phones support
112. In fact, most people here are completely unaware that 112 is the EU
emergency number, or that it's supposed to be a globally recognized GSM
emergency number. My dual mode handset (GSM + WiFi, with outbound WiFi
calls going to IP PBX) only supports 112 when in GSM mode. Since the IP
PBX doesn't support 112, 112 doesn't work when the phone is in WiFi
mode. 911 is supported in both modes.
 
Speaking of PBXs, most PBXs in the US will recognize "911", independent
of any prefix that may be used for normal outbound dialing. They will
also recognize <prefix> + 911. While "9" is commonly used as a prefix,
it's by no means a standard. From my desktop IP phone, I have to dial
"99" as a prefix. If a requirement is desired that references IP PBX
prefixes, perhaps:
 
If a prefix is normally required for outside-line dialing by a UA, the
UA SHOULD support mapping of emergency dial strings with or without the
prefix.
Barbara

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Stastny Richard
Sent: Monday, January 23, 2006 10:33 AM
To: Michael Hammer (mhammer)
Cc: [email-masked]
Subject: RE: [Ecrit] Issue 30: Summary

Richard

  _____  

Mike

  _____  

I am really getting tired of this discussion, which goes on now for
years,
simply because there is no solution to have home and local emergency
dial strings working in any case because of conflicts that are not
resolvable
on a global scale, and especially NOT by ECRIT.

Since any user needs to have a dial plan agreed upon with his provider
(which will be in most cases the home dial plan) and this dial plan
can be configured into the device

I suggest the following:

The global emergency dial strings 911 and 112 MUST be supported by any
device

and MUST be mapped to the default sos identifier
In addition, the emergency dial strings supported in the home dial plan
MUST be supported

and mapped accordingly

Local emergency dial strings may be supported if there exists no
conflict. If the device
is not aware of the local emergency dial strings or conflicting other
dial strings, it MUST NOT
support these dial strings (in doubt)

VoIP users should be made aware at subscription time that they SHALL
only use
911 or 112 when abroad (also by NENA and EENA)

Regards

Richard

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Raymond Forbes
Sent: Monday, January 23, 2006 3:23 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [Ecrit] Issue 30: Summary

I was only pointing to the example in GSM (3GPP) today where there most
commonly used global numbers are stored in all SIM modules, and further
local national numbers may be additionally stored. 

The GSM solution requires that other national numbers not in the Prime
list may be additionally stored. 

This solves the problem of encountered my the majority of tourists, US
or Japanese Tourists in London. who do not know that their national
number (911 or 110) needs translating to 112. It does not solve all
problems. For example 110 in Germany will reach the Police not the
Emergency services. 

Regards,

Ray Forbes.

+44 24 7656 3106 phone
+44 24 7656 3816 fax.
+44 771 851 1361 Mobile/text
------------
This e-mail and any attachments are confidential.  If you are not the
intended recipient, please notify us immediately by reply e-mail and
then delete this message from your system. Do not copy this e-mail or
any attachments, use the contents for any purpose, or disclose the
contents to any other person: to do so could be a breach of confidence.

23/01/2006 13:45 

Hannes,

Also, you seem to suggest that each of the hundred or so emergency dial
strings (112, 911, etc.) are reserved for emergency use globally.  Right
now I understand there are some conflicts.  Are you proposing that all
those emergency codes be reserved for emergency use in all countries.
That is, where any of those codes is used for another purpose, that
country must change their usage?  So, that the tourist from any country
can visit any country and any emergency code will work?

Mike 

> > region), if only to make the job of the tour guide a bit easier :-)
> > 
> > of Emergency numbers from the SIM Card. The Phone can translate the 

*****
"The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material.  Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited.  If you received this in error, please contact the sender and delete the material from all computers."  118

---

From: "Stastny Richard" <[email-masked]>
Date: Mon, 23 Jan 2006 19:11:32 +0100

>I can find you 30 locations in the UK where 911345 is a valid dial string
>leading to a local telephone number
 
In these special cases 911 shoild be made unavailable in
the device by the operator. These customers normally would
not dial 911.
 
There is also the question if devices for nomadic use
should be used with local dial plans at all. It should be 
recommended to operators to use in this case only national
dial plans similar to mobile phones.
 
I once wrote an (long expired) I-D intended to give
advice for implementing dial plans on VoIP.
maybe I should revive it ;-)
 
Richard

Von: Clive D.W. Feather [mailto:[email-masked]]
Gesendet: Mo 23.01.2006 18:24
An: Stastny Richard
Cc: Raymond Forbes; [email-masked]; [email-masked]
Betreff: Re: [Ecrit] Issue 30: Summary

> The global emergency dial strings 911 and 112 MUST be supported by any

I can find you 30 locations in the UK where 911345 is a valid dial string
leading to a local telephone number.

--
Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:    +44 20 8495 6138
Internet Expert     | Home:  <[email-masked]>  | Fax:    +44 870 051 9937
Demon Internet      | WWW: http://www.davros.org | Mobile: +44 7973 377646
Thus plc            |                            |

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 24 Jan 2006 12:08:21 -0000

To clarify the existing GSM/UMTS CS domain emergency call functionality which is NOT as described below.

When the ME recognises an emergency call, either from the numbers stored in the phone itself, or from those stored on the USIM, or from 3GPP release 5 onwards those downloaded from the local network, it will send an EMERGENCY SETUP message, as opposed to an ordinary SETUP message. This message has no provision for a called party number, and the message type itself acts as the identifier that this is an emergency call. It therefore does not contain any of the dial strings that Ray mentions.

It can contain an emergency category, but this is merely a bit pattern, rather than a dial string.

regards

Keith

Keith Drage
Lucent Technologies
[email-masked]
tel: +44 1793 776249

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Raymond Forbes
Sent: 23 January 2006 09:18
To: Henning Schulzrinne <hgs
Cc: [email-masked]; [email-masked]
Subject: Re: [Ecrit] Issue 30: Summary

Henning, 

See point below labelled [rcf]: 

Regards,

Ray Forbes.

+44 24 7656 3106 phone
+44 24 7656 3816 fax.
+44 771 851 1361 Mobile/text
------------
This e-mail and any attachments are confidential.  If you are not the intended recipient, please notify us immediately by reply e-mail and then delete this message from your system. Do not copy this e-mail or any attachments, use the contents for any purpose, or disclose the contents to any other person: to do so could be a breach of confidence.

Henning Schulzrinne <[email-masked]> 
Sent by: [email-masked] 
22/01/2006 16:13         
        To:        "Tschofenig, Hannes" <[email-masked]> 
        cc:        [email-masked] 
        Subject:        Re: [Ecrit] Issue 30: Summary

On Jan 22, 2006, at 8:21 AM, Tschofenig, Hannes wrote:

> hi all,
>
> i am trying to summarize the discussion related to issue 30/issue 8.
>
> - there are location-dependent and global emergency identifiers.
> global emergency identifiers are, for example the sos uris  
> introduced in
> sipping-sos
> draft. location-dependent emergency identifiers are those that are  
> used
> today in specific countries (see, for example,
> http://www.sccfd.org/travel.html)

This is probably more nit-picking than substance, but I would avoid  
using the term "identifier" for dial strings such as "9 1 1". Calling  
them 'emergency dial strings' is a bit awkward, but avoids confusion.  
We try to make this distinction in the 2806/3966 RFCs, reserving  
"identifier" to something that has a URI. (Dial strings are not tel  
URIs, for example.)

>
> - location-dependent numbers might be further categorized into 'home'
> emergency numbers (the definition of 'home' relates to a specific  
> user)
> and numbers used in a 'local' region (here 'local emergency numbers').
> "local" here means the valid emergency telephone number used in the
> geographic vicinity the user finds himself in.

I prefer the term "visited", since this corresponds fairly closely to  
the mobile IP or 3GPP issues using the same terminology.

>
> - the sip ua should translate home emergency numbers to a global
> emergency identifier. the ua is most likely pre-provisioned with this
> information to be able to make such a translation.

For SIP devices, we can probably reference the SIP configuration work  
in this regard, although I wouldn't want to require this. In  
particular, SIP configuration is, unfortunately, fairly heavy-weight.  
It is quite possible for a device to determine its home location and  
then use the same location-to-dial string mapping mechanism that it  
might use for the 'visited' emergency dial string.

>
> - there are cases where the sip ua does not recognize the home  
> emergency
> number. in this case the home emergency number is not translated to a
> global emergency identifier. a sip proxy (in the visited or the home
> network) needs to understand that this is an emergency call.
>
> - the sip ua should translate local emergency numbers to a global
> emergency identifier.

I'm guessing that you do mean SHOULD.

> phone of Alice and dials its own home emergency number (because it  
> does
> not know the local emergency number) and the home emergency number is
> different from the local emergency number and Alice/Bob have different
> home emergency numbers.
>

That seems essentially unsolvable. Given typical tourist herds that I  
have observed, they tend to cluster by nationality (or at least  
region), if only to make the job of the tour guide a bit easier :-)

[rcf]: GSM Cell Phones address this problem as they can dail a number of Emergency numbers from the SIM Card. The Phone can translate the Dialled number into the Local Emergency number 112, 911, 110, 111, 000 etc... 

>
> the problem is only that local emergency numbers in one region are not
> emergency numbers in another region.
>

And, more seriously, emergency numbers in one part of the world are  
used as regular numbers, for services (operator, directory  
assistance, etc.), prefixes or PBX extensions, elsewhere.

>
> it seems that some of you want to work on a solution for (1) (or have
> already worked on it).
>
> ciao
> hannes
>
> ps: the user interface is important to us and we need to be aware of
> these aspects (as we need to be aware of many other aspects as  
> well). i
> guess that most of you understood what i meant by "out-of-scope".

I think we can, at best, reference some of the potential problems,  
such as the ones that Barbara Stark helpfully pointed out. I suspect  
that these trade-offs may differ a bit for mobile vs. landline devices.

For example, if I'm getting service from the US, but live in  
Australia, it is probably a wise move to give the user of a  
stationary device the option of keeping '00' for international  
operator or using it as an emergency number, following local custom.  
Given that a one or two incidents of "baby sitter dials 9-1-1 on VoIP  
phone and gets no answer" caused major regulatory upheaval in the US,  
I suspect that the default will be to make emergency calls at the  
current location of the device work, even if that interferes with  
some other aspect of the dial plan. It is much better to force the  
user to dial #00 than having a house guest in Adelaide dial 000 to  
get an ambulance and talk to an international operator in New Jersey  
instead.

As always, the IETF does not have the authority to regulate device  
manufacturers. It would be up to local regulatory bodies to give  
standards the force of law or regulation.

Henning

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Tue, 24 Jan 2006 13:14:49 +0100

hi brian, 

nice text - only a minor enhancement. 
> Von: [email-masked] [mailto:[email-masked]] 
> Im Auftrag von Brian Rosen
> Gesendet: Montag, 23. Januar 2006 20:39
> An: 'Clive D.W. Feather'
> Cc: [email-masked]
> I don't think we are at cross purposes, although I do think we are
> misunderstanding each other.
> 
> SOME countries don't have emergency numbers; you must dial an 
> e.164 to get
> help.  Often, there is more than one (police, fire, ems, ...)
> 
> SOME countries have emergency numbers.  AFAIK, every one who does has
> special routing for them in the PSTN.
> 
> In ecrit, we FIRST expect dial plan interpretation to translate the
> dialstring for the location where the caller is calling from 
> to a universal
> emergency identifier.  Where there is only one emergency 
> number, that would
> be urn:service:sos.  Where there is more than one, that would be e.g.
> urn:service:sos.police. That would get all emergency calls 
> having the same
> URI regardless of where they are calling from.  
> 
> THEN we can use common (that is, country independent) routing 
> mechanisms to
> route emergency calls to an entity that can determine the 
> correct PSAP for
> that call.  

if the end host executes the mapping protocol we can skip the previous step. 

> 
> THEN, we use the ecrit mapping mechanism to translate 
> location to the URI of
> the PSAP.
> 
> THEN, when we have a URI of the PSAP, we route that.  It may 
> be an e.164 in
> a tel: uri, in which case we would use PSTN routing.  That 
> may involve an
> enum dip.  It may be a sip uri which we would route with a 
> DNS lookup and a
> normal SIP route method.

we should probably copy-and-paste this text to the beginning of section 6 of 
http://www.ietf.org/internet-drafts/draft-ietf-ecrit-requirements-02.txt

ciao
hannes
> Brian
> From: Clive D.W. Feather [mailto:[email-masked]] 
> Sent: Monday, January 23, 2006 12:35 PM
> To: Brian Rosen
> Cc: 'Michael Hammer (mhammer)'; [email-masked]
> Brian Rosen said:
> > "Routed through the network"?  Few systems do this, but 
> ones where the
> only
> > emergency number is an E.164 do.
> > 
> > In our work, we interpret an emergency dialstring within a 
> dial plan to
> the
> > universal emergency identifier.  Then we map that, using 
> the mechanisms we
> > are discussing here in ecrit, to some routable URI, be it a 
> tel URI routed
> > as any other tel URI would, a SIP URI, routed as any other 
> SIP URI would,
> > etc.
> 
> We seem to be at cross-purposes.
> 
> Someone seemed to be suggesting that any diallable (in the 
> PSTN) emergency
> number mapped to an E.164 number, so enum systems could look 
> up the latter.
> The only point I was trying to make is that in some countries 
> there *is* no
> such E.164 number. E.g. in the UK "999" (on landlines, at 
> least) is handled
> by special routeing in the telephone network, not by mapping 
> it to an E.164
> number.
> 
> --

---

From: "Tschofenig, Hannes" <[email-masked]>
Date: Tue, 24 Jan 2006 13:14:49 +0100

hi andy, 

> I thought the issue here was: either the UA or some proxy needs to  
> convert an emergency dialstring to a universal identifier (perhaps  
> Henning's URN proposal) before making an LCMS query.

right. 

> The emergency  
> dialstring comes in two varieties: "home" and "visited".  Home  
> emergency dialstrings can be preconfigured (details vary, but not  
> necessarily important to this conversation).  Visited emergency  
> dialstrings are problematic as there needs to be a way to get them  
> into the said UA or proxy.

true, again. 

we are sometimes not really efficient in our discussions because we tend
to get lost somewhere. 
i wonder what the reason for this is. 

ciao
hannes

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 25 Jan 2006 16:27:56 -0000

I consider this very much a fixed line view of the world. In the wireless environment, people still expect the same thing to happen on the same phone, even if it has crossed the national border. Conversely, if they see an emergency vehicle in the visited country that says dial 9-1-1 then they will try that. Therefore you will get all possible combinations of expectations, and in emergency calls, one cannot afford not to resolve the problem.

As a result the 3GPP cellphone standards try to take account of both views of the world, but this does involve both giving the customers information on their SIM/UICC card, downloading the local numbers to the terminal, and still having to catch the emergency calls that have escaped prior recognition in the network.

This complexity is the reason I have argued for configuration requirements.

regards

Keith

> From: Brian Rosen [mailto:[email-masked]]
> Sent: 24 January 2006 17:16
> To: [email-masked]; [email-masked]; [email-masked]
> <I'd like this to be in scope by expanding the scope to 
> include the big
> picture, but I don't think it currently is.  Defining 
> universal identifiers,
> and even figuring out what visited/local emergency 
> dialstrings probably is,
> but actual phone behavior probably is not.  This material 
> would have to live
> in a phone BCP if we were to document it>
> 
> I think it is desirable for your phone to respond to the emergency
> dialstring from your home location.  I think it is required 
> that it respond
> to the visited emergency dialstring.  We can make it work 
> with either; it's
> not a requirement because of any other element.
> 
> The emergency number in North America is 9-1-1, and it's the emergency
> number in North America whether you are a resident or a visitor.  That
> should not change.  It may even be law in some places.  Signs 
> tell you that.
> They don't say "For help, call your home emergency number", 
> around here they
> say "For help, dial 9-1-1".  Pick up any phone, on any 
> carrier, wireline or
> wireless, and you dial 9-1-1 to get help in North America.  
> Other numbers
> may work (1-1-2 for example), but 9-1-1 ALWAYS works.  We 
> need to keep it
> that way.
> 
> Brian
> 
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, January 24, 2006 12:04 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Subject: RE : [Ecrit] Issue 30: Summary
> 
> 
> 
> >From a user experience stand point, I would like to learn 
> only my "home"
> emergency dialstring and use it wherever I am and let the 
> "network" do the
> translation into a standardized and recognisable URI. So if, 
> for example,
> I'm used to dial "9-1-1" for help and I'm travelling in 
> Australia, I would
> still dial "9-1-1" and get appropriately routed to the 
> Australian PSAP as an
> emergency call. This to me would clearly be added value to 
> VoIP services.
> 
> Now, depending if the Network interfaces or not with PSTN 
> gears to route the
> call (i.e, Selective routers), may impedes this functionality 
> as those would
> likely need to interpret the emergency dialstring to properly 
> process the
> call. If there are no such things, I don't understand why "visited"
> dialstrings would be required.
> 
> My 2 cents...
> 
> 
> Guy Caron
> 
> 
> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] 
> De la part de
> Brian Rosen
> Envoyé : 24 janvier 2006 10:59
> À : 'Drage, Keith (Keith)'; [email-masked]
> Objet : RE: [Ecrit] Issue 30: Summary
> 
> I didn't mean to necessarily imply DHCP was the right 
> mechanism.  It was
> just a convenient example of how a device learns from its 
> environment rather
> than something pushed into it, which is the usual meaning of 
> "configured".
> 
> I happen to think that DHCP would be a good way to pass a 
> visited network
> emergency dialstring IF it is also providing location, but 
> there could be
> other mechanisms.
> 
> Brian
> 
> From: Drage, Keith (Keith) [mailto:[email-masked]] 
> Sent: Tuesday, January 24, 2006 10:05 AM
> To: [email-masked]'; [email-masked]
> Well I was going to let someone else turn it into real 
> specification words.
> 
> By configuration, I guess I mean any mechanism whereby the 
> terminal has the
> means of learning information about how it should operate, 
> and therefore I
> guess I would include DHCP in that (if DHCP supports such a 
> mechanism). Thus
> if the terminal has the means of learning any information, it 
> should also
> support within that mechanism the learning of information about the
> emergency dial strings it should recognise.
> 
> I do not know whether your DHCP mechanism operates on a per emergency
> request basis, or whether the information is retained in the 
> same way as
> more normal configuration, but I guess any putting into words 
> should include
> that distinction.
> 
> I would also guess that if there were multiple mechanisms, 
> then they would
> have to be prioritised by some means in order to avoid information
> conflicts. 
> 
> regards
> 
> Keith
> 
> > From: Brian Rosen [mailto:[email-masked]]
> > Sent: 24 January 2006 12:33
> > To: 'Drage, Keith (Keith)'; [email-masked]
> > I suppose this is more terminology confusion, but would you 
> > call learning
> > your, let's say, DNS gateway from DHCP "configuration"?  If 
> > so, then I think
> > you have the requirements pretty close.  If learning 
> > information from the
> > local environment is not "configuration" then we would have 
> a problem.
> > 
> > Unlike Barbara, I think it is the VISITED network's emergency 
> > dialstring
> > that must be recognized above all else.  Also recognizing the home
> > dialstring would be a good idea.  This would mirror current 
> > practice, and in
> > the absence of some good evidence that it's the wrong way to 
> > go, I think we
> > ought not to change it.  If you bring your phone from the UK 
> > to the US, then
> > you dial 9-1-1 to get emergency help, and not 9-9-9.  
> > 
> > Brian   
> > 
> > On Behalf Of
> > Drage, Keith (Keith)
> > Sent: Tuesday, January 24, 2006 7:21 AM
> > To: [email-masked]
> > To try and make a suggestion based on the discussion so far. 
> > I think the key
> > to this is the ability to configure the SIP phone. I would suggest
> > requirements something like the following:
> > 
> > -	All SIP phones MUST support recognition of emergency 
> > numbers keyed
> > by the user, and if recognised, make the call as an emergency 
> > call using the
> > universal emergency identifier (i.e. the sos SIP URI or 
> > whatever it is).
> > 
> > -	All SIP phones that are configurable, either locally or 
> > remotely,
> > MUST support configuration of recognisable emergency numbers by that
> > mechanism. 
> > 
> > -	SIP phones that are not configurable MUST recognise 112 and 911.
> > 
> > I dont think the last will ever need to be implemented in 
> > practice as I
> > suspect all SIP phones needs to support some form of 
> > configuration. As such
> > I think that if someone wants to provide such a restricted 
> > phone, it will
> > only be able to dial full E.164 numbers anyway (i.e. 
> > international format),
> > and such numbers do not conflict with 112 and 911. This is 
> > why such numbers
> > are defined as stored on the GSM phone, rather than on the UICC/SIM.
> > 
> > We do need to add the optional emergency category 
> > requirements into the
> > above, but this in my view deals with the generally 
> > recognisable numbers
> > issue.
> > 
> > regards
> > 
> > Keith
> > 
> > > From: [email-masked] 
> > > [mailto:[email-masked]]On Behalf Of
> > > Clive D.W. Feather
> > > Sent: 24 January 2006 10:15
> > > To: Raymond Forbes
> > > Cc: [email-masked]
> > > Raymond Forbes said:
> > > > I am not aware that the IETF is interested in UK PSTN 
> > > Routeing (999, 112 
> > > > or otherwise)
> > > 
> > > It isn't. However, it is interested in PSTN numbering where 
> > > that interacts
> > > with ecrit, enum, and so on.
> > > 
> > > > 911 is not supported in the UK,
> > > 
> > > Correct.
> > > 
> > > > 911345 may be a local number, national 
> > > > dialling is not required.
> > > 
> > > As I said, there are about 30 locations where this is the case.
> > > 
> > > > If you dial 911 in the UK it will respond with 
> > > > n/u tone as the 6 or 7 digit local number must be dialling 
> > > in one sequence 
> > > > and mapped by the local exchange.
> > > 
> > > Not so. While there is a timeout, my local exchange (I've 
> > > just tested it)
> > > will accept a more than 10 second gap between digits.
> > > 
> > > It so happens that, if I dial 911 here, I get an announcement 
> > > immediately
> > > after the second 1. I get the same announcement if I dial 
> > 912 or 753,
> > > because none are valid prefixes. If, however, I'm in one of 
> > > those 30 areas
> > > I would expect to get silence after dialling 911 until the 
> > > timeout expires.
> > > 
> > > --

---

From: "Stastny Richard" <[email-masked]>
Date: Thu, 26 Jan 2006 11:18:04 +0100

In future there will be only one market:

Personal devices accessing the Internet (or NGN or whatever)
via BB access. The BB access may be fixed or wireless,
whatever you choose or have available at your location

The devices will be multi-mode: quad-band, WiFi (and WiMAX)

Richard
PS: the convergence is at the user's device.

> Sent: Thursday, January 26, 2006 10:41 AM
> To: Stastny Richard
> Cc: Drage, Keith (Keith); [email-masked]; [email-masked]
> > One way out of this problem would be to establish a (currently
> > not existing) global DIALING plan for VoIP devices.
> >
> > This would be very simple, all E.164 numbers need to be dialled
> > in the international format using the "+", such as +1-234-567-8900
> 
> I don't believe this meets commercial reality.
> 
> There is a piece of the VoIP market - possibly a large one - which is
> competing head-to-head with the fixed line market. These phones need
to be
> able to dial short-form numbers in the same way as that market (this
may
> also be a regulatory requirement in the UK). At the same time, these
> accounts may be nomadic.
> 
> --

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 31 Jan 2006 14:21:01 -0500

The implication of what you are saying is that any number that begins
with a digit string that happens to match any emergency number must be
removed from any dial plan since the terminal will route it as an
emergency before any additional digits can be dialed.
 
I wonder how someone whose phone number starts with 911 (as was pointed
out earlier in examples) is just going to "get over it" as you say.  You
are saying they need to get a new phone number.  Yet, I thought an
earlier post also said that these dial plans were a national matter.  In
other words, it you don't like their dial plan, you will need to "get
over it."
 
I must not be understanding what you are suggesting.  Could you explain
it to the level of detail that Barbara did?
 
Mike

	From: Brian Rosen [mailto:[email-masked]] 
	Sent: Tuesday, January 31, 2006 2:04 PM
	To: Michael Hammer (mhammer); 'Stark, Barbara'; [email-masked]
	Subject: RE: [Ecrit] Issue 30: Summary

	You are trying to come at this by claiming that the engineering
works a particular way, so users should adapt.  I understand that the
problem is that you are putting a visited emergency number into a home
dial plan.  That is, in general, hard.

	But I think the operative phrase is English: "get over it". The
REQUIREMENT is, I think, that the visited emergency number works,
always, without anything funny.  That's an end user experience
requirement.  We have to figure out how to make the devices meet that
requirement.

	So, if you had an overlap, it is the emergency number that
"wins" (that is, is recognized as the end of dialing), with some escape
mechanism needed for whatever it overlapped in the original dial plan.

	Brian

	From: Michael Hammer (mhammer) [mailto:[email-masked]] 
	Sent: Tuesday, January 31, 2006 1:45 PM
	To: [email-masked]; Stark, Barbara; [email-masked]
	Subject: RE: [Ecrit] Issue 30: Summary

	Brian,

	I thought Barbara stated the problem well and a solution for
disambiguating the overlap in dial plans.  Note that plans is plural.
This is a question of conflicts in dial plans.

	The core of this is that *** the endpoint doesn't know *** it is
an "emergency number" until the process for separating out the overlaps
is complete.  The delay or # or immediate is *how it knows*.

	Your reasoning is circular here.  There is a Latin name for
this, but hey, I didn't study Latin.

	Mike

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of Brian Rosen
		Sent: Tuesday, January 31, 2006 12:55 PM
		To: 'Stark, Barbara'; [email-masked]
		Subject: RE: [Ecrit] Issue 30: Summary

		If you would like, I'll raise this with the PSAP and
NENA folks.  I don't think they will agree with you.

		The visited emergency number has to work immediately,
which means it has to be recognized by a dial plan, and not depend on
timeouts or # key presses.

		I think they would say that the home emergency number
could have the delay or #.

		You are proposing to change current behavior; as it
stands now, if you bring a phone into a country, it's the visited
emergency number that works.  I do understand that if you use an
enterprise phone from a VPN or something equivalent, everything breaks
(you don't have the local emergency number, you don't have correct
location, and the call goes to the home psap).   I think we really are
better off with "both", even if that causes some kinds of problems with
home dial plans.  It's much easier to deal with Extension 999 doesn't
work as a 3 digit number when I call from the UK as it does "please
remember to hit # or wait 4 seconds" to get help when you are in the
middle of London.

		Brian

		From: [email-masked]
[mailto:[email-masked]] On Behalf Of Stark, Barbara
		Sent: Tuesday, January 31, 2006 10:44 AM
		To: [email-masked]
		Subject: Re: [Ecrit] Issue 30: Summary

		This seems generally reasonable to me, also. 
		However, there is an implicit expectation in the
description below that I'm not quite comfortable with, in the
"precedence" statement. That is, whether or not end of dialing string is
automatically recognized for visited emergency numbers.

		For devices that use a "Send" button, this isn't a
problem. "Send" must always be pressed to indicate "end of dialing". For
these, there would be no clash between a US "911" and UK "911xxx" dial
string. If the user enters "911xxx" + "Send", then this must never be
interpreted as "911". Similarly, "911" + "Send" is equally unambiguous
(in this example).

		SIP devices without a "Send" button generally employ a
variety of mechanisms to recognize "end of dialing". 
		 1. Some strings are automatically recognized; for
example, when a user dials any "N11" string and has an ATA configured
for US dialing plans, the ATA recognizes this string and automatically
sends the SIP Invite without waiting any further.

		 2. The user can usually press "#" to indicate end of
dialing. Many users are unaware of this fact. 
		 3. If the user does not press another digit in 4 or 5
seconds (differs by device), this is interpreted as end of dialing, and
the SIP Invite is sent.

		What this means, is that, if a user enters a string that
is not automatically recognized as being "complete", and the user
doesn't press "#", there will be a 4 or 5 second delay between the time
when the last digit is pressed and SIP signaling begins.

		While I realize that this delay is generally
undesirable, I would prefer that there be no requirement to
automatically recognize "end of dialing" for visited emergency strings.

		The flip side of this is that if the ATA's current
dialing plan has an automatically escaped string that is shorter than
the visited emergency number (e.g., an ATA might automatically recognize
"00" as a complete string, and the visited emergency number is "000"),
then the ATA logic needs to stop recognizing "00" as a complete string.
I'm fine with this. The user can then dial "00" (+ timeout) or "00#",
and also "000" (+ timeout) or "000#".

		If done this way, the only clashes would be for exact
matches. 
		Barbara 
		======================================== 
		On Jan 28, 2006, at 12:25 PM, Stastny Richard wrote: 

		1. By default, the device is set to use the home
dialplan 
		and home emergency numbers, either directly or via 
		the home provider. 
		2. If not at home, the device get its location and also 
		the visited emergency numbers via some means 
		3. The visited emergency numbers take precendence 
		over the home dialling plan, if a clash occurs. 
		(Note: your home provider may provide you with an 
		escape code to override this, but then you definitely
know 
		what you are doing - e.g. to reach 911xxx local numbers
in UK 
		if you happen to be in the US.) 
		Note: this may cause some emergency calls done wrong, 
		but this is preferrable to missroute some real emergency
calls 

		*****

		The information transmitted is intended only for the
person or entity to which it is addressed and may contain confidential,
proprietary, and/or privileged material. Any review, retransmission,
dissemination or other use of, or taking of any action in reliance upon
this information by persons or entities other than the intended
recipient is prohibited. If you received this in error, please contact
the sender and delete the material from all computers. 117

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 31 Jan 2006 15:16:56 -0600

Perhaps some real data might help here.

The following is the dial plan string from an ATA sold here in Australia:

(*xx|[3469]11|0|00|[2-9]xxxxxx|1xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.)

It’s interesting how this shows that the vendor didn’t consider the Australian emergency number.  I think that this is the same dial plan for the device as sold in the US, we had one of those, but I think I overrode the dial plan on it.

The way that this device works is exactly as Barbara describes below: if this string is matched to the dialed digits, the call goes immediately; otherwise, the ATA waits (there are two timers that I think apply, set to 3 and 10 seconds each) before sending the invite.  I didn’t know about the hash either, so I would have to check that one.

On overlap, I note that the 0 and 00 numbers are both recognized.

If there is interest, I will do a little more digging.

M_T

From: [email-masked] [mailto:[email-masked]] On Behalf Of Stark, Barbara
Sent: Wednesday, 1 February 2006 2:44 AM
To: [email-masked]
Subject: Re: [Ecrit] Issue 30: Summary

This seems generally reasonable to me, also. 
However, there is an implicit expectation in the description below that I'm not quite comfortable with, in the "precedence" statement. That is, whether or not end of dialing string is automatically recognized for visited emergency numbers.

For devices that use a "Send" button, this isn't a problem. "Send" must always be pressed to indicate "end of dialing". For these, there would be no clash between a US "911" and UK "911xxx" dial string. If the user enters "911xxx" + "Send", then this must never be interpreted as "911". Similarly, "911" + "Send" is equally unambiguous (in this example).

SIP devices without a "Send" button generally employ a variety of mechanisms to recognize "end of dialing". 
 1. Some strings are automatically recognized; for example, when a user dials any "N11" string and has an ATA configured for US dialing plans, the ATA recognizes this string and automatically sends the SIP Invite without waiting any further.

 2. The user can usually press "#" to indicate end of dialing. Many users are unaware of this fact. 
 3. If the user does not press another digit in 4 or 5 seconds (differs by device), this is interpreted as end of dialing, and the SIP Invite is sent.

What this means, is that, if a user enters a string that is not automatically recognized as being "complete", and the user doesn't press "#", there will be a 4 or 5 second delay between the time when the last digit is pressed and SIP signaling begins.

While I realize that this delay is generally undesirable, I would prefer that there be no requirement to automatically recognize "end of dialing" for visited emergency strings.

The flip side of this is that if the ATA's current dialing plan has an automatically escaped string that is shorter than the visited emergency number (e.g., an ATA might automatically recognize "00" as a complete string, and the visited emergency number is "000"), then the ATA logic needs to stop recognizing "00" as a complete string. I'm fine with this. The user can then dial "00" (+ timeout) or "00#", and also "000" (+ timeout) or "000#".

If done this way, the only clashes would be for exact matches. 
Barbara 
======================================== 
On Jan 28, 2006, at 12:25 PM, Stastny Richard wrote: 

1. By default, the device is set to use the home dialplan 
and home emergency numbers, either directly or via 
the home provider. 
2. If not at home, the device get its location and also 
the visited emergency numbers via some means 
3. The visited emergency numbers take precendence 
over the home dialling plan, if a clash occurs. 
(Note: your home provider may provide you with an 
escape code to override this, but then you definitely know 
what you are doing - e.g. to reach 911xxx local numbers in UK 
if you happen to be in the US.) 
Note: this may cause some emergency calls done wrong, 
but this is preferrable to missroute some real emergency calls 

*****

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from all computers. 117

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]