Subject: [Ecrit] Issue 30: Requirements

From: "Tschofenig, Hannes" <[email-masked]>
Date: Tue, 24 Jan 2006 13:14:49 +0100

hi barbara, 
 
you exactly hit the point. as an outcome of the discussion we need to
add a few requirements to the requirements draft. we might need todo a
little bit wording around your suggested text: 
- UAs MUST be able to recognize emergency dial strings, and translate
these strings into the global emergency SIP URI (<reference to future
RFC>).
- UAs MUST be able to support mapping of all "home" emergency dial
strings, consistent with the "home" dialing plan of the UA.

we additionally need to add the requirements for the UA to be able to
learn the "local" dial strings. the mechanism for learning local dial
strings is likely to be different than the approach used for getting the
home dialstrings pre-configured. 
 
ciao
hannes

________________________________

	Von: [email-masked] [mailto:[email-masked]] Im
Auftrag von Stark, Barbara
	Gesendet: Montag, 23. Januar 2006 19:08
	An: Stastny Richard; Michael Hammer (mhammer)
	Cc: [email-masked]
	Betreff: RE: [Ecrit] Issue 30: Summary

	Not all VoIP or SIP implementations are GSM or specified through
3GPP. I really don't think the IETF or ecrit has any business specifying
emergency dial strings. That is the business of regulatory bodies that
have jurisdiction over the offered SIP service. The ecrit architecture
is completely independent of any particular dial string. All ecrit needs
to be requiring is something like:
	 
	UAs MUST be able to recognize emergency dial strings, and
translate these strings into the global emergency SIP URI (<reference to
future RFC>).
	 
	UAs MUST be able to support mapping of all "home" emergency dial
strings, consistent with the "home" dialing plan of the UA.
	 
	By the way, it's come as quite a revelation to myself and my
colleagues that our GSM phones do, indeed, support 112 (we've confirmed
this with our cell colleagues). None of us had any idea that this was
so. I'd be willing to go out on a limb and say that probably well over
99% of the people in the US have absolutely no idea that their GSM
phones support 112. In fact, most people here are completely unaware
that 112 is the EU emergency number, or that it's supposed to be a
globally recognized GSM emergency number. My dual mode handset (GSM +
WiFi, with outbound WiFi calls going to IP PBX) only supports 112 when
in GSM mode. Since the IP PBX doesn't support 112, 112 doesn't work when
the phone is in WiFi mode. 911 is supported in both modes.
	 
	Speaking of PBXs, most PBXs in the US will recognize "911",
independent of any prefix that may be used for normal outbound dialing.
They will also recognize <prefix> + 911. While "9" is commonly used as a
prefix, it's by no means a standard. From my desktop IP phone, I have to
dial "99" as a prefix. If a requirement is desired that references IP
PBX prefixes, perhaps:
	 
	If a prefix is normally required for outside-line dialing by a
UA, the UA SHOULD support mapping of emergency dial strings with or
without the prefix.
	Barbara

		-----Original Message-----
		From: [email-masked]
[mailto:[email-masked]]On Behalf Of Stastny Richard
		Sent: Monday, January 23, 2006 10:33 AM
		To: Michael Hammer (mhammer)
		Cc: [email-masked]
		Subject: RE: [Ecrit] Issue 30: Summary

		IMHO basically all folks from countries having GSM
implemented will accept or
		at least will know about 112, which includes all regions
you mentioned
		
		Richard

		________________________________

				From: Michael Hammer (mhammer)
[mailto:[email-masked]] 
		Sent: Monday, January 23, 2006 4:19 PM
		To: Stastny Richard
		Cc: [email-masked]
		Subject: RE: [Ecrit] Issue 30: Summary

		I like your approach, but have only one question.

		Do folks from Asia, Africa, Australia, and South America
accept that 911 and 112 are the global emergency dial strings?

		Mike

			________________________________

						From: Stastny Richard
[mailto:[email-masked]] 
			Sent: Monday, January 23, 2006 10:06 AM
			To: Raymond Forbes; Michael Hammer (mhammer)
			Cc: [email-masked]
			Subject: RE: [Ecrit] Issue 30: Summary

			I am really getting tired of this discussion,
which goes on now for years,
			simply because there is no solution to have home
and local emergency
			dial strings working in any case because of
conflicts that are not resolvable
			on a global scale, and especially NOT by ECRIT.

			Since any user needs to have a dial plan agreed
upon with his provider
			(which will be in most cases the home dial plan)
and this dial plan
			can be configured into the device

			I suggest the following:

			The global emergency dial strings 911 and 112
MUST be supported by any device

			and MUST be mapped to the default sos identifier
			In addition, the emergency dial strings
supported in the home dial plan MUST be supported

			and mapped accordingly

			Local emergency dial strings may be supported if
there exists no conflict. If the device
			is not aware of the local emergency dial strings
or conflicting other dial strings, it MUST NOT
			support these dial strings (in doubt)

			VoIP users should be made aware at subscription
time that they SHALL only use
			911 or 112 when abroad (also by NENA and EENA)

			Regards

			Richard

			________________________________

						From:
[email-masked] [mailto:[email-masked]] On Behalf Of
Raymond Forbes
			Sent: Monday, January 23, 2006 3:23 PM
			To: [email-masked]
			Cc: [email-masked]
			Subject: RE: [Ecrit] Issue 30: Summary

			I was only pointing to the example in GSM (3GPP)
today where there most commonly used global numbers are stored in all
SIM modules, and further local national numbers may be additionally
stored. 
			
			This alleviates the need for having a Global
address as the Roaming/Nomadic terminal inter-works with the region it
is in. A global address has certain advantages. 
			
			The GSM solution requires that other national
numbers not in the Prime list may be additionally stored. 
			
			This solves the problem of encountered my the
majority of tourists, US or Japanese Tourists in London. who do not know
that their national number (911 or 110) needs translating to 112. It
does not solve all problems. For example 110 in Germany will reach the
Police not the Emergency services. 
			
			Regards,
			
			Ray Forbes.
			
			+44 24 7656 3106 phone
			+44 24 7656 3816 fax.
			+44 771 851 1361 Mobile/text
			------------
			This e-mail and any attachments are
confidential.  If you are not the intended recipient, please notify us
immediately by reply e-mail and then delete this message from your
system. Do not copy this e-mail or any attachments, use the contents for
any purpose, or disclose the contents to any other person: to do so
could be a breach of confidence.

				"Michael Hammer \(mhammer\)"
<[email-masked]> 

			23/01/2006 13:45 

			        To:        "Hannes Tschofenig"
<[email-masked]>, "Raymond Forbes"
<[email-masked]> 
			        cc:        <[email-masked]>,
<[email-masked]> 
			        Subject:        RE: [Ecrit] Issue 30:
Summary

			Hannes,
			
			We still seem to be glossing over terms and
usage it seems.
			
			When you talk about "emergency numbers", are you
referring to an E.164
			number that the "emergency dial string" gets
translated to?  Or, just
			that 3 digit emergency code?
			
			Also, you seem to suggest that each of the
hundred or so emergency dial
			strings (112, 911, etc.) are reserved for
emergency use globally.  Right
			now I understand there are some conflicts.  Are
you proposing that all
			those emergency codes be reserved for emergency
use in all countries.
			That is, where any of those codes is used for
another purpose, that
			country must change their usage?  So, that the
tourist from any country
			can visit any country and any emergency code
will work?
			
			Mike 
			
			> -----Original Message-----
			> From: [email-masked]
[mailto:[email-masked]] 
			> On Behalf Of Hannes Tschofenig
			> Sent: Monday, January 23, 2006 5:15 AM
			> To: Raymond Forbes
			> Cc: [email-masked]; [email-masked]
			> Subject: Re: [Ecrit] Issue 30: Summary
			> 
			> hi raymond,
			> 
			> ~snip~
			> 
			> >  >   * Tourist Alice collapses, another
tourist Bob finds the cell
			> >  > phone of Alice and dials its own home
emergency number 
			> (because it  
			> > > does  > not know the local emergency
number) and the home 
			> emergency 
			> > number is  > different from the local
emergency number and 
			> Alice/Bob 
			> > have different  > home emergency numbers.
			> >  >
			> > 
			> > That seems essentially unsolvable. Given
typical tourist 
			> herds that I 
			> > have observed, they tend to cluster by
nationality (or at least 
			> > region), if only to make the job of the tour
guide a bit easier :-)
			> > 
			> > [rcf]: GSM Cell Phones address this problem
as they can 
			> dail a number 
			> > of Emergency numbers from the SIM Card. The
Phone can translate the 
			> > Dialled number into the Local Emergency
number 112, 911, 
			> 110, 111, 000 etc...
			> 
			> 
			> in gsm there is no equivalent to the global
emergency 
			> identifier as we discuss it here.
			> as such, you need to have a mechanism to
retrieve the local 
			> emergency numbers in order todo the
translation from the home 
			> emergency number to the local onces.
			> 
			> ciao
			> hannes
			> 
			>
_______________________________________________
			> Ecrit mailing list
			> [email-masked]
			> https://www1.ietf.org/mailman/listinfo/ecrit
			> 

			*****

		"The information transmitted is intended only for the
person or entity to which it is addressed and may contain confidential,
proprietary, and/or privileged material. Any review, retransmission,
dissemination or other use of, or taking of any action in reliance upon
this information by persons or entities other than the intended
recipient is prohibited. If you received this in error, please contact
the sender and delete the material from all computers." 118

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Stastny Richard" <[email-masked]>
Date: Tue, 24 Jan 2006 13:25:04 +0100

I forgot who proposed it recently to use the term "visited" instead
of "local" to avoid confusion. I would also prefer this terminology.

Richard

> From: Tschofenig, Hannes [mailto:[email-masked]]
> Sent: Tuesday, January 24, 2006 1:15 PM
> To: Stark, Barbara; Stastny Richard; Michael Hammer (mhammer)
> Cc: [email-masked]
> Subject: Issue 30: Requirements
> 
> hi barbara,
>