Subject: RE: [Ecrit] Issue 30: Requirements regarding Emergency Identifier s

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 17 Jan 2006 18:17:11 -0000

In order to make sure that none of this is lost, can I quote the 3GPP requirements that need to be met:

Subclause 10.1.1 of 3GPP TS 22.101

The ME shall identify a number or other identifier dialled by the end user as a valid emergency number/identifier and initiate emergency call establishment if it occurs under one or more of the following conditions. If it occurs outside of the following conditions, the ME should not initiate emergency call establishment but normal call establishment.
a)	112, 911 and a global SIP URI reserved for emergency calls shall always be available. These numbers and identifiers shall be stored on the ME.
b)	Any emergency call number stored on a SIM/USIM when the SIM/USIM is present.
c)	000, 08, 110, 999, 118 and 119 when a SIM/USIM is not present. These numbers shall be stored on the ME.
d)	Additional emergency call numbers that may have been downloaded by the serving network when the SIM/USIM is present.

Subclause 10.1 (extract) of 3GPP TS 22.101

It shall be possible to initiate emergency calls to different emergency call centers, depending on the type of emergency. The following types of emergency calls shall be possible:
-	Police
-	Ambulance
-	Fire Brigade
-	Marine Guard
-	Mountain Rescue
-	Spare, at least [three] different types

Henning took these into account in the documents he prepared for SIPPING,b ut ECRIT needs to be fully aware of them as well.

regards

Keith

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> Marc Linsner
> Sent: 17 January 2006 16:55
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [Ecrit] Issue 30: Requirements regarding Emergency
> Identifiers
> 
> 
> Brian,
> 
> > The proxy has to learn BEFORE an emergency call is placed, 
> > what the local emergency number is.  That's pretty tough now. 
> 
> I realize ECRIT is dealing with emergency calling, but this 
> problem pertains
> to all applications with roamers that use site-local numbers 
> such as 211,
> 311, 411, etc. in North America.  What is a SIP proxy located 
> in Paris going
> to do with a UA located in Texas that invites tel:211 ?  My 
> point is this
> issue needs looked at outside of ECRIT.  Whoever created 
> site-local numbers
> now needs to figure this out....(kinda sounds like private 
> addressing....)
>  
> > Caching the HOME emergency number is conceivable, for either 
> > the phone or the proxy, but only if there was some indication 
> > of where home was.  I am unaware of any mechanism that would 
> > tell you that.  You could conceivably configure that, I 
> > guess, but you probably can't learn it.  Caching in the phone 
> > assumes some non-volatile, but endpoint writable storage.  
> > Dunno if that is an acceptable requirement.  Probably, it's okay.
> 
> This is all based on the assumption that the user will 
> know/attempt to dial
> the local emergency number vs. their HOME emergency number.  
> As you state,
> the HOME emergency number is easy to cache/map, the local 
> emergency number
> is difficult at best.
> 
> -Marc-
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 17 Jan 2006 13:24:39 -0500

Keith,

unfortunately, given that SIP devices may need to work in enterprise 
environments, this approach of hard-coding two- and three-digit 
extensions is going to run into practical problems. Clearly, IMS devices 
can use a configuration mechanism to provide such numbers, but it may 
not be generalizable to all SIP devices.

Henning