Subject: RE: [Ecrit] Issue 30: Summary

From: "Stastny Richard" <[email-masked]>
Date: Thu, 26 Jan 2006 10:34:38 +0100

As I said before that this problem is in principle unsolvable,
If you only consider dialing numbers (and not an SOS button,
which has been proven to be not a good idea)

Every VoIP provider is providing his users with a dialing plan
(normally his home dialing plan, whatever this is)
and this dialing plan is the same if the user is at home
or nomadic.

Changing the dialing plan depending on location is not
a good idea, because:
1. the device needs to know the location
2. this will be very confusing for the users, especially
in countries where you have a local dialing plan.

So by default home emergency numbers and 112 will work
911 seems to have problems

Even if you load the emergency numbers in the visited network
from somewhere into the device,
the question remains, which numbers take preference if a clash
occurs (and we have seen that there is a number of clashes)

One way out of this problem would be to establish a (currently
not existing) global DIALING plan for VoIP devices.

This would be very simple, all E.164 numbers need to be dialled
in the international format using the "+", such as +1-234-567-8900

This seems to be more nasty as it is, because users of mobile
phones in non-US countries, say in Europe, are already used to
store their numbers in the contact list in this format anyway
(to be able to use their contact list anywhere) and most calls
are made via the contact list, last calls or missed calls list
ect anyway.

This would open the whole number space for non-E164 numbers
(service numbers) and within this number space the problem
should be solvable, first defining 112 and 911 and then 
Other service numbers (eg escape codes for national or provider
specific service codes)

It is up to an international standards body (say ITU-T) to
define this number space. This cannot be solved in ECRIT, although
ECRIT may deliver input.

Regards
Richard

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Drage, Keith (Keith)
> Sent: Wednesday, January 25, 2006 5:28 PM
> To: [email-masked]'; [email-masked]
> Subject: RE: [Ecrit] Issue 30: Summary
> 
> I consider this very much a fixed line view of the world. In the wireless
> environment, people still expect the same thing to happen on the same
> phone, even if it has crossed the national border. Conversely, if they see
> an emergency vehicle in the visited country that says dial 9-1-1 then they
> will try that. Therefore you will get all possible combinations of
> expectations, and in emergency calls, one cannot afford not to resolve the
> problem.
> 
> As a result the 3GPP cellphone standards try to take account of both views
> of the world, but this does involve both giving the customers information
> on their SIM/UICC card, downloading the local numbers to the terminal, and
> still having to catch the emergency calls that have escaped prior
> recognition in the network.
> 
> This complexity is the reason I have argued for configuration
> requirements.
> 
> regards
> 
> Keith
> 
> 
> 
> > -----Original Message-----
> > From: Brian Rosen [mailto:[email-masked]]
> > Sent: 24 January 2006 17:16
> > To: [email-masked]; [email-masked]; [email-masked]
> > Subject: RE: [Ecrit] Issue 30: Summary
> >
> >
> > <I'd like this to be in scope by expanding the scope to
> > include the big
> > picture, but I don't think it currently is.  Defining
> > universal identifiers,
> > and even figuring out what visited/local emergency
> > dialstrings probably is,
> > but actual phone behavior probably is not.  This material
> > would have to live
> > in a phone BCP if we were to document it>
> >
> > I think it is desirable for your phone to respond to the emergency
> > dialstring from your home location.  I think it is required
> > that it respond
> > to the visited emergency dialstring.  We can make it work
> > with either; it's
> > not a requirement because of any other element.
> >
> > The emergency number in North America is 9-1-1, and it's the emergency
> > number in North America whether you are a resident or a visitor.  That
> > should not change.  It may even be law in some places.  Signs
> > tell you that.
> > They don't say "For help, call your home emergency number",
> > around here they
> > say "For help, dial 9-1-1".  Pick up any phone, on any
> > carrier, wireline or
> > wireless, and you dial 9-1-1 to get help in North America.
> > Other numbers
> > may work (1-1-2 for example), but 9-1-1 ALWAYS works.  We
> > need to keep it
> > that way.
> >
> > Brian
> >
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Tuesday, January 24, 2006 12:04 PM
> > To: [email-masked]; [email-masked]; [email-masked]
> > Subject: RE : [Ecrit] Issue 30: Summary
> >
> >
> >
> > >From a user experience stand point, I would like to learn
> > only my "home"
> > emergency dialstring and use it wherever I am and let the
> > "network" do the
> > translation into a standardized and recognisable URI. So if,
> > for example,
> > I'm used to dial "9-1-1" for help and I'm travelling in
> > Australia, I would
> > still dial "9-1-1" and get appropriately routed to the
> > Australian PSAP as an
> > emergency call. This to me would clearly be added value to
> > VoIP services.
> >
> > Now, depending if the Network interfaces or not with PSTN
> > gears to route the
> > call (i.e, Selective routers), may impedes this functionality
> > as those would
> > likely need to interpret the emergency dialstring to properly
> > process the
> > call. If there are no such things, I don't understand why "visited"
> > dialstrings would be required.
> >
> > My 2 cents...
> >
> >
> > Guy Caron
> >
> >
> > -----Message d'origine-----
> > De : [email-masked] [mailto:[email-masked]]
> > De la part de
> > Brian Rosen
> > Envoyé : 24 janvier 2006 10:59
> > À : 'Drage, Keith (Keith)'; [email-masked]
> > Objet : RE: [Ecrit] Issue 30: Summary
> >
> > I didn't mean to necessarily imply DHCP was the right
> > mechanism.  It was
> > just a convenient example of how a device learns from its
> > environment rather
> > than something pushed into it, which is the usual meaning of
> > "configured".
> >
> > I happen to think that DHCP would be a good way to pass a
> > visited network
> > emergency dialstring IF it is also providing location, but
> > there could be
> > other mechanisms.
> >
> > Brian
> >
> > -----Original Message-----
> > From: Drage, Keith (Keith) [mailto:[email-masked]]
> > Sent: Tuesday, January 24, 2006 10:05 AM
> > To: [email-masked]'; [email-masked]
> > Subject: RE: [Ecrit] Issue 30: Summary
> >
> > Well I was going to let someone else turn it into real
> > specification words.
> >
> > By configuration, I guess I mean any mechanism whereby the
> > terminal has the
> > means of learning information about how it should operate,
> > and therefore I
> > guess I would include DHCP in that (if DHCP supports such a
> > mechanism). Thus
> > if the terminal has the means of learning any information, it
> > should also
> > support within that mechanism the learning of information about the
> > emergency dial strings it should recognise.
> >
> > I do not know whether your DHCP mechanism operates on a per emergency
> > request basis, or whether the information is retained in the
> > same way as
> > more normal configuration, but I guess any putting into words
> > should include
> > that distinction.
> >
> > I would also guess that if there were multiple mechanisms,
> > then they would
> > have to be prioritised by some means in order to avoid information
> > conflicts.
> >
> > regards
> >
> > Keith
> >
> > > -----Original Message-----
> > > From: Brian Rosen [mailto:[email-masked]]
> > > Sent: 24 January 2006 12:33
> > > To: 'Drage, Keith (Keith)'; [email-masked]
> > > Subject: RE: [Ecrit] Issue 30: Summary
> > >
> > >
> > > I suppose this is more terminology confusion, but would you
> > > call learning
> > > your, let's say, DNS gateway from DHCP "configuration"?  If
> > > so, then I think
> > > you have the requirements pretty close.  If learning
> > > information from the
> > > local environment is not "configuration" then we would have
> > a problem.
> > >
> > > Unlike Barbara, I think it is the VISITED network's emergency
> > > dialstring
> > > that must be recognized above all else.  Also recognizing the home
> > > dialstring would be a good idea.  This would mirror current
> > > practice, and in
> > > the absence of some good evidence that it's the wrong way to
> > > go, I think we
> > > ought not to change it.  If you bring your phone from the UK
> > > to the US, then
> > > you dial 9-1-1 to get emergency help, and not 9-9-9.
> > >
> > > Brian
> > >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > On Behalf Of
> > > Drage, Keith (Keith)
> > > Sent: Tuesday, January 24, 2006 7:21 AM
> > > To: [email-masked]
> > > Subject: RE: [Ecrit] Issue 30: Summary
> > >
> > > To try and make a suggestion based on the discussion so far.
> > > I think the key
> > > to this is the ability to configure the SIP phone. I would suggest
> > > requirements something like the following:
> > >
> > > -	All SIP phones MUST support recognition of emergency
> > > numbers keyed
> > > by the user, and if recognised, make the call as an emergency
> > > call using the
> > > universal emergency identifier (i.e. the sos SIP URI or
> > > whatever it is).
> > >
> > > -	All SIP phones that are configurable, either locally or
> > > remotely,
> > > MUST support configuration of recognisable emergency numbers by that
> > > mechanism.
> > >
> > > -	SIP phones that are not configurable MUST recognise 112 and 911.
> > >
> > > I dont think the last will ever need to be implemented in
> > > practice as I
> > > suspect all SIP phones needs to support some form of
> > > configuration. As such
> > > I think that if someone wants to provide such a restricted
> > > phone, it will
> > > only be able to dial full E.164 numbers anyway (i.e.
> > > international format),
> > > and such numbers do not conflict with 112 and 911. This is
> > > why such numbers
> > > are defined as stored on the GSM phone, rather than on the UICC/SIM.
> > >
> > > We do need to add the optional emergency category
> > > requirements into the
> > > above, but this in my view deals with the generally
> > > recognisable numbers
> > > issue.
> > >
> > > regards
> > >
> > > Keith
> > >
> > > > -----Original Message-----
> > > > From: [email-masked]
> > > > [mailto:[email-masked]]On Behalf Of
> > > > Clive D.W. Feather
> > > > Sent: 24 January 2006 10:15
> > > > To: Raymond Forbes
> > > > Cc: [email-masked]
> > > > Subject: Re: [Ecrit] Issue 30: Summary
> > > >
> > > >
> > > > Raymond Forbes said:
> > > > > I am not aware that the IETF is interested in UK PSTN
> > > > Routeing (999, 112
> > > > > or otherwise)
> > > >
> > > > It isn't. However, it is interested in PSTN numbering where
> > > > that interacts
> > > > with ecrit, enum, and so on.
> > > >
> > > > > 911 is not supported in the UK,
> > > >
> > > > Correct.
> > > >
> > > > > 911345 may be a local number, national
> > > > > dialling is not required.
> > > >
> > > > As I said, there are about 30 locations where this is the case.
> > > >
> > > > > If you dial 911 in the UK it will respond with
> > > > > n/u tone as the 6 or 7 digit local number must be dialling
> > > > in one sequence
> > > > > and mapped by the local exchange.
> > > >
> > > > Not so. While there is a timeout, my local exchange (I've
> > > > just tested it)
> > > > will accept a more than 10 second gap between digits.
> > > >
> > > > It so happens that, if I dial 911 here, I get an announcement
> > > > immediately
> > > > after the second 1. I get the same announcement if I dial
> > > 912 or 753,
> > > > because none are valid prefixes. If, however, I'm in one of
> > > > those 30 areas
> > > > I would expect to get silence after dialling 911 until the
> > > > timeout expires.
> > > >
> > > > --
> > > > Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:
> > > > +44 20 8495 6138
> > > > Internet Expert     | Home:  <[email-masked]>  | Fax:
> > > > +44 870 051 9937
> > > > Demon Internet      | WWW: http://www.davros.org | Mobile:
> > > > +44 7973 377646
> > > > Thus plc            |                            |
> > > >
> > > > _______________________________________________
> > > > Ecrit mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/ecrit
> > > >
> > >
> > >
> > > _______________________________________________
> > > Ecrit mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/ecrit
> > >
> > >
> >
> >
> >
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> >
> >
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Clive D.W. Feather" <[email-masked]>
Date: Thu, 26 Jan 2006 09:40:47 +0000

> in the international format using the "+", such as +1-234-567-8900

I don't believe this meets commercial reality.

There is a piece of the VoIP market - possibly a large one - which is
competing head-to-head with the fixed line market. These phones need to be
able to dial short-form numbers in the same way as that market (this may
also be a regulatory requirement in the UK). At the same time, these
accounts may be nomadic.

-- 
Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:    +44 20 8495 6138
Internet Expert     | Home:  <[email-masked]>  | Fax:    +44 870 051 9937
Demon Internet      | WWW: http://www.davros.org | Mobile: +44 7973 377646
Thus plc            |                            |

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 28 Jan 2006 12:03:54 -0500

I think we can simplify the problem slightly if we look at some  
plausible deployment scenarios for traveling users.

[Travel] User takes mobile device or laptop software to foreign  
country; keeps home service provider. Here, there is no concern about  
PBX dial plans and the like. Since all mobile devices and soft phones  
use en-bloc ("press send") rather than overlap dialing, there are no  
issues with prefix overlap. Thus, the only concern are if a visited  
emergency number is also serving some important, but different,  
function back home. The number of such collisions of practical  
interest seem to be small.

The reason for having a visited emergency number is user expectation:  
the "dial number seen on fire truck".

[ex-pat] The ex-pat user takes a terminal adapter or Ethernet phone  
to a foreign country, but gets service from a service provider back  
home, e.g., so that he can maintain a local number in his home  
country. (I use a German SIP provider, for example.)

The reason for having a visited emergency number is the babysitter  
problem: the babysitter won't know that the ex-pat is getting phone  
service from a different country and will dial the emergency number  
she is familiar with.

Relying on users to program their phone manually is unlikely to be  
done consistently.

Again, PBX extension collisions seem unlikely in this case as most  
phones would treat the foreign provider as its own "line", with its  
own dial plan. Overlap dialing is more of a concern here, due to the  
use of terminal adapters rather than IP phones. I suspect most users  
would rather have the babysitter get the fire department than  
worrying about messing up directory assistance (to take the Finnish  
118 example) in a far-away place.

Thus, a simple rule that makes the visited emergency number match  
first would seem to satisfy almost all practical considerations. This  
requires no cooperation from the service provider.

Henning

(more comments inline)

> 1. the device needs to know the location

This is not quite true. Brian has suggested DHCP, since it is likely  
local. In addition, we assume that the device, in many cases, will  
need to know its location for call routing in any event.

> in countries where you have a local dialing plan.

Given the cases above, I don't see this as a big issue in practice.  
Most people will never see this except on their mobile phone. Almost  
all service numbers on mobile phones are #something, so I think the  
number of non-emergency 3-digit dial strings used on mobile phones is  
minuscule. I can't remember ever dialing such a number on my mobile  
phone.