Subject: RE: [Ecrit] Issue 30: Summary

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 24 Jan 2006 12:21:13 -0000

To try and make a suggestion based on the discussion so far. I think the key to this is the ability to configure the SIP phone. I would suggest requirements something like the following:

-	All SIP phones MUST support recognition of emergency numbers keyed by the user, and if recognised, make the call as an emergency call using the universal emergency identifier (i.e. the sos SIP URI or whatever it is).

-	All SIP phones that are configurable, either locally or remotely, MUST support configuration of recognisable emergency numbers by that mechanism. 

-	SIP phones that are not configurable MUST recognise 112 and 911.

I dont think the last will ever need to be implemented in practice as I suspect all SIP phones needs to support some form of configuration. As such I think that if someone wants to provide such a restricted phone, it will only be able to dial full E.164 numbers anyway (i.e. international format), and such numbers do not conflict with 112 and 911. This is why such numbers are defined as stored on the GSM phone, rather than on the UICC/SIM.

We do need to add the optional emergency category requirements into the above, but this in my view deals with the generally recognisable numbers issue.

regards

Keith

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> Clive D.W. Feather
> Sent: 24 January 2006 10:15
> To: Raymond Forbes
> Cc: [email-masked]
> Subject: Re: [Ecrit] Issue 30: Summary
> 
> 
> Raymond Forbes said:
> > I am not aware that the IETF is interested in UK PSTN 
> Routeing (999, 112 
> > or otherwise)
> 
> It isn't. However, it is interested in PSTN numbering where 
> that interacts
> with ecrit, enum, and so on.
> 
> > 911 is not supported in the UK,
> 
> Correct.
> 
> > 911345 may be a local number, national 
> > dialling is not required.
> 
> As I said, there are about 30 locations where this is the case.
> 
> > If you dial 911 in the UK it will respond with 
> > n/u tone as the 6 or 7 digit local number must be dialling 
> in one sequence 
> > and mapped by the local exchange.
> 
> Not so. While there is a timeout, my local exchange (I've 
> just tested it)
> will accept a more than 10 second gap between digits.
> 
> It so happens that, if I dial 911 here, I get an announcement 
> immediately
> after the second 1. I get the same announcement if I dial 912 or 753,
> because none are valid prefixes. If, however, I'm in one of 
> those 30 areas
> I would expect to get silence after dialling 911 until the 
> timeout expires.
> 
> -- 
> Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:    
> +44 20 8495 6138
> Internet Expert     | Home:  <[email-masked]>  | Fax:    
> +44 870 051 9937
> Demon Internet      | WWW: http://www.davros.org | Mobile: 
> +44 7973 377646
> Thus plc            |                            |
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Tue, 24 Jan 2006 07:33:22 -0500

I suppose this is more terminology confusion, but would you call learning
your, let's say, DNS gateway from DHCP "configuration"?  If so, then I think
you have the requirements pretty close.  If learning information from the
local environment is not "configuration" then we would have a problem.

Unlike Barbara, I think it is the VISITED network's emergency dialstring
that must be recognized above all else.  Also recognizing the home
dialstring would be a good idea.  This would mirror current practice, and in
the absence of some good evidence that it's the wrong way to go, I think we
ought not to change it.  If you bring your phone from the UK to the US, then
you dial 9-1-1 to get emergency help, and not 9-9-9.  

Brian   

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Drage, Keith (Keith)
Sent: Tuesday, January 24, 2006 7:21 AM
To: [email-masked]
Subject: RE: [Ecrit] Issue 30: Summary

To try and make a suggestion based on the discussion so far. I think the key
to this is the ability to configure the SIP phone. I would suggest
requirements something like the following:

-	All SIP phones MUST support recognition of emergency numbers keyed
by the user, and if recognised, make the call as an emergency call using the
universal emergency identifier (i.e. the sos SIP URI or whatever it is).

-	All SIP phones that are configurable, either locally or remotely,
MUST support configuration of recognisable emergency numbers by that
mechanism. 

I dont think the last will ever need to be implemented in practice as I
suspect all SIP phones needs to support some form of configuration. As such
I think that if someone wants to provide such a restricted phone, it will
only be able to dial full E.164 numbers anyway (i.e. international format),
and such numbers do not conflict with 112 and 911. This is why such numbers
are defined as stored on the GSM phone, rather than on the UICC/SIM.

We do need to add the optional emergency category requirements into the
above, but this in my view deals with the generally recognisable numbers
issue.

regards

Keith