Subject: RE: [Ecrit] Comments on draft-ietf-ecrit-service-urn-02

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Sun, 30 Apr 2006 01:14:37 +0100

See inline below:

And one further question. I have assumed that for the emergency type "sos" in the absence of the subtype, it would still be routed to a PSAP even when subtypes are generally in use. Similarly if an unknown subtype is used, it should still get routed to a PSAP. Which draft is going to include the requirement to do this?

regards

Keith

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: 28 April 2006 19:07
> To: Drage, Keith (Keith)
> Cc: [email-masked]
> Subject: Re: [Ecrit] Comments on draft-ietf-ecrit-service-urn-02
> 
> 
> I generally agree with your comments. The inclusion of animal 
> control, 
> in particular, was motivated by the usage in an American PSAP 
> I visited, 
> which has 'animal control' as one of their transfer destinations.
> 
> I'm less certain about mental health; I suspect a suicide prevention 
> hotline is the closest we could get to an emergency service 
> and maybe it 
> should be labeled as such.
> 
We already have the suicide prevention listed as a separate subtype:

"   urn:service:sos.suicide The 'suicide' service refers to the suicide
      prevention hotline."

> In general, almost all emergency services are used for less-urgent 
> services as well. For example, the fire department often 
> extracts cats 
> from trees and the police department writes parking tickets or 
> investigates shop lifting. Neither requires flashing blue 
> lights and sirens.
> 
> As to the term animal control, it appears to be, at least in 
> the US, the 
> established term for services that deal with both emergency, 
> threat-of-life ("bear", "crocodile") and nuisance ("skunk") animal 
> issues. See http://www.nacanet.org/ for the official 
> association, as far 
> as I can tell.
> 
> Suggestions for naming the "211" and "311" services are welcome. 
> urn:service:information is a bit too generic, but maybe 
> urn:service:government and urn:service:social would be close enough.
> 
I cannot make up my mind as to whether these should go in this draft, or in a later draft:

-	the pro for putting them in this draft is that it will help to contrast the distinction between the emergency type "sos" and the other public service type.

-	the con is that we need to identify a scope for the public service type, and the perceived scope in different countries is going to vary much more drastically than that for emergency services, and therefore possibly take significant time to resolve. In some countries "pest control" may be a commercial service, and in others a service provided by local government. Counselling services may be provided by registered charities or by national government. Do we exclude those services that may be provided for commercial gain? What happens if the subtype is missing; does it get routed to a default information centre? In the USA, we seem to have two types, the UK is proposing only one; what are other countries round the world planning?

> Henning
> 
> Drage, Keith (Keith) wrote:
> > I have been rereading draft-ietf-ecrit-service-urn-02 and 
> have at least one major comment:
> > 
> > Section 4.3 describes the "sos" service type as:
> > 
> >    The 'sos' service type describes emergency services and services
> >    related to public safety and health, typically offered by various
> >    branches of the government or other public institutions. 
>  Additional
> >    sub-services can be added after expert review and should be of
> >    general public interest.
> > 
> > The general dictionary definition of "SOS" is the the 
> international call of distress in morse and carries with it 
> therefore requirements for immediate assistance rather than 
> information provision. 
> > 
> > In the case of emergency calls, the UK government currently 
> spends large sums of money in trying to educate the public 
> that the "999" service is for emergencies only, and I think 
> we are adding to that confusion by using "sos" to apparently 
> cover both immediate response and non-immediate response services.
> > 
> > This is made worse because presumably when a subtype is not 
> supported in a particular locality, I assume the call would 
> be routed to the general "sos" answer point, which certainly 
> in the UK would be the current "999" service. I can assure 
> you that any non-urgent request to such services in the UK 
> ends up with a minimum of a verbal warning.
> > 
> > Therefore in section 4.3 I consider that we should clearly 
> state that "sos" is only for emergency or immediate response 
> services, and all the subtype definitions should be rewritten 
> where they do not clearly state that intent.
> > 
> > Further the "sos" type implies some level of priority in 
> treatment of the call, and it appears to me inappropriate 
> that such priority should be given to a non-urgent request.
> > 
> > Thus the current definition of: 
> > 
> >    urn:service:sos.animal-control Animal control is defined 
> as control
> >       of dogs, cats, and domesticated or undomesticated animals.
> > 
> > needs to reflect something more dangerous or life 
> threatening that stray cats or dogs, or general problems with 
> wasp nests.
> > 
> > Similarly:
> > 
> >    urn:service:sos.mental-health The 'mental-health' 
> service refers to
> >       the "Diagnostic, treatment, and preventive care that 
> helps improve
> >       how persons with mental illness feel both physically and
> >       emotionally as well as how they interact with other persons."
> >       (U.S. Department of Health and Human Services)
> > 
> > again needs to reflect some need for immediate assistance 
> with a psychological disorder, rather than just a long term 
> counselling service.
> > 
> > Further the allocation of further values needs to reflect 
> more criteria for the allocation of values. Presumably new 
> values end up being allocated by expert review (allocation of 
> the IANA request to one of a set of designated experts), 
> rather than by reference back to the WG. I consider "of 
> general public interest" an insufficient definition to 
> conduct that review. I would suggest it 
> > 
> > -	needs to include a review of impact of world wide usage 
> in different cultures, 
> > 
> > -	whether such services are generally provided worldwide 
> in a similar fashion (because these urns are meant to support 
> roaming users who expect the same degree of support when they roam).
> > 
> > -	the type of response required to the request. 
> > 
> > In general public information services and other public 
> advice lines probably need to be given a separate type and 
> subtypes, assuming we need well known international 
> identifiers for these at all.
> > 
> > regards
> > 
> > Keith 
> > 
> > Keith Drage
> > Lucent Technologies
> > [email-masked]
> > tel: +44 1793 776249
> > 
> > _______________________________________________
> > Ecrit mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ecrit
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 29 Apr 2006 21:02:06 -0400

On Apr 29, 2006, at 8:14 PM, Drage, Keith (Keith) wrote:

> See inline below:
>
> And one further question. I have assumed that for the emergency  
> type "sos" in the absence of the subtype, it would still be routed  
> to a PSAP even when subtypes are generally in use. Similarly if an  
> unknown subtype is used, it should still get routed to a PSAP.  
> Which draft is going to include the requirement to do this?
>

This would be handled by the matching algorithm in LoST, but it  
probably doesn't hurt to describe this in general terms. The general  
notion is probably that a mapping protocol SHOULD always provide the  
non-subtyped service, which would be used for the two cases you mention.

> -	the pro for putting them in this draft is that it will help to  
> contrast the distinction between the emergency type "sos" and the  
> other public service type.
>
> -	the con is that we need to identify a scope for the public  
> service type, and the perceived scope in different countries is  
> going to vary much more drastically than that for emergency  
> services, and therefore possibly take significant time to resolve.  
> In some countries "pest control" may be a commercial service, and  
> in others a service provided by local government. Counselling  
> services may be provided by registered charities or by national  
> government. Do we exclude those services that may be provided for  
> commercial gain? What happens if the subtype is missing; does it  
> get routed to a default information centre? In the USA, we seem to  
> have two types, the UK is proposing only one; what are other  
> countries round the world planning?
>

I think it is pretty hopeless to try to work with sub-services for  
these two, given the almost endless list of government services  
offered by developed countries. The "blue pages" in many US phone  
books list government services at a very high level and still can be  
dozens of pages long. The whole point of 211 and 311 is to have a  
human or other context-aware entity determine what service the caller  
actually needs. The issues that make sub-services necessary in 911  
seem to be absent in those new services.

As I mentioned in the discussion on various police functions, I don't  
think the service URN is a substitute for a directory service, be it  
a human, an "A-Z" listing, a FAQ or query-based.

Thus, my suggestion would be to simply define two top-level services,  
'government' and 'social', and leave it at that for the time being.

Henning