Subject: [Ecrit] RE:[Geopriv] static location on a mobile device

From: "Aquil, Kamran" <[email-masked]>
Date: Thu, 6 Apr 2006 15:19:14 -0400

The dual mode Handset (802.11/Cellular) will be able to carry the same
VOIP session with same IP address when handing off between either
network. The location change trigger mechanism cannot be based on
changing IP address in this scenario. Also the ISP or the access
provider is better situated to provide some sort location update trigger
based on Pull or Push request instead of ASP/VSP.

Kamran 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, April 06, 2006 12:00 PM
To: [email-masked]
Subject: Ecrit Digest, Vol 15, Issue 3

Send Ecrit mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://www1.ietf.org/mailman/listinfo/ecrit
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific than
"Re: Contents of Ecrit digest..."

Today's Topics:

   1. ECRIT Requirements Draft WGLC Status (Hannes Tschofenig)
   2. static location on a mobile device (Andrew Newton)
   3. RE: [Geopriv] static location on a mobile device (Marc Linsner)
   4. ECRIT Security Threats Draft Status (Hannes Tschofenig)
   5. RE: [Geopriv] static location on a mobile device (Marc Berryman)
   6. RE: [Geopriv] static location on a mobile device (Stastny Richard)
   7. Re: [Geopriv] static location on a mobile device
      (Henning Schulzrinne)

----------------------------------------------------------------------

Message: 1
Date: Thu, 06 Apr 2006 11:16:50 +0200
From: Hannes Tschofenig <[email-masked]>
Subject: [Ecrit] ECRIT Requirements Draft WGLC Status
To: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Hi all,

during the WGLC for <draft-ietf-ecrit-requirements-05.txt> we have
received a number of comments.
Roger has addressed editorial comments already with the most recent
draft submission (<draft-ietf-ecrit-requirements-06.txt>)

We have added the open issues to the issue tracker and Roger has already
worked on the resolution of them. Please find them at:
http://www.ietf-ecrit.org:8080/ecrit-req/
Thanks Roger for the quick reaction.

Please take a look at the raised issues.

After we resolved all open issues there will be another draft version
and then we are restarting a short WGLC. We think that this is necessary
given the modifications the document has seen.

Ciao
Hannes & Marc

PS: Henning did a serious review based on the previous draft version. 
Please find it at: 
http://www.ietf-ecrit.org/TEMP/draft-ietf-ecrit-requirements-05_review.p
df
Note that the editorial comments have been addressed already with the
most recent draft update. The technical issues have been addressed to
the issue tracker.

------------------------------

Message: 2
Date: Thu, 06 Apr 2006 08:46:11 -0400
From: Andrew Newton <[email-masked]>
Subject: [Ecrit] static location on a mobile device
To: [email-masked], [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

[  This is being cross-posted to both GEOPRIV and ECRIT.  The use case
is for emergency services but it deals with location.  ]

Despite our best efforts, I believe in less than ideal situations (and 
there will be many) we may end up with mobile devices configured with 
static locations.  Here is the scenario as the world works today in some

situations:

   A user signs up for voip service.  In the process of getting voip 
service, their location is determined (either by asking the user or some

database lookup).  This location is based on the endpoint of the users 
broadband connection.
   Now, the user takes the device associated with that location to his 
friends house.  If a call is placed, the location conveyed will be 
different than the location of the actual device.

This is simply a fact of life.  It will happen.  I was thinking that it 
would be a good thing if the location could be conveyed to the PSAP with

the following note, "This location has been configured statically, but 
the device may have been moved."  Naturally, an actual english message 
is not the best thing... a well-known tag would work better the world
over.

Before I jump into the solution space, I was wondering what people 
thought of the idea.

-andy

------------------------------

Message: 3
Date: Thu, 6 Apr 2006 09:09:49 -0400
From: "Marc Linsner" <[email-masked]>
Subject: [Ecrit] RE: [Geopriv] static location on a mobile device
To: "'Andrew Newton'" <[email-masked]>, <[email-masked]>,
	<[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain;	charset="us-ascii"

Obviously the use case is valid.

Are you suggesting that the 'Manual' pidf-lo method is not sufficient to
cover this use case?

-Marc-

> -----Original Message-----
> From: Andrew Newton [mailto:[email-masked]] 
> Sent: Thursday, April 06, 2006 8:46 AM
> To: [email-masked]; [email-masked]
> Subject: [Geopriv] static location on a mobile device
> 
> [  This is being cross-posted to both GEOPRIV and ECRIT.  The 
> use case is for emergency services but it deals with location.  ]
> 
> 
> Despite our best efforts, I believe in less than ideal 
> situations (and 
> there will be many) we may end up with mobile devices configured with 
> static locations.  Here is the scenario as the world works 
> today in some 
> situations:
> 
>    A user signs up for voip service.  In the process of getting voip 
> service, their location is determined (either by asking the 
> user or some 
> database lookup).  This location is based on the endpoint of 
> the users 
> broadband connection.
>    Now, the user takes the device associated with that 
> location to his 
> friends house.  If a call is placed, the location conveyed will be 
> different than the location of the actual device.
> 
> This is simply a fact of life.  It will happen.  I was 
> thinking that it 
> would be a good thing if the location could be conveyed to 
> the PSAP with 
> the following note, "This location has been configured 
> statically, but 
> the device may have been moved."  Naturally, an actual 
> english message 
> is not the best thing... a well-known tag would work better 
> the world over.
> 
> Before I jump into the solution space, I was wondering what people 
> thought of the idea.
> 
> -andy
> 
> 
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv

------------------------------

Message: 4
Date: Thu, 06 Apr 2006 16:23:32 +0200
From: Hannes Tschofenig <[email-masked]>
Subject: [Ecrit] ECRIT Security Threats Draft Status
To: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Hi all,

following the discussions at the last IETF meeting here is a short 
status report regarding <draft-ietf-ecrit-security-threats-00.txt>.

Tom had two modifications in mind:

a) During the meeting we concluded that the requirements language was 
not quite right in all places.

b) Steven Kent raised a security aspect to the subject regarding the 
ESRP using a mapping server subject to a business arrangement.

Tom is working on a draft update. Thanks Tom!

After we see the new draft we should think about a WGLC for this 
document as well.

Ciao
Hannes

------------------------------

Message: 5
Date: Thu, 6 Apr 2006 09:21:56 -0500
From: "Marc Berryman" <[email-masked]>
Subject: [Ecrit] RE: [Geopriv] static location on a mobile device
To: "Marc Linsner" <[email-masked]>, "Andrew Newton"
	<[email-masked]>,	<[email-masked]>, <[email-masked]>
Message-ID:
	<[email-masked]>
Content-Type: text/plain;	charset="US-ASCII"

In the best of all worlds, the mobile device would "know" it has been
moved and request the location information be updated (either by manual
update or obtaining the location from the new connection point e.g.
wiremap). Of course this may would be the best case and not necessarily
the common case. 

While it is out of the scope of this WG, we need to make sure there is a
consumer education / awareness aspect so the end users will know this
may happen, and to update their location every time they move.

Marc B

-----Original Message-----
From: Marc Linsner [mailto:[email-masked]] 
Sent: Thursday, April 06, 2006 8:10 AM
To: 'Andrew Newton'; [email-masked]; [email-masked]
Subject: RE: [Geopriv] static location on a mobile device

Obviously the use case is valid.

Are you suggesting that the 'Manual' pidf-lo method is not sufficient to
cover this use case?

-Marc-

> -----Original Message-----
> From: Andrew Newton [mailto:[email-masked]] 
> Sent: Thursday, April 06, 2006 8:46 AM
> To: [email-masked]; [email-masked]
> Subject: [Geopriv] static location on a mobile device
> 
> [  This is being cross-posted to both GEOPRIV and ECRIT.  The 
> use case is for emergency services but it deals with location.  ]
> 
> 
> Despite our best efforts, I believe in less than ideal 
> situations (and 
> there will be many) we may end up with mobile devices configured with 
> static locations.  Here is the scenario as the world works 
> today in some 
> situations:
> 
>    A user signs up for voip service.  In the process of getting voip 
> service, their location is determined (either by asking the 
> user or some 
> database lookup).  This location is based on the endpoint of 
> the users 
> broadband connection.
>    Now, the user takes the device associated with that 
> location to his 
> friends house.  If a call is placed, the location conveyed will be 
> different than the location of the actual device.
> 
> This is simply a fact of life.  It will happen.  I was 
> thinking that it 
> would be a good thing if the location could be conveyed to 
> the PSAP with 
> the following note, "This location has been configured 
> statically, but 
> the device may have been moved."  Naturally, an actual 
> english message 
> is not the best thing... a well-known tag would work better 
> the world over.
> 
> Before I jump into the solution space, I was wondering what people 
> thought of the idea.
> 
> -andy
> 
> 
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

------------------------------

Message: 6
Date: Thu, 6 Apr 2006 16:35:00 +0200
From: "Stastny Richard" <[email-masked]>
Subject: [Ecrit] RE: [Geopriv] static location on a mobile device
To: "Marc Berryman" <[email-masked]>, "Marc Linsner"
	<[email-masked]>,	"Andrew Newton" <[email-masked]>,
	<[email-masked]>, <[email-masked]>
Message-ID:
	<[email-masked]>
Content-Type: text/plain;	charset="us-ascii"

I consider a tag or warning useful not only with
static configuration, but also with dynamic configuration

Brian is proposing in his I-D ecrit-phonebcp,
that a device immediately gets his location at
attachment time, and each time the device is moved
The device may detect this by some means, e.g. change of
IP address or change of hotspot, etc.

What may happen here is that the device is not
able to retrieve the location at this time, so the
location information may be tagged as out-dated
until a new location information may be retrieved

The same could be done with manual configuration, if
the device detects a potential change in location.

Richard

> -----Original Message-----
> From: Marc Berryman [mailto:[email-masked]]
> Sent: Thursday, April 06, 2006 4:22 PM
> To: Marc Linsner; Andrew Newton; [email-masked]; [email-masked]
> Subject: RE: [Geopriv] static location on a mobile device
> 
> In the best of all worlds, the mobile device would "know" it has been
> moved and request the location information be updated (either by
manual
> update or obtaining the location from the new connection point e.g.
> wiremap). Of course this may would be the best case and not
necessarily
> the common case.
> 
> While it is out of the scope of this WG, we need to make sure there is
a
> consumer education / awareness aspect so the end users will know this
> may happen, and to update their location every time they move.
> 
> Marc B
> 
> -----Original Message-----
> From: Marc Linsner [mailto:[email-masked]]
> Sent: Thursday, April 06, 2006 8:10 AM
> To: 'Andrew Newton'; [email-masked]; [email-masked]
> Subject: RE: [Geopriv] static location on a mobile device
> 
> Obviously the use case is valid.
> 
> Are you suggesting that the 'Manual' pidf-lo method is not sufficient
to
> cover this use case?
> 
> -Marc-
> 
> > -----Original Message-----
> > From: Andrew Newton [mailto:[email-masked]]
> > Sent: Thursday, April 06, 2006 8:46 AM
> > To: [email-masked]; [email-masked]
> > Subject: [Geopriv] static location on a mobile device
> >
> > [  This is being cross-posted to both GEOPRIV and ECRIT.  The
> > use case is for emergency services but it deals with location.  ]
> >
> >
> > Despite our best efforts, I believe in less than ideal
> > situations (and
> > there will be many) we may end up with mobile devices configured
with
> > static locations.  Here is the scenario as the world works
> > today in some
> > situations:
> >
> >    A user signs up for voip service.  In the process of getting voip
> > service, their location is determined (either by asking the
> > user or some
> > database lookup).  This location is based on the endpoint of
> > the users
> > broadband connection.
> >    Now, the user takes the device associated with that
> > location to his
> > friends house.  If a call is placed, the location conveyed will be
> > different than the location of the actual device.
> >
> > This is simply a fact of life.  It will happen.  I was
> > thinking that it
> > would be a good thing if the location could be conveyed to
> > the PSAP with
> > the following note, "This location has been configured
> > statically, but
> > the device may have been moved."  Naturally, an actual
> > english message
> > is not the best thing... a well-known tag would work better
> > the world over.
> >
> > Before I jump into the solution space, I was wondering what people
> > thought of the idea.
> >
> > -andy
> >
> >
> >
> > _______________________________________________
> > Geopriv mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/geopriv
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 
> 
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv

------------------------------

Message: 7
Date: Thu, 06 Apr 2006 11:29:29 -0400
From: Henning Schulzrinne <[email-masked]>
Subject: [Ecrit] Re: [Geopriv] static location on a mobile device
To: Marc Berryman <[email-masked]>
Cc: [email-masked], [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

This is fairly easy to determine automatically, as a move almost always 
implies a change in (public) IP address or, at least, a change in the 
802.11 AP address. For wired devices in large-scale enterprise LANs, 
loss of Ethernet carrier is a good indication, although with false 
positives.

Marc Berryman wrote:
> In the best of all worlds, the mobile device would "know" it has been
> moved and request the location information be updated (either by
manual
> update or obtaining the location from the new connection point e.g.
> wiremap). Of course this may would be the best case and not
necessarily
> the common case. 
> 
> While it is out of the scope of this WG, we need to make sure there is
a
> consumer education / awareness aspect so the end users will know this
> may happen, and to update their location every time they move.
> 
> Marc B
> 
> -----Original Message-----
> From: Marc Linsner [mailto:[email-masked]] 
> Sent: Thursday, April 06, 2006 8:10 AM
> To: 'Andrew Newton'; [email-masked]; [email-masked]
> Subject: RE: [Geopriv] static location on a mobile device
> 
> Obviously the use case is valid.
> 
> Are you suggesting that the 'Manual' pidf-lo method is not sufficient
to
> cover this use case?
> 
> -Marc-
> 
>> -----Original Message-----
>> From: Andrew Newton [mailto:[email-masked]] 
>> Sent: Thursday, April 06, 2006 8:46 AM
>> To: [email-masked]; [email-masked]
>> Subject: [Geopriv] static location on a mobile device
>>
>> [  This is being cross-posted to both GEOPRIV and ECRIT.  The 
>> use case is for emergency services but it deals with location.  ]
>>
>>
>> Despite our best efforts, I believe in less than ideal 
>> situations (and 
>> there will be many) we may end up with mobile devices configured with

>> static locations.  Here is the scenario as the world works 
>> today in some 
>> situations:
>>
>>    A user signs up for voip service.  In the process of getting voip 
>> service, their location is determined (either by asking the 
>> user or some 
>> database lookup).  This location is based on the endpoint of 
>> the users 
>> broadband connection.
>>    Now, the user takes the device associated with that 
>> location to his 
>> friends house.  If a call is placed, the location conveyed will be 
>> different than the location of the actual device.
>>
>> This is simply a fact of life.  It will happen.  I was 
>> thinking that it 
>> would be a good thing if the location could be conveyed to 
>> the PSAP with 
>> the following note, "This location has been configured 
>> statically, but 
>> the device may have been moved."  Naturally, an actual 
>> english message 
>> is not the best thing... a well-known tag would work better 
>> the world over.
>>
>> Before I jump into the solution space, I was wondering what people 
>> thought of the idea.
>>
>> -andy
>>
>>
>>
>> _______________________________________________
>> Geopriv mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/geopriv
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 
> 
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv

------------------------------

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

End of Ecrit Digest, Vol 15, Issue 3
************************************

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Andrew Newton <[email-masked]>
Date: Thu, 06 Apr 2006 15:29:45 -0400

> based on Pull or Push request instead of ASP/VSP.

I 100% agree.  This is just an attempt to cover the less than ideal 
situation.  I'm not advocating the less than ideal situation, just 
trying to cover the bases when the ideal situation cannot be achieved.

-andy