Subject: [Ecrit] RE: [Geopriv] static location on a mobile device

From: "Stark, Barbara" <[email-masked]>
Date: Mon, 10 Apr 2006 15:08:44 -0500

I'd like to suggest an additional scenario for us to consider.

We (BellSouth) currently offer a "WIMAX-like" "fixed wireless" service
in several cities (like New Orleans, Biloxi, etc., where much of the
communications infrastructure was destroyed). The customer-side antenna
for this service is rather small (about the size of a mass market
paperback book) and can be run off battery power. The output of this
little antenna is a RJ-45 Ethernet jack. A laptop can be plugged into
this Ethernet jack. The user would then run a PPPoE client (standard
feature in XP) to connect to our network. Once the network connection is
established, the user can run a SIP client on the laptop. Now the user
can drive all around the city and use VoIP from anywhere in a 7 square
mile (or so) area.

The network-side antenna is connected through ATM to our core network,
and from there to the same BRASs that serve our regular DSL customers.
These BRASs terminate the PPPoE sessions, just like they do for our
regular DSL.

The laptop and SIP client in this case have absolutely no idea that they
are "mobile". All they see is an Ethernet connection, and the IP address
they get from PPPoE doesn't change over the 7 sq mi. Only the user and
the network are aware of the laptop's mobility.

So, if we are to consider a tag or warning that originates from the
client, do we also need some way for the network to tell the client that
they are potentially mobile or have moved? 

We cannot assume that VoIP clients/devices are aware of their mobility
or potential mobility.
Barbara

> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]]
> Sent: Thursday, April 06, 2006 10:35 AM
> To: Marc Berryman; Marc Linsner; Andrew Newton; [email-masked];
> [email-masked]
> Subject: RE: [Geopriv] static location on a mobile device
> 
> 
> I consider a tag or warning useful not only with
> static configuration, but also with dynamic configuration
> 
> Brian is proposing in his I-D ecrit-phonebcp,
> that a device immediately gets his location at
> attachment time, and each time the device is moved
> The device may detect this by some means, e.g. change of
> IP address or change of hotspot, etc.
> 
> What may happen here is that the device is not
> able to retrieve the location at this time, so the
> location information may be tagged as out-dated
> until a new location information may be retrieved
> 
> The same could be done with manual configuration, if
> the device detects a potential change in location.
> 
> Richard
> 
> > -----Original Message-----
> > From: Marc Berryman [mailto:[email-masked]]
> > Sent: Thursday, April 06, 2006 4:22 PM
> > To: Marc Linsner; Andrew Newton; [email-masked]; [email-masked]
> > Subject: RE: [Geopriv] static location on a mobile device
> > 
> > In the best of all worlds, the mobile device would "know" 
> it has been
> > moved and request the location information be updated (either by
> manual
> > update or obtaining the location from the new connection point e.g.
> > wiremap). Of course this may would be the best case and not
> necessarily
> > the common case.
> > 
> > While it is out of the scope of this WG, we need to make 
> sure there is
> a
> > consumer education / awareness aspect so the end users will 
> know this
> > may happen, and to update their location every time they move.
> > 
> > Marc B
> > 
> > -----Original Message-----
> > From: Marc Linsner [mailto:[email-masked]]
> > Sent: Thursday, April 06, 2006 8:10 AM
> > To: 'Andrew Newton'; [email-masked]; [email-masked]
> > Subject: RE: [Geopriv] static location on a mobile device
> > 
> > Obviously the use case is valid.
> > 
> > Are you suggesting that the 'Manual' pidf-lo method is not 
> sufficient
> to
> > cover this use case?
> > 
> > -Marc-
> > 
> > > -----Original Message-----
> > > From: Andrew Newton [mailto:[email-masked]]
> > > Sent: Thursday, April 06, 2006 8:46 AM
> > > To: [email-masked]; [email-masked]
> > > Subject: [Geopriv] static location on a mobile device
> > >
> > > [  This is being cross-posted to both GEOPRIV and ECRIT.  The
> > > use case is for emergency services but it deals with location.  ]
> > >
> > >
> > > Despite our best efforts, I believe in less than ideal
> > > situations (and
> > > there will be many) we may end up with mobile devices configured
> with
> > > static locations.  Here is the scenario as the world works
> > > today in some
> > > situations:
> > >
> > >    A user signs up for voip service.  In the process of 
> getting voip
> > > service, their location is determined (either by asking the
> > > user or some
> > > database lookup).  This location is based on the endpoint of
> > > the users
> > > broadband connection.
> > >    Now, the user takes the device associated with that
> > > location to his
> > > friends house.  If a call is placed, the location conveyed will be
> > > different than the location of the actual device.
> > >
> > > This is simply a fact of life.  It will happen.  I was
> > > thinking that it
> > > would be a good thing if the location could be conveyed to
> > > the PSAP with
> > > the following note, "This location has been configured
> > > statically, but
> > > the device may have been moved."  Naturally, an actual
> > > english message
> > > is not the best thing... a well-known tag would work better
> > > the world over.
> > >
> > > Before I jump into the solution space, I was wondering what people
> > > thought of the idea.
> > >
> > > -andy
> > >
> > >
> > >
> > > _______________________________________________
> > > Geopriv mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/geopriv
> > 
> > _______________________________________________
> > Geopriv mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/geopriv
> > 
> > 
> > 
> > _______________________________________________
> > Geopriv mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/geopriv
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 

*****

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from all computers. 117

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Brian Rosen" <[email-masked]>
Date: Mon, 10 Apr 2006 16:45:15 -0400

There are going to be lots of such services.  This is "LAN behind a WAN"
with the caveat that the whole thing can be mobile.

I do think we need a flag somewhere that says "caution, location can change
at any moment".  I think the procedures we had in mind for emergency calls
are(get your location at boot, get a mapping at boot, update your mapping at
call time) would be changed by the addition of "if mobile flag is set,
update location at call time" prior to "update mapping".

The flag, if set, means that the AoR needs a presence service with
Subscribe/Notify

Brian

-----Original Message-----
From: Stark, Barbara [mailto:[email-masked]] 
Sent: Monday, April 10, 2006 4:09 PM
To: Stastny Richard; Marc Berryman; Marc Linsner; Andrew Newton;
[email-masked]; [email-masked]
Subject: [Ecrit] RE: [Geopriv] static location on a mobile device

*****

The information transmitted is intended only for the person or entity to
which it is addressed and may contain confidential, proprietary, and/or
privileged material. Any review, retransmission, dissemination or other use
of, or taking of any action in reliance upon this information by persons or
entities other than the intended recipient is prohibited. If you received
this in error, please contact the sender and delete the material from all
computers. 117

---

From: Randall Gellens <[email-masked]>
Date: Tue, 11 Apr 2006 15:27:27 -0700

At 4:45 PM -0400 4/10/06, Brian Rosen wrote:

>  at any moment".

I can see how such a flag might be useful.  What I was wondering 
about in my earlier mail was a flag that said "this device won't 
move", as that seems less likely to be accurate.  So, the presence of 
your flag is a warning that the device is likely to move; its absence 
doesn't imply that the device won't move.
-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
What is mind?  No matter.
What is matter?  Never mind.
        --Thomas Hewitt Key, 1799-1875