Subject: RE: [Ecrit] Re: Review of draft-ietf-ecrit-service-urn-02 (sos.police)

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 9 Apr 2006 21:27:45 -0500

The line needs to be drawn somewhere; so, I'd say that leaving as-is for now is best.

Brian's suggestion that you could purposefully mess with precision to ensure that you get the federal police is dangerous.  That sort of thing _might_ make sense in some cases; but I suspect that the end-user isn't always the one you want to have making that choice.  Division based on type of incident is probably safer, because then you get the federal police when it's appropriate for them to attend, and not because a caller thought it would be best.  Roaming users then don't make incorrect assumptions about jurisdiction.

That could lead to a different set of labels (to be slightly frivolous):

  sos.disturbance_of_the_peace
  sos.disturbance_of_the_peace.domestic_dispute
  sos.car_crash (gets police, fire and ambulance)
  sos.gas_leak
  sos.explosion
  sos.gunshots
  sos.hold-up

The problem being that this sort of list is almost infinite - but isn't that one of the jobs of the call taker?

Martin

p.s. Everyone knows that the US is "special"...and Alcohol, Tobacco and Firearms is a store.

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Monday, 10 April 2006 11:44 AM
> To: Rosen, Brian
> Cc: [email-masked]
> Subject: [Ecrit] Re: Review of draft-ietf-ecrit-service-urn-02
> (sos.police)
> 
> 
> 
> > Consider the following issue: there is sos.police.  In most areas
> > of the
> > world, there are several kinds of police services that are related to
> > the hierarchy of the jurisdictions.  In North America, you typically
> > have local police, county police, state police and national police
> > (FBI).  Some other services have this characteristic.  Do we want to
> > allow a subservice under police?  An alternative is to allow a
> > query to
> > a higher level civic address (a LoST query to a1=us, a2=pa for
> > sos.police gets you the Pennsylvania State Police).  That wouldn't
> > work
> > for a geo query.
> 
> An interesting issue.  I suspect that this would be hard to
> categorize easily by hierarchy, as the hierarchy differs across
> countries. (For example, countries such as Germany only have
> essentially two levels - state and border patrol - while centralized
> countries such as France have, I believe, only one national police
> service.)
> 
> In the US, this gets even more complicated since you have not just
> the ones you mention, but also campus police on every larger
> university campus, Amtrak police, ATF, capitol police (in DC), Secret
> Service and I'm sure FEMA has its own police force (equipped with
> bows and arrows). Until a few years ago, NYC had separate police
> forces for public housing and transit.
> 
> Thus, I suspect you have to try to find designations that are
> geographically-independent, such as
>    police. transportation
>    police. border
>    police. campus
>    police. public-housing
>    police. terrorism
> 
> It is not clear to me that this is practically useful, as most people
> who need to know will be asking for ATF or FBI, rather than trying to
> guess which label applies to which service. Others will only need
> 'police' and then be transferred to the right agency. In the US,
> there are likely going to be several competing agencies :-)
> 
> Do we want to do this now or wait until the need arises?
> 
> Henning
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 10 Apr 2006 14:29:58 -0400

That's fine for someone that does not know which service he needs, and
doesn't know the number.  Right now, if you have the number, and you
want to location based route it, we need to define a service so we can
do the right thing in LoST.

These labels aren't for human consumption; they are protocol mechanisms.
There are separate services, and we need an identifier for each separate
service.

I'm not objecting to (later) adding some more mechanisms to help users
distinguish.  I'm suggesting that we can include some more service
labels in the initial set.

Or not.

Brian

-----Original Message-----
From: Henning Schulzrinne [mailto:[email-masked]] 
Sent: Monday, April 10, 2006 2:24 PM
To: Rosen, Brian
Cc: Andrew Newton; [email-masked]
Subject: Re: [Ecrit] Re: Review of draft-ietf-ecrit-service-urn-02
(sos.police)

I think in some cases, a two-layer model may work better where services 
are not easily categorized by simple labels:

- Query for service urn:service:police.directory (or something like
that)

- Get a search interface where you can type in "FBI" or "narcotics". The

search interface would be suitably geographically tailored so that 
"county sheriff" returns your county sheriff, not somebody from another 
state.

This is similar to the approach used in big cities. In NYC, you call 
311, rather than trying to figure out which of the hundreds of agencies 
serves your particular non-emergency need.

Rosen, Brian wrote:
> I am sorry, but I find this logic questionable.
> 
> There is a clear need.  If you have a way to dial them now, and any of
> them need accurate location based routing, then we need services for
> them.  You can't say because there are more than 2 of them it's too
> hard.
> 
> OTOH, it will be easy to add them, so we can punt for now
>

---

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 10 Apr 2006 18:20:47 -0500

Yes Japan does.
Each service dialed directly.

> From: Drage, Keith (Keith) [mailto:[email-masked]]
> Sent: Tuesday, 11 April 2006 9:16 AM
> To: 'Rosen, Brian'; 'Andrew Newton'; 'Henning Schulzrinne'
> Cc: [email-masked]'
> Subject: RE: [Ecrit] Re: Review of draft-ietf-ecrit-service-urn-02
> (sos.police)
> 
> Can you clarify what you mean by " If you have a way to dial them
now".
> 
> We are talking about a substructuring of the "sos" service URN, and
surely
> this is not meant to be about a means of being able to reach the
police
> generally.
> 
> Does any country in the world have such a level of discrimination for
> emergency calls?
> 
> regards
> 
> Keith
> 
> > From: Rosen, Brian [mailto:[email-masked]]
> > Sent: 10 April 2006 19:14
> > To: Andrew Newton; Henning Schulzrinne
> > Cc: [email-masked]
> > Subject: RE: [Ecrit] Re: Review of draft-ietf-ecrit-service-urn-02
> > (sos.police)
> >
> >
> > From: Andrew Newton [mailto:[email-masked]]
> > Sent: Monday, April 10, 2006 10:18 AM
> > To: Henning Schulzrinne
> > Cc: Rosen, Brian; [email-masked]
> > Henning Schulzrinne wrote:
> > > 'police' and then be transferred to the right agency. In
> > the US, there
> >
> > > are likely going to be several competing agencies :-)
> >
> > I totally agree.  I also can't imagine the user interface
> > being all that
> >
> > helpful in an emergency situation by offering a slew of sub-police
> > function categories.
> >
> > >
> > Wait.
> > -andy

---

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 10 Apr 2006 18:27:49 -0500

You are right, I stand corrected.

> Sent: Tuesday, 11 April 2006 9:27 AM
> To: Winterbottom, James; Drage, Keith (Keith); Rosen, Brian; Andrew
> Newton; Henning Schulzrinne
> Cc: [email-masked]
> Japan does exactly what is already covered in the URN document.
> 
> The discussion being proposed is to substructure even further into
types
> of police, and so on.
> Japan does not do that.
> > From: Winterbottom, James [mailto:[email-masked]]
> > Sent: 11 April 2006 00:21
> > To: Drage, Keith (Keith); Rosen, Brian; Andrew Newton; Henning
> > Schulzrinne
> > Cc: [email-masked]
> > > > There is a clear need.  If you have a way to dial them
> > now, and any
> > of