Subject: Re. [Ecrit] WGLC - A Dynamic Host Configuration Protocol (DHCP) based Location-to-Service Translation Protocol (LoST) Discovery Procedure

From: Leslie Daigle <[email-masked]>
Date: Mon, 19 Feb 2007 18:29:32 -0500

Hi,

Having a look at the document, there's (only!) one thing that
I'm unclear about:

>    RFC 1035 [RFC1035] encoding was chosen to accommodate future
>    internationalized domain name mechanisms.

Sorry to quack like a goose, but:  huh?

I went through the mailing list archive (as I'm not a subscriber)
and couldn't find traces of the discussion about this point, so my
apologies for the lack of context.

But what is this trying to say?

Either the DHCP option supports IDNs natively (i.e., in Unicode),
in which case:
	. this option is not (just) supporting domain names,
	  it is also supporting IDNs, and
	. RFC 1035 conventions will not help, because they
	  constrain the content of the octets beyond what is needed
	  for Unicode.

Or, the DHCP option is supporting encoded IDNs (IDNA), in which
case they are identical to every other domain name, so it's not
clear why that's a motivation for a specific encoding.

Or, this group is anticipating some other developments not even
on the horizon for IDN encodings, which makes the engineering
hard.

Would it be reasonable to just drop the paragraph altogether?

Leslie.

> To: <ecrit at ietf.org>
> Subject: [Ecrit] WGLC - A Dynamic Host Configuration Protocol (DHCP) based	Location-to-Service Translation Protocol (LoST) Discovery Procedure
> From: "Marc Linsner" <mlinsner at cisco.com>
> Date: Wed, 14 Feb 2007 17:26:00 -0500
> 
> All,
> 
> This message marks the issuance of a working group last call (WGLC) on
> ECRIT's Internet Draft entitled "A Dynamic Host Configuration Protocol
> (DHCP) based Location-to-Service Translation Protocol (LoST) Discovery
> Procedure" (draft-ietf-ecrit-dhc-lost-discovery-00.txt).  You may view this
> document at
> http://www.ietf.org/internet-drafts/draft-ietf-ecrit-dhc-lost-discovery-00.t
> xt.
> 
> Please post comments and questions to this mailing list no later than 2
> March 2007.
> 
> -Marc Linsner-
> ECRIT co-chair
> 
> _______________________________________________
> Ecrit mailing list
> Ecrit at ietf.org
> https://www1.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 19 Feb 2007 20:57:50 -0500

I'm happy to drop the reference; I think this was copied from  
somewhere else and may or may not have made sense back then. The idea  
is to use IDNA, based on DHCP-WG advice received (and SIP DHCP option  
precedent).

On Feb 19, 2007, at 6:29 PM, Leslie Daigle wrote:

>> Subject: [Ecrit] WGLC - A Dynamic Host Configuration Protocol  
>> (DHCP) based	Location-to-Service Translation Protocol (LoST)  
>> Discovery Procedure

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 21 Feb 2007 20:00:31 +0100

Hi Leslie,

Here is the updated draft:
http://www.tschofenig.priv.at/svn/draft-tschofenig-dhc-lost-discovery/draft-ietf-ecrit-dhc-lost-discovery-01.txt

I have removed the sentence you pointed to. It was a copy-and-paste bug.

Ciao
Hannes

Henning Schulzrinne wrote:
>>> Subject: [Ecrit] WGLC - A Dynamic Host Configuration Protocol (DHCP) 
>>> based    Location-to-Service Translation Protocol (LoST) Discovery 
>>> Procedure