Subject: [Ecrit] LoST Implementation

From: Błaszczyk Piotr <[email-masked]>
Date: Fri, 2 Feb 2007 17:36:08 +0100

Dear Hannes,

There is a... where 'sourceId' as unique key is needed. We are wondering how to generate it.
We suppose it could be some hash (md5 or sha1) of record in db, but we are not sure.
Is this element related in any way to 'version' element.
It is not described in draft.

There is also 'expiretime' element.
Is it working as 'expiretime from last answer' or 'expiretime as constant date' ?
If in first case, is it always the same period of time or it depends on some other conditions?

Last question is about civil address, especially what about incorrect civil address.
For example: country is ok, town is ok, but all other is not the right one.
What response should be send ?

-- 
Pozdrowienia,
 Blaszczyk Piotr

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 02 Feb 2007 12:51:02 -0500

Hi

> It is not described in draft.

The draft suggests to use a *Universally Unique Identifier (UUID)*.

You could, however, us a long random number as well.

> If in first case, is it always the same period of time or it depends on some other conditions?

It indicates when the mapping is about to expire. The expiry time is 
typically quite large -- a matter of days

> What response should be send ?
Are you talking about validation or not being able to determine the 
mapping ?

Ciao
Hannes

---

From: Krzysztof Rzecki <[email-masked]>
Date: Fri, 02 Feb 2007 19:02:28 +0100

> You could, however, us a long random number as well.

[...]

Probably there is no library in Java to generate UUID, so I think 
truncated to right lenght sum (md5 or sha1) of columns should be 
enought, because, there are no (I guess) replicate records in DB.

-- 

pozdrawiam,
Krzysztof Rzecki
__________________________________________
Krzysztof Rzecki, CCNS Software Department
CCNS SA, ul. Reymonta 27, PL 30-059 Kraków
e-mail: [email-masked], mob.: +48 695 144 411

---

From: Andrew Newton <[email-masked]>
Date: Fri, 2 Feb 2007 13:55:46 -0500

> enought, because, there are no (I guess) replicate records in DB.

http://java.sun.com/j2se/1.5.0/docs/api/java/util/UUID.html

Enjoy!

-andy

---

From: Krzysztof Rzecki <[email-masked]>
Date: Fri, 02 Feb 2007 20:05:25 +0100

Thank you !

-- 

pozdrawiam,
Krzysztof Rzecki