Subject: [Ecrit] Re: [Geopriv] RFC 3205 & HELD

From: Richard Barnes <[email-masked]>
Date: Sun, 28 Oct 2007 10:19:26 -0400

It's also worth noting that RFC 3205 is just a set of recommendations, 
not anything binding.  Since the document doesn't make a general 
requirement for ALL http-based protocols to have a different URI scheme 
and port number, was there something in particular about HELD that led 
you to those requirements?

We should probably have this same debate about LoST, although it may be 
mostly subsumed by previous discussions.  (Cross-posted to ECRIT)

--RB

Hannes Tschofenig wrote:
> I have read RFC 3205 and my impression is that for HELD we have to
> * define a new URI scheme, and
> * use a different port number.
> 
> Thoughts?
> 
> Ciao
> Hannes
> 
> PS: What is the value of WSDL in the HELD specification?
> 
> 
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 28 Oct 2007 15:22:59 +0100

RFC 3205 essentially says: If you use HTTP for things other than 
webbrowsing then you should register a new URI scheme and use a 
different port number.

I was wondering what people think about that idea.

Richard Barnes wrote:
> requirement for ALL http-based protocols to have a different URI 
> scheme and port number, was there something in particular about HELD 
> that led you to those requirements?
>
> We should probably have this same debate about LoST, although it may 
> be mostly subsumed by previous discussions.  (Cross-posted to ECRIT)
>
> --RB
>
>
>
>
> Hannes Tschofenig wrote:

---

From: "Thomson, Martin" <[email-masked]>
Date: Sun, 28 Oct 2007 17:29:39 -0500

I read RFC 3205 a while back when going through the initial revisions of the document.  Given the nature of the discovery process, the URI scheme is not a definite requirement.  Originally, when a GET returned a PIDF-LO (rather than a wrapped PIDF-LO) I was of the opinion that the http: URI was best.  Given the change to a wrapped PIDF-LO, I am tending towards a new scheme.

I think that we have to consider the usage context.  Primarily, a HELD URI will be obtained from the discovery process.  Are there any other cases where a HELD URI would be used?  Perhaps the web-page test might work; that is, can we imagine the URI appearing on a web-page?  If so, we don't want the semantics of HELD confused with the semantics expected by a regular web user.

I don't think that discussing ports is necessary - I'd like the choice of port to be explicit in all cases.

I think that LoST is much clearer - make a new scheme.

Cheers,
Martin

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Monday, 29 October 2007 1:23 AM
> To: Richard Barnes
> Cc: GEOPRIV; ECRIT
> Subject: [Ecrit] Re: [Geopriv] RFC 3205 & HELD
> 

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit