Subject: Re: [Ecrit] Draft new: draft-holmberg-ecrit-callback-00

From: "DOLLY, MARTIN C (ATTSI)" <[email-masked]>
Date: Mon, 30 May 2011 13:12:16 -0400

Christer

We need callback in NA

Martin

Martin C. Dolly
Sent to you by AT&T... America's Fastest Mobile Broadband Network. Rethink Possible.
+1.609.903.3360

----- Original Message -----
From: [email-masked] <[email-masked]>
To: ECRIT <[email-masked]>
Sent: Mon May 30 08:00:17 2011
Subject: Re: [Ecrit] Draft new: draft-holmberg-ecrit-callback-00

Hi,

Does silence mean that the WG has no interest in working with a PSAP callback mechanism, and if someone wants a solution they should specify it themselves?

I understand that people are busy etc, but PSAP callback in general hasn't been discussed on the list since Prague, so I would like to know whether there is interest.

Regards,

Christer

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Christer Holmberg
> Sent: 11. toukokuuta 2011 11:38
> To: ECRIT
> Subject: Re: [Ecrit] Draft new: draft-holmberg-ecrit-callback-00
> 
> Hi,
>  
> I have received some off-line comments that it might be 
> possible to merge this draft with draft-ietf-ecrit-psap-callback.
> 
> I have no problem with that.
> 
> However, the document define different mechanisms, so we 
> would need to decided whether we are going to go forward with 
> one of those, or both.
> 
> In any case, I would like the WG to discuss and make a decission.
> 
> Regards,
> 
> Christer
> 
> 
> ________________________________
> 
> 	From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christer Holmberg
> 	Sent: 3. toukokuuta 2011 15:46
> 	To: ECRIT
> 	Subject: [Ecrit] Draft new: draft-holmberg-ecrit-callback-00
> 	
> 	
> 		 
> 	Hi PSAP callback fans,
> 	 
> 	I've submitted a draft, 
> draft-holmberg-ecrit-callback-00.txt, which extends the PSAP 
> callback "token" mechanism (previously presented by Cullen), 
> by also informing the home registrar about the token value 
> (allowing the home network to detect PSAP callbacks).
> 	 
> 	I realize much text is still missing from the draft, 
> but I hope what is now provided will be enough for the WG to 
> decide whether to start working on a solution based on the 
> one described in draft. And, if so, whether to use the draft 
> as base document.
> 	 
> 	Regards,
> 	 
> 	Christer
> 	
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit
> 
_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 31 May 2011 08:23:04 +0200

Hi Martin,

It's also needed in 3GPP.

But, if ECRIT is only going to discuss this for 30 minutes, 3 times a year during the IETF meetings, we will never get a solution in time :)

So, at this point I am not asking the WG for a decission on mechanism, but to indicate whether there is interest to work on a solution in the first place. I am sure 3GPP, and others, are interested in knowing that.

Regards,

Christer

> From: DOLLY, MARTIN C (ATTSI) [mailto:[email-masked]] 
> Sent: 30. toukokuuta 2011 20:12
> To: Christer Holmberg; [email-masked]
> Does silence mean that the WG has no interest in working with 
> a PSAP callback mechanism, and if someone wants a solution 
> they should specify it themselves?
> 
> I understand that people are busy etc, but PSAP callback in 
> general hasn't been discussed on the list since Prague, so I 
> would like to know whether there is interest.
> 
> Regards,
> 
> Christer
> 
>  
> 
> > I have received some off-line comments that it might be possible to 
> > merge this draft with draft-ietf-ecrit-psap-callback.
> > 
> would need to 
> > decided whether we are going to go forward with one of 
> those, or both.
> > 
> > draft-holmberg-ecrit-callback-00.txt, which extends the 
> PSAP callback 
> > "token" mechanism (previously presented by Cullen), by also 
> informing 
> > the home registrar about the token value (allowing the home 
> network to 
> > detect PSAP callbacks).
> > 	 
> but I hope what 
> > is now provided will be enough for the WG to decide whether 
> to start 
> > working on a solution based on the one described in draft. 
> And, if so, 
> > whether to use the draft as base document.
> > 	 
> > 	Regards,
> > 	 
> > 	Christer
> >

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 1 Jun 2011 08:26:09 +0200

Hi Brian,

I don't know the time limits for the follow up callback, but as I have said in previous discussions, the need is to be able to have a dedicated callback indicator, so that the home and visited networks can provide special treatment (e.g. disable services) for the callback (the draft I submitted provides such mechanism).

3GPP has had to move the requirement for this forward all the way since Rel-7 (2006!), due to the lack of a solution, so I would really really like to know whether ECRIT is willing to work on a solution or not. If not, I would suggest that ECRIT informs 3GPP about that.

Regards,

Christer

> From: Brian Rosen [mailto:[email-masked]] 
> Sent: 31. toukokuuta 2011 16:00
> To: Christer Holmberg
> Cc: DOLLY, MARTIN C (ATTSI); [email-masked]
> I guess this all depends on what the goals are.
> 
> There are two kinds of call back.
> 
> One is when there is a unexpected loss of connectivity, or an 
> inadvertent hang up, or a call from a responder moments after 
> the actual emergency call happened.
> 
> This kind of call back is to the Contact address, and should 
> get back to the device that placed the call.
> 
> The other is a follow up call.  It may happen hours to days 
> later.  This call is to the AoR, and it should follow the 
> normal call behavior with respect to call forwarding, device 
> selection, etc.
> 
> ISTM that the problems of a call back to the Contact address, 
> given it was an emergency call to begin with are 
> straightforward.  I'd be willing to work on that.
> 
> A call back to an AoR is a normal call, no special processing 
> is needed.
> 
> Note that today, all we have is the AoR call, with no special 
> processing.
> 
> The other k
> On May 31, 2011, at 2:23 AM, Christer Holmberg wrote:
> 
> > 
> > Hi Martin,
> > 
> > But, if ECRIT is only going to discuss this for 30 minutes, 
> 3 times a 
> > year during the IETF meetings, we will never get a solution 
> in time :)
> > 
> > So, at this point I am not asking the WG for a decission on 
> mechanism, but to indicate whether there is interest to work 
> on a solution in the first place. I am sure 3GPP, and others, 
> are interested in knowing that.
> > 
> > Regards,
> > 
> > Christer
> > 
> > 
> >> Does silence mean that the WG has no interest in working 
> with a PSAP 
> >> callback mechanism, and if someone wants a solution they should 
> >> specify it themselves?
> >> 
> >> I understand that people are busy etc, but PSAP callback 
> in general 
> >> hasn't been discussed on the list since Prague, so I would like to 
> >> know whether there is interest.
> >> 
> >> Regards,
> >> 
> >> Christer
> >> 
> >> 
> >> 
> possible to