Subject: [Ecrit] Using Internet services to call for help

From: "Richard L. Barnes" <[email-masked]>
Date: Fri, 30 Dec 2011 17:22:20 -0500

The latest story of someone using an Internet service to call for help, in this case Facebook messaging.  She had to use Facebook because her phone only had an IP connection (over WiFi) and no PSTN link.
<http://www.northjersey.com/news/Woman_uses_Facebook_to_call_for_help_in_hackensack.html>

In a fully ECRIT world, of course, she would have been able to actually place a call/text to her local PSAP.  Even without ECRIT-enabling her device, though,  Facebook would have been able to proxy her through to 911, if only
1. The local emergency services had an IM-capable interface that they advertised through LoST (cf. [1]), and 
2. Facebook were able to get some idea of the victim's geolocation, through something like an OBO request to the mobile provider or even a generic IP-geo lookup.

--Richard

[1] <http://www.facebook.com/blog.php?post=297991732130>

---

From: Martin Thomson <[email-masked]>
Date: Sat, 31 Dec 2011 16:07:40 +1300

Or, for 2. Facebook were able to get some idea of her location because
she was able to tell Facebook.  Don't assume that Facebook is (or
should be) able to unilaterally able to acquire a person's location.

Besides, her phone should have any number of ways of working out where
it is, plus a straightforward API for sharing it with sites that have
permission.

On 31/12/2011, Richard L. Barnes <[email-masked]> wrote:
> The latest story of someone using an Internet service to call for help, in
> this case Facebook messaging.  She had to use Facebook because her phone
> only had an IP connection (over WiFi) and no PSTN link.
> In a fully ECRIT world, of course, she would have been able to actually
> place a call/text to her local PSAP.  Even without ECRIT-enabling her
> device, though,  Facebook would have been able to proxy her through to 911,
> if only
> 2. Facebook were able to get some idea of the victim's geolocation, through
> something like an OBO request to the mobile provider or even a generic
> IP-geo lookup.
>
> --Richard
>
>
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit
>