Subject: [Ecrit] Data Provider Contact URI

From: "Hannes Tschofenig" <[email-masked]>
Date: Tue, 28 May 2013 08:44:45 +0200 (CEST)

Hi all,

I just had a chat with James about the data provider contact URI and he asked me why the URI must be a SIP URI. Although the text talks about how to encode a telephone number in the SIP URI I wasn't able to explain James why we couldn't simply put a tel URI in there.

Here is the text from the current draft:

http://tools.ietf.org/html/draft-ietf-ecrit-additional-data-08#section-5.5

--------

5.5. Data Provider Contact URI

Data Element: Data Provider Contact URI

Use: Required XML Element: <ContactURI>

Description: For a service provider the contact SHOULD be a contact URI. This MUST be a SIP URI. If a telephone number is the contact address it should be provided in the form of sip:telephonenumber@serviceprovider:user=phone. If the call is from a device, this would reflect the contact information of the owner of the device. When provided by a service provider, this would be a URI to a 24/7 support organization tasked to provide PSAP support for this emergency call.

--------

Any objection to allow other URIs to be included in the ​<ContactURI> element? The XML schema only allows one occurence and I wonder why we shouldn't allow multiple occurences here.

Ciao

Hannes

---

From: Brian Rosen <[email-masked]>
Date: Tue, 28 May 2013 08:44:46 -0400

Because it might not be a telephone number, it very well could be a SIP URI.

Brian

On May 28, 2013, at 2:44 AM, Hannes Tschofenig <[email-masked]> wrote:

> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Tue, 28 May 2013 15:04:18 +0200 (CEST)

Correct. For this reason I would like to allow a SIP URI, a tel URI, or other URIs.

Gesendet: Dienstag, 28. Mai 2013 um 14:44 Uhr

Von: "Brian Rosen" <[email-masked]>

An: "Hannes Tschofenig" <[email-masked]>

Cc: [email-masked]

Betreff: Re: [Ecrit] Data Provider Contact URI

Brian

Hi all,

--------

--------

Ciao

Hannes

Ecrit mailing list

[email-masked]

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 29 May 2013 06:34:54 +0800

Thanks Hannes.

I think that the key here is that the URI is expected to contain the immediate means of contacting the provider so it shouldn’t be opened to all URI types. For example email would not be appropriate here. I would be okay with restricting it to SIP and tel for now, though I can see that with webRTC emerging we made to revisit the list.

Cheers
James

From: [email-masked] [mailto:[email-masked]] On Behalf Of Hannes Tschofenig
Sent: Tuesday, 28 May 2013 11:04 PM
To: Brian Rosen
Cc: [email-masked]
Subject: Re: [Ecrit] Data Provider Contact URI

Gesendet: Dienstag, 28. Mai 2013 um 14:44 Uhr
Von: "Brian Rosen" <[email-masked]<mailto:[email-masked]>>
An: "Hannes Tschofenig" <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Betreff: Re: [Ecrit] Data Provider Contact URI
Because it might not be a telephone number, it very well could be a SIP URI.

Brian

Hi all,

--------

5.5<http://tools.ietf.org/html/draft-ietf-ecrit-additional-data-08#section-5.5>. Data Provider Contact URI

--------

---

From: Martin Thomson <[email-masked]>
Date: Tue, 28 May 2013 16:18:29 -0700

On 28 May 2013 15:34, Winterbottom, James
<[email-masked]> wrote:
> I would be okay with restricting it to SIP and tel for now, though I can see
> that with webRTC emerging we made to revisit the list.

Restrictions might be inappropriate in light of WebRTC.  I would
recommend the use of SHOULD, with an explanation of why the SHOULD
subjects were selected.

I might be tempted to suggest that "skype:..." is equally appropriate,
but I probably have a distorted perspective in this regard.  It begs
the question: what about proprietary identifiers?  Of course, this
would only be appropriate if it weren't just one contact URI.  Why
does this have to be just one?

--Martin

---

From: "Winterbottom, James" <[email-masked]>
Date: Wed, 29 May 2013 08:33:25 +0800

Hi Martin,

I am okay with the SHOULD and the why.
The key function of this contact identifier is that the provider of the data can be contacted 24x7 by anyone that needs to. So I think that proprietary identifiers would need to be de facto standard (like Skype .. *8)) in order for them to be appropriate.

Cheers
James

-----Original Message-----
From: Martin Thomson [mailto:[email-masked]] 
Sent: Wednesday, 29 May 2013 9:18 AM
To: Winterbottom, James
Cc: Hannes Tschofenig; Brian Rosen; [email-masked]
Subject: Re: [Ecrit] Data Provider Contact URI

On 28 May 2013 15:34, Winterbottom, James <[email-masked]> wrote:
> I would be okay with restricting it to SIP and tel for now, though I 
> can see that with webRTC emerging we made to revisit the list.

Restrictions might be inappropriate in light of WebRTC.  I would recommend the use of SHOULD, with an explanation of why the SHOULD subjects were selected.

I might be tempted to suggest that "skype:..." is equally appropriate, but I probably have a distorted perspective in this regard.  It begs the question: what about proprietary identifiers?  Of course, this would only be appropriate if it weren't just one contact URI.  Why does this have to be just one?

--Martin