Subject: [Ecrit] I-D Action: draft-ietf-ecrit-additional-data-13.txt

From: [email-masked]
Date: Wed, 16 Oct 2013 02:14:16 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Emergency Context Resolution with Internet Technologies Working Group of the IETF.

	Title           : Additional Data related to an Emergency Call
	Author(s)       : Brian Rosen
                          Hannes Tschofenig
                          Roger Marshall
                          Randall Gellens
                          James Winterbottom
	Filename        : draft-ietf-ecrit-additional-data-13.txt
	Pages           : 86
	Date            : 2013-10-16

Abstract:
   When an emergency call is sent to a Public Safety Answering Point
   (PSAP), the device that sends it, as well as any application service
   provider in the path of the call, or access network provider through
   which the call originated may have information about the call, the
   caller or the location which the PSAP may be able to use.  This
   document describes data structures and a mechanism to convey such
   data to the PSAP.  The mechanism uses a Uniform Resource Identifier
   (URI), which may point to either an external resource or an object in
   the body of the SIP message.  The mechanism thus allows the data to
   be passed by reference (when the URI points to an external resource)
   or by value (when it points into the body of the message).  This
   follows the tradition of prior emergency services standardization
   work where data can be conveyed by value within the call signaling
   (i.e., in body of the SIP message) and also by reference.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ecrit-additional-data

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-ecrit-additional-data-13

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-ecrit-additional-data-13

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 16 Oct 2013 10:09:54 +0000

Hi,

I had some comments on v-11 of the draft, but I don't think they have been addressed in the new version.

----------------------

Q1: 	Question on scope of the Contact URI, defined in section 3.1.5
E-mail: 	http://www.ietf.org/mail-archive/web/ecrit/current/msg08641.html

My issue was about the semantics/usage of the Contact URI, and whether it e.g. should be used for callbacks.

Brian explained that that is not the purpose of the Contact URI, and indicated that some clarification text will be added. However, I see no such text.

----------------------

Q2:	Question on possible conflict between language feature tag and data provider language, defined in section 3.1.6
E-mail:	http://www.ietf.org/mail-archive/web/ecrit/current/msg08642.html

My issue was why we couldn't use media feature tags, indicating the supported languages.

----------------------

Q3:	Question on multiple entities adding data
E-mail:	http://www.ietf.org/mail-archive/web/ecrit/current/msg08646.html

My issue was whether multiple entities could add information, and whether multiple MIMEs would be used in such case, etc.

I also requested some example pictures, showing a call where multiple types of entities add information.

Related to this, James W asked whether a single entity should be allowed to enter multiple types of information.

----------------------

Regards,

Christer

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 16. lokakuuta 2013 12:14
To: [email-masked]
Cc: [email-masked]
Subject: [Ecrit] I-D Action: draft-ietf-ecrit-additional-data-13.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 16 Oct 2013 13:43:57 +0200

Hi Christer,

with today's draft updates we have tried to address the feedback from 
Barbara. We will try to address your remarks within the next few days.

Sorry for the delay; we certainly haven't forgotten your review remarks.

Ciao
Hannes