Subject: [Ecrit] Block name terseness in additional-data draft

From: Randall Gellens <[email-masked]>
Date: Sun, 3 Nov 2013 09:15:25 -0800

I noticed that we are not consistent in the degree of terseness of 
the block names.  We have:

	o	ProviderInfo
	o	SvcInfo
	o	DevInfo
	o	SubInfo

I wonder if people feel we should have a consistent terseness level, 
and if so, consistently more or less so.  E.g., perhaps we should go 
with less terse and have:

	o	ProviderInfo
	o	ServiceInfo
	o	DeviceInfo
	o	SubscriberInfo

Or, perhaps we should go with more terse and have:

	o	PrvdrInfo
	o	SvcInfo
	o	DevInfo
	o	SubInfo

Personally, I'm inclined towards spending the extra few octets and 
going with the less terse names, as I suspect this may be easier for 
people to remember, and perhaps less likely to have spelling errors 
in implementations.  But I'd really like to know what others in the 
group think.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
I always avoid prophesying beforehand, because it is a much better
policy to prophesy after the event has already taken place.
    --Winston Churchill

---

From: Gunnar Hellstrom <[email-masked]>
Date: Sun, 03 Nov 2013 18:51:53 +0100

I agree, the longer look better.
/Gunnar
On 2013-11-03 18:15, Randall Gellens wrote:
> I noticed that we are not consistent in the degree of terseness of the 
> block names.  We have:
>
>     o    ProviderInfo
>     o    SvcInfo
>     o    DevInfo
>     o    SubInfo
>
> people to remember, and perhaps less likely to have spelling errors in 
> implementations.  But I'd really like to know what others in the group 
> think.
>

---

From: Roger Marshall <[email-masked]>
Date: Sun, 3 Nov 2013 18:16:47 +0000

I agree to the longer styles - per the examples, at least.

Sent from my mobile device

On Nov 3, 2013, at 9:52 AM, "Gunnar Hellstrom" <[email-masked]> wrote:

>> I noticed that we are not consistent in the degree of terseness of the block names.  We have:
>> 
>>    o    ProviderInfo
>>    o    SvcInfo
>>    o    DevInfo
>>    o    SubInfo
>> 
>> I wonder if people feel we should have a consistent terseness level, and if so, consistently more or less so.  E.g., perhaps we should go with less terse and have:
>> 
>>    o    ProviderInfo
>>    o    ServiceInfo
>>    o    DeviceInfo
>>    o    SubscriberInfo
>> 
>> Personally, I'm inclined towards spending the extra few octets and going with the less terse names, as I suspect this may be easier for people to remember, and perhaps less likely to have spelling errors in implementations.  But I'd really like to know what others in the group think.
>> 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

CONFIDENTIALITY NOTICE: The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please notify the sender immediately, and delete it and all attachments from your computer and network.

---

From: James Winterbottom <[email-masked]>
Date: Mon, 4 Nov 2013 06:23:52 +1100

+1

Sent from my iPad