Subject: Re: [Ecrit] draft-ietf-ecrit-additional-data-11: Question on scope of the Contact URI, defined in section 3.1.5

From: Randall Gellens <[email-masked]>
Date: Fri, 1 Nov 2013 19:35:25 -0700

Do we really need to say MUST NOT?  Would it be sufficient
to describe why the URL is not appropriate?  E.g., "Note
that this contact information is not intended for nor is it suitable
for a callback by a PSAP...."

At 6:43 PM +0000 10/22/13, Christer Holmberg wrote:

Content-Language: en-US

Content-Type: multipart/alternative;

boundary="_000_7594FB04B1934943A5C02806D1A2204B1C4EBC2BESESSMB209erics_"

Hi,

I would suggest that the contact
information MUST NOT be used by the PSAP for callbacks, and also say
that the reason is because the contact information may not be
associated with the user or the device that made the emergency call.
No need to mention the Priority header field, simply refer to the
psap-callback draft.

Something like:

"Note that
this contact information MUST NOT be used by PSAPs for
callbacks,

as described in
[I-D.ietf-ecrit-psap-callback], as the contact information might

not be associated
with the user or device that made the emergency call."

Regards,

Christer

From: Hannes Tschofenig
[[email-masked]]

Sent: Tuesday, 22 October 2013 6:45 PM

To: Roger Marshall; Christer Holmberg; Brian Rosen

Cc: ecrit_ietf.org

Subject: Re: [Ecrit] draft-ietf-ecrit-additional-data-11:
Question on scope of the Contact URI, defined in section
3.1.5

Hi Christer,

as discussed in this email thread I added text for clarification:

----

3.1.5.  Data Provider Contact URI

Data Element:  Data Provider Contact URI

Use:  Required

XML Element:  <ContactURI>

Description:  When provided by a service
provider or an access

provider, this information MUST
be a URI to a 24/7 support

organization tasked to provide
PSAP support for this emergency

call.  If the call is from a
device, this would reflect the

contact information of the owner
of the device.  If a telephone

number is the contact address
then it MUST be tel URI.  If it is

provided as a SIP URI then it
MUST be in the form of

sip:telephonenumber@serviceprovider:user=phone.  Note that
this

contact information is not used
by PSAPs for callbacks using a SIP

Priority header field with the
value set to "psap- callback", as

described in
[I-D.ietf-ecrit-psap-callback].

----

Do you think that I managed to capture your concern?

Ciao

Hannes

On 08/26/2013 10:33 PM, Roger Marshall wrote:

> I agree with ChristerÕs suggestion to add caution text.

> -roger.

> *From:[email-masked] [mailto:[email-masked]] *On Behalf

> Of *Christer Holmberg

> *Sent:* Thursday, August 08, 2013 9:44 PM

> *To:* Brian Rosen

> *Cc:* ecrit_ietf.org

> *Subject:* Re: [Ecrit] draft-ietf-ecrit-additional-data-11:
Question on

> scope of the Contact URI, defined in section 3.1.5

> Hi,

> If the PSAP is not supposed to use the field when/if making a
callback,

> I think we shall explicitly state that in the document, and/or
in

> general say that the field must not be used for calls that are
expected

> to be given priority/special handling, and give callback as an
example.

> Regards,

> Christer

> Sent from */Windows/* using *TouchDown*(www.nitrodesk.com

> <http://www.nitrodesk.com>)

> -----Original Message-----

> *From:* Brian Rosen [[email-masked]]

> *To:* Christer Holmberg [[email-masked]]

> *CC:* ecrit_ietf.org [[email-masked]]

> *Subject:* Re: [Ecrit] draft-ietf-ecrit-additional-data-11:
Question on

> scope of the Contact URI, defined in section 3.1.5

> The Contact is how the PSAP contacts the service provider to get
help

> from the SP.

> It's not a "call back" in the sense of an emergency
call (the network

> doesn't treat it differently than a normal call), at least as far
as I

> have considered it.  I suppose it might be nice to know that
it's

> important, but I don't think that is worth any big new
mechanism.

> Brian

> On Thursday, August 8, 2013, Christer Holmberg wrote:

> I haven't seen any reply to this. Brian, do you have any
opinion?

> Regards,

> Christer

> Sent from */Windows/* using *TouchDown* (www.nitrodesk.com

> <http://www.nitrodesk.com>)

> -----Original Message-----

> *From:* Christer Holmberg [[email-masked]]

> *To:* [email-masked] [[email-masked]]

> *Subject:* [Ecrit] draft-ietf-ecrit-additional-data-11: Question
on

> scope of the Contact URI, defined in section 3.1.5

> Hi,

> A question on the scope of the Contact URI, defined in section
3.1.5 of

> draft-ietf-ecrit-additional-data-11.txt.

> Is the Contact URI supposed by the PSAP when making
callbacks?

> If the value represents a Òservice providerÓ, should PSAP
callbacks also

> be made to the service provider?

> Regards,

> Christer

> CONFIDENTIALITY NOTICE: The information contained in this message
may be

> privileged and/or confidential. If you are not the intended
recipient,

> or responsible for delivering this message to the intended
recipient,

> any review, forwarding, dissemination, distribution or copying of
this

> communication or any attachment(s) is strictly prohibited. If you
have

> received this message in error, please notify the sender
immediately,

> and delete it and all attachments from your computer and
network.

> _______________________________________________

> Ecrit mailing list

> [email-masked]

> https://www.ietf.org/mailman/listinfo/ecrit

_______________________________________________

Ecrit mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/ecrit

--

Randall Gellens

Opinions are personal;    facts are
suspect;    I speak for myself only

-------------- Randomly selected tag: ---------------

Blessed are the meek for they shall inhibit the earth.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Sat, 2 Nov 2013 15:04:34 +0000

I'd further say that if the PSAP has already tried the real contact information and failed to establish a callback, it would seem entirely reasonable that the PSAP tries any other address in the message that might represent the end user.

regards

Keith

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Randall Gellens
Sent: 02 November 2013 02:35
To: Christer Holmberg; Hannes Tschofenig; Roger Marshall; Brian Rosen
Cc: ecrit_ietf.org
Subject: Re: [Ecrit] draft-ietf-ecrit-additional-data-11: Question on scope of the Contact URI, defined in section 3.1.5

Do we really need to say MUST NOT?  Would it be sufficient to describe why the URL is not appropriate?  E.g., "Note that this contact information is not intended for nor is it suitable for a callback by a PSAP...."

Content-Language: en-US

I would suggest that the contact information MUST NOT be used by the PSAP for callbacks, and also say that the reason is because the contact information may not be associated with the user or the device that made the emergency call. No need to mention the Priority header field, simply refer to the psap-callback draft.

Something like:

    "Note that this contact information MUST NOT be used by PSAPs for callbacks,
    as described in [I-D.ietf-ecrit-psap-callback], as the contact information might
    not be associated with the user or device that made the emergency call."

Regards,

Christer

________________________________
From: Hannes Tschofenig [[email-masked]]
Sent: Tuesday, 22 October 2013 6:45 PM
To: Roger Marshall; Christer Holmberg; Brian Rosen
Cc: ecrit_ietf.org
Subject: Re: [Ecrit] draft-ietf-ecrit-additional-data-11: Question on scope of the Contact URI, defined in section 3.1.5
Hi Christer,

----

    Use:  Required

    Description:  When provided by a service provider or an access
       provider, this information MUST be a URI to a 24/7 support
       organization tasked to provide PSAP support for this emergency
       call.  If the call is from a device, this would reflect the
       contact information of the owner of the device.  If a telephone
       number is the contact address then it MUST be tel URI.  If it is
       provided as a SIP URI then it MUST be in the form of
       sip:telephonenumber@serviceprovider:user=phone.  Note that this
       contact information is not used by PSAPs for callbacks using a SIP
       Priority header field with the value set to "psap- callback", as
       described in [I-D.ietf-ecrit-psap-callback].

----

Ciao
Hannes

On 08/26/2013 10:33 PM, Roger Marshall wrote:
> *Subject:* Re: [Ecrit] draft-ietf-ecrit-additional-data-11: Question on
> If the PSAP is not supposed to use the field when/if making a callback,
> I think we shall explicitly state that in the document, and/or in
> general say that the field must not be used for calls that are expected
> to be given priority/special handling, and give callback as an example.
>
> Regards,
>
> Christer
>
>
>
> <<http:///>http://www.nitrodesk.com<http://www.nitrodesk.com/>>)
>
>
> *Subject:* Re: [Ecrit] draft-ietf-ecrit-additional-data-11: Question on
> The Contact is how the PSAP contacts the service provider to get help
> from the SP.
>
> It's not a "call back" in the sense of an emergency call (the network
> doesn't treat it differently than a normal call), at least as far as I
> have considered it.  I suppose it might be nice to know that it's
> important, but I don't think that is worth any big new mechanism.
>
> Brian
>
>
>
> I haven't seen any reply to this. Brian, do you have any opinion?
>
> Regards,
>
> Christer
>
>
>
> <<http:///>http://www.nitrodesk.com<http://www.nitrodesk.com/>>)
>
>
> *Subject:* [Ecrit] draft-ietf-ecrit-additional-data-11: Question on
> A question on the scope of the Contact URI, defined in section 3.1.5 of
> Is the Contact URI supposed by the PSAP when making callbacks?
>
> If the value represents a Òservice providerÓ, should PSAP callbacks also
> CONFIDENTIALITY NOTICE: The information contained in this message may be
> privileged and/or confidential. If you are not the intended recipient,
> or responsible for delivering this message to the intended recipient,
> any review, forwarding, dissemination, distribution or copying of this
> communication or any attachment(s) is strictly prohibited. If you have
> received this message in error, please notify the sender immediately,
> and delete it and all attachments from your computer and network.
>
>
>

--

Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 3 Nov 2013 18:10:13 +0000

Hi,

I am ok with the suggestions below, if the PSAP callback using the "real" contact has failed.

The important thing is that the text is clear on that the contact information may not even point to the device/user that made the associated emergency call.

Regards,

Christer

Lähettäjä: DRAGE, Keith (Keith) [mailto:[email-masked]]
Lähetetty: 2. marraskuuta 2013 17:05
Vastaanottaja: Randall Gellens; Christer Holmberg; Hannes Tschofenig; Roger Marshall; Brian Rosen
Kopio: ecrit_ietf.org
Aihe: RE: [Ecrit] draft-ietf-ecrit-additional-data-11: Question on scope of the Contact URI, defined in section 3.1.5

regards

Keith

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Randall Gellens

Content-Language: en-US

Something like:

Regards,

Christer

----

    Use:  Required

----

Ciao
Hannes

On 08/26/2013 10:33 PM, Roger Marshall wrote:
> <<http://>http://www.nitrodesk.com<http://www.nitrodesk.com/>>)
>
>
> <<http://>http://www.nitrodesk.com<http://www.nitrodesk.com/>>)
>
>
> *To:* [email-masked]<mailto:[email-masked]> [[email-masked]]
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Ecrit mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ecrit