Subject: Re: [Ecrit] review of draft-marshall-ecrit-similar-location-03

From: Roger Marshall <[email-masked]>
Date: Wed, 28 May 2014 22:14:59 +0000

Scott:
Thank you for reviewing this draft.  I apologize for taking this long to respond & comment.

Reply-comments inline.

-roger marshall.

-----Original Message-----
From: Ecrit [mailto:[email-masked]] On Behalf Of Bradner, Scott
Sent: Tuesday, March 25, 2014 6:00 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Ecrit] review of draft-marshall-ecrit-similar-location-03

as I agreed to do during the ecrit meeting - here is a review of  draft-marshall-ecrit-similar-location-03

This looks like a very useful and simple (the two do not always go together) addition to LoST - something that could be lifesaver in some cases.  (There was a story on the news within the last year about sending emergency response to the wrong address because of just the type of issue that is included as an example - the address was incomplete and the responders were sent to the only address that came up - at least that is how the low pass filter of the news reported it)

Section 1.

current text:

This enhancement to the validation feature within LoST is required in order to ensure a high level of address matching, to overcome user and system input errors, and to support the usefulness of  location-based systems in general.

Comment:

seems to me that the underlying purpose is to increase the likelihood of returning the actual correct civic address at the cost of possibly returning additional valid but incorrect addresses.

[rsm] Yes, agree.  Will change text for better reading.

Section 2.

The RFC 2119 cite is not needed since the capitalized terms are not used in the document

overall.

Would there be benefit to adding a section describing the behavior where the LoST server has been upgraded to support this feature but the client has not?  e.g., would there be a way to also return some indication in the completeLocation to say that there are similar addresses and that they should update their client - and maybe return one of the similar addresses or double them up?

     e.g. 6000 15th Ave NW|SW Seattle, WA 98107

[rsm] Maybe. Certainly it is a good idea to talk about compatibility issues in the document.   Would it be enough if the LoST server sent back an error message saying, "similar addresses found - no client support".

Ugly to be sure - but ...  (if this is done there should be guidance that says what the client should do - e.g. if there is a similarLocation then ignore the completeLocation)

[rsm] Agree that caution text would be required if status handled this way.  Other's have opinions on this idea?

also - should there be any discussion of what errors or warnings a LoST server should or should not return if it is returning a similarLocation? (maybe to deal with the upgrade question above)

[rsm] agree to add some better error treatment language.

Scott
_______________________________________________
Ecrit mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ecrit

CONFIDENTIALITY NOTICE: The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please notify the sender immediately, and delete it and all attachments from your computer and network.

---

From: "Bradner, Scott" <[email-masked]>
Date: Wed, 28 May 2014 22:18:54 +0000

the black hole is not permanent :-)

in line

On May 28, 2014, at 6:14 PM, Roger Marshall <[email-masked]> wrote:

> [rsm] Maybe. Certainly it is a good idea to talk about compatibility issues in the document.   Would it be enough if the LoST server sent back an error message saying, "similar addresses found - no client support”.

would work for me

Scott