Subject: [Ecrit] Additional Data: <vcard> vs. <vcards>

From: Archie Cobbs <[email-masked]>
Date: Fri, 14 Nov 2014 11:33:03 -0600

As Chris Santer pointed out in this email
<http://www.ietf.org/mail-archive/web/ecrit/current/msg08927.html>:

The DataProviderContact element is declared in the schema as an
> “xc:vcardType”; instead, it should ... [contain] a ‘vcards’ element from
> the vcard-4.0 namespace.  Specifically note the use of ‘vcards’ plural.
> This is because RFC 6351 explicitly states The <vcards> element MUST be
> present even when only a single vCard is present in an XML document.  The
> schema in 24 points to the single vCard definition, and most (but not all)
> of the examples also show a single vCard, and this appears to be a
> violation of the RFC.
>

Would it be possible to get an informal spot ruling here on the mailing
list on whether the intent here is to use <vcard> (singluar, as currently
specified) or <vcards> (plural, as required by RFC 6351)?

Thanks,
-Archie

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 14 Nov 2014 22:39:55 +0000

I think that is right, although we could have a business rule that said only one.

Brian

On Nov 14, 2014, at 7:33 AM, Archie Cobbs <[email-masked]<mailto:[email-masked]>> wrote:

As Chris Santer pointed out in this email<http://www.ietf.org/mail-archive/web/ecrit/current/msg08927.html>:

The DataProviderContact element is declared in the schema as an “xc:vcardType”; instead, it should ... [contain] a ‘vcards’ element from the vcard-4.0 namespace.  Specifically note the use of ‘vcards’ plural.  This is because RFC 6351 explicitly states The <vcards> element MUST be present even when only a single vCard is present in an XML document.  The schema in 24 points to the single vCard definition, and most (but not all) of the examples also show a single vCard, and this appears to be a violation of the RFC.

Would it be possible to get an informal spot ruling here on the mailing list on whether the intent here is to use <vcard> (singluar, as currently specified) or <vcards> (plural, as required by RFC 6351)?

Thanks,
-Archie

_______________________________________________
Ecrit mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ecrit

---

From: Randall Gellens <[email-masked]>
Date: Sat, 15 Nov 2014 01:41:38 -0800

>  I think that is right, although we could have a business rule that 

The intent all along has been to have one vcard, so I can update the 
document to use <vcards> but specify that only one vcard SHOULD be 
provided.

>
>>  On Nov 14, 2014, at 7:33 AM, Archie Cobbs 
>> <<mailto:[email-masked]>[email-masked]> 
>> wrote:
>>
>>  As Chris Santer pointed out in 
>> <http://www.ietf.org/mail-archive/web/ecrit/current/msg08927.html> 
>> this email:
>>
>> "xc:vcardType"; instead, it should ... [contain] a 'vcards' 
>> element from the vcard-4.0 namespace.  Specifically note the use 
>> of 'vcards' plural.  This is because RFC 6351 explicitly states 
>> The <vcards> element MUST be present even when only a single vCard 
>> is present in an XML document.  The schema in 24 points to the 
>> single vCard definition, and most (but not all) of the examples 
>> also show a single vCard, and this appears to be a violation of 
>> the RFC.
>>
>>
>>  Would it be possible to get an informal spot ruling here on the 
>> mailing list on whether the intent here is to use <vcard> 
>> (singluar, as currently specified) or <vcards> (plural, as 
>> required by RFC 6351)?
>>
>>  Thanks,
>>  -Archie
>>
>>  <mailto:[email-masked]>[email-masked]
>  [email-masked]

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
If A = B and B = C, then A = C, except where void or prohibited by law.

---

From: James Winterbottom <[email-masked]>
Date: Sat, 15 Nov 2014 21:13:17 +1100

And if more than one is provided only the first shall be used.

Sent from my iPhone

> On 15 Nov 2014, at 8:41 pm, Randall Gellens <[email-masked]> wrote:
> 
> The intent all along has been to have one vcard, so I can update the document to use <vcards> but specify that only one vcard SHOULD be provided.
> 
>> 
>>> On Nov 14, 2014, at 7:33 AM, Archie Cobbs <<mailto:[email-masked]>[email-masked]> wrote:
>>> 
>>> As Chris Santer pointed out in <http://www.ietf.org/mail-archive/web/ecrit/current/msg08927.html> this email:
>>> 
>>> The DataProviderContact element is declared in the schema as an "xc:vcardType"; instead, it should ... [contain] a 'vcards' element from the vcard-4.0 namespace.  Specifically note the use of 'vcards' plural.  This is because RFC 6351 explicitly states The <vcards> element MUST be present even when only a single vCard is present in an XML document.  The schema in 24 points to the single vCard definition, and most (but not all) of the examples also show a single vCard, and this appears to be a violation of the RFC.
>>> 
>>>