Subject: [Ecrit] Comments on draft-ietf-ecrit-additional-data-32 / Data Provider String Usage

From: Matt Serra <[email-masked]>
Date: Fri, 10 Jul 2015 18:00:38 +0000

An observation on the latest draft:

Section 4.1.1 Data Provider String:  The Usage is documented as "Conditional", yet the condition is not clearly specified - this may have been muddled when we added guidance for how this field is populated by Devices.

I suggest we change the Usage to Required, or minimally Optional.

Regards,

[rave_email_signature]

  Matthew A. Serra, ENP
  Sr. Director, Product Management
  Mobile:  201.245.1557
  [email-masked]<mailto:[email-masked]>

---

From: Randall Gellens <[email-masked]>
Date: Sun, 19 Jul 2015 02:52:56 -0700

At 6:00 PM +0000 7/10/15, Matt Serra wrote:

>  Section 4.1.1 Data Provider String:  The Usage is documented as 
> "Conditional", yet the condition is not clearly specified - this 
> may have been muddled when we added guidance for how this field is 
> populated by Devices.
>

I added the same text that appears for the other strings (such as 
Data Provider ID): "Optional for blocks supplied by the originating 
device, mandatory otherwise".

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Prostitutes Appeal to Pope
--Newspaper headline