Subject: [Ecrit] 3GPP impact on draft-ecall: usage of legacy modem to transport MSD

From: Christer Holmberg <[email-masked]>
Date: Fri, 3 Jun 2016 11:35:10 +0000

Hi,

3GPP agreed that, when communicating with a PSTN PSAP, it shall be
possible to transport MSD using a legacy modem on the media plane. The
reason is for not mandating the network to perform ³interworking between
MSD transported in INVITE/INFO and MSD transported using a legacy modem on
the media plane².

I don¹t think the ecall draft needs to consider WHEN the MSD will be
transported using a legacy modem on the media plane, but I think the draft
should describe the possibility, so that PSAPs are aware of it.

Also, as the same eCall URNs will be used for calls where the MSD is
transported using a legacy modem on the media plane, the draft must enable
usage of the eCall URNs in setup of an IMS emergency call where MSD is
transported using the legacy modem on the media plane.

Regards,

Christer

---

From: Randall Gellens <[email-masked]>
Date: Sat, 4 Jun 2016 16:49:03 -0700

Hi Christer,

I think in-band modem is out of scope of the draft.  The draft is 
limited to SIP signaling aspects.

--Randy

At 11:35 AM +0000 6/3/16, Christer Holmberg wrote:

>  reason is for not mandating the network to perform "interworking between
>  the media plane".
>  I don't think the ecall draft needs to consider WHEN the MSD will be
>  _______________________________________________
>  Ecrit mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/ecrit

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
>From new transmitters came the old stupidities.   --Bertolt Brecht

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 5 Jun 2016 05:21:35 +0000

Hi,

The draft also defines eCall URNs, and those cannot be limited to SIP.

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Randall Gellens<mailto:[email-masked]>
Sent: ‎05/‎06/‎2016 02:49
To: Christer Holmberg<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] 3GPP impact on draft-ecall: usage of legacy modem to transport MSD

Hi Christer,

--Randy

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 5 Jun 2016 05:27:18 +0000

Clarification: the URNs cannot be limited to the INFO mechanism for transporting MSD.

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Christer Holmberg<mailto:[email-masked]>
Sent: ‎05/‎06/‎2016 08:21
To: Randall Gellens<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] 3GPP impact on draft-ecall: usage of legacy modem to transport MSD

Hi,

Regards,

Christer

Hi Christer,

--Randy

---

From: Randall Gellens <[email-masked]>
Date: Tue, 7 Jun 2016 17:03:08 -0700

Hi Christer,

The URNs are registered as child elements of the SOS service URN, so 
they are in no way limited to INFO.

At 5:27 AM +0000 6/5/16, Christer Holmberg wrote:

>  From: <mailto:[email-masked]>Christer Holmberg
>  Sent: 05/06/2016 08:21
>  To: <mailto:[email-masked]>Randall Gellens; 
> <mailto:[email-masked]>[email-masked]
>  From: <mailto:[email-masked]>Randall Gellens
>  Sent: 05/06/2016 02:49
>  To: <mailto:[email-masked]>Christer Holmberg; 
> <mailto:[email-masked]>[email-masked]
>> <https://www.ietf.org/mailman/listinfo/ecrit>https://www.ietf.org/mailman/listinfo/ecrit
>
>
>  --
>  Randall Gellens

-------------- Randomly selected tag: ---------------
True patriotism hates injustice in its own land more than anywhere else.
    --Clarence Darrow

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Wed, 8 Jun 2016 12:27:32 +0000

I have made similar comments to Christer at least a couple of times.

Firstly, the only usage of this draft is in 3GPP networks. Noone has identified a use case or a deployment for this draft outside 3GPP. 3GPP has special usages of SIP for emergency calls, which essentially require it to be used via IMS entities. Try and use SIP outside this, and it will not be an emergency call in the 3GPP network, and the call will probably fail for roaming users. The IMS standards do specify what happens in regard to correlation with the CS domain, and the URNs defined for emergency call usage must take account of it.

The URNs identity the resource to which the call should be routed. 

For the existing sos URNs, the interworking with the CS domain has no special capabilities and is handled within IMS. The media bearers used for IMS based emergency calls are a superset of those used for CS domain emergency call, and therefore there is no disparity in the URN usage.

In 3GPP ecall, that resource must be a resource capable of handling both the data transfer mechanism specifically designed for IMS, but also the existing data transfer mechanism using a modem based mechanism. There is no interworking point defined for converting one mechnanism to the other, and the PSAP is expected to handle both (as is the calling UA). Therefore the URNs must identity a resource that handles both. If transmission fails using the mechanism defined by this draft (presumably because of interworking) then the UA and PSAP will drop back to trying to use the existing modem based approach. 

Therefore the draft that defined the URN must define these semantics for the resource addressed.

No one is saying you need to write the rest of the story relating to CS data transfer, but the URN definition must encompass it.

Regards

Keith

-----Original Message-----
From: Ecrit [mailto:[email-masked]] On Behalf Of Randall Gellens
Sent: 08 June 2016 01:03
To: Christer Holmberg; [email-masked]
Subject: Re: [Ecrit] 3GPP impact on draft-ecall: usage of legacy modem to transport MSD

Hi Christer,

The URNs are registered as child elements of the SOS service URN, so they are in no way limited to INFO.

--
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: --------------- True patriotism hates injustice in its own land more than anywhere else.
    --Clarence Darrow

---

From: Randall Gellens <[email-masked]>
Date: Wed, 8 Jun 2016 08:57:14 -0700

Hi Keith,

It seems to me that 3GPP is the entity that should define the 
semantics, since they define IMS and IMS emergency calls.

If you feel that the draft needs to do so, could you send the text 
you suggest be added to the draft, so we can see it and see if it is 
in scope for the draft?

--Randy

At 12:27 PM +0000 6/8/16, Keith (Nokia - GB) Drage wrote:

>  Firstly, the only usage of this draft is in 3GPP networks. Noone 
> has identified a use case or a deployment for this draft outside 
> 3GPP. 3GPP has special usages of SIP for emergency calls, which 
> essentially require it to be used via IMS entities. Try and use SIP 
> outside this, and it will not be an emergency call in the 3GPP 
> network, and the call will probably fail for roaming users. The IMS 
> standards do specify what happens in regard to correlation with the 
> CS domain, and the URNs defined for emergency call usage must take 
> account of it.
>
>  For the existing sos URNs, the interworking with the CS domain has 
> no special capabilities and is handled within IMS. The media 
> bearers used for IMS based emergency calls are a superset of those 
> used for CS domain emergency call, and therefore there is no 
> disparity in the URN usage.
>
>  In 3GPP ecall, that resource must be a resource capable of handling 
> both the data transfer mechanism specifically designed for IMS, but 
> also the existing data transfer mechanism using a modem based 
> mechanism. There is no interworking point defined for converting 
> one mechnanism to the other, and the PSAP is expected to handle 
> both (as is the calling UA). Therefore the URNs must identity a 
> resource that handles both. If transmission fails using the 
> mechanism defined by this draft (presumably because of 
> interworking) then the UA and PSAP will drop back to trying to use 
> the existing modem based approach.
>
>  No one is saying you need to write the rest of the story relating 
> to CS data transfer, but the URN definition must encompass it.
>
>  Regards
>
>  Keith
>
>  -------------- Randomly selected tag: --------------- True 
> patriotism hates injustice in its own land more than anywhere else.
>      --Clarence Darrow
>

-------------- Randomly selected tag: ---------------
37% of Americans agree that while they would hate being British,
they wouldn't mind having a British accent.

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Wed, 8 Jun 2016 16:24:13 +0000

Going the direction of 3GPP definition means the draft should remove the URNs entirely and leave their definition and registration to 3GPP. The document definiting the semantics should be referenced by the IANA registration.

In terms of text that we need, my suggestion as a starting point would be something along the lines of:

"ecall: This subtype of the sos URN represents a resource that is optimsed for handling emergency calls carrying ecall data. This URN represents a resource that supports both the data transfer mechanisms identified in this draft, and also those defined in 3GPP TS 26.267 [ref]."

You will need to work this definition into both 14.1 and into either clause 6 (area of last paragraph) or clause 7.

Note that "ecall" is a subtype in its own right, and will need to defined separately to "manual" and "automatic", which are also subtypes in their own right. Theorectically, in terms of what you have defined sos.ecall is equally valid as sos.ecall.manual and sos.ecall.automatic.

I notice that you will probably also need to register "ecall" as a subtype of "test.sos" in the IANA definitions.

Regards

Keith

-----Original Message-----
From: Randall Gellens [mailto:[email-masked]] 
Sent: 08 June 2016 16:57
To: Drage, Keith (Nokia - GB); Christer Holmberg; [email-masked]
Subject: RE: [Ecrit] 3GPP impact on draft-ecall: usage of legacy modem to transport MSD

Hi Keith,

It seems to me that 3GPP is the entity that should define the semantics, since they define IMS and IMS emergency calls.

If you feel that the draft needs to do so, could you send the text you suggest be added to the draft, so we can see it and see if it is in scope for the draft?

--Randy

At 12:27 PM +0000 6/8/16, Keith (Nokia - GB) Drage wrote:

>  Firstly, the only usage of this draft is in 3GPP networks. Noone has 
> identified a use case or a deployment for this draft outside 3GPP. 
> 3GPP has special usages of SIP for emergency calls, which essentially 
> require it to be used via IMS entities. Try and use SIP outside this, 
> and it will not be an emergency call in the 3GPP network, and the call 
> will probably fail for roaming users. The IMS standards do specify 
> what happens in regard to correlation with the CS domain, and the URNs 
> defined for emergency call usage must take account of it.
>
>  For the existing sos URNs, the interworking with the CS domain has no 
> special capabilities and is handled within IMS. The media bearers used 
> for IMS based emergency calls are a superset of those used for CS 
> domain emergency call, and therefore there is no disparity in the URN 
> usage.
>
> mechanism. There is no interworking point defined for converting one 
> mechnanism to the other, and the PSAP is expected to handle both (as 
> is the calling UA). Therefore the URNs must identity a resource that 
> handles both. If transmission fails using the mechanism defined by 
> this draft (presumably because of
> interworking) then the UA and PSAP will drop back to trying to use the 
> existing modem based approach.
>
>  No one is saying you need to write the rest of the story relating to 
> CS data transfer, but the URN definition must encompass it.
>
>  Regards
>
>  Keith
>
>>> <https://www.ietf.org/mailman/listinfo/ecrit>https://www.ietf.org/ma
>>> i
>>>  lman/listinfo/ecrit
>>
>>
>>   --
>>   Randall Gellens
>  -------------- Randomly selected tag: --------------- True patriotism 
> hates injustice in its own land more than anywhere else.
>      --Clarence Darrow
>

--
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: --------------- 37% of Americans agree that while they would hate being British, they wouldn't mind having a British accent.

---

From: Randall Gellens <[email-masked]>
Date: Wed, 8 Jun 2016 11:46:42 -0700

Hi Keith,

Especially since the car-crash draft references this draft and uses 
the same URNs (per your request), it might be best to leave the URN 
registration here, and add text such as "The semantics of these URNs 
when used with an IMS-based eCall are defined by 3GPP."

The draft already registers "ecall" as a child of the "test" service.

--Randy

At 4:24 PM +0000 6/8/16, Keith (Nokia - GB) Drage wrote:

>  Going the direction of 3GPP definition means the draft should 
> remove the URNs entirely and leave their definition and 
> registration to 3GPP. The document definiting the semantics should 
> be referenced by the IANA registration.
>
>  "ecall: This subtype of the sos URN represents a resource that is 
> optimsed for handling emergency calls carrying ecall data. This URN 
> represents a resource that supports both the data transfer 
> mechanisms identified in this draft, and also those defined in 3GPP 
> TS 26.267 [ref]."
>
>  You will need to work this definition into both 14.1 and into 
> either clause 6 (area of last paragraph) or clause 7.
>
>  Note that "ecall" is a subtype in its own right, and will need to 
> defined separately to "manual" and "automatic", which are also 
> subtypes in their own right. Theorectically, in terms of what you 
> have defined sos.ecall is equally valid as sos.ecall.manual and 
> sos.ecall.automatic.
>
>  I notice that you will probably also need to register "ecall" as a 
> subtype of "test.sos" in the IANA definitions.
>
>  Regards
>
>  Keith
>
> you suggest be added to the draft, so we can see it and see if it 
> is in scope for the draft?
>
>  --Randy
>
>  -------------- Randomly selected tag: --------------- 37% of 
> Americans agree that while they would hate being British, they 
> wouldn't mind having a British accent.

-------------- Randomly selected tag: ---------------
Justice is incidental to law and order.
                      --J.Edgar Hoover

---

From: Ivo Sedlacek <[email-masked]>
Date: Thu, 9 Jun 2016 07:25:12 +0000

Hello,

IMO, it does not make sense to have a part of the URN definition in the draft and rest in 3GPP TSs. 

I would like to see a text going in direction proposed by Keith.

Kind regards

Ivo Sedlacek

-----Original Message-----
From: Ecrit [mailto:[email-masked]] On Behalf Of Randall Gellens
Sent: Wednesday, June 08, 2016 8:47 PM
To: Drage, Keith (Nokia - GB); Christer Holmberg; [email-masked]
Subject: Re: [Ecrit] 3GPP impact on draft-ecall: usage of legacy modem to transport MSD

Hi Keith,

Especially since the car-crash draft references this draft and uses the same URNs (per your request), it might be best to leave the URN registration here, and add text such as "The semantics of these URNs when used with an IMS-based eCall are defined by 3GPP."

--Randy

At 4:24 PM +0000 6/8/16, Keith (Nokia - GB) Drage wrote:

>  Going the direction of 3GPP definition means the draft should remove 
> the URNs entirely and leave their definition and registration to 3GPP. 
> The document definiting the semantics should be referenced by the IANA 
> registration.
>
> represents a resource that supports both the data transfer mechanisms 
> identified in this draft, and also those defined in 3GPP TS 26.267 
> [ref]."
>
>  You will need to work this definition into both 14.1 and into either 
> clause 6 (area of last paragraph) or clause 7.
>
> subtypes in their own right. Theorectically, in terms of what you have 
> defined sos.ecall is equally valid as sos.ecall.manual and 
> sos.ecall.automatic.
>
>> has  identified a use case or a deployment for this draft outside 3GPP.
>>  3GPP has special usages of SIP for emergency calls, which 
>> CS domain, and the URNs  defined for emergency call usage must take account of it.
>>
>> no  special capabilities and is handled within IMS. The media bearers 
>> used  for IMS based emergency calls are a superset of those used for 
>> CS  domain emergency call, and therefore there is no disparity in the 
>> URN  usage.
>>

--
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: --------------- Justice is incidental to law and order.
                      --J.Edgar Hoover