Subject: [Ecrit] 3GPP impact on draft-ecall: max MSD size

From: Christer Holmberg <[email-masked]>
Date: Fri, 3 Jun 2016 11:38:54 +0000

Hi,

3GPP has specified a maximum size of 140 bytes for the MSD. We either need to make that a general limit for the info package, or we need to have a mechanism to indicate the max size. Indicating the max size can be done e.g. by defining an Recv-Info header field info package parameter.

Example:

Recv-Info: emergencyCallData.eCall; max-msd-size=140

Note that the size represents the size of the MSD in raw binary format – depending on the encoding the size may be bigger “on the wire”.

Regards,

Christer

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Fri, 3 Jun 2016 13:57:05 +0000

Maybe this is playing with words, but the MSD always has a maximum size of 140 octets, and has a standard content defined by the existing CEN document.

If there is data beyond this existing data content definition, it is no longer the MSD, but some other data set, that needs to be called something else.

I wonder if we actually have two different info packages, rather than some package parameter, i.e. package v1 with MSD only, package v2 etc with additional data beyond MSD. 3GPP release 14 only requires v1 at the moment.

Keith

From: Ecrit [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 03 June 2016 12:39
To: [email-masked]
Subject: [Ecrit] 3GPP impact on draft-ecall: max MSD size

Hi,

Example:

Note that the size represents the size of the MSD in raw binary format - depending on the encoding the size may be bigger "on the wire".

Regards,

Christer

---

From: Randall Gellens <[email-masked]>
Date: Sat, 4 Jun 2016 16:51:05 -0700

Hi Christer,

The draft will be changed to specify sending the MSD in the CEN ASN.1 
encoding, using binary content-transfer-encoding.  So, the result 
will be in conformance with 3GPP's wishes.  The draft does not need 
to impose a specific limit of its own.

At 11:38 AM +0000 6/3/16, Christer Holmberg wrote:

>  Content-Language: en-US
>  Content-Type: multipart/alternative;
>   boundary="_000_D37747B09B2Dchristerholmbergericssoncom_"
>
>  Hi,
>
>  3GPP has specified a maximum size of 140 bytes for the MSD. We 
> either need to make that a general limit for the info package, or 
> we need to have a mechanism to indicate the max size. Indicating 
> the max size can be done e.g. by defining an Recv-Info header field 
> info package parameter.
>
>  Example:
>
>  Note that the size represents the size of the MSD in raw binary 
> format - depending on the encoding the size may be bigger "on the 
> wire".
>
>  Regards,
>
>  Christer
>
>  _______________________________________________
>  Ecrit mailing list
>  [email-masked]
>  https://www.ietf.org/mailman/listinfo/ecrit

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
This fortune intentionally not included.

---

From: Randall Gellens <[email-masked]>
Date: Sat, 4 Jun 2016 16:52:21 -0700

The draft describes the current MSD, which as Keith says, has its own 
size limit.

At 1:57 PM +0000 6/3/16, Keith (Nokia - GB) Drage wrote:

>  Maybe this is playing with words, but the MSD always has a maximum 
> size of 140 octets, and has a standard content defined by the 
> existing CEN document.
>
>  If there is data beyond this existing data content definition, it 
> is no longer the MSD, but some other data set, that needs to be 
> called something else.
>
>  I wonder if we actually have two different info packages, rather 
> than some package parameter, i.e. package v1 with MSD only, package 
> v2 etc with additional data beyond MSD. 3GPP release 14 only 
> requires v1 at the moment.
>
>
>  Keith
>

-------------- Randomly selected tag: ---------------
They're only trying to make me LOOK paranoid!

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 5 Jun 2016 05:31:37 +0000

Hi,

I guess the "current MSD" also nerds to be described in the MIME description.

E.g. "This MIME is used for carrying MSDs as defined in XXX".

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Randall Gellens<mailto:[email-masked]>
Sent: ‎05/‎06/‎2016 02:52
To: Drage, Keith (Nokia - GB)<mailto:[email-masked]>; Christer Holmberg<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] 3GPP impact on draft-ecall: max MSD size

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 5 Jun 2016 06:05:10 +0000

Hi,

I guess 'Content-Type: multipart/alternative' is a mistake?

Regards,

Christer

-----Original Message-----
From: Randall Gellens [mailto:[email-masked]] 
Sent: 05 June 2016 02:51
To: Christer Holmberg <[email-masked]>; [email-masked]
Subject: Re: [Ecrit] 3GPP impact on draft-ecall: max MSD size

Hi Christer,

The draft will be changed to specify sending the MSD in the CEN ASN.1 encoding, using binary content-transfer-encoding.  So, the result will be in conformance with 3GPP's wishes.  The draft does not need to impose a specific limit of its own.

At 11:38 AM +0000 6/3/16, Christer Holmberg wrote:

>  3GPP has specified a maximum size of 140 bytes for the MSD. We either 
> need to make that a general limit for the info package, or we need to 
> have a mechanism to indicate the max size. Indicating the max size can 
> be done e.g. by defining an Recv-Info header field info package 
> parameter.
>
>  Example:
>

--
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: --------------- This fortune intentionally not included.

---

From: Randall Gellens <[email-masked]>
Date: Tue, 7 Jun 2016 17:06:21 -0700

Hi Christer,

Yes, the MIME registration will be updated from "Published 
specification: Annex C of EN 15722" to "Published specification: 
Annex A of EN 15722".

At 5:31 AM +0000 6/5/16, Christer Holmberg wrote:

>  From: <mailto:[email-masked]>Randall Gellens
>  Sent: 05/06/2016 02:52
>  To: <mailto:[email-masked]>Drage, Keith (Nokia - GB); 
> <mailto:[email-masked]>Christer Holmberg; 
> <mailto:[email-masked]> [email-masked]
>>   From: Ecrit 
>> [<mailto:[email-masked]>mailto:[email-masked]] On 
>> Behalf Of Christer Holmberg
>>   Sent: 03 June 2016 12:39
>>   To: [email-masked]
>> <https://www.ietf.org/mailman/listinfo/ecrit>https://www.ietf.org/mailman/listinfo/ecrit
>
>
>  --
>  Randall Gellens

-------------- Randomly selected tag: ---------------
Consistency is the last refuge of the unimaginative.
                                       --Oscar Wilde