Subject: [Ecrit] draft-ietf-ecrit-ecall-11- Content-ID cannot be included when SIP message has solely one body (i.e. no multipart/...)

From: Ivo Sedlacek <[email-masked]>
Date: Thu, 11 Aug 2016 14:04:34 +0000

Hello,

I found another potential issue.

If a SIP message contains solely one body (i.e. not multipart/mixed body), then the SIP message cannot contain a Content-ID header field. 

Content-ID header field is NOT a SIP header field - Content-ID cannot be found in in RFC3261 and Content-ID cannot be found in http://www.iana.org/assignments/sip-parameters/sip-parameters.xhtml#sip-parameters-2 
Content-ID header field is a MIME multipart/mixed header field.

Also, rfc5621 states:
------------
Content-ID URLs allow creating references to body *parts*.
------------

Thus, Figure 10, and Figure 11 (and related procedures) of draft-ietf-ecrit-ecall-11 use a header field (Content-ID header field) not defined in SIP.

Kind regards

Ivo

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 11 Aug 2016 10:50:30 -0400

Hmm. Interesting issue.

ISTM the proper solution to that is to define Content-ID as a SIP header 
field.

Of course a work-around is to add a multipart wrapper to the single body 
part. But that shouldn't be necessary.

	Thanks,
	Paul

On 8/11/16 10:04 AM, Ivo Sedlacek wrote:
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit
>

---

From: Ivo Sedlacek <[email-masked]>
Date: Thu, 11 Aug 2016 14:57:58 +0000

> ISTM the proper solution to that is to define Content-ID as a SIP header field.

I agree.

Actually, we might have this problem already with REFER inviting several participants - see Figure 3 of https://tools.ietf.org/html/rfc5368

So, this is something more generic than eCall draft.

Kind regards

Ivo

---

From: Randall Gellens <[email-masked]>
Date: Fri, 12 Aug 2016 12:49:57 -0700

Seems like RFC 7852 should have added Content-ID as a SIP header.

At 10:50 AM -0400 8/11/16, Paul Kyzivat wrote:

>  Of course a work-around is to add a multipart wrapper to the single 
> body part. But that shouldn't be necessary.
>
>  	Thanks,
>  	Paul
>
>>  If a SIP message contains solely one body (i.e. not 
>> multipart/mixed body), then the SIP message cannot contain a 
>> Content-ID header field.
>>
>>  Content-ID header field is NOT a SIP header field - Content-ID 
>> cannot be found in in RFC3261 and Content-ID cannot be found in 
>> http://www.iana.org/assignments/sip-parameters/sip-parameters.xhtml#sip-parameters-2
>>  Thus, Figure 10, and Figure 11 (and related procedures) of 
>> draft-ietf-ecrit-ecall-11 use a header field (Content-ID header 
>> field) not defined in SIP.
>>
>>  Kind regards
>>
>>  Ivo
>>
>>

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Associate yourself with people of good quality, for it is better to be
alone than in bad company.      --Booker T. Washington

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 15 Aug 2016 10:44:53 +0000

Hi,

I think it¹s better to do it in a separate SIPCORE draft, as it¹s also
needed for non-ECRIT cases.

Regards,

Christer