Subject: Re: [Ecrit] Ivo's review of draft-ietf-ecrit-ecall-15 - Issue 7

From: Christer Holmberg <[email-masked]>
Date: Thu, 27 Oct 2016 11:40:56 +0000

Hi,

>> >>  >  ISSUE 7

>> >>  >  section 6 - "The IVS then attaches an updated MSD to a SIP

>> >>  >     INFO request and sends it within the dialog." - what is meant by

>> >>  > "attaching MSD to SIP INFO request"?

>> >>  I think that's made abundantly clear in the multiple earlier

>> >> instances in the  same section that say "as a MIME body part".

>> >  I do not really know what "attach body to SIP request"  means.

>> > Likely, other readers will not know it either.

>> >  A reference to a section defining how to "attach body to SIP request"

>> > would help.

>> It's the same section, just a little bit before.

>I assume you refer -19 text stating: "[RFC7852] establishes a general mechanism for attaching blocks of

>   data to a SIP emergency call."

I think we could say something like:

“[RFC7852] provides the general guidelines for including emergency call related data in SIP messages”

Then, wherever the text talks about “attaching” data to a SIP message, you use similar terminology:

E.g.,

   "encoding it per Annex A of EN 15722 [msd] and attaching it to a SIP
   message as a MIME body part per [RFC7852].”

…becomes:

   "encoding it per Annex A of EN 15722 [msd] and including it in a SIP
   message as a MIME body part per [RFC7852]. "

Regards,

Christer

---

From: Ivo Sedlacek <[email-masked]>
Date: Mon, 31 Oct 2016 07:04:20 +0000

Hello,

> If you look seven paragraphs above the paragraph in question (same section), 
> you'll see:
> 
>     A PSAP or IVS transmits a metadata/control object (see Section 9) by
>     encoding it per the description in this document and attaching it to
>     a SIP message as a MIME body part per [RFC7852].
> 
> Then, three paragraphs later (four paragraphs above the paragraph in
> question) it uses "attach" again:
> 
>     An In-Vehicle System (IVS) initiating an NG-eCall attaches an MSD to
>     the initial INVITE and optionally attaches a metadata/control object
>     informing the PSAP of its capabilities.
> 
> The surrounding text makes it clear that these are "attached" as body parts 
> in the SIP message.

The above still talks about "attaching"/"attaches" without explaining what it means.

It can be easily misunderstood to refer to inclusion of a body part with Content-Disposition "attachment" in a SIP message.

Kind regards

Ivo