Subject: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA 'sos' Sub-Services registry

From: Az Mankin <[email-masked]>
Date: Thu, 3 Nov 2016 12:59:51 -0700

ECRIT Working Group,

We need a volunteer for the following IANA Expert Review request that
Amanda Baber of IANA just sent to Roger and me.  It needs to be written and
sent to the mailing list, per the IESG's appointment of the WG as the
Expert Reviewer (
http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-labels.xhtml).
Amanda's message is under the line. Who'd like to step up for this?

Thanks!  from your Chairs
----------------

The IANA Services Operator has received a request for registration in the
'sos' Sub-Services registry in the Service URN Labels group. This request
comes from Frederic Firmin of ETSI.

According to RFC 7163, registration in 'sos' Sub-Services requires expert
review as designated by the ECRIT working group or its successor (or, in
their absence, the IESG). Can you send this request for review?

The IESG has asked that expert reviews be completed within two weeks, if
possible.

See below.

thanks,

Amanda Baber
Lead IANA Services Specialist
PTI

===

Contact Name:
Frederic Firmin

Contact Email:
[email-masked]

Type of Assignment:
sub-service URN

Registry:
Service URN Labels registry with the "sos" URN Service Labels subregistry.

Description:
This sub-service type is used before an appropriate sub-service type is
registered with IANA for a specific emergency service. This sub-service
type is not used where an appropriate sub-service type has been registered
with IANA for the specific emergency service.
The next level of sub-services indicates the country where the specific
emergency service is used. Subtypes below this are defined by national
regulation of that country and are not registered with IANA.

Additional Info:
The following service URN is proposed to be registered:
urn:service:sos.country-specific

reference: 24.229 12.14.0 available at http://www.3gpp.org/ftp/Specs/
archive/24_series/24.229/24229-ce0.zip (cf subclause 7.11.1)

---

From: Brian Rosen <[email-masked]>
Date: Thu, 3 Nov 2016 16:56:37 -0400

I’ll do it

Brian

> On Nov 3, 2016, at 3:59 PM, Az Mankin <[email-masked]> wrote:
> 
> ECRIT Working Group,
> 
> We need a volunteer for the following IANA Expert Review request that Amanda Baber of IANA just sent to Roger and me.  It needs to be written and sent to the mailing list, per the IESG's appointment of the WG as the Expert Reviewer (http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-labels.xhtml <http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-labels.xhtml>).  Amanda's message is under the line. Who'd like to step up for this?
> 
> Thanks!  from your Chairs
> ----------------
> 
> 
> The IANA Services Operator has received a request for registration in the 'sos' Sub-Services registry in the Service URN Labels group. This request comes from Frederic Firmin of ETSI.
> 
> According to RFC 7163, registration in 'sos' Sub-Services requires expert review as designated by the ECRIT working group or its successor (or, in their absence, the IESG). Can you send this request for review?
> 
> The IESG has asked that expert reviews be completed within two weeks, if possible.
> 
> See below.
> 
> thanks,
> 
> Amanda Baber
> [email-masked] <mailto:[email-masked]>
> 
> Type of Assignment:
> sub-service URN
> 
> Registry:
> This sub-service type is used before an appropriate sub-service type is registered with IANA for a specific emergency service. This sub-service type is not used where an appropriate sub-service type has been registered with IANA for the specific emergency service.
> The next level of sub-services indicates the country where the specific emergency service is used. Subtypes below this are defined by national regulation of that country and are not registered with IANA.
> 
> 
> Additional Info:
> reference: 24.229 12.14.0 available at http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-ce0.zip <http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-ce0.zip> (cf subclause 7.11.1)
> 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecrit

---

From: Allison Mankin <[email-masked]>
Date: Thu, 3 Nov 2016 14:02:53 -0700

Brian,

Thank you!

On 3 November 2016 at 13:56, Brian Rosen <[email-masked]> wrote:

> Expert Reviewer (http://www.iana.org/assignments/urn-serviceid-
> labels/urn-serviceid-labels.xhtml).  Amanda's message is under the line.
> Who'd like to step up for this?
>
> Thanks!  from your Chairs
> ----------------
>
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 3 Nov 2016 17:09:42 -0400

> I’ll do it

I think it would be good to have this discussed on the list. (Wasn't 
there already some discussion, somewhere?)

	Thanks,
	Paul

> Brian
>
>> On Nov 3, 2016, at 3:59 PM, Az Mankin <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>> ECRIT Working Group,
>>
>> Amanda Baber of IANA just sent to Roger and me.  It needs to be
>> written and sent to the mailing list, per the IESG's appointment of
>> the WG as the Expert Reviewer
>> (http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-labels.xhtml).
>> The IANA Services Operator has received a request for registration in
>> the 'sos' Sub-Services registry in the Service URN Labels group. This
>> request comes from Frederic Firmin of ETSI.
>>
>> According to RFC 7163, registration in 'sos' Sub-Services requires
>> expert review as designated by the ECRIT working group or its
>> successor (or, in their absence, the IESG). Can you send this request
>> for review?
>>
>> This sub-service type is used before an appropriate sub-service type
>> is registered with IANA for a specific emergency service. This
>> sub-service type is not used where an appropriate sub-service type has
>> been registered with IANA for the specific emergency service.
>> The next level of sub-services indicates the country where the
>> specific emergency service is used. Subtypes below this are defined by
>> national regulation of that country and are not registered with IANA.
>>
>>
>> Additional Info:
>> reference: 24.229 12.14.0 available at
>> http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-ce0.zip
>> <http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-ce0.zip>
>> (cf subclause 7.11.1)
>>
>>
>> [email-masked] <mailto:[email-masked]>

---

From: Brian Rosen <[email-masked]>
Date: Thu, 3 Nov 2016 17:14:57 -0400

I intend to.  ISTM this violates the spirit of urn:service:sos

I don’t recall being in or seeing a discussion on this.

Is anyone on the list familiar with this work?

Brian
> On Nov 3, 2016, at 5:09 PM, Paul Kyzivat <[email-masked]> wrote:
> 
> I think it would be good to have this discussed on the list. (Wasn't there already some discussion, somewhere?)
> 
> 	Thanks,
> 	Paul
> 
>> Brian
>>

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Fri, 4 Nov 2016 00:47:08 +0000

This suggestion to discuss on the list before anyone had even looked at it suggests that the WG has totally failed in setting the review criteria for IANA registration to Expert Review. It should be the awkward ones where the reviewer might come to the list, not all of them.

Keith

-----Original Message-----
From: Ecrit [mailto:[email-masked]] On Behalf Of Brian Rosen
Sent: 03 November 2016 21:15
To: Paul Kyzivat
Cc: [email-masked]
Subject: Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA 'sos' Sub-Services registry

I don't recall being in or seeing a discussion on this.

Brian
>> I'll do it
>>> We need a volunteer for the following IANA Expert Review request 
>>> that Amanda Baber of IANA just sent to Roger and me.  It needs to be 
>>> The IANA Services Operator has received a request for registration 
>>> in the 'sos' Sub-Services registry in the Service URN Labels group. 
>>> This request comes from Frederic Firmin of ETSI.
>>> 
>>> successor (or, in their absence, the IESG). Can you send this 
>>> request for review?
>>> 
>>> sub-service type is not used where an appropriate sub-service type 
>>> has been registered with IANA for the specific emergency service.
>>> specific emergency service is used. Subtypes below this are defined 
>>> by national regulation of that country and are not registered with IANA.
>>> 
>>> 
>>> Additional Info:

---

From: Az Mankin <[email-masked]>
Date: Fri, 4 Nov 2016 06:49:34 -0700

Hi, Keith,

When the RFC was reviewed by the IESG, the Expert Review policy was set to
"ECRIT WG or their successor or the IESG if there is no successor."  I
asked for this to be on the list (but noting that it has a two week
deadline) because of this, and I'm not sure what the concern is.

Allison

On Thu, Nov 3, 2016 at 5:47 PM, Drage, Keith (Nokia - GB) <
[email-masked]> wrote:

> This suggestion to discuss on the list before anyone had even looked at it
> suggests that the WG has totally failed in setting the review criteria for
> IANA registration to Expert Review. It should be the awkward ones where the
> reviewer might come to the list, not all of them.
>
> Keith
>

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 4 Nov 2016 10:54:14 -0400

Keith,

> This suggestion to discuss on the list before anyone had even looked at it suggests that the WG has totally failed in setting the review criteria for IANA registration to Expert Review. It should b…

RFC5226 says about expert review:

       - The designated expert is not required to personally bear the
         burden of evaluating and deciding all requests, but acts as a
         shepherd for the request, enlisting the help of others as
         appropriate.  In the case that a request is denied, and
         rejecting the request is likely to be controversial, the expert
         should have the support of other subject matter experts.  That
         is, the expert must be able to defend a decision to the
         community as a whole.

That gives the expert latitude to consult, such as with the WG. And that 
would be the case even if the expert was an individual. In this case the 
wg itself is identified as the "expert".

	Thanks,
	Paul

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Fri, 4 Nov 2016 14:55:28 +0000

The process is that the WG should have (long ago) appointed an expert or experts for the registry, and that information should be given to IANA.

IANA would then send the review request to the appropriate expert and the review would have taken place without necessarily any direct involvement of the WG, based on the criteria specified in the RFC 7163.

Instead this appears to be automatically turning into “Working Group Review” for which there is no such case, rather than “Expert Review”.

Keith

From: Az Mankin [mailto:[email-masked]]
Sent: 04 November 2016 13:50
To: Drage, Keith (Nokia - GB)
Cc: Brian Rosen; Paul Kyzivat; [email-masked]
Subject: Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA 'sos' Sub-Services registry

Hi, Keith,
When the RFC was reviewed by the IESG, the Expert Review policy was set to "ECRIT WG or their successor or the IESG if there is no successor."  I asked for this to be on the list (but noting that it has a two week deadline) because of this, and I'm not sure what the concern is.
Allison

On Thu, Nov 3, 2016 at 5:47 PM, Drage, Keith (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:
This suggestion to discuss on the list before anyone had even looked at it suggests that the WG has totally failed in setting the review criteria for IANA registration to Expert Review. It should be the awkward ones where the reviewer might come to the list, not all of them.

Keith

-----Original Message-----
From: Ecrit [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Brian Rosen
Sent: 03 November 2016 21:15
To: Paul Kyzivat
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA 'sos' Sub-Services registry

Brian
> On Nov 3, 2016, at 5:09 PM, Paul Kyzivat <[email-masked]<mailto:[email-masked]>> wrote:
>
>>> On Nov 3, 2016, at 3:59 PM, Az Mankin <[email-masked]<mailto:[email-masked]>
>>> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>>>
>>> ECRIT Working Group,
>>>
>>> [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>>>
>>> Type of Assignment:
>>> sub-service URN
>>>
>>> Registry:
>>> [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Ecrit mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ecrit

_______________________________________________
Ecrit mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ecrit

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Fri, 4 Nov 2016 15:00:27 +0000

I would add further that the process is for the Expert Reviewer to send any questions or concerns back to IANA and thence to the original requester, not make a post on the list asking if anyone is aware of the issue.

I would stress that any response in this case would need to be based on 3GPP CT1 discussion of the response to the IANA registration requestion, and possibly amendment of the IANA registration section of the referenced specification.

Keith

From: Ecrit [mailto:[email-masked]] On Behalf Of Drage, Keith (Nokia - GB)
Sent: 04 November 2016 14:55
To: Az Mankin
Cc: [email-masked]; Brian Rosen
Subject: Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA 'sos' Sub-Services registry

Keith

Cc: Brian Rosen; Paul Kyzivat; [email-masked]<mailto:[email-masked]>

Hi, Keith,

Keith

-----Original Message-----
From: Ecrit [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Brian Rosen
Sent: 03 November 2016 21:15
To: Paul Kyzivat
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA 'sos' Sub-Services registry

Brian

---

From: Brian Rosen <[email-masked]>
Date: Fri, 4 Nov 2016 11:32:28 -0400

I think the criteria is fine.

If they had proposed a service in the way we envisioned services, say “Swift Water Rescue”, it would be a no-brainer.  

In this case they want to create an escape hatch, country specific, with no registry.  This is not what we anticipated.  That means that the review will be difficult.

An expert reviewer is needed.  Alison asked, and I accepted.  I am the expert reviewer.

I will follow the normal process, which includes consulting with others, in this case, the entire WG, and responding back through the usual channels.

It may be that as a result of this request we generate a document that updates 7163.  We’ll see.

But right now, I think we have a workable process that comports with established IETF procedures.

Brian

> On Nov 4, 2016, at 11:00 AM, Drage, Keith (Nokia - GB) <[email-masked]> wrote:
> 
> From: Ecrit [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Drage, Keith (Nokia - GB)
> Cc: [email-masked] <mailto:[email-masked]>; Brian Rosen
> From: Az Mankin [mailto:[email-masked] <mailto:[email-masked]>] 
> Cc: Brian Rosen; Paul Kyzivat; [email-masked] <mailto:[email-masked]>
> On Thu, Nov 3, 2016 at 5:47 PM, Drage, Keith (Nokia - GB) <[email-masked] <mailto:[email-masked]>> wrote:
> From: Ecrit [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Brian Rosen
> Cc: [email-masked] <mailto:[email-masked]>
> > On Nov 3, 2016, at 5:09 PM, Paul Kyzivat <[email-masked] <mailto:[email-masked]>> wrote:
> >
> >>> On Nov 3, 2016, at 3:59 PM, Az Mankin <[email-masked] <mailto:[email-masked]>
> >>> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
> >>>
> >>> ECRIT Working Group,
> >>>
> >>> (http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-labels.xhtml <http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-labels.xhtml>).
> >>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
> >>>
> >>> Type of Assignment:
> >>> sub-service URN
> >>>
> >>> Registry:
> >>> http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-ce0.zip <http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-ce0.zip>
> >>> <http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-ce0.zi <http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-ce0.zi>
> >>> p>
> >>> (cf subclause 7.11.1)
> >>>
> >>>
> >>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
> >>> https://www.ietf.org/mailman/listinfo/ecrit <https://www.ietf.org/mailman/listinfo/ecrit>
> >>
> >>
> >>
> >> https://www.ietf.org/mailman/listinfo/ecrit <https://www.ietf.org/mailman/listinfo/ecrit>
> >>
> >
> > https://www.ietf.org/mailman/listinfo/ecrit <https://www.ietf.org/mailman/listinfo/ecrit>
> 
> https://www.ietf.org/mailman/listinfo/ecrit <https://www.ietf.org/mailman/listinfo/ecrit>
> 
> https://www.ietf.org/mailman/listinfo/ecrit <https://www.ietf.org/mailman/listinfo/ecrit>

---

From: "Drage, Keith (Nokia - GB)" <[email-masked]>
Date: Sun, 6 Nov 2016 13:51:34 +0000

So your first action to the request should be to review the request against the criteria in the RFC and respond to the requester with your analysis, not the WG.

I would note that CT1 meets in a weeks time, so this gets urgent if you want them to consider your expert reviewer postion.

Keith

From: Brian Rosen [mailto:[email-masked]]
Sent: 04 November 2016 15:32
To: Drage, Keith (Nokia - GB)
Cc: Az Mankin; [email-masked]
Subject: Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA 'sos' Sub-Services registry

Brian

On Nov 4, 2016, at 11:00 AM, Drage, Keith (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:

Keith

From: Ecrit [mailto:[email-masked]] On Behalf Of Drage, Keith (Nokia - GB)
Sent: 04 November 2016 14:55
To: Az Mankin
Cc: [email-masked]<mailto:[email-masked]>; Brian Rosen
Subject: Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA 'sos' Sub-Services registry

Keith

Hi, Keith,

Keith

-----Original Message-----
From: Ecrit [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Brian Rosen
Sent: 03 November 2016 21:15
To: Paul Kyzivat
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA 'sos' Sub-Services registry

Brian

---

From: Brian Rosen <[email-masked]>
Date: Thu, 10 Nov 2016 09:53:52 -0500

I am the expert reviewer designated by the ecrit working group for this request.

I believe this request is not consistent with the words and the intent of the registry.  “country-specific’ is not an emergency service.  Since the management policy of the emergency service is “expert review”, the barrier to adding new, possibly experimental services is low, and the consequences of having services that are not eventually deployed persisting in the registry is minimal.  The URN was not intended to have a generic X- service or equivalent, which is what this registration attempts to do.  New services, even experimental services, should register the service with IANA following the normal procedure.

Therefore, I recommend that we deny this request and suggest that the specific services be registered with IANA as they are deployed.  This decision has been reviewed with the ecrit working group.

Brian

---

From: <[email-masked]>
Date: Wed, 16 Nov 2016 01:07:30 +0000

Hi Brian,
the aimed registration is for 3GPP networks only and not to be intended to be used everywhere.

So from my understanding there are a many of existing specific emergency services out in the world which need the equivalent within the 3GPP IMS world.

An example is Poland:
Please see http://uke.gov.pl/tablice-numerow-kierowania-alarmowego-nka-9410 which lists the number 986 for "straż miejska" (= municipal police) and the number 997 for Policja (= police) as "numery alarmowe" (= emergency numbers).
Which cannot use the normal sos urn.

3GPP had the requirement to specify this for the 3GPP IMS world. And the easiest way was to have such an mechanism.
Since this is only used for the 3GPP IMS world, 3GPP would like to have a mechanism to allow these  specific suptypes.

So what could be done to get such an solution where IETF can agree upon?

Best Regards

Roland

Von: Ecrit [mailto:[email-masked]] Im Auftrag von Brian Rosen
Gesendet: Donnerstag, 10. November 2016 15:54
An: [email-masked]
Cc: ECRIT
Betreff: [Ecrit] Expert Reviewer's response to request to register 'country-specific' in 'sos' Subservice Registry in the Service URN Labels group

Brian

On Nov 3, 2016, at 3:59 PM, Az Mankin <[email-masked]<mailto:[email-masked]>> wrote:

ECRIT Working Group,
We need a volunteer for the following IANA Expert Review request that Amanda Baber of IANA just sent to Roger and me.  It needs to be written and sent to the mailing list, per the IESG's appointment of the WG as the Expert Reviewer (http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-labels.xhtml).  Amanda's message is under the line. Who'd like to step up for this?
Thanks!  from your Chairs
----------------

See below.

thanks,

Amanda Baber

===

Contact Name:
Frederic Firmin

Contact Email:
[email-masked]<mailto:[email-masked]>

Type of Assignment:
sub-service URN

Registry:

Description:

Additional Info:

reference: 24.229 12.14.0 available at http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-ce0.zip (cf subclause 7.11.1)

---

From: Ivo Sedlacek <[email-masked]>
Date: Wed, 16 Nov 2016 01:17:17 +0000

Hello,

> Since the management policy of the emergency service is “expert review”, the barrier to adding new, possibly experimental services is low,
> and the consequences of having services that are not eventually deployed persisting in the registry is minimal.

I tried to register emergency URNs
- for emergency service of municipal police; and
- for emergency service of national police
(both of which are used in Czech republic) with IANA in https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html

The registration was rejected ....

So, I disagree that barrieer is low.

Kind regards

Ivo Sedlacek

From: Ecrit [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, November 15, 2016 5:08 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Ecrit] Expert Reviewer's response to request to register 'country-specific' in 'sos' Subservice Registry in the Service URN Labels group

Hi Brian,

An example is Poland:

Best Regards

Roland

Von: Ecrit [mailto:[email-masked]] Im Auftrag von Brian Rosen
Gesendet: Donnerstag, 10. November 2016 15:54
An: [email-masked]<mailto:[email-masked]>
Cc: ECRIT
Betreff: [Ecrit] Expert Reviewer's response to request to register 'country-specific' in 'sos' Subservice Registry in the Service URN Labels group

Brian

ECRIT Working Group,

See below.

thanks,

Amanda Baber

===

Contact Name:
Frederic Firmin

Contact Email:

Type of Assignment:
sub-service URN

Registry:

Description:

Additional Info:

---

From: Ivo Sedlacek <[email-masked]>
Date: Wed, 16 Nov 2016 01:20:20 +0000

(the below was a response to Brian's mail. Also the quote is from Brian's mail)

Hello,

Kind regards

Ivo Sedlacek

Hi Brian,

An example is Poland:

Best Regards

Roland

Brian

ECRIT Working Group,

See below.

thanks,

Amanda Baber

===

Contact Name:
Frederic Firmin

Contact Email:

Type of Assignment:
sub-service URN

Registry:

Description:

Additional Info:

---

From: Brian Rosen <[email-masked]>
Date: Wed, 16 Nov 2016 10:25:00 +0900

<leaving off IANA for now>
The URN is an address for routing, and not a user visible label. Creating new entries is simple and fast.  So we request that new entries be created for different services.

One simple approach is to create a “municipalPolice” urn, and use urn:service:sos.municipal.police for 986 and urn:service:sos.police for 997 in Poland.

Then any country that uses municipal police can use the same URN.

Actually, the problem of multiple police forces occurred in NENA, the North American emergency services group.  For internal routing purposes, we created a urn:nena::responder.police entry with sub registry for the various types of police.  I would be very willing to do the work to create a similar sub registry for urn:service:sos.police, which would allow urn:service:sos.police.municipal because many countries have multiple police forces that can be reached at different emergency numbers.  The sub registry could have “state”, “provincial”, “federal”, and other entries.

I also note that the registration says “This sub-service type is used before an appropriate sub-service type is registered with IANA for a specific emergency service.”  Emphasis added.  This explicitly says that this use is temporary and will be replaced with a “real” registration at some time.  Since registration is easy and fast, there is no need for a temporary work around to actual registration.

Brian

> On Nov 16, 2016, at 10:07 AM, [email-masked] wrote:
> 
> Hi Brian,
> Please see http://uke.gov.pl/tablice-numerow-kierowania-alarmowego-nka-9410 <http://uke.gov.pl/tablice-numerow-kierowania-alarmowego-nka-9410> which lists the number 986 for "straż miejska" (= municipal police) and the number 997 for Policja (= police) as "numery alarmowe" (= emergency numbers).
> Von: Ecrit [mailto:[email-masked] <mailto:[email-masked]>] Im Auftrag von Brian Rosen
> An: [email-masked] <mailto:[email-masked]>
> Cc: ECRIT
> On Nov 3, 2016, at 3:59 PM, Az Mankin <[email-masked] <mailto:[email-masked]>> wrote:
>  
> ECRIT Working Group,
>

---

From: Ivo Sedlacek <[email-masked]>
Date: Wed, 16 Nov 2016 01:31:02 +0000

> Creating new entries is simple and fast.  So we request that new entries be created for different services.

I disagree that it is simple and fast.

I tried that (https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html) and it was rejected.

Kind regards

Ivo

From: Ecrit [mailto:[email-masked]] On Behalf Of Brian Rosen
Sent: Tuesday, November 15, 2016 5:25 PM
To: [email-masked]
Cc: ECRIT <[email-masked]>
Subject: Re: [Ecrit] Expert Reviewer's response to request to register 'country-specific' in 'sos' Subservice Registry in the Service URN Labels group

Brian

On Nov 16, 2016, at 10:07 AM, [email-masked]<mailto:[email-masked]> wrote:

Hi Brian,

An example is Poland:

Best Regards

Roland

Brian

ECRIT Working Group,

See below.

thanks,

Amanda Baber

===

Contact Name:
Frederic Firmin

Contact Email:

Type of Assignment:
sub-service URN

Registry:

Description:

Additional Info:

---

From: Brian Rosen <[email-masked]>
Date: Wed, 16 Nov 2016 10:43:25 +0900

Ivo, I apologize for not making sure this request was not ultimately concluded satisfactorily.

I would like to ask the work group for advice for police, and I will do the work to make registrations simple.

We can use the “a” levels, or we can create a sub registry for .police.  Either requires a standards track document to create a sub registry.  Alternatively, we could just allow a period in a name and register “police.municipal” or “police.a2” as top level registrations in a registration.

Let’s first decide which way: .police.a2 or .police.municipal

The  former is more regular and handles political subdivision easily.  However, there are police forces which don’t fit this pattern.  US has “Federal Marshals” and “FBI” and “Secret Service” although some of them don’t have emergency numbers.

My suggestion is to create the sub registry for police, have the “a” levels as initial values, and allow additional values to be added with expert review.

I am not aware of similar issues with fire or emergency medical.  There are many countries which have multiple medical services but AFAIK only one emergency number that is used for emergency medical.  If there are some isolated instances, I’d allow a random sub service (urn:service:sos.medical.mountain) registration.

I do think that if we don’t allow “country-specific” then we are obligated to make handling these kinds of requests straightforward.

Brian

> On Nov 16, 2016, at 10:17 AM, Ivo Sedlacek <[email-masked]> wrote:
> 
> Hello,
>  
> (both of which are used in Czech republic) with IANA in https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html <https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html>
>  
> From: Ecrit [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of [email-masked] <mailto:[email-masked]>
> To: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 16 Nov 2016 06:06:45 +0000

Hi all,

Because we have no way to gauge consensus ourselves, and because each message is generating a new ticket, we would suggest removing [email-masked] asking the designated expert to contact us when/if the registration(s) have been approved. We understand that Brian has been designated as the expert. 

Best regards,

Amanda Baber

On Wed Nov 16 01:43:40 2016, [email-masked] wrote:
> I would like to ask the work group for advice for police, and I will
> do the work to make registrations simple.
> 
> We can use the “a” levels, or we can create a sub registry for
> .police.  Either requires a standards track document to create a sub
> registry.  Alternatively, we could just allow a period in a name and
> register “police.municipal” or “police.a2” as top level registrations
> in a registration.
> 
> The  former is more regular and handles political subdivision easily.
> However, there are police forces which don’t fit this pattern.  US has
> “Federal Marshals” and “FBI” and “Secret Service” although some of
> them don’t have emergency numbers.
> 
> My suggestion is to create the sub registry for police, have the “a”
> levels as initial values, and allow additional values to be added with
> expert review.
> 
> I am not aware of similar issues with fire or emergency medical.
> There are many countries which have multiple medical services but
> AFAIK only one emergency number that is used for emergency medical.
> If there are some isolated instances, I’d allow a random sub service
> (urn:service:sos.medical.mountain) registration.
> 
> I do think that if we don’t allow “country-specific” then we are
> obligated to make handling these kinds of requests straightforward.
> 
> Brian
> 
> 
> > > Since the management policy of the emergency service is “expert
> > > review”, the barrier to adding new, possibly experimental services
> > > is low,
> > >   and the consequences of having services that are not eventually
> > > deployed persisting in the registry is minimal.
> >
> > (both of which are used in Czech republic) with IANA in
> > https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html
> > <https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html>
> >
> > From: Ecrit [mailto:[email-masked] <mailto:ecrit-
> > [email-masked]>] On Behalf Of [email-masked]
> > <mailto:[email-masked]>
> > Subject: Re: [Ecrit] Expert Reviewer's response to request to
> > register 'country-specific' in 'sos' Subservice Registry in the
> > Service URN Labels group
> >
> > Hi Brian,
> > So from my understanding there are a many of existing specific
> > emergency services out in the world which need the equivalent within
> > the 3GPP IMS world.
> >
> > An example is Poland:
> > Please see http://uke.gov.pl/tablice-numerow-kierowania-alarmowego-
> > nka-9410 <http://uke.gov.pl/tablice-numerow-kierowania-alarmowego-
> > nka-9410> which lists the number 986 for "straż miejska" (= municipal
> > police) and the number 997 for Policja (= police) as "numery
> > alarmowe" (= emergency numbers).
> > 3GPP had the requirement to specify this for the 3GPP IMS world. And
> > the easiest way was to have such an mechanism.
> > Since this is only used for the 3GPP IMS world, 3GPP would like to
> > have a mechanism to allow these  specific suptypes.
> >
> > Von: Ecrit [mailto:[email-masked] <mailto:ecrit-
> > [email-masked]>] Im Auftrag von Brian Rosen
> > Betreff: [Ecrit] Expert Reviewer's response to request to register
> > 'country-specific' in 'sos' Subservice Registry in the Service URN
> > Labels group
> >
> > I believe this request is not consistent with the words and the
> > intent of the registry.  “country-specific’ is not an emergency
> > service.  Since the management policy of the emergency service is
> > “expert review”, the barrier to adding new, possibly experimental
> > services is low, and the consequences of having services that are not
> > eventually deployed persisting in the registry is minimal.  The URN
> > was not intended to have a generic X- service or equivalent, which is
> > what this registration attempts to do.  New services, even
> > experimental services, should register the service with IANA
> > following the normal procedure.
> >
> > Therefore, I recommend that we deny this request and suggest that the
> > specific services be registered with IANA as they are deployed.  This
> > decision has been reviewed with the ecrit working group.
> >
> > Brian
> >
> > the WG as the Expert Reviewer (http://www.iana.org/assignments/urn-
> > serviceid-labels/urn-serviceid-labels.xhtml
> > <http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-
> > labels.xhtml>).  Amanda's message is under the line. Who'd like to
> > step up for this?
> >
> > Thanks!  from your Chairs
> > ----------------
> >
> >
> > is registered with IANA for a specific emergency service. This sub-
> > service type is not used where an appropriate sub-service type has
> > <http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-
> > ce0.zip> (cf subclause 7.11.1)
> >
> > <https://www.ietf.org/mailman/listinfo/ecrit>

---

From: Dan Banks <[email-masked]>
Date: Wed, 16 Nov 2016 16:16:01 +0000

I generally agree with Brian so far in this discussion in that the barrier to registration should be low (RFC 7163 lowered it from what it was) and the proposed registration is not well aligned with the way the service names are intended to be defined and used.   This is further reinforced by the suggestion that the proposed registration is “3GPP networks only and not to be intended to be used everywhere.”  To me, that calls into question whether the urn:service prefix should be used at all.

I do have one specific issue with what Brian is suggesting below, however – the service name syntax does not allow periods in a top level service name (for good reason).

Aside from that, I do see potential value in defining subservices under .police.  I would lean toward borrowing the “a” levels for indicating police services by the level of government under which they function, as these seem sufficiently broad and reusable.  It may also make sense to separately have subservices to indicate police for specific concerns (drugs, traffic, etc.).  I think all of these could co-exist under .police because they describe different things, even though the answers may overlap.

Dan Banks

From: Ecrit [mailto:[email-masked]] On Behalf Of Brian Rosen
Sent: Tuesday, November 15, 2016 8:43 PM
To: Ivo Sedlacek
Cc: [email-masked]; [email-masked]
Subject: Re: [Ecrit] Expert Reviewer's response to request to register 'country-specific' in 'sos' Subservice Registry in the Service URN Labels group

Brian

On Nov 16, 2016, at 10:17 AM, Ivo Sedlacek <[email-masked]<mailto:[email-masked]>> wrote:

Hello,

Kind regards

Ivo Sedlacek

From: Ecrit [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Tuesday, November 15, 2016 5:08 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] Expert Reviewer's response to request to register 'country-specific' in 'sos' Subservice Registry in the Service URN Labels group

Hi Brian,

An example is Poland:

Best Regards

Roland

Brian

ECRIT Working Group,

See below.

thanks,

Amanda Baber

===

Contact Name:
Frederic Firmin

Contact Email:

Type of Assignment:
sub-service URN

Registry:

Description:

Additional Info:

---

From: <[email-masked]>
Date: Wed, 16 Nov 2016 17:20:52 +0000

Hi,
pointing to your words: “To me, that calls into question whether the urn:service prefix should be used at all.”

So even if it is used only within 3GPP networks it is still an emergency call and routed towards a PSAP.
We will use the IMS structure for emergency calling i.e. E-CSCF (Emergency Call Session Control Function).
So the 3GPP network (IMS) will use the urn for routing purposes.

Best Regards

Roland

Von: Ecrit [mailto:[email-masked]] Im Auftrag von Dan Banks
Gesendet: Mittwoch, 16. November 2016 17:16
An: Brian Rosen; Ivo Sedlacek
Cc: [email-masked]; [email-masked]
Betreff: Re: [Ecrit] Expert Reviewer's response to request to register 'country-specific' in 'sos' Subservice Registry in the Service URN Labels group

Dan Banks

From: Ecrit [mailto:[email-masked]] On Behalf Of Brian Rosen
Sent: Tuesday, November 15, 2016 8:43 PM
To: Ivo Sedlacek
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Ecrit] Expert Reviewer's response to request to register 'country-specific' in 'sos' Subservice Registry in the Service URN Labels group

Brian

Hello,

Kind regards

Ivo Sedlacek

Hi Brian,

An example is Poland:

Best Regards

Roland

Brian

ECRIT Working Group,

See below.

thanks,

Amanda Baber

===

Contact Name:
Frederic Firmin

Contact Email:

Type of Assignment:
sub-service URN

Registry:

Description:

Additional Info:

---

From: Randall Gellens <[email-masked]>
Date: Wed, 16 Nov 2016 15:22:21 -0800

At 1:17 AM +0000 11/16/16, Ivo Sedlacek wrote:

> <https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html>https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html
>

Hi Ivo,

That URL returns a 404 for me.  Can you double check it and/or post a 
the rejection message or a summary of it?

Thanks,

--Randy

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Political T.V. commercials prove one thing: some candidates can
tell all their good points and qualifications in just 30 seconds.

---

From: Randall Gellens <[email-masked]>
Date: Wed, 16 Nov 2016 15:41:12 -0800

At 10:43 AM +0900 11/16/16, Brian Rosen wrote:

>  Ivo, I apologize for not making sure this 
> request was not ultimately concluded 
> satisfactorily.
>
>  I would like to ask the work group for advice 
> for police, and I will do the work to make 
> registrations simple.
>
>  We can use the "a" levels, or we can create a 
> sub registry for .police.  Either requires a 
> standards track document to create a sub 
> registry.  Alternatively, we could just allow a 
> period in a name and register 
> "police.municipal" or "police.a2" as top level 
> registrations in a registration.

Since a period is used now to delineate child 
services, I don't think we can use a period in a 
label for the pseudo sub-service.  Creating a new 
subregistry seems cleaner, and better fits with 
the intent.  That way, if a URN requests 
"sos.police.municipal" (or "sos.police.FBI" or 
"sos.police.DEA") in a region that doesn't have 
that specific subservice, the call can be treated 
as "sos.police" or just "sos".

>  Let's first decide which way: .police.a2 or .police.municipal
>
>  The  former is more regular and handles 
> political subdivision easily.  However, there 
> are police forces which don't fit this pattern. 
>  US has "Federal Marshals" and "FBI" and 
> "Secret Service" although some of them don't 
> have emergency numbers.
>
>  My suggestion is to create the sub registry for 
> police, have the "a" levels as initial values, 
> and allow additional values to be added with 
> expert review.

Since you've identified cases that don't fit well 
into the "a" levels, as long as we don't expect a 
large number of such police subservices to be 
registered, I'd suggest using the descriptive 
names instead.  (E.g., "police.municipal", 
"police.tourist", maybe "police.FBI" or 
"police.DEA".

>  I am not aware of similar issues with fire or 
> emergency medical.  There are many countries 
> which have multiple medical services but AFAIK 
> only one emergency number that is used for 
> emergency medical.  If there are some isolated 
> instances, I'd allow a random sub service 
>  I do think that if we don't allow 
> "country-specific" then we are obligated to 
> make handling these kinds of requests 
> straightforward.
>
>  Brian
>
>
>>  On Nov 16, 2016, at 10:17 AM, Ivo Sedlacek 
>> <<mailto:[email-masked]>[email-masked]> 
>> wrote:
>>
>>  Hello,
>>
>>   > Since the management policy of the 
>> emergency service is "expert review", the 
>> barrier to adding new, possibly experimental 
>> services is low,
>>   > and the consequences of having services 
>> that are not eventually deployed persisting in 
>> the registry is minimal.
>>
>>  (both of which are used in Czech republic) 
>> with IANA 
>> in <https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html>https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html
>>
>>  From: Ecrit 
>> [<mailto:[email-masked]>mailto:[email-masked]] On 
>> Behalf 
>> Of <mailto:[email-masked]>[email-masked]
>> To: <mailto:[email-masked]>[email-masked]; <mailto:[email-masked]>[email-masked]
>>  Cc: <mailto:[email-masked]>[email-masked]
>>  Subject: Re: [Ecrit] Expert Reviewer's 
>> response to request to register 
>> 'country-specific' in 'sos' Subservice 
>> Registry in the Service URN Labels group
>>
>>  Hi Brian,
>>  the aimed registration is for 3GPP networks 
>> only and not to be intended to be used 
>> everywhere.
>>
>>  So from my understanding there are a many of 
>> existing specific emergency services out in 
>> the world which need the equivalent within the 
>> 3GPP IMS world.
>>
>>  An example is Poland:
>>  Please 
>> see <http://uke.gov.pl/tablice-numerow-kierowania-alarmowego-nka-9410>http://uke.gov.pl/tablice-numerow-kierowania-alarmowego-nka-9410 which 
>> lists the number 986 for "stra› miejska" (= 
>> municipal police) and the number 997 for 
>> Policja (= police) as "numery alarmowe" (= 
>> emergency numbers).
>>  3GPP had the requirement to specify this for 
>> the 3GPP IMS world. And the easiest way was to 
>> have such an mechanism.
>>  Since this is only used for the 3GPP IMS 
>> world, 3GPP would like to have a mechanism to 
>> allow these  specific suptypes.
>>
>>  Von: Ecrit 
>> [<mailto:[email-masked]>mailto:[email-masked]] Im 
>> Auftrag von Brian Rosen
>>  An: <mailto:[email-masked]>[email-masked]
>>  Cc: ECRIT
>>  Betreff: [Ecrit] Expert Reviewer's response to 
>> request to register 'country-specific' in 
>> 'sos' Subservice Registry in the Service URN 
>> Labels group
>>
>>  I believe this request is not consistent with 
>> the words and the intent of the registry. 
>>  "country-specific' is not an emergency 
>> service.  Since the management policy of the 
>> emergency service is "expert review", the 
>> barrier to adding new, possibly experimental 
>> services is low, and the consequences of 
>> having services that are not eventually 
>> deployed persisting in the registry is 
>> minimal.  The URN was not intended to have a 
>> generic X- service or equivalent, which is 
>> what this registration attempts to do.  New 
>> services, even experimental services, should 
>> register the service with IANA following the 
>> normal procedure.
>>
>>  Therefore, I recommend that we deny this 
>> request and suggest that the specific services 
>> be registered with IANA as they are deployed. 
>>  This decision has been reviewed with the 
>> ecrit working group.
>>
>>  Brian
>>
>>
>>  On Nov 3, 2016, at 3:59 PM, Az Mankin 
>> <<mailto:[email-masked]>[email-masked]> 
>> wrote:
>>
>>
>>  ECRIT Working Group,
>>
>>  We need a volunteer for the following IANA 
>> Expert Review request that Amanda Baber of 
>> IANA just sent to Roger and me.  It needs to 
>> be written and sent to the mailing list, per 
>> the IESG's appointment of the WG as the Expert 
>> Reviewer 
>> (<http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-labels.xhtml>http://www.iana.org/assignments/urn-serviceid-labels/urn-serviceid-labels.xhtml). 
>>  The IANA Services Operator has received a 
>> request for registration in the 'sos' 
>> Sub-Services registry in the Service URN 
>> Labels group. This request comes from Frederic 
>> Firmin of ETSI.
>>
>>  According to RFC 7163, registration in 'sos' 
>> Sub-Services requires expert review as 
>> designated by the ECRIT working group or its 
>> successor (or, in their absence, the IESG). 
>> Can you send this request for review?
>>
>>  <mailto:[email-masked]>[email-masked]
>>
>>  Type of Assignment:
>>  sub-service URN
>>
>>  Registry:
>>  This sub-service type is used before an 
>> appropriate sub-service type is registered 
>> with IANA for a specific emergency service. 
>> This sub-service type is not used where an 
>> appropriate sub-service type has been 
>> registered with IANA for the specific 
>> emergency service.
>>  The next level of sub-services indicates the 
>> country where the specific emergency service 
>> is used. Subtypes below this are defined by 
>>  reference: 24.229 12.14.0 available 
>> at <http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-ce0.zip>http://www.3gpp.org/ftp/Specs/archive/24_series/24.229/24229-ce0.zip (cf 
>> subclause 7.11.1)
>>
>>  <mailto:[email-masked]>[email-masked]
>> 
>> <https://www.ietf.org/mailman/listinfo/ecrit>https://www.ietf.org/mailman/listinfo/ecrit
>>
>
>

-------------- Randomly selected tag: ---------------
Very funny, Scotty.  Now beam down my clothes.

---

From: Brian Rosen <[email-masked]>
Date: Thu, 17 Nov 2016 13:50:06 +0900

>> My suggestion is to create the sub registry for police, have the "a" levels as initial values, and allow additional values to be added with expert review.
> 
> Since you've identified cases that don't fit well into the "a" levels, as long as we don't expect a large number of such police subservices to be registered, I'd suggest using the descriptive names instead.  (E.g., "police.municipal", "police.tourist", maybe "police.FBI" or "police.DEA".
> 

How would you suggest we handle multiple names for the same “level”.  An easy example is “State Police” vs “Provincial Police”.  These are the same A1 level.  You can have “County”, or “Borough” or “Regional” for A2.  You can have “City” or “Municipal” or “Local” or … for A3.

Do we have separate listings (they are cheap, but we really want to be able to differentiate easily.

Brian

---

From: Brian Rosen <[email-masked]>
Date: Thu, 17 Nov 2016 13:51:39 +0900

And I’ve copied IANA again!  Argh.  Dropped from this email. Please delete IANA if you reply to that message.
> On Nov 17, 2016, at 1:50 PM, Brian Rosen <[email-masked]> wrote:
>

---

From: Randall Gellens <[email-masked]>
Date: Wed, 16 Nov 2016 21:36:54 -0800

At 1:50 PM +0900 11/17/16, Brian Rosen wrote:

>   >> My suggestion is to create the sub registry 
> for police, have the "a" levels as initial 
> values, and allow additional values to be added 
> with expert review.
>>
>>  Since you've identified cases that don't fit 
>> well into the "a" levels, as long as we don't 
>> expect a large number of such police 
>> subservices to be registered, I'd suggest 
>> using the descriptive names instead.  (E.g., 
>> "police.municipal", "police.tourist", maybe 
>> "police.FBI" or "police.DEA".
>>
>
>  How would you suggest we handle multiple names 
> for the same "level".  An easy example is 
> "State Police" vs "Provincial Police".  These 
> are the same A1 level.  You can have "County", 
> or "Borough" or "Regional" for A2.  You can 
> have "City" or "Municipal" or "Local" or Š for 
> A3.
>
>  Do we have separate listings (they are cheap, 
> but we really want to be able to differentiate 
> easily.

I'd suggest we just pick one name (e.g., either 
"state" or "province").  The IANA registration 
can say "Used for state-level or provincial 
level."  For the most part, users won't be 
entering or seeing these names anyway.

-------------- Randomly selected tag: ---------------
An economist is an expert who will know tomorrow why the things he
predicted yesterday didn't happen today.       --Laurence J. Peter

---

From: Ivo Sedlacek <[email-masked]>
Date: Thu, 17 Nov 2016 18:43:34 +0000

Hello

> I'd suggest we just pick one name (e.g., either "state" or "province").  The IANA registration can say "Used for state-level or provincial level."  For the most part, users won't be entering or seeing these names anyway.

The original IANA registration (https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html) was for two emergency emergency services existing in Czech republic:

Emergency-Service-1: emergency service offered by the police department or other law enforcement authorities of the local or municipal authorities.

Emergency-Service-2:-emergency service offered by the police department or other law enforcement authorities of the national government.

So two URNs are needed for Czech republic.

A lot of other emergency URNs will probably be needed for other countries - see last column in https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers

Kind regards

Ivo Sedlacek

---

From: Brian Rosen <[email-masked]>
Date: Fri, 18 Nov 2016 09:46:54 +0900

I am working on a draft to create a sub registry for police

It will include “national” and “municipal” as well as “provincial”,  “border”, “traffic”, “tourist” and “transport” with expert review to add others.

I may also include registrations for some of the other services listed in that article.

Brian
> On Nov 18, 2016, at 3:43 AM, Ivo Sedlacek <[email-masked]> wrote:
> 
> Hello
>  
> The original IANA registration (https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html <https://www.ietf.org/mail-archive/web/ecrit/current/msg08419.html>) was for two emergency emergency services existing in Czech republic:
>  
> A lot of other emergency URNs will probably be needed for other countries - see last column inhttps://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers <https://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers>
>  
> Kind regards
>  
> Ivo Sedlacek

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 6 Nov 2016 15:14:56 -0500

Keith,

On 11/6/16 8:51 AM, Drage, Keith (Nokia - GB) wrote:
> So your first action to the request should be to review the request
> against the criteria in the RFC and respond to the requester with your
> analysis, not the WG.

I don't think it is up to you to say what the expert should do to come 
to a decision. The expert is given considerable discretion to consult 
with whoever s/he wishes.

> I would note that CT1 meets in a weeks time, so this gets urgent if you
> want them to consider your expert reviewer postion.

 From 5226:

       - A designated expert must respond in a timely fashion, normally
         within a week for simple requests to a few weeks for more
         complex ones.

The CT1 schedule is their problem.

	Thanks,
	Paul

> Keith
>
>
>
> *From:*Brian Rosen [mailto:[email-masked]]
> *Sent:* 04 November 2016 15:32
> *To:* Drage, Keith (Nokia - GB)
> *Cc:* Az Mankin; [email-masked]
> *Subject:* Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA
> 'sos' Sub-Services registry
>
>
>
> If they had proposed a service in the way we envisioned services, say
> “Swift Water Rescue”, it would be a no-brainer.
>
>
>
> In this case they want to create an escape hatch, country specific, with
> no registry.  This is not what we anticipated.  That means that the
> review will be difficult.
>
>
>
> I will follow the normal process, which includes consulting with others,
> in this case, the entire WG, and responding back through the usual channels.
>
>
>
>     On Nov 4, 2016, at 11:00 AM, Drage, Keith (Nokia - GB)
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>
>
>     I would add further that the process is for the Expert Reviewer to
>     send any questions or concerns back to IANA and thence to the
>     original requester, not make a post on the list asking if anyone is
>     aware of the issue.
>
>
>
>     I would stress that any response in this case would need to be based
>     on 3GPP CT1 discussion of the response to the IANA registration
>     requestion, and possibly amendment of the IANA registration section
>     of the referenced specification.
>
>
>
>     Keith
>
>
>
>     *From:* Ecrit [mailto:[email-masked]] *On Behalf Of *Drage,
>     Keith (Nokia - GB)
>     *Sent:* 04 November 2016 14:55
>     *To:* Az Mankin
>     *Cc:* [email-masked] <mailto:[email-masked]>; Brian Rosen
>     *Subject:* Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA
>     'sos' Sub-Services registry
>
>
>
>     The process is that the WG should have (long ago) appointed an
>     expert or experts for the registry, and that information should be
>     given to IANA.
>
>
>
>     IANA would then send the review request to the appropriate expert
>     and the review would have taken place without necessarily any direct
>     involvement of the WG, based on the criteria specified in the RFC 7163.
>
>
>
>     Instead this appears to be automatically turning into “Working Group
>     Review” for which there is no such case, rather than “Expert Review”.
>
>
>
>     Keith
>
>
>
>     *From:* Az Mankin [mailto:[email-masked]]
>     *Sent:* 04 November 2016 13:50
>     *To:* Drage, Keith (Nokia - GB)
>     *Cc:* Brian Rosen; Paul Kyzivat; [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA
>     'sos' Sub-Services registry
>
>
>
>     Hi, Keith,
>
>     When the RFC was reviewed by the IESG, the Expert Review policy was
>     set to "ECRIT WG or their successor or the IESG if there is no
>     successor."  I asked for this to be on the list (but noting that it
>     has a two week deadline) because of this, and I'm not sure what the
>     concern is.
>
>     Allison
>
>
>
>     On Thu, Nov 3, 2016 at 5:47 PM, Drage, Keith (Nokia - GB)
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>     This suggestion to discuss on the list before anyone had even looked
>     at it suggests that the WG has totally failed in setting the review
>     criteria for IANA registration to Expert Review. It should be the
>     awkward ones where the reviewer might come to the list, not all of them.
>
>     Keith
>
>
>     From: Ecrit [mailto:[email-masked]
>     <mailto:[email-masked]>] On Behalf Of Brian Rosen
>     <mailto:[email-masked]>
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>     >>>
>     >>> Type of Assignment:
>     >>> sub-service URN
>     >>>
>     >>> Registry:

---

From: Roger Marshall <[email-masked]>
Date: Mon, 21 Nov 2016 15:50:07 +0000

Paul:
I apologize for this late release of this earlier queued message to the ECRIT list.

-roger.

-----Original Message-----
From: Ecrit [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: Sunday, November 06, 2016 12:15 PM
To: [email-masked]
Subject: Re: [Ecrit] DUE 11/17 - Volunteer for Expert Review: IANA 'sos' Sub-Services registry

Keith,

> against the criteria in the RFC and respond to the requester with your 

I don't think it is up to you to say what the expert should do to come to a decision. The expert is given considerable discretion to consult with whoever s/he wishes.

> I would note that CT1 meets in a weeks time, so this gets urgent if 
> you want them to consider your expert reviewer postion.

 From 5226:

        Thanks,
        Paul

> "Swift Water Rescue", it would be a no-brainer.
>
>
>
> In this case they want to create an escape hatch, country specific, 
> with no registry.  This is not what we anticipated.  That means that 
> the review will be difficult.
>
>
>
> I will follow the normal process, which includes consulting with 
> others, in this case, the entire WG, and responding back through the usual channels.
>
>
>
> It may be that as a result of this request we generate a document that 
> updates 7163.  We'll see.
>
>
>
>     Instead this appears to be automatically turning into "Working Group
>     Review" for which there is no such case, rather than "Expert Review".
>
>
>
>     Keith
>
>
>

________________________________

NOTICE TO RECIPIENT: This email, including attachments, may contain information which is confidential, proprietary, attorney-client privileged and/or controlled under U.S. export laws and regulations and may be restricted from disclosure by applicable State and Federal law. Nothing in this email shall create any legal binding agreement between the parties unless expressly stated herein and provided by an authorized representative of Comtech Telecommunications Corp. or its subsidiaries. If you are not the intended recipient of this message, be advised that any dissemination, distribution, or use of the contents of this message is strictly prohibited. If you received this message in error, please notify us immediately by return email and permanently delete all copies of the original email and any attached documentation from any computer or other media.

---

From: Ivo Sedlacek <[email-masked]>
Date: Wed, 30 Nov 2016 08:41:00 +0000

Hello,

IMO, the proposed way of progress (a *draft* to create a sub registry for police) is not appropriate.

When an operator rolls out VoIP in a country which already provides an emergency service over circuit switched network, then the operator needs the emergency URNs for all emergency services (including all the various police emergency services) at VoIP *rollout*. This is needed (at least) for identification of a call as an emergency call in the operator's SIP network.

Waiting for a new RFC defining a sub registry for police would really mean that the operator needs to have some temporary emergency service URIs for the police emergency services, similarly as requested by 3GPP in the registration of the "country-specific" emergency service URN.

Moreover, the IANA response to 3GPP registration of the "country-specific" emergency service URN stated:
----------------------
> review”, the barrier to adding new, possibly experimental services is
> *low*, and the consequences of having services that are not eventually
----------------------

Therefore, I decided to re-submit the IANA registration for the police emergency services in the Czech republic.

Kind regards

Ivo Sedlacek

From: Brian Rosen [mailto:[email-masked]]
Sent: Friday, November 18, 2016 1:47 AM
To: Ivo Sedlacek <[email-masked]>
Cc: Randall Gellens <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Ecrit] Expert Reviewer's response to request to register 'country-specific' in 'sos' Subservice Registry in the Service URN Labels group

Brian
On Nov 18, 2016, at 3:43 AM, Ivo Sedlacek <[email-masked]<mailto:[email-masked]>> wrote:

Hello

A lot of other emergency URNs will probably be needed for other countries - see last column inhttps://en.wikipedia.org/wiki/List_of_emergency_telephone_numbers

Kind regards

Ivo Sedlacek