Subject: Re: [Ecrit] WGLC for draft-ietf-ecrit-lost-planned-changes - end date April 8

From: Dan Banks <[email-masked]>
Date: Thu, 5 Apr 2018 22:07:09 +0000

Regarding the draft version -01,

I have a concern about providing a “replacement” schema.  I recognize the value in providing an alternative, equivalent expression of the LoST schema, but it is unclear to me if the intent here is for the new schema to be informative or normative.  The abstract states refers to it as an “alternative”, but the text elsewhere states the RFC 5222 schema is “replaced with” the one in this document.  That seems to be contradictory to me.

In general, I believe a normative replacement of the LoST schema would be a dramatic expansion of the scope of this draft, even if it appears on the surface to be easy to do.  I would prefer that this document only provide a non-normative alternative schema for the existing parts of LoST, much as RFC 5222 does itself in Appendix A.

Additionally, the replacement schema does not appear to take the verified errata for RFC 5222 into account.  If this document is to be a normative update to the schema, I believe it should include the corrections identified.  If it is only intended to provide an informative alternative, I’m not sure – but I would still like to see the corrections included if possible.

For the extension itself:

Section 4 describes a <locationInvalidated> element, but this element does not appear in any schema.  It also describes the server as performing an HTTPS POST to the previously provided URI, containing this element, but does not include other details such as what Content-Type should be used.  The ‘invalidAsOf’ attribute is described in this section as well, but is listed as an xs:element in the plannedChange group.  The text refers to a <plannedChange> element, but the schema only includes a group with that name.  The text also discusses an ‘asOf’ attribute in the <plannedChange> element, but the schema includes only an <invalidAsOf> element in the group.  I think this needs more work and further review before it proceeds.

Dan Banks

From: Ecrit [mailto:[email-masked]] On Behalf Of Az Mankin
Sent: Sunday, March 25, 2018 5:50 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Ecrit] WGLC for draft-ietf-ecrit-lost-planned-changes - end date April 8

This starts WGLC for  draft-ietf-ecrit-lost-planned-changes-01, Validation of Locations Around a Planned Change

Please send both comments and messages that you support advancement to this mailing list before April 8.
Roger and Allison

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 25 Apr 2018 08:40:33 -0700

On 3/25/18 2:49 AM, Az Mankin wrote:
> 
> This starts WGLC for  draft-ietf-ecrit-lost-planned-changes-01,
> Validation of Locations Around a Planned Change
> 

Again, thanks for your patience with my tardy reply. I took another look
at the schema. There are a few details I still want to check, but
overall it seems to be in good shape.

However, this is not right:

   <xs:attributeGroup name="anyElement">
     <xs:annotation>
       <xs:documentation>
         A wildcard pattern for including any element
         from any other namespace.
       </xs:documentation>
     </xs:annotation>
     <xs:anyAttribute processContents="skip"/>
   </xs:attributeGroup>

Presumably that should define something about attributes, not elements
(it seems to have been copied from the <xs:group name="anyElement">
definition).

Peter