Subject: [Efficientnd-dt] http://tools.ietf.org/html/draft-desmouceaux-ipv6-mcast-wifi-power-usage-00

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 21 Jul 2014 18:50:15 +0000

Hi Andrew:

It'd be good if we could give some airtime to the draft at the efficient-nd meeting.
Perhaps we can use the presentation that was used in int-area,

One curious question: The draft refers to Eric Vyncke's draft on  multicast-not-efficient and then Andrew and Collitti draft but there is no mention of what so ever on draft-chakrabarti-efficient-nd - that is very strange. Because efficient-nd  draft brings up the issue first  with a solution and the follow up drafts are written with evidences which support the idea.

Did you not find efficient-nd draft relevant to your document or  there is some other unobvious reason to  avoid referencing that document?

Regards,
-Samita

---

From: Andrew Yourtchenko <[email-masked]>
Date: Mon, 21 Jul 2014 18:31:47 -0400

Hi Samita,

On Mon, 21 Jul 2014, Samita Chakrabarti wrote:

> 
> Hi Andrew:
>
> 
> 
> It’d be good if we could give some airtime to the draft at the efficient-nd meeting.

yeah I think we can definitely invite Yoann into one of the next meetings 
so he can present, or if we are meeting at IETF, maybe he might be able to 
attend..

> One curious question: The draft refers to Eric Vyncke’s draft on  multicast-not-efficient and then Andrew and
> Collitti draft but there is no mention of what so ever on draft-chakrabarti-efficient-nd – that is very
> strange. Because efficient-nd  draft brings up the issue first  with a solution and the follow up drafts are
> written with evidences which support the idea. 
>
> 
> 

It was partially intentional, partially oversight on my part.

The intentional part was I wanted him to try to do more of "research" 
(since it was his final project in the university), and approach it 
from a more abstract point of view than efficient-nd does - he did look at 
multicast in general, not just ND, so I did not want to bias him, and did 
not emphasize efficient-nd.

But efficient-nd should have been acknowledged as being the trigger for 
all of the work, and that's the oversight that we did not include the 
reference into the text (I was in a rush for a vacation, and I came back 
already after the submission deadline).

Yoann's final thesis is mostly finished, but I think there is 
plenty of further research that can be done - there are a couple more 
points that I think are worth exploring further:

1) Would be interesting to match the network behavioral model that Yoann 
has derived, with the other networks. We analyzed a couple of networks and 
distribution of connections was exponential, if we prove this is 
universal, together with everything else, this could make it a pretty 
powerful tool to measure the network size's impact on battery life. If the 
folks on the team have the access to such a data, correlating it with the 
model would be very useful.

2) Digging deeper into the impact of all-hosts multicast traffic going to 
multiple APs, potentially causing the co-channel contention/interference, 
thus blocking the network at large, and how much this can be different
with different designs.

We can discuss this stuff the next time we meet.

--a

---

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 21 Jul 2014 23:20:07 +0000

Hi Andrew,

Thanks for the explanation and indicating further possibilities of work in this area.

An intern in my team also has done   some simple ND measurements  in last few weeks  but that was a very very simple network setup but part of the results might be of interest.  But the scale of the experiment is nothing compared to what you guys have done  on this draft. 

We will analyse the data  and share but one observation was that the wireless cellphones when powered up sends all-node mcast RS message ---> followed  by multicast RA from the router. So if there are 100 devices in a room and some of them had gotten their IP-address etc., the newly powered on devices will always generate extra multicast  noise in this case.  I don't know if this is just implementation issue or lack of clarity in the RFC. But it is an interesting behavior.

Adding the host wireless cell-phone behaviors to the scale of network size and its behavior should be interesting to study deeper.

Cheers,
-Samita

-----Original Message-----
From: Andrew Yourtchenko [mailto:[email-masked]] 
Sent: Monday, July 21, 2014 3:32 PM
To: Samita Chakrabarti
Cc: [email-masked]
Subject: Re: [Efficientnd-dt] http://tools.ietf.org/html/draft-desmouceaux-ipv6-mcast-wifi-power-usage-0 0

Hi Samita,

> It’d be good if we could give some airtime to the draft at the efficient-nd meeting.

yeah I think we can definitely invite Yoann into one of the next meetings so he can present, or if we are meeting at IETF, maybe he might be able to attend..

> One curious question: The draft refers to Eric Vyncke’s draft on  
> multicast-not-efficient and then Andrew and Collitti draft but there 
> is no mention of what so ever on draft-chakrabarti-efficient-nd – that 
> is very strange. Because efficient-nd  draft brings up the issue first  with a solution and the follow up drafts are written with evidences which support the idea.
>
> 
> 
> Did you not find efficient-nd draft relevant to your document or  
> there is some other unobvious reason to
>  avoid referencing that document?

The intentional part was I wanted him to try to do more of "research" 
(since it was his final project in the university), and approach it from a more abstract point of view than efficient-nd does - he did look at multicast in general, not just ND, so I did not want to bias him, and did not emphasize efficient-nd.

But efficient-nd should have been acknowledged as being the trigger for all of the work, and that's the oversight that we did not include the reference into the text (I was in a rush for a vacation, and I came back already after the submission deadline).

Yoann's final thesis is mostly finished, but I think there is plenty of further research that can be done - there are a couple more points that I think are worth exploring further:

1) Would be interesting to match the network behavioral model that Yoann has derived, with the other networks. We analyzed a couple of networks and distribution of connections was exponential, if we prove this is universal, together with everything else, this could make it a pretty powerful tool to measure the network size's impact on battery life. If the folks on the team have the access to such a data, correlating it with the model would be very useful.

2) Digging deeper into the impact of all-hosts multicast traffic going to multiple APs, potentially causing the co-channel contention/interference, thus blocking the network at large, and how much this can be different with different designs.

--a