Subject: [Emailcore] RESOLVED: Ticket #43: G.13. Deprecating HELO

From: "Alexey Melnikov" <[email-masked]>
Date: Tue, 19 Jan 2021 15:41:17 +0000

Hi all,
[Top post]

I changed the subject for ease of searching.

As per discussion, I propose to resolve this ticket as "no change".

Best Regards,
Alexey

On Fri, Dec 18, 2020, at 8:24 PM, John C Klensin wrote:
> 
> 
> --On Friday, December 18, 2020 17:47 +0000 Alexey Melnikov
> <[email-masked]> wrote:
> 
> > On Fri, Dec 18, 2020, at 5:23 PM, Alessandro Vesely wrote:
> >> On Fri 18/Dec/2020 02:24:26 +0100 John R Levine wrote:
> >> > On Thu, 17 Dec 2020, Ned Freed wrote:
> >> >> There's still quite a few HELO's being sent by IOT stuff
> >> >> that supports email. And I can understand why - when every
> >> >> byte counts, code to fall back from EHLO to HELO isn't
> >> >> going to be written.
> >> > 
> >> > Is that SMTP or submission?  I think we will continue to
> >> > tolerate a lot more  sloppiness in submission than in SMTP
> >> > relay.
> >> 
> >> 
> >> What is going to be gained by not tolerating HELO on port 25
> >> any more?  The  server code is not going to shrink
> >> considerably, especially if the same code  also supports port
> >> 587.
> >> 
> >> Sometimes I use HELO for a quick test with telnet[*] if for
> >> some reason I don't  want the terminal window to scroll by
> >> the amount of lines that EHLO responses  imply.
> > 
> > [As a participant]
> > 
> > For reasons stated by Alessandro and Ned I have a weak
> > preference to leave HELO as is in rfc5321bis.
> 
> (As a participant and for the same reasons)
>  I share that preference
> 
> (And, as author)
>  I recommend that the bar for making substantive changes, even
> to drop things previously required or allowed, should be fairly
> high.  My inclusion of that item was because I found it in my
> notes from prior suggestions and comments; it was not a
> recommendation for any particular action.
> 
>    john

---

From: Alessandro Vesely <[email-masked]>
Date: Tue, 19 Jan 2021 18:48:23 +0100

> As per discussion, I propose to resolve this ticket as "no change".

+1