Subject: Re: [Emailcore] Ticket #28: Erratum 1851: Location of text about TCP connection has closure/reset

From: Julien ÉLIE <[email-masked]>
Date: Sun, 3 Jan 2021 18:23:10 +0100

Hi Alexey,

>>      o  After detecting the need to shut down the SMTP service and
>>         returning a 421 reply code.  This reply code can be issued after
>>         the server receives any command or, if necessary, asynchronously
>>         from command receipt (on the assumption that the client will
>>         receive it after the next command is issued).
>>
>> I'm wondering whether the part in parenthesis really occurs in practice,
>> notably when the closure is asynchronous from command receipt.  Maybe it
>> should be reworded this way:  "on the assumption that the client will
>> receive it after the next command is issued or read it before closing
>> the connection at its side"?
> 
> I think we should open a separate ticket on this.

Ticket #46 just opened, thanks.

-- 
Julien ÉLIE

« Hâte-toi de bien vivre et songe que chaque jour est à lui seul une
   vie. » (Sénèque)

---

From: Julien ÉLIE <[email-masked]>
Date: Sun, 3 Jan 2021 18:35:46 +0100

Hi all,

> Strawman proposal: Section 4.1.1.5 is indeed a wrong place for this 
> text. I think Section 3.8 is the right place for it. The last paragraph 
> of 3.8 already contains the following text:
> 
>     SMTP clients that experience a connection close, reset, or other
>     communications failure due to circumstances not under their control
>     (in violation of the intent of this specification but sometimes
>     unavoidable) SHOULD, to maintain the robustness of the mail system,
>     treat the mail transaction as if a 451 response had been received and
>     act accordingly.

Incidentally, I see in rfc5321bis-01 that the suggested response code in 
erratum 1851 has been changed from 451 to 421 (in Section 3.8).
Is 421 really the right code to assume in the above paragraph in Section 
3.8?

451 is described as:

    451  Requested action aborted: error in processing

If not mentioned elsewhere in the document, nobody will know its 
intended use case.

421 is described as:

    421  <domain> Service not available, closing transmission channel
       (This may be a reply to any command if the service knows it must
       shut down)

Though 421 mentions the closure, it does not suggest the abortion (451) 
whereas the above paragraph in Section 3.8 hints at that.

-- 
Julien ÉLIE

« Il n'y a qu'un remède à l'amour : aimer davantage. » (Henry David
   Thoreau)

---

From: John C Klensin <[email-masked]>
Date: Sun, 03 Jan 2021 21:40:22 -0500

--On Sunday, January 3, 2021 18:23 +0100 Julien ÉLIE
<[email-masked]> wrote:

> Hi Alexey,
> 
>>>      o  After detecting the need to shut down the SMTP
>>>      service and returning a 421 reply code.  This reply
>>>         code can be issued after the server receives any
>>>         command or, if necessary, asynchronously from
>>>         command receipt (on the assumption that the client
>>>         will receive it after the next command is issued).
>>> 
>>> I'm wondering whether the part in parenthesis really occurs
>>> in practice, notably when the closure is asynchronous from
>>> command receipt.  Maybe it should be reworded this way:  "on
>>> the assumption that the client will receive it after the
>>> next command is issued or read it before closing the
>>> connection at its side"?
>> 

Ok, but please see the last paragraph or two of my note to
Alexey in this thread sent December 31, 2020 18:16 -0500.

best,
   john

---

From: Julien ÉLIE <[email-masked]>
Date: Mon, 4 Jan 2021 07:29:34 +0100

Hi John,

> Alexey in this thread sent December 31, 2020 18:16 -0500.

Did your note reach this mailing-list?
I'm sorry, I do not manage to find it in
   https://mailarchive.ietf.org/arch/browse/emailcore/
(neither 2020-12-31 23:16 UTC nor on that day)

-- 
Julien ÉLIE

« Donner un sens plus pur aux mots de la tribu. » (Stéphane Mallarmé)