Subject: [Gendispatch] another possibly problematic word

From: "Salz, Rich" <[email-masked]>
Date: Tue, 8 Sep 2020 11:38:17 +0000

This was news to me.  FYI

From: "Rob Wilton (rwilton)" <rwilton=[email-masked]>
…
A separate issue that we may want to consider relates to use of the word/term “nonce”.  In British English this term is slang for a paedophile, https://dictionary.cambridge.org/dictionary/english/nonce<https://urldefense.proofpoint.com/v2/url?u=https-3A__dictionary.cambridge.org_dictionary_english_nonce&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=h3vPGHnErcFST8UylIdbLohcl4jQGcLXlgr6I_5jpwk&s=4NlmGbVCeTGF1CWzghVwoa1yDT9sIiWHbnji9xdIlzE&e=>

I’m not saying that we should necessarily change this, but we might want to consider whether there is an alternative equivalent term that could be used instead.
…

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 8 Sep 2020 13:40:01 +0100

> This was news to me.  FYI

I believe it's archaic slang, that wasn't ever very common
and perhaps only commonly used before the 1960's but that's
just my impression from general reading and listening and
could well vary from place to place, and time to time, the
word being slang.

I'm currently unconvinced by that one tbh. And not that
convinced that curated lists of dodgy words is a good way
to handle this. (*)

S.

(*) That may be due to also originating from a place where
censorship was still somewhat common in my youth - in our
case the censors were mainly interested in religion and
maintaining their ideas of the good bits of the social
status quo. One of their last gasps was banning "the life
of Brian" movie;-)

> 
> From: "Rob Wilton (rwilton)" <rwilton=[email-masked]> … A
> separate issue that we may want to consider relates to use of the
> word/term “nonce”.  In British English this term is slang for a
> paedophile,
> https://dictionary.cambridge.org/dictionary/english/nonce<https://urldefense.proofpoint.com/v2/url?u=https-3A__dictionary.cambridge.org_dictionary_english_nonce&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=h3vPGHnErcFST8UylIdbLohcl4jQGcLXlgr6I_5jpwk&s=4NlmGbVCeTGF1CWzghVwoa1yDT9sIiWHbnji9xdIlzE&e=>
>
>  I’m not saying that we should necessarily change this, but we might
> want to consider whether there is an alternative equivalent term that
> could be used instead. …
> 
>

---

From: "John Levine" <[email-masked]>
Date: 8 Sep 2020 12:20:56 -0400

In article <[email-masked]> you write:
>A separate issue that we may want to consider relates to use of the word/term “nonce”.  In British English this
>term is slang for a paedophile,

There is an unlimited supply of slang words and idioms that mean
different things in different varieties of English, and we could
spend an unlimited amount of time rooting* them out.

It seems to me we need to consider the context and whether it
plausibly would offend or demean people. For example, the US and UK
meanings of to knock someone up are utterly different, but people
invariably find that amusing, not offensive.

R's,
John

* - I hear that in the Antipdes, "root" is a fairly vulgar slang
sexual term, leading to some care in one's pronunciation of "router."
But I don't see any need to change our terminology for the node at the
top of a tree of data.

---

From: Bob Hinden <[email-masked]>
Date: Tue, 8 Sep 2020 10:19:36 -0700

It does show up here:

https://en.wikipedia.org/wiki/Nonce

Seem to me if it is being used in the context of security it’s not an issue.

Bob

> On Sep 8, 2020, at 4:38 AM, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> This was news to me.  FYI
> 
> A separate issue that we may want to consider relates to use of the word/term “nonce”.  In British English this term is slang for a paedophile, https://dictionary.cambridge.org/dictionary/english/nonce
> 
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_spasm&d=DwICAg&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=h3vPGHnErcFST8UylIdbLohcl4jQGcLXlgr6I_5jpwk&s=xlmYiCjEtRDmYetTcHbmCDTYCJ2nVTn16sk4KlxwfZo&e=
> --
> Gendispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gendispatch

---

From: Jay Daley <[email-masked]>
Date: Wed, 9 Sep 2020 06:24:46 +1200

I haven't lived in the UK for over 10 years but when I was there this was not archaic but was sort of regional (London and surrounding area + criminal culture such as prisons, gritty TV shows) and common parlance in that context.  I was surprised when I discovered the security usage in my 20s but I’ve never considered there to be much chance of confusion between the two communities that use the word differently.

Jay

> On 9/09/2020, at 12:40 AM, Stephen Farrell <[email-masked]> wrote:
> 
> 
> 
> <0x5AB2FAF17B172BEA.asc>-- 
> Gendispatch mailing list
> [email-masked]

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Dan Harkins <[email-masked]>
Date: Wed, 09 Sep 2020 13:12:05 -0700

Well I was looking at some Android code the other day and came across
the following:

   "native int functionName();"

This is highly problematic. I believe "indigenous" would be much preferred
but I don't know how to go about addressing this egregious offense.

   Dan.

On 9/8/20 4:38 AM, Salz, Rich wrote:
>
> This was news to me.  FYI
>
> *From: *"Rob Wilton (rwilton)" <rwilton=[email-masked]>**
>
> …
>
> A separate issue that we may want to consider relates to use of the 
> paedophile, https://dictionary.cambridge.org/dictionary/english/nonce 
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__dictionary.cambridge.org_dictionary_english_nonce&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=h3vPGHnErcFST8UylIdbLohcl4jQGcLXlgr6I_5jpwk&s=4NlmGbVCeTGF1CWzghVwoa1yDT9sIiWHbnji9xdIlzE&e=>
>
> could be used instead.

---

From: Kyle Rose <[email-masked]>
Date: Wed, 9 Sep 2020 17:29:02 -0400

As someone who is nonetheless sympathetic to your implication about the
practicality of word policing, I think we could use less sarcasm/snark on
IETF mailing lists in general. Let's not have a repeat of the ietf list
thread.

Kyle

On Wed, Sep 9, 2020 at 4:12 PM Dan Harkins <[email-masked]> wrote:

> *From: *"Rob Wilton (rwilton)" <rwilton=[email-masked]>
> <rwilton=[email-masked]>
>
> …
>
> word/term “nonce”.  In British English this term is slang for a paedophile,
> https://dictionary.cambridge.org/dictionary/english/nonce
> I’m not saying that we should necessarily change this, but we might want
> to consider whether there is an alternative equivalent term that could be
> used instead.
>
> …
>
>
> --
> Gendispatch mailing list
> [email-masked]

---

From: Colin Perkins <[email-masked]>
Date: Fri, 11 Sep 2020 11:44:36 +0100

This matches my understanding as someone who grew up in, and currently lives in, the UK. I’ve had people react negatively to the term.

Colin

> On 8 Sep 2020, at 19:24, Jay Daley <[email-masked]> wrote:
> 
>> On 9/09/2020, at 12:40 AM, Stephen Farrell <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> 
>>> From: "Rob Wilton (rwilton)" <rwilton=[email-masked] <mailto:rwilton=[email-masked]>> … A
>>> https://dictionary.cambridge.org/dictionary/english/nonce<https://urldefense.proofpoint.com/v2/url?u=https-3A__dictionary.cambridge.org_dictionary_english_nonce&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=h3vPGHnErcFST8UylIdbLohcl4jQGcLXlgr6I_5jpwk&s=4NlmGbVCeTGF1CWzghVwoa1yDT9sIiWHbnji9xdIlzE&e=> <https://dictionary.cambridge.org/dictionary/english/nonce%3Chttps://urldefense.proofpoint.com/v2/url?u=https-3A__dictionary.cambridge.org_dictionary_english_nonce&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=h3vPGHnErcFST8UylIdbLohcl4jQGcLXlgr6I_5jpwk&s=4NlmGbVCeTGF1CWzghVwoa1yDT9sIiWHbnji9xdIlzE&e=%3E>
>>> 
>> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>
> 
> -- 
> Gendispatch mailing list
> [email-masked]

-- 
Colin Perkins
https://csperkins.org/