Subject: [Gendispatch] WG Review: Effective Terminology in IETF Documents (term)

From: Lars Eggert <[email-masked]>
Date: Fri, 23 Apr 2021 17:43:16 +0300

Hi,

the latest version of the charter for TERM just went out for IETF-wide review. This is the second such review cycle, which I deemed necessary due to the number of changes to the charter text the first review resulted in.

Please send constructive comments on the charter for the proposed WG to [email-masked] <mailto:[email-masked]>, or privately to the IESG or even only to me as the responsible AD.

To make sure that your feedback is taken into account on this latest version of the charter text, I encourage you to send comments even if you commented during the last IETF review cycle, or when the charter was earlier discussed in GENDISPATCH.

Thanks,
Lars

> 
> A new IETF WG has been proposed in the General Area. The IESG has not made
> any determination yet. The following draft charter was submitted, and is
> provided for informational purposes only. Please send your comments to the
> IESG mailing list ([email-masked]) by 2021-05-03.
> 
> Effective Terminology in IETF Documents (term)
> -----------------------------------------------------------------------
> Current status: Proposed WG
> 
> Chairs:
>  TBD
> 
> Assigned Area Director:
>  Lars Eggert <[email-masked]>
> 
> General Area Directors:
>  Lars Eggert <[email-masked]>
> 
> Mailing list:
>  Address: [email-masked]
>  To subscribe: https://www.ietf.org/mailman/listinfo/terminology
>  Archive: https://mailarchive.ietf.org/arch/browse/terminology/
> 
> Group page: https://datatracker.ietf.org/group/term/
> 
> Charter: https://datatracker.ietf.org/doc/charter-ietf-term/
> 
> The mission of the IETF as specified in BCP 95 is to produce high quality,
> relevant technical documents that influence the way people design, use, and
> manage the Internet. Contributions to the IETF, including Internet-Drafts and
> RFCs, are most understandable and effective when they use terminology that is
> clear, precise, and widely accessible to readers from varying backgrounds and
> cultures. This maximizes the benefits the IETF derives from its central
> principles, such as its open process and volunteer core.
> 
> In the years leading up to the chartering of this working group, there has
> been discussion in the IETF, in other standards organizations, and in the
> broader technology industry about the use of certain terms of art in
> technical writing and whether those and other terms have an exclusionary
> effect. While opinions vary among IETF participants about this topic, there
> is widespread agreement that the IETF community would benefit from advice
> about using effective terminology that would improve clarity and
> approachability.
> 
> The TERM working group is therefore chartered to produce an Informational RFC
> containing guidance to IETF participants on the use of effective terminology
> that also minimizes exclusionary effects. The RFC will express general
> principles for assessing when language is effective. The principles should be
> derived considering input from a broad set of IETF participants. The WG will
> identify and recommend external, independently updated resources containing
> examples of potentially problematic terms and potential alternatives to IETF
> participants for their consideration, to align its efforts with broader
> activities by the technology industry.
> 
> The TERM working group is a focused group aiming to produce a single
> deliverable. It is designed to complement other efforts at fostering
> inclusivity in the IETF and will liaise with appropriate external groups,
> such as other SDOs or industry initiatives, to coordinate.
> 
> The output of this WG will provide guidance to IETF participants and will not
> restrict the type or content of contributions that can be made to the IETF
> standards process. The output of this WG may inform a potential future
> activity by the RFC Editor to establish terminology guidance for the overall
> RFC series, but does not constrain any such future action.
> 
> Milestones:
> 
>  Jun 2021 - Adopt draft providing informational terminology recommendations
> 
>  Dec 2021 - Submit informational terminology recommendations to IESG

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 23 Apr 2021 17:01:33 +0200

On 2021-04-23, at 16:43, Lars Eggert <[email-masked]> wrote:
> 
>> The WG will
>> identify and recommend external, independently updated resources 

I’d add “a small set of” — this list is not intended to be exhaustive, but useful for authors (and the kitchen sink isn’t).

Grüße, Carsten

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 23 Apr 2021 16:03:05 +0100

Hiya,

In general I support this.

I think it's a mistake to craft or point at a curated
list of bad terms as I've said before but I seem to be
in the rough on that, which is ok.

One related nit though:

> activities by the technology industry.

The "will" there seems wrong. Even if the WG does
identity a perfect external resource for this, that
resource could disappear or become lots less perfect
over time.

Maybe s/will identify and recommend/will consider and
potentially recommend/ or something like that?

Cheers,
S.

---

From: Keith Moore <[email-masked]>
Date: Fri, 23 Apr 2021 16:52:57 -0400

On 4/23/21 11:03 AM, Stephen Farrell wrote:

> list of bad terms as I've said before

FWIW, I agree.   Or at least, if this turns into an effort to find as 
many "bad" terms as possible, or an effort to signal more and more 
"virtue" by excising more and more terms from IETF's vocabulary, IMO 
that would be a Bad Thing.

Keith

---

From: Lloyd W <[email-masked]>
Date: Sat, 24 Apr 2021 18:31:21 +1000

Stephen

how can you support this if you think a list of bad terms is a mistake, which means that you don't support this?

Can you actually clearly articulate your position?

thanks,

Lloyd Wood
[email-masked]

I support the war in general, just not any of the actions that the war requires.

> On 24 Apr 2021, at 01:03, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
>

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 24 Apr 2021 21:25:34 +0100

On 24/04/2021 09:31, Lloyd W wrote:
> Stephen
> 
> how can you support this if you think a list of bad terms is a
> mistake, which means that you don't support this?

No that's not correct. The list is only one aspect of the
overall charter.

I'm fine with a WG crafting an informational RFC that gives
us better guidance as to how to write better drafts, and am
ok that that includes a few examples of terms that are now
considered less good.

I think a curated list of bad terms is a mistake because it
threatens to prolong and occasionally re-ignite controversies
around terminology. Secondly, no matter what opinion one
holds on any specific term, the risk exists that the list's
then curators have the opposite opinion at some future date.
So, I think it's a mistake to consider such a list from any
starting position.

Cheers,
S.

> 
> Can you actually clearly articulate your position? >
> thanks,
> 
> Lloyd Wood [email-masked]
> 
>> I think it's a mistake to craft or point at a curated list of bad
>> terms as I've said before but I seem to be in the rough on that,
>> which is ok.
>

---

From: Lloyd W <[email-masked]>
Date: Sun, 25 Apr 2021 10:07:20 +1000

Stephen,

an informational RFC including 'a few examples of terms' in itself constitutes a curated list, set in stone. Who decides and crafts that initial list? Slippery slope, that. The controversies start well before that RFC is done.

And, with that in mind, that's why I wrote

https://datatracker.ietf.org/doc/draft-wood-term-modest-proposal/
https://tools.ietf.org/html/draft-wood-term-modest-proposal-annotations-00

just to call out some problems that I could see with the list idea (and include better terminology than 'less good'j.

And after those drafts were published, 00-04 of the terminology charter was produced, which handily removed any mention of two terms for the list -- because a document without any list of terms is so much more palatable than a document with a list. (and two items IS a list.)

yes, the curators of this hypothetical list (or lists) may change their minds at a future date. But the trend is to more authoritarianism, not less. Terms that are added to the list clearly should always have been on the list and will always be on the list, and who are we, or they, to question that?

I think we're long past the point of 'just be sensible and apply best engineering judgement'.

Lloyd Wood
[email-masked]

for my next inspired-by-the-modern-classics draft I will be drawing upon Joyce and Ulysses. Seems utterly pointless. But I do have until Bloomsday.

> On 25 Apr 2021, at 06:25, Stephen Farrell <[email-masked]> wrote:
> 
> 
> <OpenPGP_0x5AB2FAF17B172BEA.asc>
> -- 
> Terminology mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/terminology

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 25 Apr 2021 02:01:48 +0100

On 25/04/2021 01:07, Lloyd W wrote:
> Stephen,
> 
> an informational RFC including 'a few examples of terms' in itself
> constitutes a curated list, set in stone.

I don't agree. Set-in-stone != curated. E.g., I have
no problem if we emit an RFC that recommends that
blocklist is currently considered better than blacklist
in almost all cases.

> Who decides and crafts that
> initial list? 

The WG, followed by IETF LC. All normal stuff. Hopefully
the draft/RFC will have additional positive guidance and
not just a couple of examples of what to not do.

But my comment on the charter was more to the effect
that considering that an "initial" list would be a mistake,
for (at least) the reasons stated in my mail in response
to yours.

...snip...

> yes, the curators of this hypothetical list (or lists) may change
> their minds at a future date. But the trend is to more
> authoritarianism, not less. 

Who knows what'll happen in future? My imperfect guess
is that we'll mostly lose interest once the fuss dies
down TBH;-)

Personally, I'll oppose attempts to create any curated
list of prohibited terms, but I'm fine with doing that
later, if/as needed. (I'm sanguine about having to oppose
that even if the charter text says it "will" be done,
as I'm fairly sure the proponents of that will see that
it's a bad plan later if not sooner - another level of
indirection may be good CompSci practice in general, but
likely isn't the right plan here:-)

Cheers,
S.

---

From: Lloyd W <[email-masked]>
Date: Sun, 25 Apr 2021 12:42:36 +1000

Stephen,

"RFC 10984 on inclusive terminology obsoletes RFC 9184 on inclusionary terminology. This new product of the TERMINATOR (formerly TERM) workgroup specifically adds the following terms, which are now discouraged from use:

exclusive (and variants)
fnord (not fjord! fjord is fine! [At this time.])
huxleyan (and variants)
I'll be blocked
orwellian (and variants)
poison attack
timestamp crank..." etc.

curation for RFCs is not strictly set in stone, as you say. But with RFCs, the published list curation and modification process is rather more drawn out, carefully thought out, and tedious, which is arguably a good thing, at least until you're in the middle of arguing the next round of changes to be published. It's rather like trying to engrave one's own headstone. with a spoon.

If you start with any list, anyhow, that list will only grow.

can someone please tell the RFC Ed to reserve RFC 9184 for TERM...

Lloyd Wood
[email-masked]

> On 25 Apr 2021, at 11:02, Stephen Farrell <[email-masked]> wrote:
>

---

From: [email-masked]
Date: Sat, 24 Apr 2021 19:48:00 -0400

(I am a new subscriber, so I apologize in advance if I break any 
conventions.  Thanks.)

A couple of points concerning a list, I would think that any list of 
good words would have to say the bad words with which the good 
correlate.  Otherwise one is in the position of a person trying to guess 
from contextuual clues what a redacted word might be.  Which is common 
in living languages, but is difficult without some amount of shared 
context.  But including the bad words leads to the problem of 
auto-filtering eliminating the list; which leads to the need for a 
special status by which bad words can be identified as being merely 
written about.  (This is the usual problem of confusing meaningful use 
of a word versus merely talking about the word as a word, ie mentioning 
it.  There is a lot of philosophy and logic about this.  The usual 
solution is to distinguish mention cases by identifying with some or 
other quote mark--including finger quotes--any occurrence of a word 
being mentioned.)

As for having a list, I think any occurrence can be taken to be a list, 
eg a singleton word-pair can be taken to be a one-member list, normal in 
computing.  If the example is in regular prose writing, there is more 
context than there is for the usual idea of the efficiency of the list 
form.  A hybrid could be a list entry being a word-pair plus a brief 
example usage.

As for controversy, these are controversial times.  If IETF wants some 
internal advice people--internal or exteral--can refer to, why not try 
to do one's part to help.

Cheers.
Tom

> So, I think it's a mistake to consider such a list from any
  . . .

---

From: Pete Resnick <[email-masked]>
Date: Sat, 24 Apr 2021 22:39:23 -0500

[Chair hat]

I'd really appreciate if people would remove gendispatch from the Cc 
line (or at least move it to a Bcc) unless you really think gendispatch 
needs to be part of this discussion. The TERM charter is not a 
gendispatch topic.

Cheers,

pr

-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best