Subject: [Gendispatch] Updating the IETF Discussion List Charter (was: Fwd: New Version Notification for draft-eggert-bcp45bis-02.txt)

From: Lars Eggert <[email-masked]>
Date: Wed, 23 Jun 2021 15:14:21 +0300

Hi,

I'd like to restart the discussion on updating the charter for the [email-masked] <mailto:[email-masked]> discussion list, and have hence submitted an -02 update to draft-eggert-bcp45bis.

As you may remember, a past IESG promised an update to BCP45 after the "last-call" experiment succeeded [1]. (The second promised action, an update of the 2007 IESG Statement on Last Call Guidance - was already taken [2].)

draft-eggert-bcp45bis is intended to be a minimal update to BCP45, reflecting the creation of the last-call mailing list. It seemed sensible to also add information about other lists that have similarly taken over some of the original purposes for [email-masked] <mailto:[email-masked]> (e.g., admin-discuss, the per-meeting "attendees" lists, etc.), and to reference the current Sergeants-at-Arms procedures. I did not intend to make any other changes to BCP45.

I'll point out that there are other proposals [3][4] that propose more fundamental changes to [email-masked] <mailto:[email-masked]>. it would be useful to understand which direction the community would like to take here.

Thanks,
Lars

[1] https://mailarchive.ietf.org/arch/msg/ietf/LiB_dlvv3ZFlTF8hGp7GbGngqSg/ <https://mailarchive.ietf.org/arch/msg/ietf/LiB_dlvv3ZFlTF8hGp7GbGngqSg/>
[2] https://www.ietf.org/about/groups/iesg/statements/last-call-guidance/ <https://www.ietf.org/about/groups/iesg/statements/last-call-guidance/>
[3] https://www.ietf.org/archive/id/draft-nottingham-discussion-recharter-00.txt <https://www.ietf.org/archive/id/draft-nottingham-discussion-recharter-00.txt>
[4] https://mailarchive.ietf.org/arch/msg/gendispatch/kprAAlSfmWcQmaC8W4ZJn5c1XzI <https://mailarchive.ietf.org/arch/msg/gendispatch/kprAAlSfmWcQmaC8W4ZJn5c1XzI>

Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-eggert-bcp45bis-02.txt
> Date: June 23, 2021 at 14:54:57 GMT+3
> To: "Lars Eggert" <[email-masked]>
> 
> 
> A new version of I-D, draft-eggert-bcp45bis-02.txt
> has been successfully submitted by Lars Eggert and posted to the
> IETF repository.
> 
> Name:		draft-eggert-bcp45bis
> Revision:	02
> Title:		IETF Discussion List Charter
> Document date:	2021-06-23
> Group:		Individual Submission
> Pages:		6
> URL:            https://www.ietf.org/archive/id/draft-eggert-bcp45bis-02.txt
> Status:         https://datatracker.ietf.org/doc/draft-eggert-bcp45bis/
> Html:           https://www.ietf.org/archive/id/draft-eggert-bcp45bis-02.html
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-eggert-bcp45bis
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-eggert-bcp45bis-02
> 
> Abstract:
>   The Internet Engineering Task Force (IETF) discussion mailing list
>   furthers the development and specification of Internet technology
>   through the general discussion of topics for which no dedicated
>   mailing lists exists.  As this is the most general IETF mailing list,
>   considerable latitude is allowed, but there are posts that are
>   unsuitable for this mailing list.
> 
>   This document obsoletes RFC3005.
> 
> 
> 
> 
> The IETF Secretariat
> 
>

---

From: "Martin Thomson" <[email-masked]>
Date: Thu, 24 Jun 2021 12:06:37 +1000

While a discussion on the broader topic is worthwhile, we should not let that stand in the way of making real progress on things we know to be good, like the changes in this document.  I would prefer to see this document advance.

Dispatch answer: AD sponsorship, at worst it needs the sort of tuning that was in the last revision (all good changes).

On Wed, Jun 23, 2021, at 22:14, Lars Eggert wrote:
> Hi,
> 
> I'd like to restart the discussion on updating the charter for the 
> [email-masked] discussion list, and have hence submitted an -02 update 
> to draft-eggert-bcp45bis.
> 
> As you may remember, a past IESG promised an update to BCP45 after the 
> "last-call" experiment succeeded [1]. (The second promised action, an 
> update of the 2007 IESG Statement on Last Call Guidance - was already 
> taken [2].)
> 
> draft-eggert-bcp45bis is intended to be a minimal update to BCP45, 
> reflecting the creation of the last-call mailing list. It seemed 
> sensible to also add information about other lists that have similarly 
> taken over some of the original purposes for [email-masked] (e.g., 
> admin-discuss, the per-meeting "attendees" lists, etc.), and to 
> reference the current Sergeants-at-Arms procedures. I did not intend to 
> make any other changes to BCP45.
> 
> I'll point out that there are other proposals [3][4] that propose more 
> fundamental changes to [email-masked]. it would be useful to understand 
> which direction the community would like to take here.
> 
> Thanks,
> Lars
> 
> [1] 
> https://mailarchive.ietf.org/arch/msg/ietf/LiB_dlvv3ZFlTF8hGp7GbGngqSg/
> [2] 
> https://www.ietf.org/about/groups/iesg/statements/last-call-guidance/
> [3] 
> https://www.ietf.org/archive/id/draft-nottingham-discussion-recharter-00.txt
> [4] 
> https://mailarchive.ietf.org/arch/msg/gendispatch/kprAAlSfmWcQmaC8W4ZJn5c1XzI
> 
> 
> Begin forwarded message:
> > 
> > *From: [email-masked]
> > *Subject: **New Version Notification for draft-eggert-bcp45bis-02.txt*
> > *Date: *June 23, 2021 at 14:54:57 GMT+3
> > *To: *"Lars Eggert" <[email-masked]>
> > 
> > 
> -- 
> Gendispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gendispatch
> 
> Attachments:
> * signature.asc

---

From: Rob Sayre <[email-masked]>
Date: Wed, 23 Jun 2021 19:25:23 -0700

Agreeing with Martin: there's nothing to object to
in draft-eggert-bcp45bis-02. I also agree with "Dispatch answer: AD
sponsorship".

I think my proposal[4] still has some benefits. For example, I don't think
this kind of thread is an accurate representation of the IETF:

https://mailarchive.ietf.org/arch/msg/ietf/v78xy4qs-EgrMVNx8BkNhIONODU/

but happy to defer to others on this one,
Rob

[4]

On Wed, Jun 23, 2021 at 7:07 PM Martin Thomson <[email-masked]> wrote:

> While a discussion on the broader topic is worthwhile, we should not let
> that stand in the way of making real progress on things we know to be good,
> like the changes in this document.  I would prefer to see this document
> advance.
>
> Dispatch answer: AD sponsorship, at worst it needs the sort of tuning that
> was in the last revision (all good changes).
>
> > > URL:
> https://www.ietf.org/archive/id/draft-eggert-bcp45bis-02.txt
> > > Status:
> https://datatracker.ietf.org/doc/draft-eggert-bcp45bis/
> > > Html:
> https://www.ietf.org/archive/id/draft-eggert-bcp45bis-02.html
> > > Htmlized:
> https://datatracker.ietf.org/doc/html/draft-eggert-bcp45bis
> > > Diff:
> https://www.ietf.org/rfcdiff?url2=draft-eggert-bcp45bis-02
> > >
> > > Abstract:

---

From: Keith Moore <[email-masked]>
Date: Wed, 23 Jun 2021 23:01:43 -0400

I'm mostly fine with this document, except that IMO the Sergeant-at-arms 
should NOT be appointed by the IETF Chair, should not take direction 
from the IETF Chair, and the IAB should have explicit power to override 
the decisions of the SAA.

More generally, neither the IETF Chair nor the IESG should be in the 
business of policing the IETF list, because having the IESG "take sides" 
in such discussions interferes with the ability of the IESG to serve as 
a fair and trusted arbiter of technical decisions.

Keith

On 6/23/21 8:14 AM, Lars Eggert wrote:
> [email-masked] <mailto:[email-masked]> discussion list, and have hence 
> submitted an -02 update to draft-eggert-bcp45bis.
>
> taken over some of the original purposes for [email-masked] 
> <mailto:[email-masked]> (e.g., admin-discuss, the per-meeting 
> "attendees" lists, etc.), and to reference the 
> current Sergeants-at-Arms procedures. I did not intend to make any 
> other changes to BCP45.
>
> fundamental changes to [email-masked] <mailto:[email-masked]>. it would 
> be useful to understand which direction the community would like to 
> take here.
>
> Thanks,
> Lars
>
> [1] 
> <https://mailarchive.ietf.org/arch/msg/ietf/LiB_dlvv3ZFlTF8hGp7GbGngqSg/>
> [2] 
> <https://www.ietf.org/about/groups/iesg/statements/last-call-guidance/>
> [3] 
> <https://www.ietf.org/archive/id/draft-nottingham-discussion-recharter-00.txt>
> [4] 
> <https://mailarchive.ietf.org/arch/msg/gendispatch/kprAAlSfmWcQmaC8W4ZJn5c1XzI>
>
>
> Begin forwarded message:
>>
>> *From: [email-masked] <mailto:[email-masked]>
>> *To: *"Lars Eggert" <[email-masked] <mailto:[email-masked]>>
>>
>>
>> Name:draft-eggert-bcp45bis
>> Revision:02
>> Title:IETF Discussion List Charter
>> Document date:2021-06-23
>> Group:Individual Submission
>> Pages:6
>> <https://www.ietf.org/archive/id/draft-eggert-bcp45bis-02.txt>
>> <https://datatracker.ietf.org/doc/draft-eggert-bcp45bis/>
>> <https://www.ietf.org/archive/id/draft-eggert-bcp45bis-02.html>
>> <https://datatracker.ietf.org/doc/html/draft-eggert-bcp45bis>
>> <https://www.ietf.org/rfcdiff?url2=draft-eggert-bcp45bis-02>
>>
>> Abstract:

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 24 Jun 2021 15:28:59 +1200

Ready for AD Sponsorship IMHO. The deeper issues need a different discussion.

Regards
   Brian

On 24-Jun-21 00:14, Lars Eggert wrote:
> draft-eggert-bcp45bis is intended to be a minimal update to BCP45, reflecting the creation of the last-call mailing list. It seemed sensible to also add information about other lists that have similarly taken over some of the original purposes for [email-masked] <mailto:[email-masked]> (e.g., admin-discuss, the per-meeting "attendees" lists, etc.), and to 
reference the current Sergeants-at-Arms procedures. I did not intend 
to make any other changes to BCP45.
>> URL:            https://www.ietf.org/archive/id/draft-eggert-bcp45bis-02.txt <https://www.ietf.org/archive/id/draft-eggert-bcp45bis-02.txt>
>> Status:         https://datatracker.ietf.org/doc/draft-eggert-bcp45bis/ <https://datatracker.ietf.org/doc/draft-eggert-bcp45bis/>
>> Html:           https://www.ietf.org/archive/id/draft-eggert-bcp45bis-02.html <https://www.ietf.org/archive/id/draft-eggert-bcp45bis-02.html>
>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-eggert-bcp45bis <https://datatracker.ietf.org/doc/html/draft-eggert-bcp45bis>
>> Diff:           https://www.ietf.org/rfcdiff?url2=draft-eggert-bcp45bis-02 <https://www.ietf.org/rfcdiff?url2=draft-eggert-bcp45bis-02>
>>
>> Abstract:

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 24 Jun 2021 17:24:13 +0000

Looks fine to me. I think Keith’s concern should be raised when discussion the other proposals. This is a small quick fix to update some outdated things, as you said.

---

From: Bob Hinden <[email-masked]>
Date: Thu, 24 Jun 2021 10:42:10 -0700

I read the draft and support it.

Bob

> On Jun 24, 2021, at 10:24 AM, Salz, Rich <rsalz=[email-masked]> wrote:
>

---

From: Keith Moore <[email-masked]>
Date: Thu, 24 Jun 2021 18:29:57 -0400

On 6/24/21 1:24 PM, Salz, Rich wrote:

> Looks fine to me. I think Keith’s concern should be raised when 
> discussion the other proposals. This is a small quick fix to update 
> some outdated things, as you said.
>
it's not a fix, it's  something that has been broken for a very long 
time... it just hasn't caused many problems until relatively recently.

the real question is: are we a concensus-making body or is it okay if 
the leaders impose their prejudices on the discussion?

IMO the current text is absolutely unacceptable.

Keith

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 24 Jun 2021 15:33:38 -0700

This looks like a good start.

One thing I would note here is that the guidelines/procedures for the SAA
function are references to non-RFCs. I think that's OK, but it's worth
noting that this means that they are not cast in stone by this RFC.

-Ekr

On Wed, Jun 23, 2021 at 5:14 AM Lars Eggert <[email-masked]> wrote:

> [email-masked] discussion list, and have hence submitted an -02 update to
> draft-eggert-bcp45bis.
>
> update of the 2007 IESG Statement on Last Call Guidance - was already taken
> [2].)
>
> reflecting the creation of the last-call mailing list. It seemed sensible
> to also add information about other lists that have similarly taken over
> some of the original purposes for [email-masked] (e.g., admin-discuss, the
> per-meeting "attendees" lists, etc.), and to reference the
> current Sergeants-at-Arms procedures. I did not intend to make any other
> changes to BCP45.
>
> [2] https://www.ietf.org/about/groups/iesg/statements/last-call-guidance/
> [3]

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 24 Jun 2021 15:36:46 -0700

On Thu, Jun 24, 2021 at 3:30 PM Keith Moore <[email-masked]>
wrote:

> Looks fine to me. I think Keith’s concern should be raised when discussion
> the other proposals. This is a small quick fix to update some outdated
> things, as you said.
>
> the real question is: are we a concensus-making body or is it okay if the
> leaders impose their prejudices on the discussion?
>
Well, I suppose it's *a* question, but I don't think I agree that it's
*the* real question.

In any case, ISTM that this document simply records the status quo. I would
suggest that if we want to revisit how the IETF list is moderated or other
bigger changes that should be done separately.

-Ekr

---

From: Keith Moore <[email-masked]>
Date: Thu, 24 Jun 2021 19:01:49 -0400

On 6/24/21 6:36 PM, Eric Rescorla wrote:

> In any case, ISTM that this document simply records the status quo. I 
> would suggest that if we want to revisit how the IETF list is 
> moderated or other bigger changes that should be done separately.

I disagree because I believe there have been significant problems caused 
by the abuse of power enabled by the "status quo", which have made IETF 
much more toxic.  To reaffirm the status quo in light of that experience 
seems like a huge mistake.

Keith

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 24 Jun 2021 16:09:11 -0700

> seems like a huge mistake.

I don't propose to debate the substance of this claim here as I think our
respective positions are quite clear. Suffice to say that I do not agree
with this analysis of the situation.

-Ekr

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 25 Jun 2021 00:44:52 +0100

On 25/06/2021 00:01, Keith Moore wrote:
> much more toxic.

FWIW, I don't agree with the above. And I think accusations
related to toxicity are neither wise nor warranted.

It's very easy and maybe even lazy to claim toxicity and to
thereby close off conversation. Seems like a bad plan to me,
reminiscent of decrying snuff at a wake. (Apologies if the
colloquialism doesn't resonate;-)

S.

PS: The draft seems ok, but going beyond it would require a
pile of debate.

---

From: Keith Moore <[email-masked]>
Date: Thu, 24 Jun 2021 19:51:11 -0400

On 6/24/21 7:44 PM, Stephen Farrell wrote:

>> I disagree because I believe there have been significant problems 
>> caused by the abuse of power enabled by the "status quo", which have 
>> made IETF much more toxic.
>

OK but I sincerely believe that it's an accurate description of a 
problem that I've observed.   Am I obligated to pretend that the problem 
doesn't exist or that the situation can't be improved?

Keith

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 25 Jun 2021 17:14:11 +1000

Hi Lars,

Thanks for bringing this up.

I agree that draft-eggertg-bcp45bis is a good starting point for discussion.

Looking at draft-nottingham-discussion-recharter again, I think there are a few things we could pull out and discuss as potential additions, without going as far as that draft suggests. For example:

- [ ] Reminding readers (including the IESG) that the list does not have all (or even a majority of) IETF participants subscribed, and so it is not appropriate to consider it as reaching the entire community. Along these lines, the current text about announcements being on ietf-announce@ should be strengthened, at least in the case of official announcements. I.e., it's not just a 'preference'.

- [ ] Clarifying language regarding when it's appropriate to move a discussion to another, more specific/appropriate list. Sometimes, people push back on this -- either because they want a larger audience, or they think the ietf@ is more sympathetic to their cause, for whatever reason. I think it would help if this scenario were specifically addressed.

I'd also hope that if we adjust this document, we'll also take the time to adjust the web site; right now, newcomers have no idea what the function of GENDISPATCH is (for example).

Cheers,

> On 23 Jun 2021, at 10:14 pm, Lars Eggert <[email-masked]> wrote:
> 
> Hi,
> 
> I'd like to restart the discussion on updating the charter for the [email-masked] discussion list, and have hence submitted an -02 update to draft-eggert-bcp45bis.
> 
> draft-eggert-bcp45bis is intended to be a minimal update to BCP45, reflecting the creation of the last-call mailing list. It seemed sensible to also add information about other lists that have similarly taken over some of the original purposes for [email-masked] (e.g., admin-discuss, the per-meeting "attendees" lists, etc.), and to reference the current Sergeants-at-Arms procedures. I did not intend to make any other changes to BCP45.
> 
> I'll point out that there are other proposals [3][4] that propose more fundamental changes to [email-masked]. it would be useful to understand which direction the community would like to take here.
> 
> Thanks,
> Lars
> 
> [1] https://mailarchive.ietf.org/arch/msg/ietf/LiB_dlvv3ZFlTF8hGp7GbGngqSg/
> [3] https://www.ietf.org/archive/id/draft-nottingham-discussion-recharter-00.txt
> [4] https://mailarchive.ietf.org/arch/msg/gendispatch/kprAAlSfmWcQmaC8W4ZJn5c1XzI
> 
> 
> Begin forwarded message:
>> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Keith Moore <[email-masked]>
Date: Fri, 25 Jun 2021 04:29:51 -0400

> - [ ] Clarifying language regarding when it's appropriate to move a discussion to another, more specific/appropriate list. Sometimes, people push back on this -- either because they want a larger a…

IMO we need to reconsider whether "move the discussion to another list" 
is being overused, because (a) it doesn't seem to work very well, and 
(b) it often seems as if this technique is used as a tactic to suppress 
inconvenient input rather than to help build community consensus.   
(i.e. if you can't win your argument, maybe you can change the game, and 
force your opponent to start over from square one.)   It has often 
seemed to me that gendispatch was created specifically for that purpose.

I also strongly suspect that over-fragmentation of our discussions onto 
different lists makes us less productive and results in even more 
traffic that people need to wade through. Rather than follow only one 
list for a particular topic, participants need to follow multiple lists 
or otherwise risk being blindsided when some other list develops 
"consensus" on that topic.   And some lists have so much volume that 
it's very cumbersome to keep up with the traffic, that I wonder whether 
the creation of increasingly narrow lists actually results in more 
volume for each list.    As in "now that we have a list for this narrow 
topic, we can post more messages to that list".   How many people really 
want to scan through every  Last Call announcement, or every message to 
ietf-announce?   Is it really ok that many WGs are frequently having 
"interim" meetings, which is another tactic used to discourage input 
from the broader community?   Especially when those interim meetings 
conflict with IETF-wide meetings (virtual or not)?

Discussions don't always fit neatly into some narrow category, and there 
are now so many IETF lists that expecting everyone to choose the "right" 
list for every input may be unrealistic. Moving a discussion from one 
list to another may also require many participants to subscribe to new 
lists, and also to catch up with the discussion context on a different 
list, both of which are cumbersome and time consuming.

I'm not sure what the best answer is, but it's pretty clear that there's 
a point of diminishing returns to siloing of discussions.

Keith

p.s. I highly recommend reading IETF mail through the IETF's IMAP server 
because it doesn't require you to use mailman to subscribe to a new list 
every time a discussion is moved.   Once I got it working it saved me a 
great deal of time and frustration.   But I personally found it rather 
tricky to get it working well enough to use with my MUA (Thunderbird) 
and suspect I'm not the only one.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 26 Jun 2021 09:05:46 +1200

> - [ ] Reminding readers (including the IESG) that the list does not have all (or even a majority of) IETF participants subscribed, and so it is not appropriate to consider it as reaching the entire…

I find myself wondering whether ietf-announce should be an opt-out list. In other words, people who sign up for a meeting or at least one WG list should be subscribed to ietf-announce unless they decline. (Personally, I still don't understand how anyone who participates at all in the IETF can survive without the -announce list.)

> - [ ] Clarifying language regarding when it's appropriate to move a discussion to another, more specific/appropriate list. Sometimes, people push back on this -- either because they want a larger a…

I agree with Keith that there's a tricky balance here. But as long as such a tiny fraction of participants even join ietf@, I'm not sure it is worth worrying too much. We should perhaps rather be worrying about why so few people actually care about IETF-wide issues at all.

> I'd also hope that if we adjust this document, we'll also take the time to adjust the web site; right now, newcomers have no idea what the function of GENDISPATCH is (for example).

The risk in overloading the newcomers info is that it becomes TL;DR. So my answer is a definite maybe. I did notice that https://www.ietf.org/about/participate/get-started/ doesn't have an obvious pointer to ietf-announce, for example. Adding that is another definite maybe.

Rgds
    Brian

---

From: Keith Moore <[email-masked]>
Date: Fri, 25 Jun 2021 17:48:56 -0400

> I find myself wondering whether ietf-announce should be an opt-out list. In other words, people who sign up for a meeting or at least one WG list should be subscribed to ietf-announce unless they d…

I guess I find myself wondering whether the mailman-style subscription 
model is becoming obsolete, and what percentage of IETF participants who 
don't use the IMAP server (wish this were easy for everyone) would 
prefer to read IETF traffic via a webmail server hosted at IETF if one 
were provided.   The whole process of subscribing to a new list anytime 
a conversation moves seems like a significant burden (particularly if 
you don't want all of your IETF mail to show up in your usual inbox), 
and it would be a lot less onerous if everyone could move to the new 
list with a simple click.

Regarding ietf-announce, I find it contains far too much low-value 
information for my tastes, e.g. Last Call and interim meeting 
announcements for WGs in areas far distant from my concerns, but "too 
much low-value information" seems like one of email's biggest problems 
in general.  It's not just spam any more, email has become the dumping 
ground for all kinds of low-value information.  Nevertheless, I was 
subscribed to it before I started using the IMAP server, and even now 
that I'm using the IETF IMAP archive, it's a folder that my MUA is 
configured to check.

> I agree with Keith that there's a tricky balance here. But as long as such a tiny fraction of participants even join ietf@, I'm not sure it is worth worrying too much. We should perhaps rather be w…

I wonder if it's the case that so few people really care about IETF-wide 
issues, or if instead the discussions have become so fragmented across 
multiple lists that the ietf@ list is stuck with the leftovers.   There 
was some value in having general discussion occur on the same list as 
important announcements.

> The risk in overloading the newcomers info is that it becomes TL;DR. So my answer is a definite maybe. I did notice thathttps://www.ietf.org/about/participate/get-started/  doesn't have an obvious pointer to ietf-announce, for example. Adding that is another definite maybe.

What I find is that the list of IETF mailing lists is bewildering, it's 
hard to know which lists are currently active and which aren't, and the 
IETF web site doesn't really help even experienced participants figure 
out which lists are relevant to their purposes.

Keith

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 25 Jun 2021 14:56:53 -0700

On Fri, Jun 25, 2021 at 2:49 PM Keith Moore <[email-masked]>
wrote:

> don't use the IMAP server (wish this were easy for everyone) would prefer
> to read IETF traffic via a webmail server hosted at IETF if one were
> provided.
>
FWIW, I would not. I prefer to read it in my ordinary mail client.

-Ekr

---

From: "Bron Gondwana" <[email-masked]>
Date: Tue, 29 Jun 2021 13:35:21 +1000

On Sat, Jun 26, 2021, at 07:48, Keith Moore wrote:
> I guess I find myself wondering whether the mailman-style subscription model is becoming obsolete, and what percentage of IETF participants who don't use the IMAP server (wish this were easy for everyone) would prefer to read IETF traffic via a webmail server hosted at IETF if one were provided.   The whole process of subscribing to a new list anytime a conversation moves seems like a significant burden (particularly if you don't want all of your IETF mail to show up in your usual inbox), and it would be a lot less onerous if everyone could move to the new list with a simple click.
> 

It's still rather slow for a variety of reasons - not really optimised for that many lists on the news page - but https://ietf.topicbox-scratch.com/ tracks pretty much every mailing list by polling the IMAP server.

An interesting entry point might be https://ietf.topicbox-scratch.com/groups/gendispatch/T1b2bb28f15250377-M8b77ac097797624a866f4900/gendispatch-updating-the-ietf-discussion-list-charter-was-fwd-new-version-notification-for-draft-eggert-bcp45bis-02-txt - which links to this message that I'm replying to in this thread.**

You can make it faster by logging in (you can use any email address - it will email you a code to login) and then subscribe to just the groups you want to see.

Also, unfortunately, when I put this together a couple of years ago at the hackathon, I didn't find an easy way to get a listing of groups and descriptions, so it doesn't auto-create new groups when they get added to the IMAP server.  I'll see what I can do about that at some point, because it would be nice to have the conference lists since IETF108!

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]