Subject: [Gendispatch] some thoughts about ietf communication

From: Eliot Lear <[email-masked]>
Date: Thu, 29 Jul 2021 11:45:38 +0200

Hi,

As one of the people who think that the plenary function of the IETF 
needs a more serious rethink, I thought I would put this out to the 
gendispatch list and see what people think.  At the end of the day, I am 
aiming for an experiment, and might write this or something else up in a 
draft with others, if others are interested in this or some alternative 
to this (cough, Pete).  If nobody else is interested, or lots of people 
think that trying something new for plenary communication is A Bad Idea, 
this discussion will be the last you hear from me on it.  But what is 
written below is meant as a starting point, not an endpoint.

FWIW, and with apologies to Joel and others, I've a copy of the below in 
Github at https://github.com/elear/ietf-plen/tree/main. Mostly so that 
all the below can be modified, substituted, etc, and later turned into a 
draft if there is interest.

The Principles

  * Plenary communication is expensive and burdensome, and should be
    reserved for important issues that are cross-cutting.
  * Plenary communication is necessary when there is an important
    question for the community to consider.
  * Discussion of such issues must be well organized and facilitated;
    and the plenary discussion should be of finite duration.
  * There should be some outcome.  The outcome may be a mailing list, a
    BOF, dispatch to a dispatch group, an IAB program, or feedback from
    a body such as the IESG or IAB.  The outcome shouldn't be an
    immediate policy change, but if there is interest, some means to
    focus the discussion that might later use our existing processes to
    effect that change.
  * Plenary discussions may not happen on a regular basis, because there
    may not be anything important to discuss.
  * The community should decide what's important.  This is a bit of a
    chicken and egg issue, though.  Sometimes, an issue must get tossed
    around before its importance is understood by others.  What's
    important is that just because Eliot thinks an issue is important
    and cross cutting doesn't mean that it is to others.

How does this differ from *dispatch?

There are two major differences:

 1. The matter must be of cross-cutting importance.
 2. The input to the process may not be a draft to be dispatched, but
    simply an important question.

Possible Examples

  * How should the IESG/LLC organize its COVID response? (past)
  * Is there anything the IETF should be doing to address particular
    threats or changes to the Internet model? (potential future)
  * What should be done about the RFC Editor process? (past)
  * What sort of working group working methods should be acceptable?
    (potential future?)
  * Should our work take into account HR considerations (past and future?)

The astute will note that this isn't much different from what you might 
expect at an in person plenary.

Modalities

  * EMail may not be the best way to hold plenary discussions.  I think
    we've all seen bad interactions in email,  and we seem to do better
    in person, and I think we largely enjoy each other's company, quite
    frankly, even if that involves meetecho.  perhaps a "discussion"
    might really be a set of meetings, the way Heather did consultations
    toward the end of her tenor.
  * We need a way for the community to upvote issues to the point that a
    plenary discussion can occur.  Perhaps Github could provide us this
    opportunity.
  * IMHO a facilitator should drive the discussion (not lead it), and
    help interested parties develop their views *prior* to a plenary
    discussion.
  * A good way to identify those interested parties would be *short*
    position papers.  Again, not email.

Comments?

Eliot

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 29 Jul 2021 14:12:57 +0000

I think the biggest problem with previous plenaries is that it is too easy for the general public to get on a soapbox, er the microphone line.

I think think that the plenary that happened a 12 hours ago, as well as the other “remote only” ones, went much better. I attribute it to the fact that getting up to speak was much harder, but maybe there’s another reason.

---

From: Eliot Lear <[email-masked]>
Date: Thu, 29 Jul 2021 16:21:16 +0200

Thanks, Rich.  Mostly I was thinking more about how the old ietf list 
function should evolve.  What if we want to have plenary discussions in 
between big meetings?  What I outlined might feel to some almost like a 
thematic workshop, but with an open invitation to participate.

On 29.07.21 16:12, Salz, Rich wrote:
>
> I think the biggest problem with previous plenaries is that it is too 
> easy for the general public to get on a soapbox, er the microphone line.
>
> I think think that the plenary that happened a 12 hours ago, as well 
> as the other “remote only” ones, went much better. I attribute it to 
> the fact that getting up to speak was much harder, but maybe there’s 
> another reason.
>
>

---

From: Dan Harkins <[email-masked]>
Date: Thu, 29 Jul 2021 07:37:22 -0700

Rich,

   It is very easy to misconstrue a statement that says that the biggest
problem is when it's too easy for the general public to speak and how
it's much better when getting up to speak was much harder.

   In fact, it's very easy to take that as elitist and a call to clamp
down on the free speech of others. I'm sure you didn't mean it that way
but it sure sounds that way to this tin ear. Maybe try and rephrase?

   Dan.

-- 
"The object of life is not to be on the side of the majority, but to
escape finding oneself in the ranks of the insane." -- Marcus Aurelius

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 29 Jul 2021 14:58:54 +0000

Thanks Dan, you’re right, and I appreciate the input.

Everyone’s right to free speech must be balanced by the time and effort of everyone else in the room. That’s hard to do “fairly” that works in a globally-distributed populace. Perhaps the remote nature of the past couple of plenaries made people think twice, I don’t know.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 29 Jul 2021 11:14:11 -0400

I may be misreading this, but it seems that it misses one important 
purpose for the plenary.

Sometimes, the community has concerns that need to be expressed, whether 
the leadership thinks the issue is important or not.  That is why, even 
though it is usually vacuous, I consider the open mic portion of the 
plenary to be important.

Also, sometimes it is important to air and compare perspectives on an 
issue (particularly in the4 above category) even if we do not know what 
a reasonable result could be, and can not arrive at a reasonable outcome 
during that time.

I do not see how that would fit with what you have below.

Yours,
Joel

---

From: Bob Hinden <[email-masked]>
Date: Thu, 29 Jul 2021 09:02:02 -0700

Joel,

> On Jul 29, 2021, at 8:14 AM, Joel M. Halpern <[email-masked]> wrote:
> 
> I may be misreading this, but it seems that it misses one important purpose for the plenary.
> 
> Sometimes, the community has concerns that need to be expressed, whether the leadership thinks the issue is important or not.  That is why, even though it is usually vacuous, I consider the open mic portion of the plenary to be important.

I agree.  One very important purpose of the plenary is for the community to speak to our leadership and for them to listen.

Bob

> 
> Also, sometimes it is important to air and compare perspectives on an issue (particularly in the4 above category) even if we do not know what a reasonable result could be, and can not arrive at a reasonable outcome during that time.
> 
>> As one of the people who think that the plenary function of the IETF needs a more serious rethink, I thought I would put this out to the gendispatch list and see what people think.  At the end of the day, I am aiming for an experiment, and might write this or something else up in a draft with others, if others are interested in this or some alternative to this (cough, Pete).  If nobody else is interested, or lots of people think that trying something new for plenary communication is A Bad Idea, this discussion will be the last you hear from me on it.  But what is written below is meant as a starting point, not an endpoint.
>> FWIW, and with apologies to Joel and others, I've a copy of the below in Github at https://github.com/elear/ietf-plen/tree/main. Mostly so that all the below can be modified, substituted, etc, and later turned into a draft if there is interest.
>> The Principles
>> The astute will note that this isn't much different from what you might expect at an in person plenary.
>> Modalities
> Gendispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gendispatch

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 29 Jul 2021 09:12:25 -0700

On Thu, Jul 29, 2021 at 9:02 AM Bob Hinden <[email-masked]> wrote:

> I agree.  One very important purpose of the plenary is for the community
> to speak to our leadership and for them to listen.
>

I 100% agree. While it might be worth thinking about how to make that part
more productive, it seems to me to be the one non-optional part.

-Ekr

Bob
> issue (particularly in the4 above category) even if we do not know what a
> reasonable result could be, and can not arrive at a reasonable outcome
> during that time.
> >
> draft with others, if others are interested in this or some alternative to
> this (cough, Pete).  If nobody else is interested, or lots of people think
> that trying something new for plenary communication is A Bad Idea, this
> discussion will be the last you hear from me on it.  But what is written
> below is meant as a starting point, not an endpoint.
> >> FWIW, and with apologies to Joel and others, I've a copy of the below
> in Github at https://github.com/elear/ietf-plen/tree/main. Mostly so that

---

From: Eliot Lear <[email-masked]>
Date: Thu, 29 Jul 2021 18:15:12 +0200

On 29.07.21 18:12, Eric Rescorla wrote:
>
>
> On Thu, Jul 29, 2021 at 9:02 AM Bob Hinden <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Joel,
>
>     > On Jul 29, 2021, at 8:14 AM, Joel M. Halpern
>     <[email-masked] <mailto:[email-masked]>> wrote:
>     >
>     > Sometimes, the community has concerns that need to be expressed,
>     whether the leadership thinks the issue is important or not.  That
>     is why, even though it is usually vacuous, I consider the open mic
>     portion of the plenary to be important.
>
>     I agree.  One very important purpose of the plenary is for the
>     community to speak to our leadership and for them to listen.
>
>
> I 100% agree. While it might be worth thinking about how to make that 
> part more productive, it seems to me to be the one non-optional part.

So do I.  As I wrote in the proposal, there is a bit of a chicken and 
egg problem here.  I just view that as something to work on

Eliot

>
> -Ekr
>
>     Bob
>
>
>     >
>     > Also, sometimes it is important to air and compare perspectives
>     on an issue (particularly in the4 above category) even if we do
>     not know what a reasonable result could be, and can not arrive at
>     a reasonable outcome during that time.
>     >
>     >> As one of the people who think that the plenary function of the
>     IETF needs a more serious rethink, I thought I would put this out
>     to the gendispatch list and see what people think.  At the end of
>     the day, I am aiming for an experiment, and might write this or
>     something else up in a draft with others, if others are interested
>     in this or some alternative to this (cough, Pete).  If nobody else
>     is interested, or lots of people think that trying something new
>     for plenary communication is A Bad Idea, this discussion will be
>     the last you hear from me on it.  But what is written below is
>     meant as a starting point, not an endpoint.
>     >> FWIW, and with apologies to Joel and others, I've a copy of the
>     below in Github at https://github.com/elear/ietf-plen/tree/main
>     <https://github.com/elear/ietf-plen/tree/main>. Mostly so that all
>     the below can be modified, substituted, etc, and later turned into
>     a draft if there is interest.
>     >> The Principles
>     >> The astute will note that this isn't much different from what
>     you might expect at an in person plenary.
>     >> Modalities
>     > [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/gendispatch>
>
>     -- 
>     Gendispatch mailing list
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/gendispatch>
>
>

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 29 Jul 2021 09:45:27 -0700

> Comments?

I don't understand why this is on gendispatch@ and not ietf@.

--Paul Hoffman

---

From: Kyle Rose <[email-masked]>
Date: Thu, 29 Jul 2021 12:59:20 -0400

Because many important members of the community have decided that too many
of the opinions expressed on ietf@ are beneath them, and have unsubscribed.
If you want to reach them, you have to post elsewhere.

Kyle

---

From: Eliot Lear <[email-masked]>
Date: Thu, 29 Jul 2021 19:08:46 +0200

More mundanely, this was an outgrowth of the discussion of Lars' draft.

Eliot

On 29.07.21 18:59, Kyle Rose wrote:
> Because many important members of the community have decided that too 
> many of the opinions expressed on ietf@ are beneath them, and have 
> unsubscribed. If you want to reach them, you have to post elsewhere.
>
> Kyle
>
> On Thu, Jul 29, 2021 at 12:46 PM Paul Hoffman <[email-masked] 
> <mailto:[email-masked]>> wrote:
>

---

From: Rob Sayre <[email-masked]>
Date: Thu, 29 Jul 2021 11:53:31 -0700

> More mundanely, this was an outgrowth of the discussion of Lars' draft.

Why not both?

Lars' draft seems like an uncontroversial update that is fine to be handled
without a WG.

The fact that this discussion is happening here rather than on the IETF
list might be evidence that a tighter charter for that list is necessary.
It seems like there's been less traffic there (reading the archives, I
unsubscribed a while back, after 15 years). Maybe that does show that the
large audience and wide charter was being taken advantage of.

thanks,
Rob

> of the opinions expressed on ietf@ are beneath them, and have

---

From: Bob Hinden <[email-masked]>
Date: Thu, 29 Jul 2021 12:01:48 -0700

Kyle,

> On Jul 29, 2021, at 9:59 AM, Kyle Rose <[email-masked]> wrote:
> 
> Because many important members of the community have decided that too many of the opinions expressed on ietf@ are beneath them, and have unsubscribed. If you want to reach them, you have to post elsewhere.

Perhaps the actual important members of community are the ones subscribed to the IETF list.

Bob

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 29 Jul 2021 12:05:36 -0700

> Perhaps the actual important members of community are the ones subscribed

I think it would be helpful if we refrained from characterizing members of
the community as "important" or "unimportant".

-Ekr

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 30 Jul 2021 07:51:35 +1200

Yes. When I was on the IAB or IESG, I always felt it was a *duty* to be on ietf@, and maybe we should actually codify that. (And when I stepped down, in both cases I gave myself a few months holiday from the list.)

Speaking truth to power doesn't work if power isn't listening.

Regards
   Brian Carpenter

On 30-Jul-21 04:59, Kyle Rose wrote:
> On Thu, Jul 29, 2021 at 12:46 PM Paul Hoffman <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     https://www.ietf.org/mailman/listinfo/gendispatch <https://www.ietf.org/mailman/listinfo/gendispatch>
> 
>

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 30 Jul 2021 07:47:56 +1000

Purposes I've seen claimed for the IETF list now include:

- community-building
- incubation of ideas
- general discussion
- unofficial announcements
- "forcing" people to listen to one's ideas
- speaking "truth to power"

As a result, it is a *very* noisy list. People feel they have a right (and sometimes a duty) to go on and on about their particular hobby horse. Because the list can't actually resolve anything, there is often no stopping function. 

I would point out that one can speak truth to power in the plenary meeting, during the IAB and IESG sessions. One can also speak truth to power by directly e-mailing iab@ and/or iesg@. 

If the point of doing it on ietf@ is to do so in front of the broader community, I will yet again point out that that list is *not* the community -- it's a self-selecting group of people who despite the noise choose to engage in the list. Nevertheless, you can cc: ietf@ on your truth-y message to get the same effect.

If the point of doing it on ietf@ is to get it "on the record", cc:ing it to ietf@ has a similar function. I'd also point out that the W3C has a dedicated list just for this purpose: https://lists.w3.org/Archives/Public/www-archive/

So (unsurprisingly), I would dispute any effort to characterise IAB or IESG to have such a duty (although I reluctantly remained subscribed while I was on the IAB). 

My views on that might change if we are able to clean up the mess that is ietf@.

Cheers,

> On 30 Jul 2021, at 5:51 am, Brian E Carpenter <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Jay Daley <[email-masked]>
Date: Fri, 30 Jul 2021 09:55:19 +1200

> On 30/07/2021, at 4:12 AM, Eric Rescorla <[email-masked]> wrote:
> 
> 
> 
> On Thu, Jul 29, 2021 at 9:02 AM Bob Hinden <[email-masked] <mailto:[email-masked]>> wrote:
> Joel,
> 
> > On Jul 29, 2021, at 8:14 AM, Joel M. Halpern <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> I 100% agree. While it might be worth thinking about how to make that part more productive, it seems to me to be the one non-optional part.

I agree and would add one other non-optional part, which is leadership presenting to the community on what they are doing, as that taken together with the open-mic ensures a f2f session of transparency and scrutiny.  

Jay

> >> FWIW, and with apologies to Joel and others, I've a copy of the below in Github at https://github.com/elear/ietf-plen/tree/main <https://github.com/elear/ietf-plen/tree/main>. Mostly so that all the below can be modified, substituted, etc, and later turned into a draft if there is interest.
> >> The Principles
-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Rob Sayre <[email-masked]>
Date: Thu, 29 Jul 2021 14:58:46 -0700

> - speaking "truth to power"

Don't forget the ability of anyone in the world to suggest that the IETF
hold a meeting in their area, thus enabling list participants to weigh in
on geopolitical issues.

thanks,
Rob

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 29 Jul 2021 18:15:26 -0400

> though it is usually vacuous, I consider the open mic portion of the

Sometimes there are issues that have to be raised in public BECAUSE the
IESG doesn't want to talk about them.

Like that time that the chair of a working group who was also an AD in
another area flagrantly abused their power by refusing to recognize WG
consensus on a draft he personally opposed and filibustered the issue for
over a year by referring it to a cabal for review and nobody on the IESG
dared to acknowledge the situation because the WG chair might retaliate in
IESG.

If the only venue for talking truth to power is the law courts, that is
where it is going to be taken.

Since then, a number of reforms have prevented a repeat. SECDIR and GENART
reviews explicitly state that they are not privileged and should be treated
as other comments. The referral of a WG item to a directorate should never
have been allowed then, it would be much harder to justify today. Another
important reform is that with the exception of GENAREA which is
traditionally chaired by IETF Chair, members of the IESG are not WG chairs.
And there is a general expectation that AD tenure is limited to two terms
with three being exceptional.

---

From: Keith Moore <[email-masked]>
Date: Fri, 30 Jul 2021 07:45:42 -0400

> easy for the general public to get on a soapbox, er the microphone line.
IMO, this is a sign of strength.   An organization that can tolerate 
input from anyone can have a conscience, can be self-correcting. Even if 
listening to such input is often tiring, occasionally such input is 
quite valuable.   I don't know of any effective way of filtering out the 
less-valuable input without also filtering the more-valuable input.

Keith

---

From: Keith Moore <[email-masked]>
Date: Fri, 30 Jul 2021 07:56:23 -0400

On 7/29/21 3:05 PM, Eric Rescorla wrote:

> I think it would be helpful if we refrained from characterizing 
> members of the community as "important" or "unimportant".

Agree with that.

 From my perspective the IETF community has (for a variety of reasons) 
become so fragmented, that there is no longer any effective way to have 
a community-wide discussion.

Keith

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 30 Jul 2021 14:23:01 +0000

Keith and Dan have made me re-think my posting, and I was wrong. An open mic is really like the price of an open organization.  Thanks.

(Ironic since I’ve said that exact same thing more than once when people put up proposals to make “ietf@ietf” more useful. :)

---

From: Eliot Lear <[email-masked]>
Date: Fri, 30 Jul 2021 17:32:05 +0200

There are two issues:

 1. How are new concerns developed/discussed?
 2. How do we manage the conversation so that it comes to a productive
    outcome?

The ietf list works ok for (1) but generally poorly for (2).

And so what to do about (2)?  My proposal was an attempt to address that 
by having someone organize a discussion a bit, and have people prepare 
for that, with an eye toward SOME outcome.

Let's take a complaint about the IESG from someone who says that there 
are currently no people with on the IESG that have good skills at polo, 
and can we have a conversation about qualifications and where to get 
good horses. Some people take different directions, and argue that the 
underlying issue is a dearth of scuba divers, and the conversation goes 
on for a while, and nothing happens, and our IESG remains woefully 
unprepared for the next polo match.

First of all, was that the optimal outcome?  With the given example, 
quite possibly so, since we don't need IESG members who play polo or 
scuba dive.

But supposing the issue was around three party communication models and 
their interactions between security, application, and Internet layers, 
and the impact was around 1st responders?  Now what would you like to 
have happen?  Especially if there are passionate views?  Who is prepared 
to engage in an informed way?  What IETF processes should be used?

With an outcome comes a next step and hopefully a cessation of the 
discussion on the ietf list; unless and until that next step has led to 
some sort of dead end.

Eliot

On 30.07.21 16:23, Salz, Rich wrote:
>
> Keith and Dan have made me re-think my posting, and I was wrong. An 
> open mic is really like the price of an open organization.  Thanks.
>
> (Ironic since I’ve said that exact same thing more than once when 
> people put up proposals to make “ietf@ietf” more useful. :)
>
>

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 30 Jul 2021 17:43:47 +0200

I don’t think the proposals was to filter input. I agree that it is important to listen and haven different ways to provide feedback such that we can get a large variation of different views. That’s one of the reason why we have the open mic in the first place.

However, the open mic is not only a way to provide input because there  also is discussion and a large number people are “forced” to listen (more than e.g. on a mailings). Also the open mic is and should not be the only way to provide input. 

So the question for me is: how can we direct the input to the right input channel? And how can we use the limited amount of valuable time we have in the plenary most efficiently? For the second question for me that mean that we should try to use interactive discussion time in front of a large audience for those topics that this large audience is most interested in. This is not about surpassing other input (that would be a bad outcome) but maybe direct some of the input to other input channels and have a more structured approach about what to discuss in the open mic session at the plenary.

Mirja

> On 30. Jul 2021, at 13:45, Keith Moore <[email-masked]> wrote:
> 
> IMO, this is a sign of strength.   An organization that can tolerate input from anyone can have a conscience, can be self-correcting.   Even if listening to such input is often tiring, occasionally such input is quite valuable.   I don't know of any effective way of filtering out the less-valuable input without also filtering the more-valuable input.
> Keith
> 
> 
> 
> -- 
> Gendispatch mailing list
> [email-masked]

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 30 Jul 2021 14:04:07 -0400

A lesson I learned from Jock Gill and co when we built the email
publication system for the Clinton White House was that mass listening is a
really hard problem.

At the time, the President received two 20 ton trucks of mail every day.
Every single letter was read by a large team of volunteers. This was then
digested through multiple layers resulting in a one page summary delivered
to the President every day.

Changing from atoms to bits does not change the nature of the problem.

One thing we can do is to get the Web site right.

The links to the List of Current Working Groups and the ietf discussion
list should be front and center on the front page. today they are
buried many clicks down and I have to hunt and peck every single time I try
to find them.

A link in a paragraph of text is much less prominent than one in a list or
a dropdown.

On Fri, Jul 30, 2021 at 11:44 AM Mirja Kuehlewind <[email-masked]>
wrote:

> I don’t think the proposals was to filter input. I agree that it is
> important to listen and haven different ways to provide feedback such that
> we can get a large variation of different views. That’s one of the reason
> why we have the open mic in the first place.
>
> However, the open mic is not only a way to provide input because there
> also is discussion and a large number people are “forced” to listen (more
> than e.g. on a mailings). Also the open mic is and should not be the only
> way to provide input.
>
> So the question for me is: how can we direct the input to the right input
> channel? And how can we use the limited amount of valuable time we have in
> the plenary most efficiently? For the second question for me that mean that
> we should try to use interactive discussion time in front of a large
> audience for those topics that this large audience is most interested in.
> This is not about surpassing other input (that would be a bad outcome) but
> maybe direct some of the input to other input channels and have a more
> structured approach about what to discuss in the open mic session at the
> plenary.
>
> Mirja
>
>
>
>
> listening to such input is often tiring, occasionally such input is quite
> valuable.   I don't know of any effective way of filtering out the