Subject: [GGIE] Scoping our discussions

From: "Leslie Daigle" <[email-masked]>
Date: Fri, 08 Sep 2017 16:07:58 -0400

Hi,

Following up the discussion in Prague, here’s a first cut at trying to 
capture some scoping for our onward discussions:

Video and the IETF

“Video” covers a vast range of technologies and uses, and its use of 
Internet technologies is changing traditional industries and Internet 
technologies at the same time.   Creative uses of technologies for 
video, and opportunities for new uses, abound.  None of this will be 
realized effectively without increased communication between engineers 
working in different parts of the problem space.

The purpose of the group is to provide a forum to discuss current issues 
in handling video on the Internet and with Internet protocols.  The 
scope is deliberately broad in topics covered, and shallow in terms of 
purpose.  Problems are identified and discussed, and, where possible, 
appropriate venues for further discussion are identified.  Work can be 
done to refine problem statements for individual work items that are 
proposed in IETF WGs or elsewhere.   This forum is appropriate for 
sharing and discussing, but it is not expected to develop protocols or 
technologies.

Breadth of topic areas includes:  (end to end) transport, distribution 
and production of video, across multiple (potential) architectures).    
This includes signaling, MPEG multimedia, subtitles, containers and 
gateways/gateway performance.

The important outcomes of discussion are:  knowledge sharing and help in 
framing problem statements and finding appropriate venues to address 
them.

Leslie.

-- 

-------------------------------------------------------------------
Leslie Daigle
Principal, ThinkingCat Enterprises
[email-masked]
-------------------------------------------------------------------

---

From: Roni Even <[email-masked]>
Date: Mon, 11 Sep 2017 08:48:49 +0000

Hi Leslie,
This is a good start. I agree with the proposed outcome. 
In general we are talking about converging video/multimedia delivery over IP network (Internet?)  from production to distribution till the end user.
We probably need as part of the problem statement  to describe the different architectures and  media flow today in order to identify the problems we want to address.

Thanks
Roni Even

> -----Original Message-----
> From: GGIE [mailto:[email-masked]] On Behalf Of Leslie Daigle
> Sent: יום ו 08 ספטמבר 2017 23:08
> To: [email-masked]
> Subject: [GGIE] Scoping our discussions
> 
> 
> Hi,
> 
> Following up the discussion in Prague, here’s a first cut at trying to capture
> some scoping for our onward discussions:
> 
> Video and the IETF
> 
> “Video” covers a vast range of technologies and uses, and its use of Internet
> technologies is changing traditional industries and Internet
> video, and opportunities for new uses, abound.  None of this will be realized
> effectively without increased communication between engineers working in
> different parts of the problem space.
> 
> The purpose of the group is to provide a forum to discuss current issues in
> handling video on the Internet and with Internet protocols.  The scope is
> deliberately broad in topics covered, and shallow in terms of purpose.
> Problems are identified and discussed, and, where possible, appropriate
> venues for further discussion are identified.  Work can be done to refine
> problem statements for individual work items that are
> _______________________________________________
> GGIE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ggie

---

From: Amreesh Phokeer <[email-masked]>
Date: Mon, 11 Sep 2017 23:49:00 +0200

Hi Leslie,

I'm Amreesh from UCT, South Africa. I agree with the proposed outcome as
well.
I'd be interested in video content delivery in low-resourced networks
especially in developing countries. Actually at a recent Internet Peering
Forum in Africa, content providers mentioned about a lack of demand to
deploy caches because of a relatively high cost of transit/co-location in
some countries. I'm interested in the caching dynamics.

This part of the work can eventually be tied back into the GAIA IRTF
group's areas of interest.

Regards,
Amreesh

On Mon, Sep 11, 2017 at 10:48 AM, Roni Even <[email-masked]> wrote:

> In general we are talking about converging video/multimedia delivery over
> IP network (Internet?)  from production to distribution till the end user.
> We probably need as part of the problem statement  to describe the
> different architectures and  media flow today in order to identify the
> problems we want to address.
>
> Thanks
> Roni Even
>
> Internet
> realized
> in

-- 
Amreesh Phokeer

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Tue, 12 Sep 2017 02:36:48 +0000

I agree that understanding  the different architectures is key, I'm wondering what the right level of detail maybe, and the format for capturing it all.  It can get pretty complex quickly, especially with the current legacy mix of SDI some have.

Do we:

1. Describe the "ideal" world that we think should come about and just keep the description tightly focused on how it should be?

2. Attempt to document the potentially ugly mix of old and new as the world evolves?

The first has the nice, clean, approach of focusing on how things really should end up, while the second attempts to capture the reality of the operational transition.

Thoughts?  

I'm leaning towards 1 as it's cleaning and doesn't attempt to boil the ocean.

Glenn

Sent from my iPad

> On Sep 11, 2017, at 10:51 AM, Roni Even <[email-masked]> wrote:
> 
> Hi Leslie,

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Tue, 12 Sep 2017 02:40:11 +0000

Hi Amreesh,

The low resourced networks are an interesting problem.  Would it be fair to equate them to networks that are very highly congested and have depleted resources due to high competition? Or is that potentially ignoring unique problems of the low resourced networks?

Glenn

Sent from my iPad

On Sep 11, 2017, at 11:49 PM, Amreesh Phokeer <[email-masked]<mailto:[email-masked]>> wrote:

Hi Leslie,

I'm Amreesh from UCT, South Africa. I agree with the proposed outcome as well.
I'd be interested in video content delivery in low-resourced networks especially in developing countries. Actually at a recent Internet Peering Forum in Africa, content providers mentioned about a lack of demand to deploy caches because of a relatively high cost of transit/co-location in some countries. I'm interested in the caching dynamics.

This part of the work can eventually be tied back into the GAIA IRTF group's areas of interest.

Regards,
Amreesh

On Mon, Sep 11, 2017 at 10:48 AM, Roni Even <[email-masked]<mailto:[email-masked]>> wrote:
Hi Leslie,
This is a good start. I agree with the proposed outcome.
In general we are talking about converging video/multimedia delivery over IP network (Internet?)  from production to distribution till the end user.
We probably need as part of the problem statement  to describe the different architectures and  media flow today in order to identify the problems we want to address.

Thanks
Roni Even

> From: GGIE [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Leslie Daigle
> Sent: ??? ? 08 ?????? 2017 23:08
> To: [email-masked]<mailto:[email-masked]>
> Following up the discussion in Prague, here's a first cut at trying to capture
> "Video" covers a vast range of technologies and uses, and its use of Internet
> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>
_______________________________________________
GGIE mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ggie

--
Amreesh Phokeer
_______________________________________________
GGIE mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ggie

---

From: Amreesh Phokeer <[email-masked]>
Date: Tue, 12 Sep 2017 10:36:52 +0200

Hi Glenn,

The low resourced networks are an interesting problem.  Would it be fair to
> equate them to networks that are very highly congested and have depleted
> resources due to high competition? Or is that potentially ignoring unique
> problems of the low resourced networks?
>

I think there are cross-cutting aspects, low-resourced networks (in terms
of bandwidth) can easily get congested. Other aspects to consider is low
link quality for e.g. high delay, jitter and packet loss.
We can think of an IoT network also being "low-resourced". In the realm of
community networks for e.g. we go with the premise that networks are highly
congested, has low bandwidth capacity and high jitter/packet loss
especially many of them are using expensive VSAT links.

Regards,
Amreesh

---

From: "Leslie Daigle" <[email-masked]>
Date: Thu, 14 Sep 2017 18:53:42 -0400

Thanks, all, for the comments so far.  I’ve attempted to capture them 
in the updated text below.  One off-list comment suggested that this 
clarify it’s not talking about the video protocols themselves (e.g., 
WebRTC), so much as the use of these protocols for the handling of video 
content.

Some of the comments seemed to hint at framing a group to do specific 
bits of work.  I think that’s beyond the scope of what has been 
discussed to date.  I.e., we’ve been focused on having a venue to 
discuss the broad range of issues that need solving, with a view to 
figure out what other forum is appropriate to do the actual work.

If people think that’s not the right focus, we should discuss.

Updated:

Video Content Handling and the IETF

“Video content handling” (delivery, management, etc)  over IP 
networks, from production to distribution till the end user, covers a 
vast range of technologies and uses.  Its use of Internet technologies 
is changing traditional industries and Internet technologies at the same 
time.   Creative uses of technologies for video content handling, and 
opportunities for new uses, abound.  None of this will be realized 
effectively without increased communication between engineers working in 
different parts of the problem space.

The purpose of the group is to provide a forum to discuss current issues 
in handling video on the Internet and with Internet protocols.

The scope is deliberately broad in topics covered, and shallow in terms 
of purpose.  Problems are identified and discussed, and, where possible, 
appropriate venues for further discussion are identified.  Work can be 
done to refine problem statements for individual work items that are 
proposed in IETF WGs or elsewhere.   This forum is appropriate for 
sharing and discussing, but it is not expected to develop protocols or 
technologies.

Breadth of topic areas includes:
	. (end to end) transport, distribution and production of video, across 
multiple (potential) architectures,
	. the existing architectures
	. working within low-resourced networks.

-- 

On 8 Sep 2017, at 16:07, Leslie Daigle wrote:

> Hi,
>
> Following up the discussion in Prague, here’s a first cut at trying 
> to capture some scoping for our onward discussions:
>
> Video and the IETF
>
> “Video” covers a vast range of technologies and uses, and its use 
> of Internet technologies is changing traditional industries and 
> Internet technologies at the same time.   Creative uses of 
> technologies for video, and opportunities for new uses, abound.  None 
> of this will be realized effectively without increased communication 
> between engineers working in different parts of the problem space.
>
> The purpose of the group is to provide a forum to discuss current 
> issues in handling video on the Internet and with Internet protocols.  
> The scope is deliberately broad in topics covered, and shallow in 
> terms of purpose.  Problems are identified and discussed, and, where 
> possible, appropriate venues for further discussion are identified.  
> Work can be done to refine problem statements for individual work 
> items that are proposed in IETF WGs or elsewhere.   This forum is 
> appropriate for sharing and discussing, but it is not expected to 
> develop protocols or technologies.
>
> The important outcomes of discussion are:  knowledge sharing and help 
> in framing problem statements and finding appropriate venues to 
> address them.
>
>
> Leslie.
>
> -- 
>