Subject: Re: [GGIE] Proposing an actual BoF for IETF 105 in Montreal, looking for volunteers and suggestions

From: "Holland, Jake" <[email-masked]>
Date: Sun, 7 Jul 2019 23:36:05 +0000

Hi mops folks,

My contribution morphed slightly, but I’ve submitted a draft I hope will be useful:
https://tools.ietf.org/html/draft-jholland-mops-taxonomy-00

Chairs: can I have about 15 minutes to present?

I’ve tried to make this draft a start at a taxonomy of networking issues in media operations.  It includes the video scaling issue, but also a few other issues that occurred to me, as things I’ve wished I could point people to a document about in the past.

I think there’s probably a lot more that could be added and refined, but if a document like this seems like a useful direction, I’d be willing to flesh it out and try to make it into a more complete overview of known considerations worth thinking about when trying to work out networked video solutions in practice.

Please read and give feedback if you’ve got any, there’s still a good 24.5 hours until the deadline, so plenty of time to update...

- Jake

(PS: do we have a mops mailing list yet?)

From: "Holland, Jake" <[email-masked]>
Date: 2019-06-04 at 10:26
To: Leslie Daigle <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [GGIE] Proposing an actual BoF for IETF 105 in Montreal, looking for volunteers and suggestions

Hi guys,

Sorry for the delayed response.

I’ve been attending these and I wanted to take a moment to express support for creating a mops working group.  I’ve found the meeting so far valuable, and I hope they’ll be more valuable going forward, if the group becomes a normal working group.

I presented at a couple of these meetings, most recently a presentation about the scale of media delivery titled “Multicast Video: Motivating Observations”:
https://yana.techark.org/wp-content/uploads/2019/04/ietf104-vig-multicast-video.pdf<https://urldefense.proofpoint.com/v2/url?u=https-3A__yana.techark.org_wp-2Dcontent_uploads_2019_04_ietf104-2Dvig-2Dmulticast-2Dvideo.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=LlaiDQnX01BtPrtiQBbe5oOyjhHqsmaiQPXc1S27-zE&s=RIYHQUHhV4-J27VB5hivnpLba9mGsulLu9BZMQ8QIS8&e=>

I’m working on reframing some of the observations presented there into an I-D as a problem statement of the scalability issues in today’s video delivery landscape.

I hadn’t thought of it as having great archival value since the numbers I’ve got in that first presentation are just sort of a snapshot, but I think there’s a useful point in there that’s a little more timeless or that can capture an important trend, and I’m thinking about how to express it, and tentatively aiming to submit something for the first proposed slot in the agenda (about scope of video).  (Co-authors would be most welcome, if you’ve got some insights or good numbers on this topic :) )

Another thing I’d love to get out of this group at some point is a roadmap document about the various video-related and video-delivery-related standards, ideally with some pointers about implementation status, and maybe a bit of history and the motivating factors for the tradeoffs made in the different designs.  I get confused every time I try to figure that stuff out, and I’m hoping someone who knows it better will take the time to write it up and give a good overview as it relates to media delivery.  (Additionally, I’ve found the presentations so far very helpful for staying informed about the networking aspects of the various approaches people are trying, as they struggle to handle the deluge of video data.)

I wish the presentations so far had been recorded and archived, as I think there has been some good stuff covered.  On a couple of occasions I’ve gone and looked back at the presentations that were so graciously and helpfully posted at yana.techark.org, and asked the authors or presenters some follow-up questions later, but I sometimes wished I could review the presentations, as I’ve been able to do with the regular working group meetings on youtube.

It’s my opinion that the networking-related issues driven by media delivery (particularly the scaling issues and the real-time requirements, where those are a factor) are really worthwhile to examine in detail, and to consider various proposed solutions in a context like IETF, with access to and comments from networking experts and network operators.

Sorry I’ve been unresponsive on this, and I know there’s deadlines coming up.  It’s not quite my top priority and I’ve had several other fairly urgent things going, but I consider this group to be filling an important role at the IETF, at least for my purposes there, and I’d like to see it normalized.

I also have some comments on the draft charter that was recently sent out, I’ll send those in a follow-up.

Best regards,
Jake

From: Leslie Daigle <[email-masked]>
Date: 2019-05-29 at 11:01
To: "[email-masked]" <[email-masked]>
Subject: [GGIE] Proposing an actual BoF for IETF 105 in Montreal, looking for volunteers and suggestions

Hi,

We’ve been working with Éric to see about having a “Media OPS” bof in Montreal, and I’ve copied a draft agenda/proposal framework, below. Comments welcome.

As the BoF request deadline is approaching, I’d like to get some firm commits on concrete contributions (I-Ds are ideal; presentations are possible). If you have a contribution you’d like to share in the agenda, please let me know; if you’ve already heard from me with a request, I’ll be following up :^) .

Media OPerationS (MOPS) BoF
Area: OPS
Chairs: Leslie Daigle ([email-masked]<mailto:[email-masked]>), Glenn Deen ([email-masked]<mailto:[email-masked]>)

Agenda

0/ Agenda bash

1/ Scope of video on the Internet
<contributions solicited>

2/ Video using IETF technologies
<contributions solicited; I was thinking that LURK and OpenCache might fit well here, again>

3/ Open questions for IETF and video

AOB

Full description of BoF:

Internet- and Internet-protocol-delivered video/media is popular, leading to significant technology development across industries not traditionally thought of as Internet technology developers or operators, as well as considerable quantities of traffic on local and transit networks. Continued development of Internet-using technologies should be properly coordinated in order to ensure that the existing technologies are well-utilized, and new ones are developed in sympathy with the Internet’s core protocols and design.

The purpose of this BoF is to highlight the many existing video activities that are leveraging IETF protocol work, identify gaps in IETF work and/or areas of incompatibility with video technology development efforts being carried out elsewhere, and identify a core group of IETF participants working on video activities across the IETF’s technology areas.

Conflicts to avoid: ???

Expected attendance: 40

Length of session: 90min

Leslie.

--

________________________________

Leslie Daigle
Principal, ThinkingCat Enterprises

[email-masked]<mailto:[email-masked]>

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Sun, 7 Jul 2019 23:59:37 +0000

On Jul 7, 2019, at 4:36 PM, Holland, Jake <[email-masked]<mailto:[email-masked]>> wrote:

Hi mops folks,

Absolutely.

Will have a look tomorrow. I’m working on a one myself which will go in tomorrow.

- Jake

Nope, not yet.

From: "Holland, Jake" <[email-masked]<mailto:[email-masked]>>
Date: 2019-06-04 at 10:26
To: Leslie Daigle <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [GGIE] Proposing an actual BoF for IETF 105 in Montreal, looking for volunteers and suggestions

Hi guys,

I wish the presentations so far had been recorded and archived, as I think there has been some good stuff covered.  On a couple of occasions I’ve gone and looked back at the presentations that were so graciously and helpfully posted at yana.techark.org<http://yana.techark.org>, and asked the authors or presenters some follow-up questions later, but I sometimes wished I could review the presentations, as I’ve been able to do with the regular working group meetings on youtube.

Best regards,
Jake

From: Leslie Daigle <[email-masked]<mailto:[email-masked]>>
Date: 2019-05-29 at 11:01
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [GGIE] Proposing an actual BoF for IETF 105 in Montreal, looking for volunteers and suggestions

Hi,

Agenda

0/ Agenda bash

AOB

Full description of BoF:

Conflicts to avoid: ???

Expected attendance: 40

Length of session: 90min

Leslie.

--

Leslie Daigle

[email-masked]<mailto:[email-masked]>
_______________________________________________
GGIE mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ggie

---

From: "Ali C. Begen" <[email-masked]>
Date: Mon, 8 Jul 2019 12:06:45 +0200

Hi Jake

thanks for putting this together. A couple of non-urgent comments:
1) You might want to say a few things about audio probably. It has some bw
reqs, too. And maybe point cloud since you mentioned VR already.
2) Live vs. on-demand should be mentioned explicitly IMO as again they have
quite a bit different bw and caching implications.
3) Also different and asymmetric networks (wifi vs lte vs dsl, etc.)
probably deserves a few paragraphs as well.

Cheers,
-acbegen

On Mon, Jul 8, 2019 at 1:36 AM Holland, Jake <[email-masked]> wrote:

> I’ve tried to make this draft a start at a taxonomy of networking issues
> in media operations.  It includes the video scaling issue, but also a few
> other issues that occurred to me, as things I’ve wished I could point
> people to a document about in the past.
>
>
>
> I think there’s probably a lot more that could be added and refined, but
> if a document like this seems like a useful direction, I’d be willing to
> flesh it out and try to make it into a more complete overview of known
> considerations worth thinking about when trying to work out networked video
> solutions in practice.
>
>
>
> Please read and give feedback if you’ve got any, there’s still a good 24.5
> hours until the deadline, so plenty of time to update...
>
>
>
> - Jake
>
>
>
> *From: *"Holland, Jake" <[email-masked]>
> *Date: *2019-06-04 at 10:26
> *To: *Leslie Daigle <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: [GGIE] Proposing an actual BoF for IETF 105 in Montreal,
> looking for volunteers and suggestions
>
>
>
> Hi guys,
>
>
>
> I’ve been attending these and I wanted to take a moment to express support
> for creating a mops working group.  I’ve found the meeting so far valuable,
> and I hope they’ll be more valuable going forward, if the group becomes a
> normal working group.
>
>
>
> I presented at a couple of these meetings, most recently a presentation
> about the scale of media delivery titled “Multicast Video: Motivating
> Observations”:
>
>
> https://yana.techark.org/wp-content/uploads/2019/04/ietf104-vig-multicast-video.pdf
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__yana.techark.org_wp-2Dcontent_uploads_2019_04_ietf104-2Dvig-2Dmulticast-2Dvideo.pdf&d=DwMGaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=LlaiDQnX01BtPrtiQBbe5oOyjhHqsmaiQPXc1S27-zE&s=RIYHQUHhV4-J27VB5hivnpLba9mGsulLu9BZMQ8QIS8&e=>
>
>
>
> I’m working on reframing some of the observations presented there into an
> I-D as a problem statement of the scalability issues in today’s video
> delivery landscape.
>
>
>
> I hadn’t thought of it as having great archival value since the numbers
> I’ve got in that first presentation are just sort of a snapshot, but I
> think there’s a useful point in there that’s a little more timeless or that
> can capture an important trend, and I’m thinking about how to express it,
> and tentatively aiming to submit something for the first proposed slot in
> the agenda (about scope of video).  (Co-authors would be most welcome, if
> you’ve got some insights or good numbers on this topic :) )
>
>
>
> Another thing I’d love to get out of this group at some point is a roadmap
> document about the various video-related and video-delivery-related
> standards, ideally with some pointers about implementation status, and
> maybe a bit of history and the motivating factors for the tradeoffs made in
> the different designs.  I get confused every time I try to figure that
> stuff out, and I’m hoping someone who knows it better will take the time to
> write it up and give a good overview as it relates to media delivery.
>  (Additionally, I’ve found the presentations so far very helpful for
> staying informed about the networking aspects of the various approaches
> people are trying, as they struggle to handle the deluge of video data.)
>
>
>
> I wish the presentations so far had been recorded and archived, as I think
> there has been some good stuff covered.  On a couple of occasions I’ve gone
> and looked back at the presentations that were so graciously and helpfully
> posted at yana.techark.org, and asked the authors or presenters some
> follow-up questions later, but I sometimes wished I could review the
> presentations, as I’ve been able to do with the regular working group
> meetings on youtube.
>
>
>
> It’s my opinion that the networking-related issues driven by media
> delivery (particularly the scaling issues and the real-time requirements,
> where those are a factor) are really worthwhile to examine in detail, and
> to consider various proposed solutions in a context like IETF, with access
> to and comments from networking experts and network operators.
>
>
>
> Sorry I’ve been unresponsive on this, and I know there’s deadlines coming
> up.  It’s not quite my top priority and I’ve had several other fairly
> urgent things going, but I consider this group to be filling an important
> role at the IETF, at least for my purposes there, and I’d like to see it
> normalized.
>
>
>
> *From: *Leslie Daigle <[email-masked]>
> *Date: *2019-05-29 at 11:01
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *[GGIE] Proposing an actual BoF for IETF 105 in Montreal,
> looking for volunteers and suggestions
>
>
>
> Hi,
>
> We’ve been working with Éric to see about having a “Media OPS” bof in
> Montreal, and I’ve copied a draft agenda/proposal framework, below.
> Comments welcome.
>
> As the BoF request deadline is approaching, I’d like to get some firm
> commits on concrete contributions (I-Ds are ideal; presentations are
> possible). If you have a contribution you’d like to share in the agenda,
> please let me know; if you’ve already heard from me with a request, I’ll be
> following up :^) .
>
> Chairs: Leslie Daigle ([email-masked]), Glenn Deen (
> [email-masked])
>
> Agenda
>
> 0/ Agenda bash
>
> Internet- and Internet-protocol-delivered video/media is popular, leading
> to significant technology development across industries not traditionally
> thought of as Internet technology developers or operators, as well as
> considerable quantities of traffic on local and transit networks. Continued
> development of Internet-using technologies should be properly coordinated
> in order to ensure that the existing technologies are well-utilized, and
> new ones are developed in sympathy with the Internet’s core protocols and
> design.
>
> The purpose of this BoF is to highlight the many existing video activities
> that are leveraging IETF protocol work, identify gaps in IETF work and/or
> areas of incompatibility with video technology development efforts being
> carried out elsewhere, and identify a core group of IETF participants
> working on video activities across the IETF’s technology areas.
>
> Conflicts to avoid: ???
>
> Expected attendance: 40
>
> Length of session: 90min
>
> Leslie.
>
> --
> ------------------------------
>
> Leslie Daigle
> [email-masked]
> [email-masked]

---

From: "Holland, Jake" <[email-masked]>
Date: Mon, 8 Jul 2019 11:51:40 +0000

Hi Ali,

Thanks, I can see right away that #1 and 2 are good suggestions, I’m reasonably sure I can think of some useful text about those for the next rev.

Could you elaborate a bit on the media issues related to different and asymmetric networks (#3), or point to a paper or 2 that discuss some issues they cause?  I will not be surprised to find that there’s some important things to raise, but I don’t have very good ideas yet of what a few paragraphs in that section should be saying.

Cheers,
Jake

From: "Ali C. Begen" <[email-masked]>
Date: 2019-07-08 at 03:06
To: "Holland, Jake" <[email-masked]>
Cc: Leslie Daigle <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [GGIE] Proposing an actual BoF for IETF 105 in Montreal, looking for volunteers and suggestions

Hi Jake

thanks for putting this together. A couple of non-urgent comments:
1) You might want to say a few things about audio probably. It has some bw reqs, too. And maybe point cloud since you mentioned VR already.
2) Live vs. on-demand should be mentioned explicitly IMO as again they have quite a bit different bw and caching implications.
3) Also different and asymmetric networks (wifi vs lte vs dsl, etc.) probably deserves a few paragraphs as well.

Cheers,
-acbegen

On Mon, Jul 8, 2019 at 1:36 AM Holland, Jake <[email-masked]<mailto:[email-masked]>> wrote:
Hi mops folks,

My contribution morphed slightly, but I’ve submitted a draft I hope will be useful:
https://tools.ietf.org/html/draft-jholland-mops-taxonomy-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Djholland-2Dmops-2Dtaxonomy-2D00&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=CbcL0ZZPlqgp2Kt2Qw0K8p20jP7VEffok9Hva6tfkVE&s=cFLw-uuo45fFprbenY5b1U4kTnUWeAZwdPFAUd1LiMg&e=>

- Jake

Hi guys,

I wish the presentations so far had been recorded and archived, as I think there has been some good stuff covered.  On a couple of occasions I’ve gone and looked back at the presentations that were so graciously and helpfully posted at yana.techark.org<https://urldefense.proofpoint.com/v2/url?u=http-3A__yana.techark.org&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=CbcL0ZZPlqgp2Kt2Qw0K8p20jP7VEffok9Hva6tfkVE&s=Pe5uU1ucsiW0gvfYhHpRXjVVjB75GsrGULyZwk45-mM&e=>, and asked the authors or presenters some follow-up questions later, but I sometimes wished I could review the presentations, as I’ve been able to do with the regular working group meetings on youtube.

Best regards,
Jake

Hi,

Agenda

0/ Agenda bash

AOB

Full description of BoF:

Conflicts to avoid: ???

Expected attendance: 40

Length of session: 90min

Leslie.

--

Leslie Daigle

[email-masked]<mailto:[email-masked]>
_______________________________________________
GGIE mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ggie<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ggie&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=CbcL0ZZPlqgp2Kt2Qw0K8p20jP7VEffok9Hva6tfkVE&s=9ZvNBPl1IFJlI2Mv_OhRmshP9tZzQ8Ft27nOj03lZaA&e=>

---

From: "Ali C. Begen" <[email-masked]>
Date: Mon, 8 Jul 2019 13:58:23 +0200

The primary issue over there is the asymmetry in most consumer networks (cable, dsl, wifi, lte and such). As personal broadcast is used more and more like twitch or periscope, etc. rather limited upload speeds become important. 

I suppose facetime, skype type of apps are not discussed here, should they be? I am not sure.

> On Jul 8, 2019, at 1:51 PM, Holland, Jake <[email-masked]> wrote:
> 
> Hi Ali,
>  
>> Chairs: Leslie Daigle ([email-masked]), Glenn Deen ([email-masked])
>> 
>> Agenda
>> 
>> 0/ Agenda bash
>>