Subject: [Hipsec] draft-moskowitz-hip-08.txt IS OUT!

From: [email-masked] (Pekka Nikander)
Date: Thu Oct 23 07:02:00 2003

Folks,

I submitted just a few moments ago draft-moskowitz-hip-08.txt to
the repositories.  It should resolve almost all of the issues
raised, with two exceptions:

   Issue 18: Example chacksums

             The reason for this having been left open is that
             I am getting weary on editing this draft, and
             don't have the energy to produce high quality
             examples from the raw material.

   Issue 25: Renumbering of parameter IDs once again.

             This I have left open deliberately so that there
             is *some* change for -08-pre-Oct01 and -08
             versions to interoperate.  Unfortunately the HMAC
             computation is different between these two
             versions (Issue 24), and therefore care must be
             taken.  Other than that, there should not be any
             major showstoppers.

The issues page, http://www.tml.hut.fi/~pnr/HIP/issues.html
has been updated to reflect the status of the issues.

It may take some time before the draft appears at the repository
due to the large number of last minute submissions.  However, as
usual, the draft is available at the following URLs:

http://www.tml.hut.fi/~pnr/HIP/draft-moskowitz-hip-08.txt
http://www.tml.hut.fi/~pnr/HIP/draft-moskowitz-hip-08.xml
http://www.tml.hut.fi/~pnr/HIP/draft-moskowitz-hip-08.html

What is less usual, though, is that this time I produced
diffs against the previous pre-release, too:

http://www.tml.hut.fi/~pnr/HIP/draft-moskowitz-hip-08-from-pre-Oct01.html
http://www.tml.hut.fi/~pnr/HIP/draft-moskowitz-hip-08-from-pre-Oct01.txt

It has been a honor to be able to serve as the editor for this
draft.  I think that it represents an important piece of work.
However, as some people know, I am best in working on new and
complex issues, and not so good in trying to track zillions of details.
For this and for other reasons, we have agreed that Petri Jokela will
act as the draft editor from here on.  I wish Petri good luck and
enough of patience with this new job!

--Pekka Nikander

---

From: [email-masked] (Miika Komu)
Date: Fri Oct 24 09:37:01 2003

This message is in MIME format.  The first part should be readable text,
  while the remaining parts are likely unreadable without MIME-aware tools.
  Send mail to [email-masked] for more info.

---559023410-684387517-1067004425=:9487
Content-Type: TEXT/PLAIN; charset=US-ASCII

>              taken.  Other than that, there should not be any

A patch for solving the issue for draft-09 is attached. I incremented all
of the type values up by one and changed the text specifying the syntax of
the "critical" value. The CERT parameter type value was wrong in draft-08
(CERT is optional; isn't it?) and it is also fixed.

-- 
Miika Komu              [email-masked]          http://www.iki.fi/miika/
---559023410-684387517-1067004425=:9487
Content-Type: TEXT/PLAIN; charset=US-ASCII; name="draft-moskowitz-hip-08.xml.patch"
Content-Transfer-Encoding: BASE64
Content-ID: <[email-masked]>
Content-Description: 
Content-Disposition: attachment; filename="draft-moskowitz-hip-08.xml.patch"

---559023410-684387517-1067004425=:9487--