Subject: [Hipsec] Closing issue #4/12: Adding HMAC to R2

From: [email-masked] (Pekka Nikander)
Date: Wed Oct 1 04:01:00 2003

In -08-pre, we have added HMAC to the R2 to plug
a potential R1/R2 replay attack.

Please read the relevant sections and send your comments
to the list, even if they are just "looks good".

The relevant sections are:

6.3.9  HMAC
7.4  R2 - the second HIP responder packet
8.7  Processing incoming R2 packets

URLs for easy reading:

http://www.tml.hut.fi/~pnr/HIP/draft-moskowitz-hip-08-pre-Sep24.html#HMAC
http://www.tml.hut.fi/~pnr/HIP/draft-moskowitz-hip-08-pre-Sep24.html#R2
http://www.tml.hut.fi/~pnr/HIP/draft-moskowitz-hip-08-pre-Sep24.html#anchor45

--Pekka Nikander

---

From: [email-masked] (Andrew McGregor)
Date: Thu Oct 2 16:34:03 2003

-----BEGIN PGP SIGNED MESSAGE-----

This looks good.  We may wish to add to the note on the signature 
processing something along these lines:

   Signature      the signature is calculated over the HIP packet,
                  excluding the HIP_SIGNATURE TLV field, but including the
                  HMAC field if present.
...

and similarly for HIP_SIGNATURE_2.

Andrew

- --On Wednesday, October 01, 2003 11:28:48 AM +0300 Pekka Nikander 
<[email-masked]> wrote:

> _______________________________________________
> Hipsec mailing list
> [email-masked]
> http://honor.trusecure.com/mailman/listinfo/hipsec
>
>

- --------
Andrew McGregor
Director, Scientific Advisor
IndraNet Technologies Ltd
http://www.indranet.co.nz/
Office: +64 3 3656485
Mobile: +64 21 898856

---

From: [email-masked] (Pekka Nikander)
Date: Fri Oct 3 02:06:01 2003

> and similarly for HIP_SIGNATURE_2.

Ok, added.  Thanks for the comment!

--Pekka

...