Subject: [Hipsec] Closing issue 14: New state E4

From: [email-masked] (Pekka Nikander)
Date: Wed Oct 1 04:04:01 2003

In -08-pre, there is a new state E4 in the state machine.
It is used in the E3 state if the host receives an I2
with a proper birthday.

Please read the revised sections and send your comments,
even if they were just "looks good".

The relevant sections are:

5.4  HIP State Machine
8.6  Processing incoming I2 packets

URLs for easy reading:

http://www.tml.hut.fi/~pnr/HIP/draft-moskowitz-hip-08-pre-Sep24.html#state-machine
http://www.tml.hut.fi/~pnr/HIP/draft-moskowitz-hip-08-pre-Sep24.html#anchor44

--Pekka Nikander

---

From: [email-masked] (Andrew McGregor)
Date: Thu Oct 2 16:44:01 2003

-----BEGIN PGP SIGNED MESSAGE-----

Looks good.  Actually, E4 is spread around all the processing, not just on 
incoming I2.  This change does remove the rekey race (I can make the race 
happen in practice with the old rules, the window can be as much as a 
couple of seconds).

Andrew

- --On Wednesday, October 01, 2003 11:31:30 AM +0300 Pekka Nikander 
<[email-masked]> wrote:

> _______________________________________________
> Hipsec mailing list
> [email-masked]
> http://honor.trusecure.com/mailman/listinfo/hipsec
>
>

- --------
Andrew McGregor
Director, Scientific Advisor
IndraNet Technologies Ltd
http://www.indranet.co.nz/
Office: +64 3 3656485
Mobile: +64 21 898856

---

From: [email-masked] (Pekka Nikander)
Date: Fri Oct 3 02:16:01 2003

Andrew,

> happen in practice with the old rules, the window can be as much as a 

Thanks for the comment!  I must have been half asleep when sending
the original closing message.  Yes, E4 is spread around all the
processing.

--Pekka