Subject: [Hipsec] Status of the HIP implementation for BSD

From: [email-masked] (Juan Rodriguez Hervella)
Date: Thu Dec 4 14:56:02 2003

Hello,

I'd like to know when the status of the implementation
for BSD will be released.

Is an open source project ? Can anybody make contributions
to it ? 

Thanks!

-- 
******
JFRH
******

---

From: [email-masked] (Pekka Nikander)
Date: Sat Dec 6 05:42:01 2003

> for BSD will be released.

We have been working towards a release.  Our original
goal was the end of October, but there has been a large
number of small issues that each have delayed the
process.  Anyway, as far as I know, the release should
be any day now.  On the other hand, it is better that I
do not state any fixed dates any more, since such promises
would be empty, given the experience so far.

> Is an open source project ? Can anybody make contributions

The initial release will basically be a snapshot of
our current development.  The code will be released under
a new license that should be open source compatible
but does not have open source status, at least not yet.

Once the code is out, we would be happy to see anyone to
use it.  We will also accept bug fixes and integrate them to
the code.  However, since at this time we will be only
releasing time-to-time snapshots, I'm afraid that doing
any larger modifications may be hard.  At some future
date we may put up a live repository in a public access
CVS site, but that depends largely on how much demand
there would be for such a service.

--Pekka Nikander