Subject: [Hipsec] WG charter proposal

From: [email-masked] (Pekka Nikander)
Date: Tue Dec 16 06:43:00 2003

--Apple-Mail-10-928091257
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
	charset=US-ASCII;
	format=flowed

Folks,

Here is a new proposal for the WG charter, based on
the discussions on this list and with the ADs.  We
should find some kind of consensus on the charter
fairly soon, in order to get it in time to the IESG
meeting agendas etc, if we want to have a WG chartered
before Seoul.  Hence, please send your comments as soon
as possible, even if it is just a plain "looks good".

This proposal is based on the assumption that there will
be a short term, very focused WG, and a parallel RG.  The
purpose of the WG is to finalize those parts of HIP
design that are either fairly mature already, or seem
to be very straightforward.

I am still working on a proposal for the RG charter.

Note that this charter does *not* address Steve Kent's
request for a problem statement.  IMHO, it would be
unwise to try to define a precise problem statement
for the WG.  To me, it looks better to start from the
architecture document and from the requirement of
providing "minimal  infrastructure support."  The
large, overall problem statement is to be understood
from the context, and is partially discussed in the
architecture draft.

--Pekka Nikander

--Apple-Mail-10-928091257
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
	x-unix-mode=0644;
	name="hip_charter_proposal_031216.txt"
Content-Disposition: attachment;
	filename=hip_charter_proposal_031216.txt

Host Identity Protocol (HIP)

Chairs (tentative, subject to AD decision):
David Ward <[email-masked]>
Gonzalo Camarillo <[email-masked]>

Internet Area Directors:
Thomas Narten <[email-masked]>
Margaret Wasserman <[email-masked]>

Internet Area Advisor:
Margaret Wasserman <[email-masked]>

Security Area Liason:
TBD.

Mailing Lists:

General Discussion: [email-masked]
Send mail to: [email-masked]
With a subject line: subscribe
List archive: http://honor.trusecure.com/pipermail/hipsec/

Description of Working Group:

The Host Identity Protocol (HIP) provides a method of
separating the end-point identifier and locator roles of
IP addresses.  It introduces a new Host Identity (HI)
name space, based on public keys.  The public keys are
typically, but not necessarily, self generated.

The specifications for the architecture and protocol
details for these mechanisms consist of:

   draft-moskowitz-hip-arch-05.txt (at RFC editor) and
   draft-moskowitz-hip-08.txt (soon -09.txt)

There are five publicly known, interoperating
implementations, some of which are open source.

Currently, the HIP base protocol works well with any pair
of co-operating end-hosts.  However, to be more useful
and more widely deployable, HIP needs some support from
the existing infrastructure, including the DNS, and a new
piece of infrastructure, called the HIP rendezvous
server.

+-------------------------------------------------------+
| The purpose of this Working Group is to define the    |
| minimal infrastructure elements that are needed for   |
| HIP experimentation on a wide scale.                  |
+-------------------------------------------------------+

In particular, the objective of this working group is to
complete the base protocol specification, define one or
more DNS resource records for storing HIP related data,
to complete the existing work on basic mobility and
multi-homing, and produce Experimental RFCs for these.

Note that even though the specifications are chartered 
for Experimental, it is understood that their quality and
security properties should match the standards track
requirements.  The main purpose for producing
Experimental documents instead of standards track ones
are the unknown effects that the mechanisms may have on
applications and on the Internet in the large.  

It is expected that there will be a rougly parallel IRTF
Research Group that will focus both on more forward
looking aspects of the HIP architecture and on the
effects that HIP may have on the applications and the
Internet.

The following are charter items for the working group:

1) Complete the HIP base protocol specification.
   Starting point: draft-moskowitz-hip-08.txt (or newer)

2) Complete the basic mobility and multi-homing support for HIP.
   Starting point: draft-nikander-hip-mm-01.txt (or newer)
   
   While this work partially overlaps the work in Mobile
   IP and Multi6 Working Groups, it is very different in
   the sense that is based on the Experimental HIP
   specification, and cannot function without it.

3) Define one or more new DNS Resource Records for
   storing HIP related data, such as Host Identifiers and
   Host Identity Tags (HITs).  This task explicitly
   excludes the task of defining reverse DNS entries
   based on HITs.

4) Define a basic HIP rendezvous mechanism.

   A basic HIP rendezvous server allows mobile and
   non-mobile HIP hosts to register their current IP
   addresses at the server.  Other hosts can then send
   the initial I1 packets to the rendezvous server, which
   forwards the packets to the HIP host's current
   address.

   This task explicitly excludes solving more general
   problems, such as the referral problem.  Also excluded
   is the problem of finding the right rendezvous server.
   It is expected that the DNS records will be used for
   that.

The Working Group bases all the work on the HIP achitecture
specification (as defined above).

Goals and Milestones:

Mar 04    WG LC on the base protocol specification.

Mar 04    First version of the HIP basic mobility and
     	  multi-homing mechanism specification.

Mar 04    First version of the HIP DNS resource record(s)
     	  specification.

Apr 04    Complete the base protocol specification and
          submit it to the IESG for Experimental.

Apr 04    First version of the HIP basic rendezvous mechanism
     	  specification.

May 04    WG LC on the HIP DNS resource record(s)
          specification.

Jun 04    WG LC on the HIP basic mobility and multi-homing
     	  specification.

Jun 04    Submit the HIP DNS resource record(s) specification
          to the IESG for Experimental.

Jul 04    Submit the HIP basic mobility and multihoming
     	  specification to the IESG for Experimental.

Aug 04    WG LC on the basic HIP rendezvous mechanism
     	  specification.

Sep 04    Submit the basic HIP rendezvous mechanism
     	  specification to the IESG for Experimental.

Oct 04    Recharter the WG.

Current Internet-Drafts:

draft-moskowitz-hip-arch-05.txt (at RFC editor)
draft-moskowitz-hip-08.txt (soon -09.txt)
draft-nikander-hip-mm-00.txt (soon -01.txt)

Proposed WG items:

draft-ietf-hip-protocol-XX.txt   (HIP base exchange)
draft-ietf-hip-mm-XX.txt	 (HIP basic mobility and multihoming)
draft-ietf-hip-dns-rr-XX.txt     (HIP DNS resource record)
draft-ietf-hip-rendezvous-XX.txt (HIP basic rendezvous)

--Apple-Mail-10-928091257
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
	charset=US-ASCII;
	format=flowed

--Apple-Mail-10-928091257--

---

From: [email-masked] (Jari Arkko)
Date: Tue Dec 16 08:25:01 2003

Pekka,

The charter looks good to me. A few nits:

- What's the box that is drawn around "The purpose of
   this Working..."?
- s/rougly/roughly/

--Jari

---

From: [email-masked] (Julien Laganier)
Date: Tue Dec 16 09:38:01 2003

Hi Pekka,

The WG charter proposal looks quite good to me.

Thanks,

--julien

---

From: [email-masked] (Petri Jokela)
Date: Wed Dec 17 02:40:01 2003

> Here is a new proposal for the WG charter, based on

I think it looks good.

/petri

-- 
Petri Jokela                        Tel:    +358 9 299 2413
Research scientist                  Fax:    +358 9 299 3535
NomadicLab, Ericsson Research       Mobile: +358 44 299 2413
Oy L M Ericsson Ab                  email: [email-masked]

---

From: [email-masked] (Mika Kousa)
Date: Wed Dec 17 05:18:00 2003

On more "me too".

The charter looks good to me, too.

-- 
  "Real programmers don't comment their code.  It was hard to write, it
   should be hard to understand."