Subject: [Hipsec] ESP_TRANSFORM (64-bit sequence number)

From: [email-masked] (Henderson, Thomas R)
Date: Sun Jan 25 16:01:01 2004

this is a nit, but I am wondering whether there is any
reason to use the most significant bit of the reserved
field for the "E" bit, rather than the least significant
bit?  Use of bits in the HIP control field has started
from least significant bit, and that is also the practice
I am familiar with in various protocols.

Tom

> -----Original Message-----
> From: Petri Jokela [mailto:[email-masked]]
> Sent: Friday, January 23, 2004 3:16 AM
> To: [email-masked]
> Subject: [Hipsec] ESP_TRANSFORM (64-bit sequence number)
>=20
>=20
> The need for 64-bit sequence numbers was indicated with the=20
> E-bit in the=20
> HIP header. As discussed earlier on the HIPSEC list, this bit is now=20
> removed from the header and moved to the ESP_TRANSFORM parameter.
>=20
>=20

---

From: [email-masked] (Miika Komu)
Date: Mon Jan 26 03:00:01 2004

On Sun, 25 Jan 2004, Henderson, Thomas R wrote:

> > The need for 64-bit sequence numbers was indicated with the
> > E-bit in the
> > HIP header. As discussed earlier on the HIPSEC list, this bit is now

Perhaps the whole "reserved" field could also be changed to "flags". The
flags field could then contain the "E" bit.

-- 
Miika Komu              [email-masked]          http://www.iki.fi/miika/