Subject: [Hipsec] Moving NES_INFO before Diffie-Hellman

From: [email-masked] (Petri Jokela)
Date: Tue Feb 3 02:22:01 2004

Are there any thoughts about the following issue raised earlier by Pekka?

/petri

Pekka Nikander wrote:
> I'd like to move the NES_INFO parameter so that it always
> preceeds the Diffie-Hellman parameter.  That would make
> middlebox implementation slightly easier, since middle-boxes
> need  to track NES_INFO but they do not need to care about
> Diffie-Hellman.
> 
> The change would also make it easier to include several
> REA parameters in a single NES packet.
> 
> Hence, the new type values would be something like
> 
>    NES_INFO          9                Old SPI, New SPI and other
>                                       info needed for NES
> 
>    DIFFIE_HELLMAN    13    variable   public key
> 
> The new format for the NES packet would be
> 
>   IP ( HIP ( NES_INFO, [ DIFFIE_HELLMAN, ] HMAC, HIP_SIGNATURE ) )
> 
> Then, when REA is included, it would be
> 
>   IP ( HIP ( REA, NES_INFO, [ DIFFIE_HELLMAN, ] HMAC, HIP_SIGNATURE ) )
> 
> This may require some changes to the NES processing logic
> on some implementations, but that shouldn't be too hard,
> since the end-hosts need to scan for the HMAC before
> processing the NES_INFO anyway.
> 
> Any thoughts?

-- 
Petri Jokela                        Tel:    +358 9 299 2413
Research scientist                  Fax:    +358 9 299 3535
NomadicLab, Ericsson Research       Mobile: +358 44 299 2413
Oy L M Ericsson Ab                  email: [email-masked]

---

From: [email-masked] (Julien Laganier)
Date: Tue Feb 3 04:46:00 2004

> Are there any thoughts about the following issue raised earlier by

I support this change.

Tnx,

--julien

-- 
Julien Laganier 
SUN Microsystems Laboratories

---

From: [email-masked] (Mika Kousa)
Date: Tue Feb 3 05:57:00 2004

On Tue, 3 Feb 2004, Petri Jokela wrote:

-> Are there any thoughts about the following issue raised earlier by Pekka?

This change is ok.

-- 
  Windows NT - Version of Windows for optimized for
  crashing high-end servers.