Subject: [Hipsec] NOTIFY in response to I1

From: [email-masked] (Henderson, Thomas R)
Date: Sat Apr 24 13:16:01 2004

> -----Original Message-----
> From: Jonathan Wood [mailto:[email-masked]]
> Sent: Thursday, April 22, 2004 12:38 PM
> To: [email-masked]
> Subject: [Hipsec] NOTIFY in response to I1
>=20
>=20
>=20
> There are a few situations where a NOTIFY might be
> sent in response to an I1 (i.e. BLOCKED_BY_POLICY,
> INVALID_MAJOR_VERSION, CHECKSUM_FAILED).
>=20
> At this stage, the initiator probably won't have the
> responders public key, just its HIT. So the initiator
> will not be able to verify the signature in the NOTIFY.
>=20
> To handle this, do we need a HOST_ID in the NOTIFY
> as well?
>

It seems reasonable to allow HOST_ID to be a parameter
in a NOTIFY.  We will need at some point to work out
the issues regarding how these various NOTIFYs should
be crafted. =20

Tom=20

---

From: [email-masked] (Pekka Nikander)
Date: Tue Apr 27 03:28:00 2004

>> INVALID_MAJOR_VERSION, CHECKSUM_FAILED).

As I wrote in a separate message, IMHO a Responder SHOULD
never respond with a NOTIFY to an I1.  There we should
use ICMP instead.

But then we come to more trusted environments.  There
constructing a NOTIFY (and even signing it -- gulp)
may make sense.  So ...

> be crafted.

... I agree that it may be good to allow a HOST_ID in
a NOTIFY packet, just for the case.

--Pekka