Subject: [Hipsec] Base HIP: new issues

From: [email-masked] (Henderson, Thomas R)
Date: Tue May 11 17:00:01 2004

> -----Original Message-----
> From: Petri Jokela [mailto:[email-masked]]=20
> Sent: Tuesday, May 11, 2004 12:56 AM
> To: [email-masked]
> Subject: [Hipsec] Base HIP: new issues
>=20

> Issue #38: Size of K in PUZZLE and the Opaque field.
>=20
> Shall we maintain the Opaque field in the PUZZLE/SOLUTION or should we
> use only ECHO REQUEST/REPLY for this purpose? And what to do=20
> with the K
> that is currently 8 bits in front of the Opaque field: is 8=20
> bits enough,
> or shall we allocate more space for it?
>=20
> K and Opaque should probably be two different issues, but they are
> fighting for the same space in the parameter, so that's why I put
> them under the same issue.
>=20
> Any comments/proposals?
>=20

My proposal to put Opaque in the puzzle was strictly a bit conservation
proposal-- avoiding another TLV in the R1 if the opaque data was small=20
enough to be stored in a few bytes. =20

4 bytes for K is overkill-- a K larger than 160 doesn't make sense
in the context of the SHA-1 hash, and in practice it will be much
smaller than 160.

Tom

---

From: [email-masked] (Pekka Nikander)
Date: Wed May 12 02:42:00 2004

>> Shall we maintain the Opaque field in the PUZZLE/SOLUTION
>> or should we use only ECHO REQUEST/REPLY for this purpose?
>> And what to do with the K that is currently 8 bits in front
>> of the Opaque field: is 8 bits enough, or shall we allocate
>> more space for it?
>>
> proposal-- avoiding another TLV in the R1 if the opaque data was small
> enough to be stored in a few bytes.
>

I agree with Tom.

--Pekka

---

From: [email-masked] (Petri Jokela)
Date: Fri May 14 05:08:00 2004

>> in the context of the SHA-1 hash, and in practice it will be much

Ok, we leave it as described in draft version 10-pre2. Issue closed.

/petri