Subject: [Hipsec] new preview of mobility mgmt. draft

From: [email-masked] (Henderson, Thomas R)
Date: Tue Jul 6 10:21:01 2004

A new "pre" version of the mobility management draft is at:
http://hip.piuha.net/drafts/draft-nikander-hip-mm-02-pre3.txt

The plan is to submit this prior to the cutoff, but comments
are welcome this week.

The main changes are:
i) remove the address group identifiers in favor of just=20
directly using SPIs
ii) align with the UPDATE exchange defined in the new base spec
iii) better definition of the address verification procedure

One of the main open issues is the parameter type for REA.
This is tied in with middlebox traversal.  We could put
REA at parameter type 3, which would mean that it precedes
everything except SPI and R1_COUNTER.  (R1_COUNTER could
also be defined down from 2 to 4, since REA might be found
in R1).  The main messiness IMO, and I don't know how to
fix this, is that some UPDATEs may have SPI, some may have
both SPI and REA, and some may have just REA (or REA/NES),
making it harder in general for middleboxes to parse.  This
is probably something for which we need to get some=20
experience with before deciding, and redefine if a better
way is found.  So I would suggest that we set REA to parameter
type 3 and consider making R1_COUNTER parameter type 4.

Thanks to Mika, Pekka, Jari, and Jonathan for offline comments
in developing the above draft revision.

Tom

---

From: [email-masked] (Mika Kousa)
Date: Wed Jul 7 07:14:03 2004

About section 5.1 "Mobility with single SA pair" bullet point 1, when the
UPDATE does not have a NES parameter, the draft says "the host transitions
to a logical READDRESSING state, in which it waits until its UPDATE is
acknowledged."

What does this "logical READDRESSING state" mean from an implementation
point of view ? I did not find any other references what this logical
state really means. It is not related to the state machine in any way,
right ?

If we receive other than the acknowledging UPDATE packets before we
receive the acknowledging UPDATE packet, are they just dropped ?