Subject: [Hipsec] Recovery from state loss

From: [email-masked] (Henderson, Thomas R)
Date: Tue Jul 6 10:02:06 2004

> -----Original Message-----
> From: Erik Nordmark [mailto:[email-masked]]=20
> Sent: Monday, July 05, 2004 2:53 AM
> To: Henderson, Thomas R
> Cc: Erik Nordmark; [email-masked]
> Subject: RE: [Hipsec] Recovery from state loss
>=20
>=20
>=20
> Is there some encrypted set of bits exchange when the HIP association
> is setup which could be used just to apply a keyed hash on=20
> the close message?
>=20
There is an HMAC parameter based on keying material derived from the =
Diffie Hellman exchange.

Tom

---

From: [email-masked] (Julien Laganier)
Date: Tue Jul 6 10:13:01 2004

On Tuesday 06 July 2004 16:59, Henderson, Thomas R wrote:
> > From: Erik Nordmark [mailto:[email-masked]]
> > Is there some encrypted set of bits exchange when the HIP
> > association is setup which could be used just to apply a keyed
> > hash on the close message?
>
> There is an HMAC parameter based on keying material derived from
> the Diffie Hellman exchange.

BTW, having both a HMAC and a SIGNATURE might make sense: The end-node 
verifies only the HMACs while midboxes verify SIGNATUREs.

--julien