Subject: [Hipsec] draft-ietf-hip-base-00 submitted

From: [email-masked] (Henderson, Thomas R)
Date: Fri Jul 9 11:23:01 2004

> -----Original Message-----
> From: Mika Kousa [mailto:[email-masked]]=20
> Sent: Friday, July 09, 2004 3:27 AM
> To: [email-masked]
> Subject: Re: [Hipsec] draft-ietf-hip-base-00 submitted
>=20
>=20
> On Fri, 9 Jul 2004, Jan Mikael Melen wrote:
>=20
> -> On Thursday 08 July 2004 19:39, Mika Kousa wrote:
> -> > So, if understood correctly, when received UPDATE=20
> contains both SEQ and
> -> > NES parameters, we reply to it with the above mentioned=20
> new UPDATE packet
> -> > containing only the ACK parameter (+ HMAC and=20
> HIP_SIGNATURE) and nothing
> -> > else, right ? If yes, then section 8.11.2 needs one more=20
> bullet point
> -> > which tells that "The system sends the UPDATE packet .."

If we changed "generates" to "sends", will that clarify it?

> ->
> -> If I have understood it correctly one can include SEQ, NES=20
> of it's own to this
> -> ACK packet and then the other end sends ACK back after=20
> which the rekeying
> -> state is changed to established.
> ->
> -> So you have to two ways to complete the rekeying:
> -> ---------- SEQ, NES -------->
> -> <----- SEQ, NES, ACK ----
> -> ---------------- ACK ----------->
> ->
> -> Or:
> -> ---------- SEQ, NES -------->
> -> <-------------- ACK -------------
> -> <----- SEQ, NES -------------
> -> ---------------- ACK ----------->
>=20
> Yes, I was also thinking that it should be done this way.

Yes, both above options are valid.  If we are in REKEYING, this
corresponds to being on the left side of the above figures.  Point 1
in 8.11.2 handles the first figure above, and point 2 handles
the second figure above.

>=20
> But anyway, I would still like to see third bullet point added to the
> section 8.11.2 as I mentioned. Just for clarity.

Will the proposed word change mentioned above be sufficient?

---

From: [email-masked] (Mika Kousa)
Date: Fri Jul 9 12:14:00 2004

On Fri, 9 Jul 2004, Henderson, Thomas R wrote:

-> > -----Original Message-----
-> > From: Mika Kousa [mailto:[email-masked]]
-> > Sent: Friday, July 09, 2004 3:27 AM
-> > To: [email-masked]
-> > Subject: Re: [Hipsec] draft-ietf-hip-base-00 submitted
-> >
-> >
-> > On Fri, 9 Jul 2004, Jan Mikael Melen wrote:
-> >
-> > -> On Thursday 08 July 2004 19:39, Mika Kousa wrote:
-> > -> > So, if understood correctly, when received UPDATE
-> > contains both SEQ and
-> > -> > NES parameters, we reply to it with the above mentioned
-> > new UPDATE packet
-> > -> > containing only the ACK parameter (+ HMAC and
-> > HIP_SIGNATURE) and nothing
-> > -> > else, right ? If yes, then section 8.11.2 needs one more
-> > bullet point
-> > -> > which tells that "The system sends the UPDATE packet .."
->
-> If we changed "generates" to "sends", will that clarify it?

That is much better.

-> > But anyway, I would still like to see third bullet point added to the
-> > section 8.11.2 as I mentioned. Just for clarity.
->
-> Will the proposed word change mentioned above be sufficient?

I think it is just ok.