Subject: [Hipsec] (not) using HITs as an application identifier

From: [email-masked] (Henderson, Thomas R)
Date: Tue Jul 20 21:27:00 2004

> -----Original Message-----
> From: marcelo bagnulo braun [mailto:[email-masked]]=20
> Sent: Tuesday, July 20, 2004 2:19 AM
> To: Pekka Nikander
> Cc: Henderson, Thomas R; [email-masked]
> Subject: Re: [Hipsec] (not) using HITs as an application identifier
>=20
>=20
> Hi Pekka,
>=20
>=20
> > I haven't thought about the security implications of this, yet.
> >
>=20
> i guess that the problem is how to (securely) link an AID with a HIT.
>=20
> I mean, how does a node knows that a given AID (routable IP address)=20
> actually corresponds to a given HIT?
>=20

What scenario are you worried about? =20

If a system is only provided with a routable AID, there are some=20
limits to the security of being able to link it to a HIT.  However,
trusted DNS with reverse lookup is one way.  CB64 approach to the AID is
another. =20

If system is provided with a HIT and a routable AID as a hint of
a locator to use, then we shouldn't have lost any security with this =
change.

---

From: [email-masked] (marcelo bagnulo braun)
Date: Wed Jul 21 09:20:11 2004

Hi Tom,

El 21/07/2004, a las 4:25, Henderson, Thomas R escribi=F3:

>> From: marcelo bagnulo braun [mailto:[email-masked]]
>> I mean, how does a node knows that a given AID (routable IP address)
> What scenario are you worried about?
>
> If a system is only provided with a routable AID, there are some
> trusted DNS with reverse lookup is one way.  CB64 approach to the AID=20=

> is
> another.

I agree that those mechanism can provide the security features, but=20
then i wonder what do you use the HIT for?
I guess i am not understanding Pekka's suggestion...
I mean if the apps uses the routable AID and you build the security=20
mechanisms as those you describe above in order to provide the required=20=

security for those identifiers, then why do you need to map to the HIP,=20=

for instance in the pseudo header, in other words, who would deal with=20=

the HIT in this case?

Regards, marcelo

> a locator to use, then we shouldn't have lost any security with this=20=

> change.
> _______________________________________________
> Hipsec mailing list
> [email-masked]
> http://honor.trusecure.com/mailman/listinfo/hipsec
>

---

From: [email-masked] (Julien Laganier)
Date: Wed Jul 21 10:52:08 2004

Hi Marcelo,

I tried to answer your question below...

On Wednesday 21 July 2004 16:15, marcelo bagnulo braun wrote:
> >> I mean, how does a node knows that a given AID (routable IP
> >> address) actually corresponds to a given HIT?
> >
> > limits to the security of being able to link it to a HIT.=20
> > However, trusted DNS with reverse lookup is one way.  CB64
> > approach to the AID is
> > another.
>
> I agree that those mechanism can provide the security features, but
> I mean if the apps uses the routable AID and you build the security
> mechanisms as those you describe above in order to provide the
> required security for those identifiers, then why do you need to
> map to the HIP, for instance in the pseudo header, in other words,
> who would deal with the HIT in this case?

My understanding is that some simple client/server applications like=20
telnet, http or ftp can use HITs in the socket API instead of IP=20
addresses, while more complex referral applications might require to=20
use IP addresses in the API.=20

And we might have a library call or something like that for setting=20
the AID API type to IP addresses or HIT , and a global system=20
variable allowing to choose the default system-wide policy.

Thanks,

=2D-julien