Subject: [Hipsec] layer

From: [email-masked] ([email-masked])
Date: Mon Sep 13 06:13:00 2004

Hi!
could anybody tell me which should the level of HIP in layer architecture=
?
higher or lower than IP's?
capacity

---

From: [email-masked] (Pekka Nikander)
Date: Mon Sep 13 06:23:01 2004

> could anybody tell me which should the level of HIP in layer 
> architecture?

In most presentations it is shown on the top of IP,
just below TCP and UDP.

In practise, most implementations seem to integrate it
within the IP layer, in one way or another.

IIRC, the architecture draft discusses this issue briefly.

--Pekka Nikander