Subject: [Hipsec] Digital Signature Algorithms

From: [email-masked] (Henderson, Thomas R)
Date: Wed Oct 20 23:27:01 2004

> -----Original Message-----
> From: Pekka Nikander [mailto:[email-masked]]
> Sent: Monday, October 18, 2004 3:46 AM
> To: [email-masked]
> Subject: Re: [Hipsec] Digital Signature Algorithms
>=20
>=20
> My sense from the discussion so far is that people slightly
> favour RSA.  Hence, apparently we should go for
>=20
>    - RSA MUST implement algorithm
>    - DSA SHOULD implement algorithm

I support that.

>=20
> What comes to algorithm negotiation, I think that we can
> go with the following approach:

I am not worried about negotiation or evolving this
for now, but it seems difficult, if only HITs are known
before the handshake, to use anything but RSA.  If we
ever go away from "MUST" RSA, we may have to consider
some extensions for negotiation.

Tom

---

From: [email-masked] (Pekka Nikander)
Date: Thu Oct 21 00:34:01 2004

Tom,

> some extensions for negotiation.

I don't quite understand this.  If all you have is a HIT,
you can't do anything else but use the algorithm associated
with the HIT.  If you don't know the key type of the HI
from which the remote HIT was generated from, you can always
test.  You'll get the key in an R1.  If you get a HI that
you can't handle, you have no other option but trying another
HIT.  So, as far as I can see, there is no need for a negotiation.

The problematic case is the opportunistic mode, but for that
we outlined the interoperability requirements.

--Pekka