Subject: [Hipsec] Base draft - 01-pre2

From: [email-masked] (Henderson, Thomas R)
Date: Wed Oct 20 20:42:01 2004

> The 01-pre2 version of the base draft is available at
>=20
> http://hip4inter.net/drafts.php
>=20

A few comments:

Section 5:

5.4.1-- CLOSED HIP SA clos, no data (ESP) can be sent
                         ^^ed
                       =20
in state CLOSING, receive I1, stay at UNASSOCIATED
                                       ^^^^^^^^^^^^
                                       CLOSING

(same copy and paste error for state CLOSED)
                                      =20
Section 6:

Why is CLOSE/CLOSE_ACK Packet Type value TBD?  Makes it tough to try to =
interoperate these packets.   Can we pick some values now?=20

Section 8.16:

as i specified in Section 6.3.5.
   ^^
 (delete)

Section 13:    =20

NATing, etc.).  However, the optionnal behavior of replying to CLOSE
                             ^^^^^^^^^
                             optional
  =20
reflexion attacks.
^^^^^^^^^
reflection

---

From: [email-masked] (Petri Jokela)
Date: Thu Oct 21 01:25:00 2004

Thanks for the fixes!

Henderson, Thomas R wrote:

> Why is CLOSE/CLOSE_ACK Packet Type value TBD?  Makes it tough to try to interoperate these packets.   Can we pick some values now? 

How about 10 and 11?

/petri

---

From: [email-masked] (Pekka Nikander)
Date: Thu Oct 21 10:06:01 2004

>> Why is CLOSE/CLOSE_ACK Packet Type value TBD?  Makes it tough to try 
>> to interoperate these packets.   Can we pick some values now?
>
> How about 10 and 11?

I would suggest the following values, and also reordering
Sections 7 and 8 to reflect the same logic.

I1		1
R1		2
I2		3
R2		4
CER		5
UPDATE	6
NOTIFY	7
CLOSE	8
CACK	9
BOS	   	  --remove--  (should be an extension, separate document)
PAYLOAD   --remove--  (should be an extension, separate document)

I do see some strange beauty in the above series, but
that is minor.  If people prefer to retain existing
packet types, I don't have anything against it.

10 and 11 are fine.

--Pekka